# Table of Contents

1. Introduction ................................................................................................................................. 1  
   Welcome to TreeAge Pro ............................................................................................................. 1  
   TreeAge Pro Interface .................................................................................................................. 1  
   Get technical support .................................................................................................................. 1  
   What's New in TreeAge Pro ......................................................................................................... 2  

2. Using TreeAge Pro ......................................................................................................................... 3  
   Get Started Layout ....................................................................................................................... 3  
   Launch Pad .................................................................................................................................. 6  
   Model Building Assistants ......................................................................................................... 7  
   Tree Editing/Reporting Pane ....................................................................................................... 9  
   Tree Diagram Editor ..................................................................................................................... 10  
   Tips for Navigating TreeAge Pro ................................................................................................ 13  
   Controlling the display with perspectives/layouts ..................................................................... 17  
   TreeAge Pro Views ..................................................................................................................... 21  

3. Example Models and Files ............................................................................................................ 26  
   Example Models ........................................................................................................................ 26  
   Create a project/folder for your models/documents .................................................................. 28  
   Working within a project/folder - saving and comparing models ............................................ 29  

4. Get Started with Decision Analysis .............................................................................................. 31  
   What is decision analysis? ......................................................................................................... 31  
   Modeling ..................................................................................................................................... 31  
   Expected values and optimal decisions .................................................................................... 32  
   Sensitivity analysis ..................................................................................................................... 33  
   Decision tree structure .............................................................................................................. 33  
   Further reading ........................................................................................................................... 34  

5. Get Started - Building a Decision Tree Model ............................................................................. 35  
   Defining the problem .................................................................................................................. 35  
   Create the tree structure .......................................................................................................... 36  
   Setup Model Configuration ........................................................................................................ 41  
   Entering payoff values .............................................................................................................. 45  
   Entering probabilities ................................................................................................................ 48  
   Calculating the tree ................................................................................................................... 49  
   Next steps .................................................................................................................................. 50  

6. Influence Diagrams ....................................................................................................................... 52  
   Influence diagrams ................................................................................................................... 52  
   Constructing an influence diagram ............................................................................................ 52  
   Converting an influence diagram to a decision tree ................................................................. 59  

7. Printing and Presenting Trees ....................................................................................................... 61  
   Printing ...................................................................................................................................... 61  
   Exporting Pictures ..................................................................................................................... 62  
   Print / Export Wizard .................................................................................................................. 64  

8. Analyzing Decision Trees ............................................................................................................ 66  
   Numeric Formatting .................................................................................................................... 66  
   Expected values ......................................................................................................................... 67  
   Roll back .................................................................................................................................... 68  
   Rankings ..................................................................................................................................... 69  
   Standard deviation ..................................................................................................................... 70  
   Discrete simulation/microsimulation ......................................................................................... 72
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>16</td>
<td>Working With Variables</td>
<td>190</td>
</tr>
<tr>
<td></td>
<td>Variable Properties View</td>
<td>190</td>
</tr>
<tr>
<td></td>
<td>Variable Definitions View</td>
<td>197</td>
</tr>
<tr>
<td></td>
<td>Defining a Variable at a Specific Node</td>
<td>201</td>
</tr>
<tr>
<td></td>
<td>Variable Sets</td>
<td>204</td>
</tr>
<tr>
<td></td>
<td>Variable Categories</td>
<td>205</td>
</tr>
<tr>
<td></td>
<td>Sensitivity Analysis Variable Properties</td>
<td>208</td>
</tr>
<tr>
<td></td>
<td>Sensitivity analysis correlations</td>
<td>209</td>
</tr>
<tr>
<td></td>
<td>Variables testing tools</td>
<td>211</td>
</tr>
<tr>
<td></td>
<td>Formula Editor</td>
<td>212</td>
</tr>
<tr>
<td></td>
<td>Variable Definition Arrays</td>
<td>213</td>
</tr>
<tr>
<td>17</td>
<td>Building Formulas Using Variables and Functions</td>
<td>217</td>
</tr>
<tr>
<td></td>
<td>Quantity expressions in a model</td>
<td>217</td>
</tr>
<tr>
<td></td>
<td>Formula Editor</td>
<td>217</td>
</tr>
<tr>
<td></td>
<td>Content-Assist</td>
<td>219</td>
</tr>
<tr>
<td></td>
<td>Function Helper</td>
<td>220</td>
</tr>
<tr>
<td></td>
<td>Summation nodes</td>
<td>221</td>
</tr>
<tr>
<td></td>
<td>User-defined python functions</td>
<td>222</td>
</tr>
<tr>
<td></td>
<td>Variable formula examples</td>
<td>223</td>
</tr>
<tr>
<td></td>
<td>Using mathematical, statistical, and other functions</td>
<td>229</td>
</tr>
<tr>
<td></td>
<td>Arithmetic functions</td>
<td>230</td>
</tr>
<tr>
<td></td>
<td>Financial/discounting functions</td>
<td>231</td>
</tr>
<tr>
<td></td>
<td>Miscellaneous functions</td>
<td>232</td>
</tr>
<tr>
<td></td>
<td>Using mathematical, statistical, and other functions</td>
<td>233</td>
</tr>
<tr>
<td></td>
<td>Recursive variable definitions</td>
<td>234</td>
</tr>
<tr>
<td></td>
<td>Operators</td>
<td>237</td>
</tr>
<tr>
<td></td>
<td>Keywords</td>
<td>240</td>
</tr>
<tr>
<td>18</td>
<td>More Sensitivity Analysis Tools</td>
<td>242</td>
</tr>
<tr>
<td></td>
<td>Analyzing variables with multiple definitions</td>
<td>242</td>
</tr>
<tr>
<td></td>
<td>Tornado diagrams</td>
<td>244</td>
</tr>
<tr>
<td></td>
<td>Two-way sensitivity analysis</td>
<td>254</td>
</tr>
<tr>
<td></td>
<td>Three-way sensitivity analysis</td>
<td>258</td>
</tr>
<tr>
<td></td>
<td>Threshold analysis</td>
<td>259</td>
</tr>
<tr>
<td></td>
<td>Analyzing correlated variables</td>
<td>261</td>
</tr>
<tr>
<td></td>
<td>Additional sensitivity analysis topics</td>
<td>263</td>
</tr>
<tr>
<td>19</td>
<td>Monte Carlo Simulation, Distributions and Probabilistic Sensitivity Analysis</td>
<td>265</td>
</tr>
<tr>
<td></td>
<td>Uses of Monte Carlo simulation in modeling</td>
<td>265</td>
</tr>
<tr>
<td></td>
<td>Creating distributions</td>
<td>268</td>
</tr>
<tr>
<td></td>
<td>Performing probabilistic sensitivity analysis</td>
<td>274</td>
</tr>
<tr>
<td></td>
<td>Probabilistic Sensitivity Analysis Reports</td>
<td>276</td>
</tr>
<tr>
<td></td>
<td>Saving Monte Carlo Simulations</td>
<td>285</td>
</tr>
<tr>
<td></td>
<td>Simulation options</td>
<td>286</td>
</tr>
<tr>
<td></td>
<td>Customizing simulations</td>
<td>296</td>
</tr>
<tr>
<td></td>
<td>Two- and three-dimensional simulations</td>
<td>299</td>
</tr>
<tr>
<td>20</td>
<td>Distribution Functions, Options and Types</td>
<td>302</td>
</tr>
<tr>
<td></td>
<td>Distribution functions</td>
<td>302</td>
</tr>
<tr>
<td></td>
<td>Distribution options</td>
<td>304</td>
</tr>
<tr>
<td></td>
<td>Distribution Formulas</td>
<td>308</td>
</tr>
<tr>
<td></td>
<td>Sampling from tables during Monte Carlo simulation</td>
<td>308</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
<td></td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
<td></td>
</tr>
<tr>
<td>Correlated Inputs - MultiNormal Distribution</td>
<td>316</td>
<td></td>
</tr>
<tr>
<td>21. Creating and Using Tables</td>
<td>323</td>
<td></td>
</tr>
<tr>
<td>Creating and editing tables</td>
<td>323</td>
<td></td>
</tr>
<tr>
<td>Referencing tables in formulas</td>
<td>327</td>
<td></td>
</tr>
<tr>
<td>Model tables and global table files</td>
<td>329</td>
<td></td>
</tr>
<tr>
<td>Importing tables from older versions of TreeAge Pro (2009 and earlier)</td>
<td>332</td>
<td></td>
</tr>
<tr>
<td>The All Tables Report</td>
<td>335</td>
<td></td>
</tr>
<tr>
<td>Managing tables using the Excel module</td>
<td>335</td>
<td></td>
</tr>
<tr>
<td>Linking a table to an ODBC data source</td>
<td>335</td>
<td></td>
</tr>
<tr>
<td>22. Stored Analysis Abstracts and Sequences</td>
<td>342</td>
<td></td>
</tr>
<tr>
<td>Using stored analyses</td>
<td>342</td>
<td></td>
</tr>
<tr>
<td>Sequencing stored analyses</td>
<td>344</td>
<td></td>
</tr>
<tr>
<td>23. Linking with Excel and Other Applications</td>
<td>347</td>
<td></td>
</tr>
<tr>
<td>BiLinks to connect with Excel</td>
<td>347</td>
<td></td>
</tr>
<tr>
<td>Pull parameters from Excel via BiLinks</td>
<td>347</td>
<td></td>
</tr>
<tr>
<td>Dynamic linking with Excel via BiLinks</td>
<td>349</td>
<td></td>
</tr>
<tr>
<td>Creating a BiLinks report</td>
<td>351</td>
<td></td>
</tr>
<tr>
<td>Calculating payoffs using dynamic links: a simple example</td>
<td>353</td>
<td></td>
</tr>
<tr>
<td>Using a single link to a range of cells</td>
<td>356</td>
<td></td>
</tr>
<tr>
<td>24. Tools and Functions for Complex Trees</td>
<td>358</td>
<td></td>
</tr>
<tr>
<td>Working with very large trees</td>
<td>358</td>
<td></td>
</tr>
<tr>
<td>TreeAge Pro Workspace, Tree Explorer and Model Overview</td>
<td>358</td>
<td></td>
</tr>
<tr>
<td>Viewing/editing document XML</td>
<td>361</td>
<td></td>
</tr>
<tr>
<td>Cloning subtrees</td>
<td>366</td>
<td></td>
</tr>
<tr>
<td>User-defined Python functions</td>
<td>374</td>
<td></td>
</tr>
<tr>
<td>Node(), Tree(), User(), Global() and other special functions</td>
<td>375</td>
<td></td>
</tr>
<tr>
<td>The Node() function</td>
<td>375</td>
<td></td>
</tr>
<tr>
<td>The Tree() function</td>
<td>379</td>
<td></td>
</tr>
<tr>
<td>The Command() function</td>
<td>383</td>
<td></td>
</tr>
<tr>
<td>The Debug() functions</td>
<td>385</td>
<td></td>
</tr>
<tr>
<td>The Global() and GlobalN() functions</td>
<td>385</td>
<td></td>
</tr>
<tr>
<td>Custom Functions</td>
<td>387</td>
<td></td>
</tr>
<tr>
<td>The TrackerIncr() function</td>
<td>388</td>
<td></td>
</tr>
<tr>
<td>List function</td>
<td>389</td>
<td></td>
</tr>
<tr>
<td>String Processing</td>
<td>389</td>
<td></td>
</tr>
<tr>
<td>25. Python</td>
<td>390</td>
<td></td>
</tr>
<tr>
<td>A Simple Python Function Example</td>
<td>390</td>
<td></td>
</tr>
<tr>
<td>Python Access to Model Data</td>
<td>392</td>
<td></td>
</tr>
<tr>
<td>Using External Python and Importing Python Libraries</td>
<td>395</td>
<td></td>
</tr>
<tr>
<td>Python Example with Logical Syntax</td>
<td>398</td>
<td></td>
</tr>
<tr>
<td>Python Syntax Errors</td>
<td>400</td>
<td></td>
</tr>
<tr>
<td>Python-initiated Access to TreeAge Pro models</td>
<td>400</td>
<td></td>
</tr>
<tr>
<td>Calling Python via the User function (Pre-2018)</td>
<td>401</td>
<td></td>
</tr>
<tr>
<td>Other Python syntax options</td>
<td>401</td>
<td></td>
</tr>
<tr>
<td>26. Advanced Chance Node Techniques and Options</td>
<td>404</td>
<td></td>
</tr>
<tr>
<td>Using non-coherent probabilities</td>
<td>404</td>
<td></td>
</tr>
<tr>
<td>Sampling probabilities from a Dirichlet distribution</td>
<td>409</td>
<td></td>
</tr>
<tr>
<td>27. Bayes' Revision in Decision Trees</td>
<td>413</td>
<td></td>
</tr>
<tr>
<td>An introduction to Bayes’ revision</td>
<td>413</td>
<td></td>
</tr>
<tr>
<td>Bayes' Revision - Sensitivity/Specificity</td>
<td>415</td>
<td></td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
<td></td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
<td></td>
</tr>
<tr>
<td>Variables/Markov Info</td>
<td>507</td>
<td></td>
</tr>
<tr>
<td>Dynamic Links</td>
<td>508</td>
<td></td>
</tr>
<tr>
<td>Identifying Variables</td>
<td>508</td>
<td></td>
</tr>
<tr>
<td>Debugging/Calculation Trace</td>
<td>509</td>
<td></td>
</tr>
<tr>
<td>Output Reports</td>
<td>511</td>
<td></td>
</tr>
<tr>
<td>Report Filters</td>
<td>513</td>
<td></td>
</tr>
<tr>
<td>Monte Carlo Options</td>
<td>513</td>
<td></td>
</tr>
<tr>
<td>Time Reporting Selection</td>
<td>517</td>
<td></td>
</tr>
<tr>
<td>Stored Analysis Abstracts and Sequences</td>
<td>517</td>
<td></td>
</tr>
<tr>
<td>Application Preferences</td>
<td>517</td>
<td></td>
</tr>
<tr>
<td>Application Preferences Dialog</td>
<td>517</td>
<td></td>
</tr>
<tr>
<td>Application Preferences - Backup/Save</td>
<td>518</td>
<td></td>
</tr>
<tr>
<td>Application Preferences - Display</td>
<td>519</td>
<td></td>
</tr>
<tr>
<td>Application Preferences - Keys</td>
<td>520</td>
<td></td>
</tr>
<tr>
<td>Application Preferences - Launch Pad</td>
<td>520</td>
<td></td>
</tr>
<tr>
<td>Application Preferences - Automatic Updates</td>
<td>521</td>
<td></td>
</tr>
<tr>
<td>Application Preferences - Monte Carlo Distributed Processing</td>
<td>522</td>
<td></td>
</tr>
<tr>
<td>Application Preferences - Storage</td>
<td>523</td>
<td></td>
</tr>
<tr>
<td>Application Preferences - Python</td>
<td>523</td>
<td></td>
</tr>
<tr>
<td>36. Technical Details &amp; Utilities</td>
<td>525</td>
<td></td>
</tr>
<tr>
<td>TreeAge Pro products and modules</td>
<td>525</td>
<td></td>
</tr>
<tr>
<td>Node Types</td>
<td>525</td>
<td></td>
</tr>
<tr>
<td>Random number generator details</td>
<td>527</td>
<td></td>
</tr>
<tr>
<td>Report Output Files (*.rptx)</td>
<td>527</td>
<td></td>
</tr>
<tr>
<td>Importing TP 2009 Simulation Output</td>
<td>529</td>
<td></td>
</tr>
<tr>
<td>TreeAge Pro News Reader</td>
<td>530</td>
<td></td>
</tr>
<tr>
<td>Integration with other software</td>
<td>531</td>
<td></td>
</tr>
<tr>
<td>Installation and system requirements</td>
<td>531</td>
<td></td>
</tr>
<tr>
<td>Cross-Platform Compatibility</td>
<td>531</td>
<td></td>
</tr>
<tr>
<td>File compatibility</td>
<td>532</td>
<td></td>
</tr>
</tbody>
</table>
1. Introduction

You have installed TreeAge Pro Business - primarily used for analyzing decisions in the areas of business, law and oil/gas. Functions focused on Healthcare Modeling have been removed from this product, providing a more seamless convenient modeling product.

👋 If you work in the healthcare field, you likely have the wrong product. Please contact sales@treeage.com for assistance.

1.1 Welcome to TreeAge Pro

TreeAge Pro implements the techniques of decision analysis in a visual, intuitive and easy-to-use manner. It transforms decision analysis from a potentially tedious exercise into an easily applied means of:

1. *Organizing* the decision making process;
2. *Analyzing* the problem at hand; and
3. *Communicating* the structure of the problem, the nature of the uncertainties, and the basis for a strategy recommendation.

If you are experienced in decision analysis, you will find TreeAge Pro easy to use following only a cursory review of the software commands, although the richness of the program will become more apparent with further study of the manual.

If you are looking for features added to recent releases, please refer to the What's New in TreeAge Pro section of this chapter.

If you have no, or only limited experience with decision analysis, TreeAge Pro will make it much easier to learn. Go to the Get Started with Decision Analysis Chapter for a basic decision analysis theory. Then proceed to the Get Started - Build a Decision Tree Model Chapter, which provides step-by-step instructions for building and analysing an example model.

1.2 TreeAge Pro Interface

TreeAge Pro Interface is based on the Eclipse development environment. For an introduction to the layout of interface and navigation tips, please refer to the Using TreeAge Pro chapter.

1.3 Get technical support

There are several ways to get help in using TreeAge Pro.
1.3.1 Using the online help

TreeAge Pro installs with the Online Help you are currently reading. This Help is quite extensive and describes both modeling techniques and technical aspects of TreeAge Pro. Use the search field at the top of the Help View to look for help with specific topics.

1.3.2 Technical support and web site resources

The support section of our web site includes a variety of information for users of the software:

http://www.treeage.com/support

Resources available via this page include the following:

- Access to the Knowledge Base.
- Submit a request for technical support.
- Contact us by phone for support.
- Product demos.
- This manual in pdf.

1.3.3 Example models

Most topics in this manual include references to Example Models, which are installed on your computer with TreeAge Pro. The Example Models and Files Chapter describes how to access these models.

1.4 What’s New in TreeAge Pro

This section identifies new features in the latest releases.

1.4.1 TreeAge Pro 2020, Release 1

This is the first release of a separate installer for TreeAge Pro Business, designed for business analysts, attorneys, oil/gas exploration and other business areas.
2. Using TreeAge Pro

TreeAge Pro includes many functions that are dispersed among a set of editors, views, menus and toolbars. This chapter helps you navigate through these system elements to perform tasks associated with building and analyzing models.

We recommend that you start with the Get Started Layout, described in the first section of this Chapter. When you are ready for more complex tasks, switch to the more advanced layouts (Build and Analyze).

2.1 Get Started Layout

TreeAge Pro layouts (a.k.a, perspectives) control the way your application screen is presented. When you change layouts, you will see a different arrangement of editors and views as well as changes to the toolbar and menu.

The Get Started Layout highlights the most important tools for basic modeling and analysis. When you are ready for more complex tasks, switch to the more advanced layouts (Build and Analyze).

- a limited set of functions focusing only on the most common tasks
- videos that will help you navigate through the software
- assistants that provide step-by-step instructions to help you build your first models

Get Started Layout

If it is the first time you have used TreeAge Pro, TreeAge Pro will startup with the Get Started Layout on and the Launch Pad activated. The Launch Pad has four components, and you will start with the Intro to TreeAge Pro video component, which consists of a series of very short videos to help you navigate the software.
We recommend you watch all the videos, which in total last about 5 minutes. After each video, click the Next button to proceed to the next one. After the last video, click Finish to move to the Create new component of the Launch Pad.

At the top right of the screen, you will see a list of available layouts - Get Started, Build, Analyze and Simple. Stay in the Get Started Layout when you first begin using TreeAge Pro. When you have more experience with TreeAge Pro, switch to the Build layout for building models and the Analyze layout for analyzing models.

You may see different perspectives in your workbench based on a workspace created with an older version of TreeAge Pro. To use the new perspectives, you can create a new workspace. Click here for instructions in the TreeAge Software Knowledge Base.
Perspectives: Get Started, Build, Analyze and Simple

The Get Started perspective is arranged into the following sections:

- Top left pane: The main pane for the Launch Pad, models and analysis output
- Bottom left pane: The model input pane for entering model input data
- Right pane: The helper pane for opening models, accessing TreeAge Pro Help and model building assistants
Get Started perspective with Launch Pad, Help Views and Input Views

While this is the default display, the components of these panes can change as you open additional TreeAge Pro views.

2.2 Launch Pad

You can access the Launch Pad at any time by clicking on the tab in the top left pane of the application window. The "home" button in the toolbar will also access the Launch Pad.

Access the Launchpad via the House icon

*The Launch Pad is a quick way to:*
- Create new models using the Assistants
- Create new models
- Open recent models
- Play the Intro to TreeAge Pro Video

2.3 Model Building Assistants

The model building assistants provide step-by-step instructions for building models - specifically a CE Decision, a CE Markov Model or Legal Tree.

Open the Assistants from any of the following locations:

- Toolbar via the icons
- Launch Pad via the links (Decision, Markov or Legal Assistants)
- Help View using the link
- Help menu where the Assistants is an option (not shown in the figure below)
TreeAge Pro with some of the ways to open the Assistants highlighted

The Assistants will open within the Help View. If you open an Assistant directly from one of the buttons, a new tree will also open as the starting point for building a model using that Assistant.
2.4 Tree Editing/Reporting Pane

The top left pane within TreeAge Pro is used to build model structure and to review analysis output (reports and graphs).

Typically, you will have multiple tabs open in this pane - one for each open model and each open model output. The currently active tab will be shown with a gray tab, while the inactive tabs will have a white tab. Simply click on one of the other tabs to change the active tab within the pane.

Note that the main application toolbar includes yellow back and forward arrows to that allow you to move among the open tabs for models and analysis output.
The next section describes the Tree Diagram Editor used to create your model structure.

### 2.5 Tree Diagram Editor

The Tree Diagram Editor is the primary modeling window within TreeAge Pro. You create the model structure within the Tree Diagram Editor by adding, editing, moving and deleting nodes. Changes made within an editor are not saved until you instruct TreeAge Pro to save the model document.

You can open multiple models at once, and each will be presented within a different Tree Diagram Editor tab within the overall pane.

The Launch Pad is always the left-most tab. The "+" option to create a new model is always the right-most tab.

To maximize the size of the Tree Diagram Editor, double-click on the tree editor pane. This will help you see more of the structure for large trees. Double-click on the tree editor pane again to return the editor to its prior size and position.

The Tree Diagram Editor consists of a modeling pane and a modeling palette (to the right-hand-side). The *Modeling Pane* is the primary editing window, which contains the visual representation of the model. If the size of the model exceeds the size of the Modeling Pane, scroll bars will appear.

Several actions are performed within the Modeling Pane:

- Add/delete nodes in the model.
- Click on a node label to enter/edit label text.
- Drag nodes to different places within the model.
- Enter probabilities beneath the branches of chance nodes.
- Select a node to change the perspective of node-specific views (Node Properties, Variable Definitions, etc.).
- Etc.

**Modeling Pane edit options**

The *Modeling Palette* contains tools for creating model structure and for viewing the model. Access the palette using the little arrow at the top right of the tree editor pane.

You can add branches to the right of any node by double-clicking on the node. Double-click will typically add two branches if there are no existing branches and one branch if there are existing branches.

You can also use the toolbar to add new branches and nodes into your model. You do this by selecting the location for the new branch and node, then use the toolbar to add a new branch. If you want to add nodes within the existing structure rather than as additional branches, use the Insert Node option either via the Node menu or the right-click > Insert node context menu option. Both of these options are shown in the figures below.
Select a node and then use the tool bar to add nodes and branches.

You can also drag nodes from the palette into the modeling pane to add a branch/node to the model. The location of the new node is controlled by where it is dropped within the model. The new node line and branch connector will appear as you drag a new node around the existing model.
The zoom in and out buttons allow you to zoom in and out within the modeling pane. First, click on the zoom in or out button in the palette, then click on the model in the modeling pane. The modeling pane will visually recenter and resize based on your selection. To stop the zoom (in and out), just select the arrow from the top of the pallet.

The note and arrow buttons allow you to add those non-structural elements to your model. Click on either element button, then drag a note or arrow onto the model and use for making comments.

Undo any actions which are wrong by using the Blue back arrow in the tool bar.

To UNDO any action during model building, click the blue and black return arrow in the toolbar or choose Edit > Undo from the menu.

2.6 Tips for Navigating TreeAge Pro

There is an Intro to TreeAge Pro video which is available from the Launch Pad. We strongly recommend watching this to get an overview of how to navigate the software. This section repeats some of the tools and provides some additional tips too.

Maximize an editor or view:

- Select an editor or view by clicking the tab.
- Double-click on the tab to maximize that editor or view to populate the entire application window.
- To return to the original size, double-click again on the tab to return it its original size.
A Tree Editor maximized to take up all of the interface.

Re-sizing panes

- Hover over any “margin” between two different panes until a double arrow appears.
- Left-click with the mouse and drag the pane to the size you require.
Use the arrows between panes to re-size editors and views

Minimizing, maximizing and resetting panes

Panes are different sections of the overall interface with tabs for different editors and views within the pane. There are typically 3-4 panes visible in each layout. Panes can be minimized to allow more space for other panes.

- At the top of the pane, click the “minimize” icon (the same as in Windows or Mac) to minimize the pane.
- The pane will be minimized to the edge of the interface.
- Within each minimized group, you can either:
  - Restore the entire pane by clicking on the “restore” icon from the edge of the interface.
  - Restore a given View temporarily by clicking on the icon for that specific view within the minimized pane. When you click another place in the interface, that view will return to the minimized pane.
Views pane minimized showing where to restore one or all

**Detach views**

Individual Views (but not editors) can be detached from the main application window. This can be useful if you have a second screen.

- Right-click on the tab for the View you want to detach.
- Select “Detached” from the menu.
- The View will now be “floating” above the interface and can be moved around your screen(s).
- To reattach to the interface, right-click on the tab of the detached pane and deselect “Detached”. The View will be incorporated back into the interface.

**Moving views between panes**

You can move a View to another Pane within the interface via click and drag.

- Click on the tab at the top of the View you want to move and hold the mouse key down.
- Drag the selected View to the new location/pane and release the mouse button.

Tree Diagram Editor tabs and model result tabs cannot be moved to a different pane.

**Splitting panes**

The Tree Editor tabs (models and analysis output) cannot be moved to another pane, but you can split the Tree Editor pane to look at two or more tabs side-by-side.
- Click on a Tree Editor pane tab and hold down the mouse button.
- Drag the tab to the left, right, top, or bottom of the Tree Editor pane.
- A bold line will appear down the center of the Tree Editor. Release the mouse button and the moved tab will appear in a separate section or the Tree Editor pane.
- To move back, click and drag the tab back to its original location.

Split the Tree Editor to look at two models (or outputs) side by side.

### 2.7 Controlling the display with perspectives/layouts

A perspective (or layout) is a collection of views and editors that makeup the layout of your display. Perspectives are linked to the TreeAge Pro software and not to your specific model. You can create/use different perspectives associated with different sets of tasks. Get Started, Simple, Build and Analyze perspectives come preinstalled with the software.

ℹ️ You may see different perspectives in your workbench based on a workspace created with an older version of TreeAge Pro. To use the new perspectives, you can create a new workspace. Click here for instructions in the TreeAge Software Knowledge Base.

Perspectives can be selected from the top-right corner of the TreeAge Pro application window. The pre-installed perspectives may meet all your needs, but you can manipulate and then save the layout to suit personal preferences.
New users of TreeAge Pro will start with the Get Started layout. This layout shows the most common views and actions. When you are ready to move beyond the basis, select the Build and Analysis layouts for additional functions associated with building and analysing models, respectively.

The Simple perspective is a more concise layout for simple modeling.

The three perspectives are shown in the figures below with different tools associated with each. You can roll over each tool icon with a mouse and the tool tips (comments associated with that tool) will describe what each tool does.
Build perspective
Analyze perspective
2.7.2 Manipulating layouts

The current layout remembers the layout as you change the organization of views and editors to meet your needs. The next time you open TreeAge Pro with that layout, the visual organization will be the same as when you left it.

If you ever want to return a layout to the original "factory specs", right-click on the layout and choose Reset from the context menu.

2.8 TreeAge Pro Views

TreeAge Pro includes several views to support different features of the software. All TreeAge Pro views fall into one of these three categories.

1. Associated with the active model (e.g., Variable Properties, Distributions).
2. Associated with the selected node in the active model (e.g., Variable Definitions, Markov Info).
3. Helper views not associated with a model (e.g., Help, Files).
You can open any of the Views from the tool bar by selecting the dropdown Views menu, as in the figure below.

Open any Views from the dropdown Views menu in the toolbar

The following table lists some of the most commonly used TreeAge Pro views, along with a link to the section(s) of the Manual where each view is described in detail.

<table>
<thead>
<tr>
<th>View/Description</th>
<th>Manual Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Model Dashboard:</strong> Provides an overview of the important model configuration and model inputs in the model</td>
<td>Model Dashboard and Documentation Chapter</td>
</tr>
<tr>
<td><strong>Files View:</strong> Manages sets of documents associated with a folder/project, including but not limited to model documents. The Files View provides a standard tree/explorer interface to help you navigate to files and open files with double-click from within the software.</td>
<td>Example Models and Files Chapter</td>
</tr>
<tr>
<td><strong>Tree Explorer View:</strong> Allows you to navigate to nodes within a tree using a standard tree/explorer navigational interface.</td>
<td>Tools and Functions for Complex Trees Chapter</td>
</tr>
<tr>
<td><strong>Model Overview:</strong> Presents a miniature view of the active tree in the Tree Diagram Editor. The portion of the model that is currently visible in the Tree Diagram Editor is highlighted.</td>
<td>Tools and Functions for Complex Trees Chapter</td>
</tr>
<tr>
<td>View/Description</td>
<td>Manual Reference</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Tree Properties View: Edits the properties of a tree. Includes several tabs for different tree elements.</td>
<td>TreeAge Pro 201x Interface Chapter</td>
</tr>
<tr>
<td>Variable Properties View: Edits variables in the model.</td>
<td>Working With Variables Chapter</td>
</tr>
<tr>
<td>Tracker Properties View: Edits trackers in the model.</td>
<td>Individual-Level Simulation and Markov Models Chapter</td>
</tr>
<tr>
<td>Tables View: Edits the properties and data of the model's tables.</td>
<td>Creating and Using Tables Chapter</td>
</tr>
<tr>
<td>Distribution Properties View: Edits the model's distributions.</td>
<td>Monte Carlo Simulation, Distributions and Probabilistic Sensitivity Analysis Chapter</td>
</tr>
<tr>
<td>Clone Masters/Copies View: Edits the model's clone masters and copies.</td>
<td>Tools and Functions for Complex Trees Chapter</td>
</tr>
<tr>
<td>Node Properties View: Edits the properties of the selected node and the elements associated with that node.</td>
<td>TreeAge Pro 201x Interface Chapter</td>
</tr>
<tr>
<td>Variable Definitions View: Edits variable definitions of the selected node.</td>
<td>Working With Variables Chapter</td>
</tr>
<tr>
<td>Tracker Modifications View: Edits tracker modifications of the selected node.</td>
<td>Individual-Level Simulation and Markov Models Chapter</td>
</tr>
<tr>
<td>DES Info View: Edits DES info at the selected node.</td>
<td>DES Models Chapter</td>
</tr>
<tr>
<td>State Bindings View: Edits Markov state bindings of the selected node.</td>
<td>Markov Modeling Tools and Techniques Chapter</td>
</tr>
<tr>
<td>Evaluator View: Calculates numeric expressions of the selected node.</td>
<td>Working With Variables Chapter</td>
</tr>
<tr>
<td>Probability Wheel: Uses the wheel to edit numeric probabilities for branches of the selected node.</td>
<td>Making Changes to Tree Structure Chapter</td>
</tr>
</tbody>
</table>
2.8.1 Tree Properties View

The Tree Properties View allows you to edit the properties of a tree. The contents are tied to the model in the active Tree Diagram Editor. Switching editor windows will change the contents of the view.

The following tabs are available within the view to edit particular sets of tree properties:

- **General**: Edits model document information - creator, description. Also allows you to freeze the model from changes.
- **Variables**: Edits variable names, properties, default values and sensitivity analysis ranges. The contents of the Variables Tab are the same as those in the Variable Properties View.
- **Trackers**: Edits tracker names, properties and default values. The contents of the Trackers Tab are the same as those in the Tracker Properties View.
- **Tables**: Edits table properties and data. The contents of the Tables Tab are the same as those in the Tables View.
- **Distributions**: Edits distribution properties, type and parameters. The contents of the Distributions Tab are the same as those in the Distributions View.
- **Clones**: Edits clone master properties. The contents of the Clones Tab are the same as those in the Clone Master/Copies View, which is described in the Tools and Functions for Complex Trees Chapter.

2.8.2 Node Properties View

The Node Properties View allows you to edit the properties of a specific node and the elements associated with that node. The contents are tied to the selected node within the model in the active Tree Diagram Editor. Selecting another node or switching editor windows will change the contents of the view. If no node is selected, the view is disabled.

The following tabs are available within the view to edit particular sets of tree properties:

- **General**: Edits label, probability (for branch of chance node), and payoffs (for terminal nodes) of the selected node.
- **Variables**: Edits variable definitions at the selected node. The contents of the Variables Tab are the same as those in the Variable Definitions View.
- **Trackers**: Edits tracker modifications at the selected node. The contents of the Trackers Tab are the same as those in the Tracker Modifications View.
- **Markov**: Edits Markov info for the selected node. This tab is only visible for nodes within Markov models. There are three different contexts for the view for Markov nodes, Markov state nodes and Markov transition nodes. At the Markov node, the Markov Info View shows information about the Markov node, Health States and Transition Rewards in one place.
- **State Bindings**: Edits Markov state bindings at the selected node. The contents of the State Bindings Tab are the same as those in the State Bindings View.

**Node Properties View Tabs**

Note that variable definitions are associated with a specific node, while variable properties are associated with the entire model.
3. Example Models and Files

TreeAge Pro's Files View will help to organize your model documents. The Files View will provide a way to access files on your computer or network from within TreeAge Pro.

![Files View - showing all the example models](image)

The Files View provides a hierarchical view of the documents/resources from within TreeAge Pro. From here, you can open files for editing or select resources for operations such as exporting.

The folders within the Files View are also known as projects.

Right-click on any resource in the Files View to open a pop-up menu that allows you to perform operations such as copying, moving, creating new resources, comparing resources with each other, or performing other operations.

⚠️ Changes made to your folders within TreeAge Pro are immediately visible in the Files View. However, changes to the file system made outside TreeAge Pro are not reflected in the Files View until you refresh the View via the right-click context menu (and select Refresh).

3.1 Example Models

When you start TreeAge Pro for the first time, you will have an *Example Models folder* in the Files View. The Example Models folder contains the tutorial models that are installed on your computer with TreeAge Pro. Many of these example models are referenced within this manual.
3.1.1 References to Example Models

Within this manual, we will reference the Example Models. The following table shows the location of the model we reference them in tutorials. You should refer back to this section often to find the location of the models.

<table>
<thead>
<tr>
<th>Help file reference to the Example</th>
<th>Where to find the Example in Files View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Get Started tutorial example</td>
<td>Example Models\ Get Started</td>
</tr>
<tr>
<td>Business tutorial example</td>
<td>Example Models \ Business</td>
</tr>
<tr>
<td>Health Care tutorial example</td>
<td>Example Models \ Health Care</td>
</tr>
<tr>
<td>DES tutorial example</td>
<td>Example Models \ Discrete Event Simulation</td>
</tr>
<tr>
<td>Health Care Training tutorial example</td>
<td>Example Models \ Health Care Training Examples</td>
</tr>
<tr>
<td>Legal tutorial example</td>
<td>Example Models \ Legal</td>
</tr>
<tr>
<td>Oil tutorial example</td>
<td>Example Models \ Oil</td>
</tr>
<tr>
<td>Special Features tutorial example</td>
<td>Example Models \ Special Features</td>
</tr>
<tr>
<td>Bilinks tutorial example</td>
<td>Example Models \ Special Features \ Bilinks</td>
</tr>
<tr>
<td>Clemmens et al tutorial example</td>
<td>Example Models \ Others \ Clemmen Marshall Skinner et al</td>
</tr>
<tr>
<td>TreeAge Pro interface tutorial example</td>
<td>Using the TP Object Interface</td>
</tr>
<tr>
<td>Other tutorial example</td>
<td>Example Models \ Others</td>
</tr>
<tr>
<td>PartSA tutorial example</td>
<td>Example Models \ Partitioned Survival Analysis</td>
</tr>
</tbody>
</table>

3.1.2 Recreating the Example Models

If, at any time, you delete and modify the Example Models and want to recreate them, you can follow these instructions to do so.

Open the File menu and select Projects > Recreate Tutorial Examples. Follow the prompts and either overwrite the current "Example Models" folder or provide a new folder name for the Example Models (we used "Recreated Example Models" for the new name in the figure below).
3.2 Create a project/folder for your models/documents

A project is a reference to a folder on the file system on your computer or network where project-related files are stored. At any time, you can create a new project for new or existing models and related documents.

To create a new empty project:

- Right-click in the empty space within the Files View and select New > Project from the context menu.
- In the New Project Dialog, expand the group General and select Project. Click Next.
- Enter a project name. The name you enter will be the name of the Folder you are creating.
- Specify the existing folder where you want to place the new project and its files. Uncheck the box "Default location" if you want the folder to be outside the current workspace.
- You do not need to specify the working sets or referenced projects options.
- Click Finish.

The new project will then appear in the Files View. Models can then be saved within that folder via the menu: use File > Save in Project.

To create a new project from an existing folder:

- Right-click in the empty space within the Files View and choose New > Project from the context menu.
- Expand the group General and select Project. Click Next.
- Enter a project name. The name you enter will be the name of the Folder you are creating.
- Uncheck the box "Default location".
- Specify the folder where the project files are located. (This is usually a folder on your computer or network).
- You do not need to specify the working sets or referenced projects options.
- Click Finish.

The new folder now provides a shortcut directly to the folder (and subfolders) where your project files are located. Existing files in that folder can then be accessed directly from the Files View.

If a project already exists, perhaps on a network share, you can import it directly into the Files View.

To import an existing project into your workspace:
- Right-click in the empty space within the Files View and choose Import from the context menu.
- Expand the group General and select Existing Projects into Workspace. Click Next.
- Click on the Browse button next to the Select root directory input.
- Navigate to a folder within which there are one or more projects and click OK.
- The existing projects will be presented in the Projects list. Check the projects you want to select.
- Click the Finish button.

3.3 Working within a project/folder - saving and comparing models

Once you have a folder in the Files View, you can immediately open documents within that folder via double-click. Double-click will open trees via the Tree Diagram Editor. It will also open files that require additional editors like Excel™ and Word™. The right-click menu provides access to file editing options like delete, move, and rename.

In addition, Files View provides limited version control through the Team, Compare With and Replace With menus. These allow you to compare the current version of the file with prior versions.

When choosing where to save a file, you have two options from the menu:

1. File > Save in Workspace: Save your file within an existing project in the workspace. The file will be saved within the project's root folder, which could be on your computer or on a network.
2. File > Save As: Save your file as an independent document on your computer or on a network.

Note that when you save your models within a Project, TreeAge Pro provides tools to allow you to see revisions of the model and compare versions. Hidden revision files are stored within your TreeAge workspace to provide access to revisions beyond what you save directly.

To compare with recent revisions:

1. Right-click on a model file and choose Compare With > Local History from the context menu.
2. Choose a revision to compare to the latest copy.

To compare two model files:

1. Click on one model file to select it.
2. Hold the Control key down and click on a second file to select both files.
3. Right-click on either selected file and choose Compare With > Each Other from the context menu.
4. Get Started with Decision Analysis

This chapter introduces the core concepts and methods of decision analysis as implemented in TreeAge Pro.

4.1 What is decision analysis?

Decision analysis — as it is taught and practiced today in diverse fields such as healthcare, law, business, engineering, and oil/gas exploration — is a systematic approach to decision making under uncertainty. The process is designed to help decision makers think clearly about the many elements of complex decisions, such as:

- the range of possible consequences of actions (or inaction)
- preferences among different sets of consequences
- the impact of complex, unpredictable systems and processes (e.g., markets, geological structure, health)
- the actions of others (e.g., consumers, competitors, regulators, patients)

The concepts and methods of decision analysis are uniquely suited to incorporating into the decision making process both what is known about a problem, and also what is uncertain. TreeAge Pro is used in two of the key steps in decision analysis, modeling and analysis.

4.2 Modeling

Using decision analysis, a complex problem can be disaggregated into smaller problems and elements, which can be easier to understand. These components are then employed in building a model of the problem’s essential elements.

First, a set of alternatives (strategies) is compiled. Then, events and other factors that may affect the outcome of an alternative are identified. A factor whose impact on the final outcome is not known at the time of the decision is referred to as an uncertainty. It can be represented as either a structural element of the model, or a parameterized distribution used in a formula in the model. Based on the decision maker’s objectives, one or more attributes are selected to quantify preferences for the range of possible final outcomes (and, ultimately, to rank alternatives). For example, a monetary scale would be used to measure different project cost scenarios and then to rank alternatives.

Compared to basic spreadsheet analysis or statistical modeling, a particular strength of decision analysis is the intuitive, visual form of the model. The model may be either a decision tree or an influence diagram, which are different means of visually representing the same problem.

TreeAge Pro models take the form of a decision tree. A decision tree is a branching structure in which various node symbols are used to represent different kinds of events, including decisions and
uncertainties. A node’s branches represent the outcomes or alternatives associated with that event. Every series of actions and outcomes is clearly represented with a distinct path.

Alternatively, the same problem often may be represented more compactly by an influence diagram. In a influence diagram, each factor that directly or indirectly affects the final outcome is represented with a single node. Arcs between nodes show that one factor either affects another or precedes it in time. Note that TreeAge Pro supports influence diagrams, but analysis is only performed on models using the decision tree format.

4.3 Expected values and optimal decisions

While a model’s explicit identification of the sequence and linkage of events is of great value in decision making, decision analysis is designed to do much more. Using basic concepts from probability theory and statistics, the decision maker can calculate a mean value (or expected value) for each course of action. By calculating the value of each possible chain of events, and weighing uncertain results by the probability of each outcome, the decision maker can identify the sequence of decisions that will maximize value, minimize costs, or balance multiple attributes.

These calculations are commonly illustrated with a decision about playing a simple lottery, which can be thought of as a random variable having a simple probability distribution of outcomes as follows.

A $20,000 lottery offers a 1-in-1000 chance of winning. The expected value of playing this lottery — ignoring the ticket price — equals $0.001 \times ($20,000) + 0.999 \times ($0), or $20. Based on expected value, a reasonable decision would be to purchase a ticket if it costs $20 or less.

Typically, decision analysis problems involve multiple uncertainties, with the outcome of the first lottery being a second lottery, and so on. The analysis of compound lotteries works backwards, calculating an expected value for the final lottery and using this result in the calculation of the prior lottery. When all lotteries have been resolved in this way, decisions are evaluated by optimization — picking the alternative with the best expected value.

A decision maker’s attitude towards risk can be incorporated into model calculations. Using the techniques outlined in utility theory, a choice between different lotteries can be made based on their expected utilities or certainty equivalents. These in turn depend on the decision maker’s attitude towards risk, quantified using a utility function.
4.4 Sensitivity analysis

As illustrated with the lottery example, one way in which decision analysis deals with uncertainty is to reflect it explicitly in the model’s structure. Events which have a significant impact on outcomes, and which are not under the decision maker’s control, can be described using chance nodes and incorporated into the model calculation. A problem may involve numerous uncertainties; not all of them can or should be represented in the structure of the model. To deal with this, deterministic sensitivity analysis and probabilistic sensitivity analysis are used to examine the potential impact of parameter assumptions and other uncertainties.

Deterministic sensitivity analysis can take a variety of forms, including 1-way, 2-way, and 3-way sensitivity analysis and tornado diagrams. It can be used to identify critical uncertainties by examining the extent to which a model’s calculations and recommendations are affected as a consequence of changing selected assumptions. Probabilistic sensitivity analysis (PSA) can incorporate all parameter uncertainties. PSA quantifies the level of confidence that can be placed in the model’s results.

Sensitivity analysis and other analytical tools can also be used to improve decision making. This is done by determining the potential value of obtaining various kinds of information (perfect, imperfect, or sampling information) that might help resolve critical uncertainties.

4.5 Decision tree structure

In building a decision tree, there are some basic guidelines to be considered:

• **In the tree, events are ordered from left to right.** The tree often follows a time ordering of events, as outcomes become known to the decision maker. Time ordering is only critical, however, when a decision is made prior to knowing the outcome of a different event or when the probabilities of one event are dependent on another.

• **Different kinds of events are distinguished using shapes called “nodes.”** A decision node (square) indicates a choice facing the decision maker. A chance node (circle) represents an event which has multiple possible outcomes and is not under the decision maker’s control. A terminal node (triangle) denotes the endpoint of a scenario. Other node types are used in more complex models, like Markov models.

• **Branches “sprouting” from a decision node represent the set of actions being considered.** Decision alternatives are not required to be mutually exclusive. For example, one set of options could be “install smoke detectors,” “install fire extinguishers,” and “install smoke detectors and fire extinguishers”.

• **Branches from a chance node represent the set of possible outcomes of the event.** The branches must be mutually exclusive and exhaustive — in other words, defined such that all possibilities are covered and none overlap. Their probabilities must sum to 1.0 (100%).
• Terminal nodes are assigned a value, referred to generically as a "payoff". All right-most nodes (those without branches) must be terminal nodes and have a payoff representing the net value (e.g., profit, cost, or utility) of that particular scenario's series of actions and events.

### 4.6 Further reading

For additional background on decision analysis in general, here are some suggested references:


There are also numerous books and journals dealing with the application of decision analysis in specific fields and industries. Here are just a few selected references:

5. Get Started - Building a Decision Tree Model

There are two “get started” chapters. This chapter focuses on a simple legal model with one outcome – legal damages. The next chapter focuses on a healthcare model with two outcomes – cost and effectiveness. Much of the contents are repeated, so use the chapter that is appropriate for the types of models you will build.

You may want to review the TreeAge Pro Interface Chapter before continuing, in order to familiarize yourself with the many elements of the user interface.

5.1 Defining the problem

Let us consider a legal case where we are the Defendant in a civil lawsuit. The Plaintiff alleges that we are liable for damages. We will build a model to assess the value of the case (to advise our client).

In a more realistic legal model, proving liability would likely involve several steps. It is likely that the Plaintiff would have to prove they suffered damages and that the Defendant’s negligence caused the damages. For the purposes of illustration, we will focus on a single step of proving liability on the part of the Defendant.

5.1.1 Representing the problem as a model

We have a decision to make regarding our legal strategy. We have two strategies:

1. Proceed with litigation; or
2. Settle the case out of court.

If we choose to settle, there is only one outcome which is to pay the Settlement amount.

If we choose to litigate, there are two outcomes:

1. Jury finds we are liable for the damages; or
2. Jury finds we are not liable for the damages.

The final issue is the size of the damages award if we are found liable. There will be several estimates for the damages award amount.

We can represent this problem with a decision tree based on the information above. However, we will also need numeric values associated with this problem, specifically probabilities and damage estimates.

5.1.2 Numeric Values

At the first decision, we are faced with a settlement option based on a demand from the Plaintiff.
- Settlement demand: $1 million

If we choose to proceed with litigation, then we need to know the likelihood of the jury finding us liable.

- Probability the jury finds us liable: 30%
- Probability the jury finds us not liable: 70%

If the jury finds we are not liable for damages, we are not required to pay compensation.

- Damages if not liable: $0

If the jury finds we are liable, then we need to pay damages. The jury may award a range of damages, so we will use three estimates for damages – High, Medium or Low. It is a common technique in legal models to use High, Medium and Low damage amounts with probabilities 25%, 50%, and 25%, respectively.

- High damages: $4.5 million (25% likely)
- Medium damages: $2.5 million (50% likely)
- Low damages: $0.5 million (25% likely)

We now have all the information we require to build a decision tree in TreeAge Pro. The remaining sections of this chapter go through how to build this example model and analyze the model to make an informed decision. The finished model can be found in the Get Started Example models, and is called Plaintiff v Defendant.

5.2 Create the tree structure

We will now create the tree structure for the legal Plaintiff vs Defendant model described in the previous section.

The software has a perspective/layout to assist with building models. Select the Build perspective from the top right hand corner of the application window, and the interface will present you with toolbars, editors, and views related to model building.

5.2.1 Create a new tree

To create a new tree document:

- Select File > New from the menu or click Ctrl-N on the keyboard.
- ... OR ...
- In the toolbar click the icon for New Decision Tree.

This opens a new empty tab within the Tree Diagram Editor. The new model will consist of a single Decision Node.
A Model Setup dialogue will appear, asking if you want to configure the calculation method and outcomes for your model. Click ‘No’, but in the future you may choose to setup your model before building. (You can return to the Model Setup at any point by selecting the gears icon in the toolbar).

The node furthest to the left within the model is the root node. All models must have a single root node from which all other nodes emanate, either directly or indirectly.

You should always **Enter a label** for every node in the model, including the root node. The red text that appears above the node in the Tree Editor prompts you to enter the label.

### Prompts for data entry include:

- **Enter label**: Appears above branches and prompts you to enter a label for the branch.
- **Enter prob**: Appears below the branches (nodes to the right) of a chance node and prompts you to enter the probability.
- **Enter condition**: Appears below the branches of a logic node and prompts you to enter the condition to test at the logic node.
- **Enter time**: Appears below the branches of a time node branch for Discrete Event Simulation models.
- **Enter payoff**: Appears at terminal nodes and prompts you to enter values for a scenario.

### 5.2.2 Selecting a node

TreeAge Pro shows a node is selected by filling in the node symbol.

*To select a single node using the mouse:*

- Click on the node line or the node symbol.

### 5.2.3 Entering and resizing node labels

When a single node is selected, a box will appear around the node label text. In the case of a new node, the initial text will be “Enter label”.

*To enter a node label:*

- Click where it says "Enter label", above the node line, and an input text box will appear.
- Enter a brief phrase in the box to describe the event — in this case *Plaintiff v Defendant*.
- Press ENTER on your keyboard to save the new text as the node label.
- To undo the text you have typed…
  - Select ‘esc’ on your keyboard if you have not already saved the node label text.
5 Get Started - Building a Decision Tree Model

- Choose Edit > Undo from the menu if you have already saved the node label text.

To resize a node label (or text box):

Node (and other) labels entered into text boxes may wrap depending on the length of the description. Follow these instructions to resize the text box.

- Use the tick markers _above and to the right_ of the text box in the ruler bar.
- Hover over the tick mark until a double arrow appears and then drag to resize the text box, as in the figure below.
- All text boxes directly above and below a given text box will also change size.
- Fonts and alignments of the node labels and nodes can also be changed via the Tree Preferences > Display settings which you can access via the tool bar.

Use the ruler at the top of the Tree Editor to resize the label boxes

5.2.4 Adding branches/nodes

A branch must be added to the decision node to represent each strategy. For this model, add branches _Litigate_ and _Settle at current demand._

To add branches:

- Select the Decision Node.
- Click the ‘Add branches’ toolbar icon which will add two branches.
- ... OR ...
- Drag a chance node from the Tree Diagram Editor Palette to the right of the existing decision node. A red line will appear indicating where the node can be placed. Release the mouse when the new node is visible as a branch of the decision node.
- Repeat this for a second chance node which should also be a branch of the decision node.
- ... OR ...
- Right-click on the decision node and select Add Branch from the context menu. Two chance nodes will be added as branches.
Don't be confused by the terms branch and node. They both refer to the same element of a tree model. The term branch is normally used to describe the specific nodes that emanate directly from a parent node (the closest node to the left).

For more information on changing tree structure, refer to the following sections:

- Deleting nodes (refer to Deleting nodes/branches)
- Zoom in or out (refer to Tree Building and Navigating the Tree)
- Navigating the tree using the keyboard (refer to Tree Building and Navigating the Tree)

5.2.5 Label the strategy nodes

Now we can enter node labels for our strategy nodes.

- Select the top branch from the decision node, opening the text box, and type Litigate.
- Select the bottom branch from the decision node, opening the text box, and type Settle at current demand.

The tree should now look like this:

- Rather than entering extensive comments in the node itself, it is often better to use note boxes or node comments (refer to the Annotation Chapter).
- Many tree-building commands are found under the Node menu or by right-clicking on a node.
- If you delete a branch that is a parent (i.e., that has branches), its subtree (i.e., its children as well as their descendants) will not be deleted; instead the children and their descendants will move up one generation. Refer to the Changing the Tree Structure Chapter for more information on inserting and deleting nodes.

5.2.6 Complete the tree structure

The decision tree has two strategies. The Settle strategy only needs to incorporate the settlement demand value, which is entered via Payoffs. The Litigate strategy requires additional structure to replicate the jury’s findings.

Add two branches to Litigate and label:

- Select the Litigate node and use either the tool bar to add 2 branches (or double-click on the node);
- Label the two new nodes:
  - Jury finds Defendant liable for damages; and
  - Jury finds Defendant not liable for damages.

Add three branches to Jury finds Defendant liable for damages and label:
- Select Jury finds Defendant liable for damages node and add three branches (using techniques as above);
- Label the three branches:
  - High damages awarded;
  - Medium damages awarded; and
  - Low damages awarded.

The tree should now look like this:

![Decision Tree Diagram]

5.2.7 Saving the tree

Now that all necessary nodes have been added, it is a good time to save your work.

TreeAge Pro models are documents. You save, open, and close trees and other documents in TreeAge Pro the same way you do in other programs — using the File menu commands.

To save a TreeAge Pro document:
- Choose File > Save … OR … select the "save" icon (floppy disc) on the tool bar.
- In the Save As dialog, select or create a directory, type "Legal Example Tree" for the file name, and press ENTER or click Save.
TreeAge Pro can be set to periodically autosave each document that you open and modify. You can adjust the backup/autosave settings under Window > Application Preferences. In case of a problem, you can recover the latest auto-saved copy. You should still save your work periodically. It is also recommended that you save your tree files in a location that is regularly backed up. If you open and save files in the Files View, a local history for the file will be maintained. Right-click on the file in the Files View to access the local history.

5.3 Setup Model Configuration

In addition to its structure and numeric values, models must be setup or configured so that they are calculated and displayed in an appropriate way.

Setting up the model is essential to ensure the calculation preferences are set prior to analyzing the model, that is setting the way a model calculates and displays the model.

Model configuration settings are stored in Tree Preferences. The most important Tree Preference is the Calculation Method, which determines how TreeAge Pro selects the optimal strategy at each decision node. For this legal example tree, we want the “simple” calculation method, which uses a single outcome measure (damages). As the defendant, we want to choose the strategy that minimizes the damages.

It is useful to set Tree Preferences for numeric values to use appropriate Numeric Formatting when displaying calculated values (number of decimal places, currency symbols, and abbreviations like K for thousands).

These Tree Preferences can be set with or without the Model Setup Wizard, which navigates through the most commonly used Tree Preferences. We recommend using the Model Setup Wizard but also provide details below of how to configure the model directly via Tree Preferences.

Each tree has its own independent set of preferences. Changes to this tree’s preferences will not affect other trees.

5.3.1 Setting Tree Preferences with the Model Setup Wizard

When you create a new decision tree, the Model Setup Wizard prompt will ask if you want to configure your model. To deactivate this prompt, check the box as highlighted in the figure below. To reactivate this prompt, choose Tree > Auto-Configure New Models from the menu.
Creating a new tree prompts you to use the Model Setup Wizard.

To start the Model Setup Wizard at any other time, click the gears icon highlighted in the figure below or choose Tree > Model Setup Wizard from the menu bar.

The Model Setup Wizard walks you through the most commonly used Tree Preferences listed below:

- Calculation method
- Additional options associated with the selected calculation method including the active payoff(s)
- Number of enabled payoffs
- Global discounting
- Custom payoff names
- Numeric formatting

The figure below shows the first step in the Model Setup Wizard. Choose the Next, Back, and Finish buttons as highlighted below to navigate through important Tree Preferences.
The Model Setup Wizard walking you through important Tree Preferences.

In this Legal Example Tree, there are two things we are going to set via the Model Setup Wizard:

- Calculation method; and
- Numeric formatting.

In other models, additional Tree Preferences may need setting. We will use the Next button to skip through the other preferences. Open the Model Setup Wizard and then:

**Configure the model:**

- Select the "Simple" calculation method.
- Select "Low" as the optimal path. The model will identify the strategy with the lowest Expected Value as the optimal strategy. As the Defendant we want to minimize costs. Choose Next.
- Skip Payoffs. We do not want to enable any additional payoffs.
- Skip Global Discounting.
- Skip Custom payoff names. We could change payoff 1 to “Cost” here.
- In Numeric formatting, we want to set the format as Currency. Set:
  
  - Decimal places to “0”;  
  - Select to use thousands separator;  
  - Show numbers in thousands; and  
  - Select units as Currency.
- Click Finish.

Tree Preferences - Calculation Method is set to Simple with the optimal path as "low"

Tree Preferences - Calculation > Numeric Formatting

To find out more details about setting model preferences, refer to the Preferences Chapter.

5.3.2 Setting Tree Preferences without the Model Setup Wizard

Using the Model Setup Wizard will prompt you to enter the most important Tree Preferences (recommended). You can also choose to set individual Tree Preferences without the Wizard. Use the toolbar to open the Edit Tree Preferences dialogue.

To set each required Tree Preference for the Legal Example Tree, open the Tree Preferences and then...

Set the Calculation Method:
- Navigate to the category Calculation > Calculation Method.
- Select the "Simple" and select the optimal path as "Low".

**Set the Numeric Format:**

- Navigate to the category Calculation > Numeric Formatting.
  - Change the numeric formatting for Payoff 1 as follows:
    - Decimal place to “0”;
    - Select to use thousands separator;
    - Show numbers in thousands; and
    - Select units as Currency.

Press ENTER or click "Apply and close" to apply changes, and save the tree again now, by choosing File > Save.

Refer to the Preferences Chapter for more details on numeric formatting and other tree preferences, including information on creating and using preferences sets.

### 5.4 Entering payoff values

We have created the tree structure and set the Tree Preferences. Now we need to complete the tree structure by terminating the end nodes and entering payoffs.

Every path from the root node to an end node within the model represents a *scenario*. When a scenario is terminated with a terminal node, you must assign value(s) to that scenario. In TreeAge Pro, this is done by entering payoff values.

The **Settle at current demand** node is the end of a *scenario*, so it can be terminated.

**To change an endpoint to a terminal node:**

- Right-click on a node with no branches (in this case the **Settle at current demand** node).
- Select Change Type > Terminal from the context menu (see figure below).
- OR ...
- Select the **Settle at current demand** node.
- Click the "Change node type" icon on the toolbar and select terminal from the list of node types.
- OR ...
- Select the **Settle at current demand** node.
- Press Control+T on the keyboard and select terminal from the list of node types.
5 Get Started - Building a Decision Tree Model

After changing *Settle at current demand* to a terminal node, TreeAge Pro automatically opens an Edit Payoff dialog for the node.

Use the Edit Payoff dialog to assign the value for the *Settle at current demand* scenario ending at this terminal node. Specifically, set the Active Payoff value to 1000000 where it says "Enter payoff" and click OK.

*Note* the "Use custom payoffs names" check box in the Enter Payoff dialogue. If you check this box, you can edit the Payoff Set Label. This would allow us to edit the label *Active Payoff* to another name, such as Cost.

The payoffs are displayed in the Tree Diagram Editor to the right of the terminal node, as in the figure below. For more information about setting payoffs see the Changing what the tree calculates section.
Decision tree with Settle at current demand terminated and payoff set as 1000000.

Note that the entered payoff value does not use the numeric formatting we set via Tree Preferences. The numeric formatting will be used in the outputs when we analyze the model. You can format the entries with currency symbols and thousands separators if so desired.

To change the payoff value(s) at an existing terminal node:

- Double-click on the terminal node or the payoff values to the right (an ellipsis if no payoff values have been entered yet).
- ... OR ...
- Right-click on the terminal node and select Edit Payoffs from the context menu.

Finish the Plaintiff v Defendant Tree structure by terminating the remaining scenarios and entering payoffs at terminal nodes.

Terminate the Jury finds defendant not liable for damages branch:

- Select the Jury finds Defendant not liable for damages node and change the node type to Terminal.
- In the Edit payoff dialog, enter the payoff value of 0 for Payoff 1 and click OK.

Terminate the three branches awarding damages:

- Select the High damages awarded node/branch and change the node type to Terminal.
- In the Edit Payoff dialog, enter the payoff value of 4500000 for Payoff 1 and click OK.
- Repeat this process twice more for the remaining scenarios:
  - Medium damages awarded. Payoff = 2500000.
  - Low damages awarded. Payoff = 500000.

We have now terminated every end node in the model and provided payoff values for each scenario. The model should now have the same structure as the Plaintiff v Defendant model from the Files View.
5.5 Entering probabilities

The model includes chance nodes where we cannot control the outcomes represented by its direct branches. We need to enter probabilities for each branch to account for the likelihood of that specific outcome. The branch probabilities for each chance node must sum to 100% (or 1.0).

To enter a probability:

- Click on the red "Enter prob" prompt beneath the Jury finds defendant liable for damages node. An input field will appear.
- Enter 0.3 into the input field and press the ENTER key.
- ... OR ...
- Select the Jury finds defendant liable for damages node and click the toolbar icon for Enter Branch Expression.
- Enter 0.3 into the input field and press the ENTER key, see figure below.

The same steps can be repeated for the remaining branches with the following probabilities:

- Jury finds defendant not liable for damages node, probability of 0.7.
- High damages awarded node, probability of 0.25.
- Medium damages awarded node, probability of 0.5.
- Low damages awarded node, probability of 0.25.

The model is now complete and can be calculated.

You can enter the hashtag ("#") for one branch of each chance node. The hashtag will evaluate to the complement of the sum of all other branch probabilities. For example, if you have branch probabilities of 0.2, 0.3, and #, the hashtag will evaluate to $1 - (0.2 + 0.3) = 0.5$. 
Regional (e.g., European) numeric settings:

- If your computer is set up to use commas (","), to represent decimals, rather than periods ("."), you should enter numbers in TreeAge Pro this way. Normally, you will enter numbers in TreeAge models just as you would in a spreadsheet or calculator.
- If your model will be shared by users with different regional numeric settings, use a special tree preference to instruct TreeAge Pro to override a computer’s regional settings (i.e., reverse the usage of separators) for that particular tree. This setting is found in the Tree Preferences under Regional Settings (see below).

5.6 Calculating the tree

The tree is now ready for analysis – the structure is complete and all necessary numeric values have been entered. Start by rolling back the tree, which performs the expected value calculations described in the Get Started with Decision Analysis chapter.

To roll back the tree:

- Select Analysis > Roll Back from the menu.
- ... OR ...
- Click the "beach ball" icon in the toolbar.

The rolled-back tree should look essentially like the picture below.
Expected value (EV) calculations start by calculating the payoff values at each terminal node. We just entered fixed numeric values, so those calculations are simple. In a typical model, there would likely be formulas here that require calculation.

At chance nodes, the EV is calculated as the weighted average of the EV of its branches – the sum of the EV of each branch multiplied by its probability.

At decision nodes, the optimal path branch is selected based on the calculation method. Our calculation method is “Simple” (one active payoff) with “low” as the optimal path. Therefore, the optimal strategy is the branch with the lowest EV.

The optimal strategy will be highlighted with a green branch connector. All rejected strategies are highlighted with a red branch connector with a double "strike through" marker. If a strategy were excluded from the analysis, its branch connector would be colored grey.

If TreeAge Pro displays an error message, examine the text for the course of the problem. Possible problems include endpoints that are not terminal nodes, and missing probability or payoff values.

If roll back works, but the reports look different than those shown below, you may need to check your work, and fix any probability or payoff that was entered incorrectly.

Note that changes cannot be made to structure or values while Roll Back is on. Roll back is on when the tree looks as in the figure above and the beach ball icon is “depressed” in the toolbar.

To turn off roll back display:

- Select Analysis > Roll Back from the menu.
- ... OR...
- Click the "beach ball" icon in the toolbar.

5.7 Next steps

You have completed the Get Started Building a Decision Tree tutorial: Plaintiff v Defendant. You are now ready to use TreeAge Pro to build your own decision trees.
Some questions you may have at this point:

- How can I build a tree to calculate cost-effectiveness? Refer to the Get Started - Building a Healthcare Decision Tree Model chapter which follows the same structure as this chapter, but for a cost-effectiveness model. More advanced details can be found in the Building and Analyzing Cost-Effectiveness Models Chapter.

- How do I add more payoffs? The Plaintiff v Defendant example requires only Payoff 1. However, each tree can use many payoffs or attributes; refer to the Tree Calculation Methods and Preferences Chapter for details.

- How can I customize the appearance of payoffs and other visual elements of trees? The Tree Display Preferences and Options Chapter describes how to customize these elements.

- How can I include my model in a presentation? Refer to the Printing and Presenting Trees Chapter.

- How can I do sensitivity analysis? Refer to the Introduction to Variables and Sensitivity Analysis Chapter.

- How can I handle complex values and formulas? Refer to the Building Formulas Using Variables and Functions.

You might take some time now to review the topics in these chapters. As you work with the software and have questions about functionality, bear in mind that the table of contents at the front of the manual will simplify finding answers.
6. Influence Diagrams

In TreeAge Pro, the primary model type is a decision tree. However, influence diagrams can be helpful when creating or presenting a model. You can create influence diagrams in TreeAge Pro for these purposes. However, all analyses must be performed on decision trees.

This chapter consists of a tutorial describing how to create an influence diagram.

Influence diagrams replace dependency diagrams supported by TreeAge Pro 2012 and earlier. Influence diagrams provide new functionality as well as all functionality supported by dependency diagrams. Dependency diagrams are obsolete, but they can be imported into the new influence diagram format.

6.1 Influence diagrams

Influence diagrams tend to be simpler on their face than decision trees. While they do not display the level of detail found in a tree (i.e., scenarios, probabilities, and payoffs), influence diagrams portray more clearly the factors to consider in decision making, and how those factors are related. Even in complex problems, where the decision tree is far too large to fit on a single printed page, the corresponding influence diagram is almost always small enough for simple reproduction and efficient communication.

The design of an influence diagram is subject to a number of guidelines. Here are the basic ones:

- **“Nodes” of different shapes represent the factors relevant to the problem.** Each element of the problem — the final objective (e.g., maximizing profit), along with each decision, and random event that can affect the objective — is represented by a single node. A value node (diamond) denotes a measure of the final objective. A decision node (square) is used to indicate a decision. A chance node (circle) is used to represent an event whose value (or outcome) is currently unknown.

- **Related nodes are connected by arcs.** An arc ending in an arrow is drawn between two nodes to indicate that: (a) the first event precedes the second, and/or (b) the first event or action affects (or conditions) the second. An influence arc might indicate that the probabilities for one event depend on the outcome of a prior event or action. An influence arc might also indicate that an action or event makes some contribution to, or deduction from, the final objective (e.g., project cost, or profit).

6.2 Constructing an influence diagram

The tutorial in this chapter explains in detail the software commands needed to build an influence diagram model of the investment decision described in the Decision Analysis Primer Chapter.
To get started, you will need a new influence diagram document.

To create a new influence diagram:
- Choose File > New Influence Diagram from the menu.

6.2.1 Adding and selecting nodes

Unlike a new tree, which starts with a root node, a new influence diagram window is completely blank. The first step in building the diagram is to add the required nodes. Let’s start by showing the final objective — profit.

To add a node to an influence diagram:
- Click on the appropriate node type in the Diagram Editor Palette — in this case, the red diamond, for a value node. See below.
- Click and drag the node into a space towards the right side of the influence diagram editor to place it.
- Drag the mouse down and to the right to resize the new node.

You will see a new, selected value node. TreeAge Pro indicates that the node is selected by showing a rectangular outline with resizing markers on every corner and every edge. The node label will also be selected waiting for you to enter the appropriate text.

The outline around the node can be used to move or resize the node.

When the node is not selected, the rectangular outline will disappear. Since the node label was not entered, it will appear as an elipsis.

To select a node:
- Click inside the node borders.

### 6.2.2 Entering the node label

You should enter a word or brief phrase in the text box to describe this element of the problem — in this case, the investment objective. You can enter the node label when you first create the node, or you can enter/edit the node label later.

**To enter/edit the node label:**

- Select the node.
- Click on the existing node label or the middle of the node if no text has already been entered.
- Type the node label text (in this case *Profit*) in the text area.
- Click outside the node to deselect it.

![Profit node with node label entered](image)

Now add a node for the first event that affects return on investment — the decision.

- Create a decision node (blue square).
- For its label, enter *How should I invest $1000?*

![Added decision node](image)

*To force a carriage return in a label press *Control + Enter* within the text.*

### 6.2.3 Adding arcs

Earlier in this chapter, arcs were introduced as a means of displaying the relationships between actions, variables, events, and objectives. The direction of influence between the two nodes added so far is from the investment decision to *Profit*, so an arc should be created that points to the value node.

**To draw an arc:**

- Click on Arc in the Influence Diagram Editor Palette (See figure below).
- Click on the influencing node (*How should I...*) and drag the mouse to the conditioned node (*Profit*); then release the mouse button.
Influence Diagram Palette

A new arc will be created pointing from the How should I invest $1000 node to the Profit node.

Add new arc

It is frequently useful to add a comment to a label to describe the influence relationship represented by the arc.

To edit an arc label:
- Double-click on the arc.
- Enter text ("Maximize") into the Arc Data dialog Comment field.
- Click OK.

The arc label can also be moved closer/further from the arc.

To move an arc label:
- Click on an arc label and drag it to a new location.

As the arc moves relative to its source/destination nodes, the label will automatically move with it.

Now, add the other required node — a chance node representing the risk inherent in choosing the stock — and its influence arc.
- Create a chance node (green circle), and for the node name enter Market activity.
- Create an arc from Market activity to Profit and enter the label "Determines".
- Create an arc from How should I invest $100 to Market Activity to indicate the order of actions within the influence diagram.

Here is essentially how your three-node influence diagram should now look:
Influence diagram with third node added

Now that all nodes and arcs have been added, take a moment to save your document. You save, open, and close influence diagrams and other documents in TreeAge Pro the same way you do in other programs — using the File > Save As command. Influence diagrams are saved with the file extension *.indx rather than *.trex.

6.2.4 Outcomes and Alternatives

Although the influence diagram may appear to be complete, outcomes and alternatives must be added before it can be converted to a decision tree.

- Alternatives represent the choices available to the decision maker at a decision node.
- Outcomes represent the possible events that can occur from a chance node.

To add alternatives to a decision node:

- Right-click on the decision node.
- Choose Alternatives from the context menu.
- Click Add to create an alternative and enter label text.
- Repeat the last step to add additional alternatives.
- Click OK.

For this influence diagram, the following alternatives should be added.

Edit Node Alternatives Dialog

To add outcomes to a chance node:

- Right click on the chance node.
- Choose Outcomes from the context menu.
- Click Add to create an outcome and enter label text.
- Repeat the last step to add additional outcomes.

For this influence diagram, the following outcomes should be added.

![Edit Node Outcomes Dialog](image)

### 6.2.5 Asymmetry

Asymmetry allows you to eliminate some node combinations from the converted decision tree. For instance, in this chapter’s example, market activity affects the *Risky investment* alternative but has no impact on the *CD paying 5%* alternative.

To establish asymmetry in the model:

- Double-click on the arc between *How should I invest $1000* and *Market Activity*.
- Deselect the Influence Type checkboxes for Prob and Value associated with the *Risky investment* alternative to show that the alternative choice has no influence on the *Market Activity* outcomes.
- Deselect the Influence Type checkboxes for Prob and Value associated with the *CD paying 5%* alternative.
- Choose Skip from the Additional Info column options for *CD paying 5%* alternative to indicate that *Market Activity* has no impact on that alternative.
- Click OK.

The choices from the steps above are shown below.
Because there is no impact of the decision alternatives on the chance node outcomes, the arc turns grey and dotted.

The influence diagram is now complete.

**Completed Influence Diagram**

### 6.2.6 More editing options

Additional options for editing influence diagrams are described in this section.

*To move a node:*
  - Select a node and drag its outline (not a resize point) to a new location.

When a node is moved, the arcs attached to it will also move.

*To cut a node:*
  - Select a node.
  - Choose Edit > Cut from the menu or press Control + X on the keyboard. *Arrows attached to the node will also be cut.*

*To resize a node:*
  - Select a node.
- Click and drag one of the resize marks on the rectangular outline around the node.

**To select multiple nodes:**
- Select one node then hold down the Shift key and select another node.
- ... OR ...
- Click on open space in the diagram and drag to create a rectangle that surrounds all elements you wish to select

**To delete an arc:**
- Select the arc.
- Press the *Delete* button on the keyboard.

**To bend an arc:**
- Click on the arc and drag it to another location. Rather than moving the entire arc, it will be split into two line segments, each terminated at the new drag location.
- You can bend this further by dividing up those line segments further using the same technique.

### 6.3 Converting an influence diagram to a decision tree

Now that the influence diagram is complete, it can be converted to a decision tree.

**To convert the diagram:**
- Open and activate the influence diagram editor window.
- Click the Convert to Tree icon in the toolbar.

A decision tree model is then created in the tree diagram editor with the same name as the influence diagram, but with the extension .trex added to the end.
**Decision Tree from Conversion**

The decision tree structure is created. You would then need to add probabilities and payoffs to the decision tree prior to running analyses.
7. Printing and Presenting Trees

This chapter provides basic instructions on how to customize printouts of your TreeAge Pro models, and how to import pictures of models into document and presentation programs like Microsoft® PowerPoint™, Excel™, or Word™.

7.1 Printing

Printing documents in TreeAge Pro is similar to printing documents from any other Windows application.

To print a document:

- Select the document you wish to print.
- Choose File > Print from the menu or click on the Print toolbar icon (printer).
- Click OK in the Print Dialog.

The Print Dialog includes some options that may be useful.

Within the Print Dialog, you can select the Printer from among those available to your computer. The Properties button provides access to the printer's preferences.

The Tree View section provides two options.

- **Diagram**: Print the visual representation of the tree.
- **Text Tree**: Print a textual representation of the models nodes based on their position within the tree.

The Print Range section allows you to select which pages to print. A small model easily prints on a single page. A large tree may not initially print on a single page, but you may be able to get it to fit by shrinking it, or by changing the page orientation to landscape (horizontal).
The *Orientation* section allows you to select whether to align the paper vertically or horizontally.

The *Copies* section allows you to print multiple copies of the tree.

The *Scaling* section allows you to adjust the size of the tree to fit on more or fewer pages.

You can use Print Preview from the File menu to see how your model will be printed on a page. The Print Preview Dialog has a scaling option to allow you to zoom in/out depending on how the model fits on the page(s).

You can also set page header and footer for the tree via the Tree Preferences.

To *print a tree in black and white*, first follow the instructions to export a picture of a tree in Export Pictures and then print the image.

## 7.2 Exporting Pictures

You may want to export a picture of a model or part of a model or a graph for insertion into a separate document.

To *export a picture of a tree*:

- Select the tree you wish to print by having it open in the Tree Editor.
- From the menu, choose File > Save Image where you will be prompted to select the nodes you want to export:
- Select the nodes you want to export choosing either:
  - *Selected Nodes*: Exports the nodes currently selected in the Tree Diagram Editor.
  - *Subtree*: Exports the selected node and its entire subtree.
  - *All Nodes*: Exports the entire tree.
- Select the image format and file location in the Save As Image File dialog box (see figure below).
- To export and/or print in *black and white*, check save in greyscale.
- Then click OK.
To export a graph as an image:

- Create any graph (and ensure it is the active image in the Tree Editor).
- Use one of the options for saving the image, any of:
  - Select the Save file or Save image icon from the tool bar; or
  - Select the Save file icon from above and to the right of the graph; or
  - Choose File > Save from the menu.
- Enter a filename and location, and select the image format in Type, as in the Save/Export Chart dialog figure below.
- Selecting different file types, such as PNG, JPEG and BMP, will give you the options of changing the image properties. Dimension is changed by altering the width and height. The resolution is changed by altering the scale parameter.
- Click Save.
Save graph dialog

JPEG, JPG and PNG files are good for presentation on the web. Depending on the type of graph, experimenting with different width, height and scale parameters for the image resolution will produce images of different quality. SVG and PDF files are good for sending to publishers or for further editing in graphic design software.

7.3 Print / Export Wizard

The Print/Export Wizard allows you create the best Tree Diagram image for exporting and/or printing. It provides the options in one place for:

- Paginating the output.
- Showing/hiding elements of the model.
- Choosing the output format.

To use the Print/Export Wizard

- Open the Tree you want to print or save as an image.
- Select File > Print/Export Wizard.
- Choose your Tree Image Layout Options to determine how and whether to split the tree among multiple images.
- Choose your Model Display Options to select which elements of the model to include in the image outputs. You can hide all numeric values to present just the model structure.
- Select the Output Options to send the output to image files or to a printer.
- For Printer: Select the appropriate Printer preferences and then select Print.
- For Images: Select Finish and then the Save As Image dialogue will open. Select the appropriate location to save and image type, and then select Save.

Note that the exported output will reflect the presentation on screen with the exception of the options selected via the wizard dialog. For example, node widths and collapsed subtrees will appear in the output just the same as they do on screen.

Dialog to choose whether/how to split the model into multiple images

The following dialogue appears to help you elect what you want to include in the export (selections would display details of values for active payoffs)

Options selected during the export wizard are remembered for the next time you run the wizard.

When you select Finish, the images will either be sent to a printer, or they will open in your computer's native image viewer.
8. Analyzing Decision Trees

This chapter describes in detail the variety of expected value analyses available in TreeAge Pro.

8.1 Numeric Formatting

TreeAge Pro performs calculations at the highest available precision, but values are displayed using a specified number of decimal places — up to 9 — with the option to use abbreviations and unit symbols. As described at the end of the Decision Tree Tutorial Chapter, each tree and graph has its own set of numeric formatting preferences.

To view/modify a document’s numeric formatting:

- Select the model.
- Press the F11 key or open Tree Preferences.
- In the Tree Preferences dialog, select the Calculation > Numeric Formatting category.

![Tree Preferences - Numeric Formatting](image)

Each Numeric Formatting option is described within in the Preferences Chapter.
8.2 Expected values

In addition to calculating and displaying expected values for all nodes in a tree (see Roll back in the next section), TreeAge Pro can also report a single expected value for a selected node. This provides a useful method of verifying the completeness of a single part of an incomplete tree. Roll back calculates and displays expected values for all nodes in a tree (see Roll back, below).

To calculate the expected value of a node:

- Select a node.
- Choose Analysis > Expected Value...
- ... OR ...
- Press CTRL-E on the keyboard.

Expected value at node

The result is displayed using the tree’s current numeric formatting preferences; see the previous section on numeric formatting for details.

Using the expected value result:

The Decision Analysis Primer Chapter includes a detailed description of the basic concepts used in calculating expected values in decision trees. Refer to that chapter, or one of the books listed at the end of the chapter for a review of basic concepts.
Calculation details can be reviewed for debugging purposes via Tree Preferences and the Calculation Trace Console. Usage is described in the Markov Microsimulation Chapter, even though the Healthcare Module is not required.

8.3 Roll back

As described in the Decision Analysis Primer Chapter, roll back refers to the calculation of expected values starting at the terminal nodes and continuing back to the root node. In TreeAge Pro, a variety of information is reported in the tree when it is rolled back.

To roll back the tree:
- Select Analysis > Roll Back (or click the beach ball icon in the tool bar).

The rolled back Business tutorial example, Stock Tree, from the aforementioned chapter, is shown below:

Roll back display

Note that expected values are displayed in roll back boxes at every node. The favored strategy, CD Paying 5%, is highlighted in green, while the branch connector to the rejected strategy, Risky investment, is highlighted in red and displayed with hash marks.

To turn off roll back:
- Select Analysis > Roll Back (again).

8.3.1 Roll back display details

Decision nodes: A box to the right of the node reports the name and expected value of the preferred alternative. TreeAge Pro marks the branches of non-optimal alternatives using hashes, and colors the optimal branch.

Chance nodes: A box to the right of the node reports the expected value. Probabilities are calculated (if necessary) and displayed beneath the node’s branches.

Terminal nodes: A box to the right of the node reports the calculated payoff value.
8.3.2 Customizing the roll back display

A picture of the rolled-back tree can be printed or exported to a graphic file; see Printing and Presenting Trees Chapter complete details.

There are many ways to customize the appearance of the rolled-back tree prior to printing or exporting it. In addition to the basic options described on the following page, there are a wide variety of other tree display preferences related to roll back (for example, setting up terminal node columns); see Tree Display Preferences and Options Chapter.

Values displayed in the rolled back are displayed using the tree's numeric formatting settings; see the beginning of this chapter for details on modifying these preferences.

When roll back is turned on, initially all nodes in the optimal path are selected (highlighted). Clicking on the tree will deselect these nodes.

Occasionally, a roll back box will cover the text of a branch description or probability. This can be corrected by moving the box.

To move a roll back box:
- Click and drag the box to a better location.

It is also possible to hide individual roll back boxes.

To hide a selected node’s roll back box:
- With the tree rolled back, right-click on the node whose roll back box you want to hide.
- From the pop-up quick menu, choose Hide roll back box.

Notes on roll back boxes:
- Roll back box state will be saved with the tree.
- A hidden roll back box can be redisplayed by right-clicking on the node and choosing Hide roll back box again.
- If you want to reset hidden and moved roll back boxes in a section of the tree, cut the subtree and then paste it back into place.

8.4 Rankings

The Rankings analysis, available when a single decision node is selected, displays a text report listing the alternatives at that node and their expected values, in rank order.

Try the Rankings analysis on the Business tutorial example called Rankings Analysis, which is a slightly more complex version of the Stock Tree from the Decision Tree Tutorial Chapter.

To calculate and rank decision alternatives:
- Select the decision node.
- Choose Analysis > Rankings.

A text report appears which ranks the options, and specifies their expected values. In the case of suboptimal options, it also specifies a marginal (or incremental) value — the amount by which one option is outperformed by the next best option.

The text report dialog includes an Export Report As link to export the displayed text to another program.

8.5 Standard deviation

In addition to comparing strategies based on their expected values, TreeAge Pro also offers several ways to look at an option’s risk — the degree of variability in outcomes. The basic statistical measure of risk is standard deviation. In TreeAge Pro, a standard deviation can be calculated for a single strategy (or any other chance node), based on the path probabilities and payoffs of all terminal nodes in its path.

To try the standard deviation calculation, try the Special Features tutorial example, Standard Deviation. In this tree, despite the fact that the three alternatives look different, a rankings or roll back analysis is indifferent between them — all three have the same expected value: 90. In this case, a choice might be based on minimizing risk as measured by standard deviation.
Standard Deviation Model

To calculate a standard deviation:

- Select the chance node labeled A.
- Choose Analysis > Standard Deviation.

The calculation used is:

\[ SD(\text{Strategy A}) = \sqrt{0.5(60 - 90)^2 + 0.5(120 - 90)^2} = 30 \]

where 90 is the strategy A’s expected value, or mean. Compare this to the calculated standard deviations for strategies B and C:
If you were to choose a strategy based on minimizing risk, as measured by standard deviation, strategy A would be preferred. Note that B and C are statistically identical, having the same terminal node values and path probabilities, and thus the same standard deviation:

$$SD(StrategyB/C) = \sqrt{0.25(40 - 90)^2 + 0.25(80 - 90)^2 + 0.5(120 - 90)^2} = 33.166$$

### 8.6 Discrete simulation/microsimulation

In decision analysis, the most efficient calculation is to use expected values, as described in the Decision Analysis Primer Chapter and illustrated in this chapter. However, it is also possible to evaluate decision trees using individual-level simulation, sometimes referred to as discrete simulation or microsimulation.

Discrete simulation in decision trees approximates an expected value by “sampling” a representative distribution of paths through the model’s chance events. Discrete simulation of complex models generally utilizes as many “trials” as time allows, in order to improve the EV estimation (ensuring even small probability paths are “sampled” proportionally). If run at a decision node, each trial is repeated for each strategy, to facilitate strategy comparison (e.g., CEA).

- Refer to the chapters on Monte Carlo Simulation and the Individual-Level Simulation for further details on Monte Carlo simulation, including details on running a Monte Carlo probabilistic sensitivity analysis.
- Discrete simulation can also sample values from probability distributions (e.g. to represent characteristics among “individuals”). Refer to the chapter that describes Distributions for the relevant distribution options.
- In survival/Markov models, discrete simulation is particularly useful because it allows modeling any number of continuous and discrete state variables (whereas cohort models work well for more limited numbers of discrete states). The Individual-Level Simulation Chapter provides details on Markov simulation topics.

The current topic provides a very brief example of how to run a discrete (or micro-) simulation in a decision tree, using the simple Stock Tree example from earlier in this chapter. In this model, there are no chance nodes in the “CD” strategy, so there will only be simulation variability in the random walks through the Risky investment strategy.

**To perform a simulation (1st-order trials only, no parameter sampling):**

- Select the node for simulation (in the Stock Tree example, the root, decision node).
- Choose Analysis > Monte Carlo Simulation > Trials (Microsimulation)...)
- ... OR...

- Click on the single dice toolbar button.

- Enter a small number of trials, perhaps 100 and click Begin.

Monte Carlo Simulation Dialog

If the simulation is complex enough to require a significant amount of time to complete, the output window displays the incremental progress of the simulation trials. Once the simulation is done, final statistics and other reporting/graphing options are displayed. Refer to the Individual-Level Simulation Chapter for more details.

8.7 Probability distributions

The risk associated with alternatives under consideration can be displayed graphically, using a probability distribution histogram, or risk profile. A probability distribution graphs the values (i.e., payoffs) and path probabilities of all terminal nodes within a strategy.

This analysis is deterministic (no randomness), and does not use the same approach for generating a probability distribution graph as a Monte Carlo simulation (see above). Simulation generates probability distribution graphs based on long runs of stochastic, random walks.
Open the Oil tutorial example model, Oil Drilling Problem. This model has some interesting elements, including multiple decision nodes.

Oil Drilling Problem Model

To create your first probability distributions using TreeAge Pro, start by analyzing a chance node.

To view a probability distribution histogram:

- Select a chance node – in this case the topmost chance node labeled Drill for Oil, in the No Soundings section of the tree.
- Choose Analysis > Probability Distribution.
- Use the default Histogram Type: Probability Distribution.
- Use the default Histogram Parameters. Select OK.

TreeAge Pro displays the analysis results in a graph window as shown below.

Probability Distribution Graph

There are different options available when generating the Histogram, as shown in the figure below.
More details about customizing histograms can be found in Customizing Histograms section.

8.7.1 Probability Distribution Secondary Reports

Every graph window includes a set of "Actions" links to the right of the graph. The Probability Distribution graph includes two additional links/controls in addition to the standard "Edit Chart" option.

- Edit Chart: Edit the chart’s dimension, scale, format, etc.
- Text Report (Bars): Show the numerical source data for the graph. This changes as we change the number of bars.
- Text Report (Raw): Show the numerical source data in detail including the node, path probability and node EV.
- Redo Histogram: Regenerate the histogram, selecting different Histogram parameters or adding/removing a Trend Line.

In the example Probability Distribution graph (not the CDF) shown in the previous section, TreeAge Pro displays a separate bar for each possible payoff. However, this will not always be the case, as some outcomes with similar values may be merged into a single bar within the graph.

Initially, the value range is divided into a reasonable number of intervals. The height (i.e., probability) of a bar is the sum of the path probabilities of all terminal nodes with payoffs in that interval. The height of all bars sums to 1.0 (100%). The vertical axis will scale to the height of the highest bar.

The value/probability associated with each bar can be accessed via the graph's Text Report (Bars).
Probability Distribution Text Report (Bars)

The Text Report (Raw) is similar, except that it will include every outcome (with no summarization by bar) along with the node name associated with the outcome.

Probability Distribution Text Report (Raw)

8.7.2 Downstream decision nodes

As noted above, the Oil tutorial example model, Oil Drilling Problem, includes multiple decisions. To see how the probability distribution analysis is affected by downstream decision nodes, analyze the Seismic Soundings chance node. Each of this node’s branches is a decision node. See below.
Oil Drilling Problem tree

If there are decision nodes anywhere to the right of the analyzed node, as in this analysis, TreeAge Pro calculates expected values, and then selects an optimal strategy at each downstream, or deferred, decision. The histogram only includes terminal nodes from the optimal path, therefore the path probabilities in the histogram will still sum to 1.0. To see which terminal nodes are in the optimal path, you can roll back the tree.
The information which is presented in the Probability Distribution is to allow the modeller to make decisions based on the range of possible outcomes/value and the likelihood of these outcomes happening. Using the PDF dialogue presented in the section above, changing the number of intervals or interval size can assist in this process.

The two Text Report links to the right of the graph generate reports showing the underlying data and will give you information about which outcomes are most likely.

The **Text report (Bars)** displays the individual bar values and their probabilities.

The **Text report (Raw)** shows the individual terminal nodes that contribute to each bar.
8.7.3 Cumulative Probability Distribution

If the option "Cumulative Probability Distribution" is selected from the same node, a different graph is presented.

This graph shows a complete EV range for all outcomes in the model along with the cumulative probability that the outcome will be less than or equal to a specific bar in the range. In this model there is a 50% chance that the EV will be less than or equal to approximately -600,000, while there is an 80% chance that the EV will be less than or equal to approximately 500,000. Greater precision is available via the secondary reports, which are described later in this section.

8.7.4 Comparative probability distributions

Multiple, cumulative probability distributions can be displayed in a single graph, allowing graphical comparison of options. In a comparative distributions graph, the cumulative distributions are displayed.
in outline, instead of using filled bars. This format enables graphical comparison of strategies based on their risk profile.

Details about the graphical interpretation of comparative probability distributions are provided later in this chapter, in the section on dominance.

When a single decision node is selected, the Analysis menu displays the Comparative Distributions command. The comparative distributions analysis can be tried at the root decision node in the Oil Drilling Problem tree.

To generate a comparative probability distribution graph:
- Select a decision node.
- Choose Analysis > Comparative Distributions from the menu.

The resulting graph displays the outlines of the cumulative probability distributions for the competing options Seismic Soundings and No Soundings. The outline for a strategy is marked at each corner (where the cumulative probability “curve” rises) with that strategy’s symbol, as listed in the legend to the right of the graph.
8.7.5 Dominance in probability distributions

Comparative probability distributions can be interpreted graphically, by evaluating conditions of dominance. There are two types of dominance that can be identified relatively easily: deterministic and stochastic (also called absolute and extended dominance). Conditions of dominance can provide more insight into a decision than simple expected value comparison.

Deterministic dominance occurs when one option not only has the best expected value, but its worst possible outcome is better than (or equal to) the best outcome of any other option. It can be identified as follows:

- if optimization requires maximizing value (e.g., profit), the worst “bar” of the dominant option (its left-most vertical line) lies on, or to the right of, the best (right-most) “bar” of the dominated option(s);
- if optimization requires minimizing value (e.g., costs), the worst “bar” of the dominant option (its right-most vertical line) lies on, or to the left of, the best (left-most) “bar” of the dominated option(s).

The kinds of problems in which decision analysis is applied will not often display deterministic dominance, however. Stochastic dominance is more likely. Conditions of stochastic dominance — also called extended or probabilistic dominance — are identified as follows:

- if optimization requires maximizing value, the entire outline describing the stochastically dominant option lies to the right of the dominated option’s outline — the lines can touch for part of the graph, but never cross;
- if optimization requires minimizing value, the outline describing the stochastically dominant option lies on, or to the left of, the dominated option’s outline.

8.8 Expected value of perfect information (EVPI)

Assume that you could buy information that perfectly predicted the outcome of a future uncertainty. What would this information be worth to you?

In a decision tree, the option to acquire perfect information (about a single uncertainty) can be modeled by moving the chance node representing the uncertainty to the left of a decision.

Although the uncertain event still follows the decision in time, the decision maker is assumed to have a perfect predictor of the event outcome before making the decision. Keep in mind that perfect information does not mean that you can control the event’s outcome, only that you can predict the outcome.

Ignoring for the moment the cost of the perfect information, the revised tree cannot have a worse expected value than the original tree, and may have a better expected value. This difference in expected value is referred to as the expected value of perfect information (EVPI).
While predictive information is rarely perfect, the usefulness of EVPI is in calculating a maximum reasonable price for information. If perfect information in a particular situation has a base value of x, one should certainly not pay more than x for imperfect information. To see how imperfect information is dealt with in decision analysis, see the Bayes’ Revision Chapter.

Monte Carlo simulation in TreeAge Pro can be used to calculate expected value of perfect information for any number of predictable or resolvable uncertainties; refer to the Monte Carlo Simulation Chapter.

8.8.1 How EVPI is calculated

Before trying TreeAge Pro’s shortcut for calculating EVPI in a decision tree, it is instructive to work through the extra steps required to calculate EVPI manually.

- Open the Business tutorial example model, Stock Tree.
- Also open the Business tutorial example model, Perfect Information. This version of the investment problem shows the time reversal of the Market uncertainty and the decision.

The two trees are shown below.

To calculate the EVPI manually:

- Roll back Stock Tree. The tree’s expected value is $50 (equal to CD paying 5%’s value).
- Roll back the Perfect Information tree. The root node’s expected value is $205.
- To calculate EVPI, take the difference between the expected value of the Stock Tree and that of the Perfect Information tree. The difference is $155. (If you were minimizing costs rather than maximizing profit, you would subtract the perfect information value from the regular expected value.)

In the investment model, the expected value of having perfect information about the market activity is $155. This is the most you should be willing to pay to obtain this information, and it affords some basis for appraising to you the value of a less than perfect predictor of market activity.

Now, try TreeAge Pro’s shortcut for calculating EVPI in a tree. It requires only the original Stock Tree.

To calculate EVPI automatically:
- Open the Stock Tree.
- Select the Risky investment chance node and choose Analysis > Expected Value of Perfect Info.

A dialog reports the value of $155.

It is also possible to calculate EVPI automatically in a decision tree when the same event appears in more than one strategy, as in example shown below. The assumption in the model is that each of the two stock investments under consideration is followed by the same uncertainty — whether the market will be up or down at the end of the year.

In order to calculate EVPI in this model, both market uncertainty chance nodes must be selected.

To calculate EVPI for the same chance node in multiple paths:
- Before choosing Analysis > Expected Value of Information, select all nodes in the tree which represent the same event.

If multiple chance nodes are analyzed, they:
- must be descendants of the same decision node;
- must be “siblings”; and
must have identical branches using identical probabilities. It does not matter if there are
differences in the subtrees further to the right.

If there is more than one decision prior to the selected chance event, TreeAge Pro will prompt you to
identify the decision for which EVPI should be calculated.

8.8.2 Avoiding EVPI errors

It is important to understand that it is possible to force invalid EVPI calculations. For example,

- Open the Oil Drilling Problem tree again.
- Select the Drill for Oil node in the No Soundings subtree and choose Analysis > Expected Value
  of Perfect Info.

In the resulting dialog boxes, you are presented with the option of having the analysis performed at the
root, soundings decision node or at the drilling decision.

Performing the calculation at the No Soundings node is similar to the analysis undertaken above in
connection with the EVPI tree. It certainly makes sense to calculate the value of knowing the state of
oil reserves before deciding whether or not to drill.

However, what if you perform the EVPI calculation at the root decision node? The value reported is
$437,632, significantly higher than at the No Soundings node. Is this a meaningful EVPI calculation?

The structure of the tree already includes the option of securing imperfect information in the form of
a seismic test — this is the initial decision. Performing EVPI by placing the chance node representing
the uncertain amount of oil to the left of this decision is meaningless. Having already received perfect
information, the decision as to whether to obtain additional imperfect information regarding the same
subject should have no value or relevance. Refer to the Bayes’ Revision Chapter for more information
on imperfect information.

8.9 Other Analyses

The last section of this chapter covers three simple analysis tools.

This chapter does not cover all analyses. Refer to later sections of the user's manual for information
on additional analysis options:

- Sensitivity analysis using variables is covered in the Variables and Sensitivity Analysis and More
  Sensitivity Analysis Tools Chapters. This includes 1-, 2-, and 3-way sensitivity analysis, as well
  as tornado diagrams.
- Monte Carlo probabilistic sensitivity analysis using inputted parameter distributions is covered in
  Monte Carlo Simulation and Distributions Chapters.
- Markov cohort analysis and microsimulation are covered in the Building and Analyzing Markov
  Models and Individual-Level Simulation and Markov Models Chapters.
- Cost-effectiveness analysis is covered in the Cost-Effectiveness and Cost-Effectiveness Simulation Chapters.

### 8.9.1 Range of possible payoffs

This analysis will tell you the highest and lowest payoffs which may occur from the selected node in your tree.

*To view the minimum and maximum payoffs in a subtree:*

- Select a node, and choose Analysis > Payoff Range.

![Payoff Range from root node of Oil Drilling Problem model](image1)

Payoffs from all terminal nodes are included in this analysis, not just those in the optimal path.

### 8.9.2 Over/under probabilities

The Over/Under analysis calculates the probability of achieving an outcome with a payoff over a target value, and the complementary probability of an outcome under the target.

*To calculate the over/under probabilities:*

- Select a node and choose Analysis > Over/Under….
- Enter a target value. Indicate whether payoffs equal to the target value should be included in the “under” range. Press enter or click OK.

![Over/Under from root node of Oil Drilling Problem model](image2)
Over/Under analysis only includes outcomes reached assuming the decision maker follows the optimal path at decisions.

### 8.10 Excluding Strategies from Analyses

TreeAge Pro allows you to exclude specific strategies from all analyses. When excluded, a strategy will not be presented in the analysis results. The Get Started tutorial example model, Climber Cost, is used to illustrate this technique.

**To exclude a strategy:**

- Right-click on the strategy node you wish to exclude.
- Choose Exclude Strategy from Analysis from the context menu.

The strategy is then marked as excluded by placing hash marks on its branch connector, coloring the branch connector grey and by collapsing the subtree.

Climber Cost model with top strategy excluded, coloring the connector grey.

See how roll back and rankings exclude the strategy.

Roll back with top strategy excluded and the preferred strategy highlighted in green.

<table>
<thead>
<tr>
<th>Rank</th>
<th>Strategy</th>
<th>Value</th>
<th>Incremental Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Use experimental antibiotic</td>
<td>23625</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>Amputate foot</td>
<td>24000</td>
<td>375</td>
</tr>
</tbody>
</table>

Rankings with strategy excluded
Other analyses such as Monte Carlo simulation would also exclude the strategy.

*To reverse the strategy exclusion:*

- Right-click on the strategy node you wish to exclude.
- Choose Include Strategy in analysis from the context menu.
9. Graph Windows

This chapter includes details on customizing, printing and exporting TreeAge Pro graphs.

9.1 Customizing graphs/charts

Whenever TreeAge Pro displays a graph, you will see two links to the right of the graphical output (specific graph types will provide additional links).

1. *Edit Chart*: Customize the graph’s appearance.

This section focuses on options associated with Edit Chart. The next few subsections focus on general graph customization. We will use the probability distribution graph generated from the *Risky investment* strategy of the Get Started tutorial example tree “Stock Tree” to examine these customizations. However, they are not limited to probability distribution graphs.

9.1.1 Changing the chart type and orientation

A probability distribution graph is a standard bar graph. If you click the Edit Chart link, an Edit Chart dialog opens providing a large number of options for the graph.
Edit Chart Dialog - Select Chart Type tab

The first tab is labeled "Select Chart Type". This allows you to change the chart type from "Bar" to some other format. In the case of a Probability Distribution, you probably would not change the chart type, but the option is there.

Within the selected chart type, there are subtypes and other properties. For example, you could change the Dimension option to 2D With Depth, and the chart would look like this.
Bar graph with depth

You could also change the orientation by flipping the axes. Then the graph would look like this.

Bar graph with flipped axes

9.1.2 Changing the chart data

The second tab in the Edit Chart dialog is "Select Data".
9 Graph Windows

**Edit Chart Dialog - Select Data tab**

These options allow you to select different data from the graph's text report. Note that the text report data is presented in this tab when the "Show data preview" option is selected. In general, TreeAge Pro will select the data that is appropriate for the graph. These options should only be used with care.

### 9.1.3 Changing the chart format

The third tab in the Edit Chart dialog is "Format Chart".
Edit Chart Dialog - Format Chart tab

The Format Chart tab allows you to change chart attributes like the chart title, hide/show legend, etc via the selections in the left frame.

In addition, you can change formatting options related to the X-axis and Y-axis by selecting the axis in the left frame, then clicking the Format button.
9 Graph Windows

Edit Chart Dialog - Format axis

That will open the Edit Format dialog, which allows you to edit the formatting of the selected axis.

Edit Format Dialog

After the changes are applied, the graph's X-axis is reformatted.

---

93
9.1.4 Changing the chart data scale

You can also change the data scale by clicking the Scale button with one of the axes selected. This allows you to change the minimum, maximum and step values for the selected axis.

9.2 Customizing Histograms

Although a probability distribution was used to illustrate general graph customization options, there are also some options specific to any type of histogram.

We will refer to probability distribution graphs as histograms throughout the Help files but we can use these terms interchangeably.

All histograms group data together and then divide the total range into a number of bars. By default, TreeAge Pro creates bars that start/stop on regular intervals (e.g., 100K, 200K, etc.) with an assumed default of 20 bars. The number of bars will increase/decrease based on the actual data being reported.
You can override the default settings to customize the presentation data via a dialog that opens when you first generate a histogram, or when you click the "Redo Histogram" link to the right of the graph.

We will use the Special Features Example model Distributions.trex to demonstrate these options. This "model" does nothing except generate the distributions when we run Probabilistic Sensitivity Analysis.

**Generate histogram of distribution samples**

- Open the Distributions view.
- Select the Table distribution, Dist_Table
- In the toolbar for the Distributions view select the "Graph It" icon.
- Select "OK" to use the default number of samples and generate the graph below. See below for setting different Histogram parameters.

**Histogram of distribution samples for the Dist_Table distribution**

In TreeAge Pro, most probability distributions will include a Redo Histogram link to the right of the graph. This allows you to redraw the graph with more or fewer bars. You can also control the number of bars more precisely, as described below.

**Histogram settings**

To customize the Histogram parameters use the Histogram Settings dialogue which is generated when you create a histogram or when you "Redo Histogram" which is an option in the menu on the right hand side of every histogram.

- Create a Histogram.
- In the Histogram Settings dialogue, select Custom Histogram parameters.
- Select either the Interval Size or the Number of Bars.
Histogram Settings dialog

Histogram parameters

- **Custom Interval Size.** This will set the size of the interval of each bar. (Option is to either select Interval Size or Number of Bars).
- **Custom Number of Bars.** The bar width will be generated according to the number of bars entered here taking into account the Bar Max and Bar Min. (Option is to either select Interval Size or Number of Bars).
- **Bar Min.** Change this value from the default to the required minimum bar value.
- **Bar Max.** Change this value from the default to the required maximum bar value.
- **Trend Line.** Select this box to add a trend line to the histogram. To remove, select to redo the histogram and un-select.

The Histogram Settings box will appear everytime you generate a histogram. If you don't want to see it and want to use the default parameters, then check the box at the bottom. Once the histogram is generated, you have the option to "Redo Histogram" from the tool bar to the right-hand side of the graph.

If you selected to not see the default parameters and want to change the option, go to the menu: Window > Application Preferences > Analysis Tools > Histograms and uncheck the box.

*Example: Table Distribution*

The Histogram generated from Dist_Table uses the default settings which display all the discrete values in the table. We can demonstrate changing the interval size with this Histogram Settings dialogue. Firstly, look at the table of values the Histogram is drawn from and see how the histogram above represents each row in the table with corresponding probability.

- Edit the histogram of the distribution of samples for Dist_Table by selecting Redo Histogram.
- In Histogram Settings select Custom.
- Change the interval size to 2.
- Select OK.

Histogram of distribution samples for Dist_Table with custom settings, i.e. interval size 2.

Raw data in Sample_Table in the example model Distributions.trex

In the customized histogram, the interval sizes has increased to two and now incorporate two rows of data rather than one. This changes the probability for each bar, in this instance the probability is doubled due to the nature of the discrete data.

Example: Normal Distribution

The histogram generated from Dist_Normal generates the graph below showing the typical Normal shape. The graph can be edited through the Histogram Settings using the Custom selection, as above.
9.3 Customizing cost-effectiveness graphs

This section describes customization options specific to cost-effectiveness graphs.

The graph below was generated by running cost-effectiveness analysis from the root node of the Health Care tutorial example tree "Extended Dominance".
Cost-Effectiveness Graph

Even before the graph is generated, you are offered the option to show the graph with options inverted. You can also generate the inverted graph by clicking the "CE Graph (inverted)" link. The inverted graph is presented below.
Cost-Effectiveness Graph - Inverted

Another option on this graph is to hide extended dominance lines. Clicking on that link removes the horizontal and vertical lines associated with extended dominance.

Cost-effectiveness graphs show not only points for each strategy, but also use markers for dominated strategies versus undominated strategies. Because of this, changing the chart type and other formatting options can cause unexpected effects on the graph. You can still make changes to scale and most other graph properties.

9.4 Customizing line graphs

This section describes customization options specific to line graphs. The following graph was generated from a CE one-way sensitivity analysis. Specifically, this is the x vs ICER graph.
Line graph

Note that the x-axis labels are impossible to read because the values are formatted with too many decimal places. This can be adjusted via the Edit Chart Dialog, Format Chart Tab.
Edit Chart Dialog - X-axis formatting

Select the X-Axis in the left pane then click the Format button. Then change the Fraction Digits to 2. See below.
You could also use this dialog to add a custom prefix or suffix to the values.

Let's say you also wanted to add a horizontal line to the graph to highlight the ICER value of 35,000. Select the X-Axis in the left pane then click the Markers button. In the Axis Markers dialog, click the Add Line button, then set the value and properties of the line.

The example above creates a red horizontal line at ICER value 35,000. The combination of the changes above generates the following graph.
9.5 Customizing scatterplot graphs

This section describes customization options specific to scatterplot graphs. The graph below was generated from a probabilistic sensitivity analysis simulation on the Health Care tutorial example model CE Markov Sampling. Specifically, the graph is an ICE scatterplot comparing Rx A to Rx B.
ICE scatterplot

You might want to change the X-axis scale to show the 0 value for Incremental Effectiveness. This is described earlier in this chapter.

You might also want to change the plot marker format in the Format Chart tab by selecting the appropriate series and clicking the Marker button. In the example below, the Series markers are changed from circles to triangles.
Edit scatterplot - change marker type

Note that if the scatterplot has more than one data series, change the second, third, etc. marker type in the Series Marker dialog to adjust those series.

To change the color of the points in the scatterplot:

- Click the Edit Chart link.
- Select the Format Chart tab.
- Select the category Series (not Value (Y) Series).
- Click the Series Palette button at the bottom of the dialog (may need to scroll down).
- Click on the down arrow to the right of the first palette and select the color you want.
- Click Finish in the main Edit Chart dialog.
Edit scatterplot - change series color

You might also want to reduce the number of points presented in the scatterplot if the scatter is too dense.

- You can do this by setting a filter on the data points in the Select Data tab.
- Click the Filters button.
- Then add a filter to limit the data points to be displayed.

How to reduce the number of points presented:

In the example below, a filter was added to show only the bottom 20 pct of the simulation iterations based on the iteration number. The iteration number is not correlated with any output measure, so you introduce no bias into the new graphical output.
Beyond standard scatterplot options, the ICE scatterplot has a few specific options that are available under the category ICE Scatterplot in the left frame. This allows you to change the number of points to draw, whether to draw the ICER line, the ICER line's slope and the size of the dots in the scatterplot. See below.
Edit scatterplot - options specific to the ICE scatterplot

The Confidence Interval subcategory allows you to create a custom confidence interval rather than using the default 95% confidence interval. See below.
Edit scatterplot - confidence interval

The net result of all these changes yields the following graph format.
9.6 Customizing region graphs

To change the pattern/color of the regions in a region graph:

- Click the Edit chart link.
- Select the Format chart tab.
- Choose the category "Series".
- Click the Series Palette button.
- Click on the first bar and an option arrow will appear at the right of the bar.
- Click on this arrow to change first bar to the desired color or pattern.
- Repeat the prior two steps for additional entries in the palette list as needed.

9.7 Printing, exporting and saving graphs

Graphs can be printed, exported and saved via the TreeAge Pro menu or the tool bar when the graph is selected.

To print a graph:

- Select the graph.
- Choose File > Print from the menu OR select the printer icon from the tool bar.

To copy a graph to insert directly into a document:

- Select the graph.
- To copy the graph and paste a copy into a document, choose from the menu Edit > Copy OR click the Copy icon to the top-right of the graph pane.
- The Copy Chart Image appears, as in the figure below, to select the type of image you want to copy as (jpeg, png, bmp) and to select the Image dimensions and Scale.

![Copy Chart Image](image)

Copy Chart Image appears when copying a graph to insert directly into a document.

To save a graph as an image file:

- Select the graph.
- Choose File > Save As from the menu OR use the Save Image icon in the tool bar.
- Enter the file name and location in the Save Chart As Dialog. (See below)
- Choose an image file format for the file Type such as JPG or PNG.
- Enter the appropriate image dimensions and scale.
- Select Save.
To save a graph in its native TreeAge Pro format:

- Select the graph.
- Choose File > Save from the menu.
- Select the file name and location in the Save Chart As Dialog. (See below)
- Leave the Type as RPTX.
The RPTX format is the native report output format for TreeAge Pro. You can open the RPTX file in TreeAge Pro any time in the future to see the graph and/or text report.
10. Tree Calculation Methods and Preferences

Any single tree may be calculated and evaluated in a variety of ways, simply by switching between different payoffs, or from single- to multi-attribute calculations. This chapter covers tree calculation method preferences, including two kinds of multi-attribute calculation methods.

An additional multi-attribute calculation method, Cost-Effectiveness, is available to users of the Healthcare module; refer to the Building and Analyzing Cost-Effectiveness Models for details.

Other chapters cover the other preferences categories; refer to the Preferences Chapter for an overview of all preferences.

10.1 Changing what the tree calculates

Some basic tree calculation preferences were introduced at the end of the Decision Tree Tutorial Chapter and the beginning of the Analyzing Decision Trees Chapter:

- the calculation method
- the active payoff(s)
- the optimal path criterion
- numeric formatting

Note that a set of Tree Preference Values can be stored in a Preference Set.

To view in detail the tree’s current calculation method, or to make changes to these settings, open the Preferences dialog.

To view/edit the calculation method preferences:

- Choose Tree > Tree Preferences from the menu.
- Select the category Calculation > Calculation Method.
10.1.1 Selecting calculation method

The choice of calculation method determines the formula used to calculate values for nodes in your tree. There are two kinds of calculation methods:

- Simple, single-attribute calculations;
- Multiple-attribute calculations, including: Benefit-Cost and Multi-Attribute (weighted);
- Healthcare module users can use a third form of multi-attribute calculations, Cost-Effectiveness.

Simple calculations are just that — expected values are calculated for the nodes in the tree based simply on the values in the active payoff set. If, as described above, your tree included multiple attributes — such as monetary benefits in payoff #1 and costs in payoff #2 — the two sets of payoff values could be combined in a single calculation using the Benefit-Cost calculation method’s formula.

To change the calculation method:

- Roll back must be turned off.
- With the Preferences dialog open to the Calculation Method category, select the radio button for the appropriate calculation method.
- If you select a calculation method for the first time in a particular tree, the settings for payoffs, optimal path criterion, and numeric format may need to be modified.

**Calculation method notes:**

- Changing calculation method (or other) preferences will not affect the content of your tree. Values or formulas already entered in payoff #1 will not be lost by switching the active payoff set from #1 to #2, for example. Only the calculation and display of values will be affected; the changes to the calculation preferences can be reversed at any time.
- When the Preferences dialog is closed, TreeAge Pro updates the information in the status bar. If you have switched Simple calculations to use payoff 3, “Payoff 3” will appear in the status bar. If you select Benefit-Cost using payoffs 4 and 2, the status bar will read “B-C, 4-2.” If you select Multi-Attribute, then “MultiAttr” will show in the status bar.

Additional Tree Preference categories contained within the Calculation Method group are used to specify preferences associated with each calculation method. These categories are described in subsequent sections.

10.1.2 Calculation method "Simple"

The Simple Tree Preferences category is presented below.
Tree Preferences - Simple Calculation Method

**Optimal path**

All calculation methods in TreeAge Pro require you to specify how decisions should be made in the tree (i.e., during roll back). This is done using the option labeled *Optimal path*.

The default optimal path criterion used for new trees is High, unless you save new default Preference Set. This setting would be changed if, for example, you were modeling project costs (to find the strategy with the lowest expected cost).

To set the optimal path criterion:

- Select the tree and press the F11 key to open the Tree Preferences dialog.
- Select the category Simple within the Calculation Method group.
- Next to the label Optimal path, select the radio button for either High (maximize expected values) or Low (minimize expected values).

For a tree set to High (e.g., one whose payoffs are in terms of life expectancy), at each decision node TreeAge Pro will select the alternative with the *highest* numeric value.

For a tree set to Low (e.g., one whose payoff formula is in terms of costs), the alternative with the *lowest* numeric value is selected.

Each of the nine payoff sets stores its own optimal path criterion for Simple calculations, and each form of multi-attribute calculations also has its own optimal path setting.

**Active payoff**

In TreeAge Pro, you can enter any number of payoffs at each terminal node. In a Simple analysis, you can use any one of the enabled payoff/reward sets. The *Active payoff* tree preference is used to select the active payoff for the Simple Calculation Method.

The *Active payoff* option will allow selection of any enabled payoff set. Based on the default Preference Set, two payoff sets are enabled, but this can be changed in the Payoffs Tree Preferences category.

To change the active payoff:

- In the Calculation Method/Simple preferences, select a payoff set in the Active payoff field.
- When you change to a new Active payoff for the first time in a tree, ensure that you select the appropriate optimal path criterion and numeric formatting for that payoff.

### 10.1.3 Calculation method "Cost-Effectiveness"

The Cost-Effectiveness Tree Preferences category is presented below. Note that this calculation method is only available if your license includes the Healthcare Module.

#### Cost payoff

Select the payoff set to use for cost calculations from among the enabled payoff sets.

#### Effectiveness payoff

Select the payoff set to use for effectiveness calculations from among the enabled payoff sets.

Both the above controls work the same as the Active payoff in the Calculation Method/Simple preferences.

#### Additional cost-effectiveness options

Additional Tree Preferences related to the cost-effectiveness calculation method are described in the next two sections.

### 10.1.4 Calculation method "Cost-Effectiveness", C/E Parameters

The Cost-Effectiveness, C/E Parameters Tree Preferences category is presented below.
10.1.5 Calculation method "Cost Effectiveness", Weighted Multi-Attribute

Content of the new section ...

![Image of Preferences - Weighted Multi-Attribute Costs]

10.1.6 Enabling payoffs

TreeAge Pro supports any number of distinct payoffs sets (attributes) in a tree. By default, only two payoff sets are enabled, but this can be changed via the Payoffs Tree Preferences category.

![Image of Preferences - Payoffs]

**Calculate extra payoffs**

Check this box to calculate all enabled payoffs rather than calculating only the active payoffs for the Calculation Method. This option is described in detail in the next section.

**Number of enabled payoffs**

Select the number of payoff sets to enable within the model. For example, if you change the number of enabled payoffs to 5, then payoff sets 1 through 5 will be enabled.

10.1.7 Calculate extra payoffs

It is possible to calculate the tree and optimize at decision nodes based on the current active payoff method and set(s), but report expected values for other payoff sets. For example, you could roll back the tree based on minimizing costs in payoff #1, but also report expected values for some types of utility attributes which you have entered in payoffs #2 and up.

In the Payoffs Tree Preferences category, check the box labeled *Calculate extra payoffs*, and adjust the *Enable payoffs* setting to control how many extra payoff sets will be calculated.

If *Calculate extra payoffs* is checked, extra payoffs are included in several analyses outputs.

- Extra payoffs are reported in Rankings report in the last columns of the report. The column headings will use any custom payoff names given to the extra payoffs.
- Extra payoffs are included in Monte Carlo simulation output and its secondary reports.
- Extra payoffs are included in Markov Cohort Analysis (Quick) output.

If you activate the calculation of extra payoffs, you must fill in the enabled payoff sets at all terminal nodes, even though they are not specifically required by the current calculation method. Under Multi-attribute calculations, weight values must be specified for every enabled extra payoff. Use a 0 weight to exclude an extra attribute from the regular, weighted expected value calculation (this will not zero the extra payoff’s reported value).

To illustrate the Rankings Report with calculate extra payoffs enabled, consider the Healthcare tutorial example tree MarkovExtraPayoffs.trex.

This example has 5 payoffs enabled, including Cost and Effectiveness. The model is calculated using the active payoffs of Cost and Effectiveness but displays the additional 3 payoffs in the rankings report in the last 3 columns, as illustrated in the figure.

### Cost-Effectiveness Rankings

<table>
<thead>
<tr>
<th>Category</th>
<th>Strategy</th>
<th>Cost</th>
<th>Incr Cost</th>
<th>Eff</th>
<th>Incr eff</th>
<th>Incr C/E (CER)</th>
<th>NMB</th>
<th>C/E</th>
<th>Preg to Metastases</th>
<th>Local Cancer Death</th>
<th>Metastases Death</th>
</tr>
</thead>
<tbody>
<tr>
<td>Excluding dominated</td>
<td>undominated</td>
<td>457,947</td>
<td>11.53</td>
<td></td>
<td></td>
<td></td>
<td>118,051</td>
<td>20,799</td>
<td>0.91</td>
<td>0.06</td>
<td>0.06</td>
</tr>
<tr>
<td></td>
<td>undominated</td>
<td>468,940</td>
<td>10,964</td>
<td>31.72</td>
<td>0.19</td>
<td>56,938</td>
<td>137,312</td>
<td>29,993</td>
<td>0.90</td>
<td>0.06</td>
<td>0.67</td>
</tr>
<tr>
<td>All</td>
<td>undominated</td>
<td>457,947</td>
<td>11.53</td>
<td></td>
<td></td>
<td></td>
<td>118,051</td>
<td>20,799</td>
<td>0.91</td>
<td>0.06</td>
<td>0.68</td>
</tr>
<tr>
<td></td>
<td>undominated</td>
<td>468,940</td>
<td>10,964</td>
<td>31.72</td>
<td>0.19</td>
<td>56,938</td>
<td>137,312</td>
<td>29,993</td>
<td>0.90</td>
<td>0.06</td>
<td>0.67</td>
</tr>
<tr>
<td>All referencing common baseline</td>
<td>undominated</td>
<td>457,947</td>
<td>11.53</td>
<td></td>
<td></td>
<td></td>
<td>118,051</td>
<td>20,799</td>
<td>0.91</td>
<td>0.06</td>
<td>0.68</td>
</tr>
<tr>
<td></td>
<td>undominated</td>
<td>468,940</td>
<td>10,964</td>
<td>31.72</td>
<td>0.19</td>
<td>56,938</td>
<td>137,312</td>
<td>29,993</td>
<td>0.90</td>
<td>0.06</td>
<td>0.67</td>
</tr>
<tr>
<td>All by increasing effectiveness</td>
<td>undominated</td>
<td>457,947</td>
<td>11.53</td>
<td></td>
<td></td>
<td></td>
<td>118,051</td>
<td>20,799</td>
<td>0.91</td>
<td>0.06</td>
<td>0.68</td>
</tr>
<tr>
<td></td>
<td>undominated</td>
<td>468,940</td>
<td>10,964</td>
<td>31.72</td>
<td>0.19</td>
<td>56,938</td>
<td>137,312</td>
<td>29,993</td>
<td>0.90</td>
<td>0.06</td>
<td>0.67</td>
</tr>
</tbody>
</table>

Rankings report with extra payoffs displayed in the last 3 columns

### 10.2 Calculations using multiple attributes

While many analyses will require only one attribute (e.g., cost), some models may have multiple attributes (e.g., benefits and costs) or different perspectives on the same attribute (e.g., societal, personal, or institutional costs of disease).

TreeAge Pro includes two basic calculation methods that combine multiple payoffs: benefit-cost and weighted multi-attribute calculations. (If you have the optional Healthcare module, a third calculation method using multiple payoffs is available: Cost-Effectiveness. See the Healthcare module documentation for details.)

The first step in preparing a multi-attribute model is setting the calculation preferences.

*To select a multi-attribute calculation method:*
- Select the tree and press the F11 key to open the Tree Preferences dialog.
- Select the category Calculation Method.
- Change the Calculation Method pop-up menu selection from Simple to one of the multi-attribute options.
- If you select Benefit-Cost...
  - Select the Benefit/Cost category (see below).
  - Select two payoff sets to represent the two attributes in your tree.
  - The optimal path will automatically be High (maximize value).
- If you select Multi-Attribute...
  - Select the Multi-Attribute category (see below).
  - Select the Optimal path option.
  - Enter a weight for each enabled payoff.

![Tree Preferences - Benefit/Cost Calculation Method](image1)

![Tree Preferences - Multi-Attribute Calculation Method](image2)

### 10.2.1 Entering multiple payoffs

With both kinds of multiple-attribute models — benefit-cost and multi-attribute — you will enter at least two payoffs at each terminal node. The process of entering multiple payoffs values at a terminal node is very simple — the payoff sets in the Enter Payoff window correspond to the Use payoff selections made in the Preferences dialog.
10 Tree Calculation Methods and Preferences

Enter Multiple Payoffs at Terminal Node

If a multi-attribute calculation method is used, the payoff titles in the window will indicate which payoffs are to be used. For benefit-cost, they will be labeled “Benefit” and “Cost.” For weighted multi-attribute models, they will be labeled by payoff set number (as above).

If you require more payoff sets in your model (e.g., for weighted multi-attribute calculations), you can enable additional payoffs.

10.2.2 How benefit-cost calculations are performed

This calculation will subtract the cost of a scenario, represented by one payoff, from its benefit, represented by a different payoff. Therefore, both attributes in a benefit-cost analysis must be measured in the same monetary units. All analyses available under Simple calculations (1-, 2-, 3-way sensitivity analysis, for example) are also available under the Benefit-Cost calculation method.

This calculation does not divide costs by benefits, as is done in some forms of cost-benefit analyses. To create a custom cost/benefit analysis calculation method, refer to the section on the Calculate extra payoffs preference and the Node() function.

10.2.3 How weighted multi-attribute calculations are performed

Unlike the Benefit-Cost calculation method, the weighted Multi-Attribute calculation method does not require that all attributes/payoffs be assigned using the same units. Instead, a linear equation is set up that combines up to nine payoffs; attributes given a non-zero weighting are made part of the multi-attribute calculations.

For example, if you assigned a weight of 1 to Attribute 1 and a weight of 0.5 to the next three attributes, each terminal node would be evaluated based on the expression Attribute 1 + 0.5 * Attribute 2 + 0.5 * Attribute 3 + 0.5 * Attribute 4.

Variables (see Variables Chapter) can be used in the weighting expressions. This is useful when there is uncertainty concerning how much one factor should be weighted versus another.

Weightings are entered through the Multi-Attribute Tree Preferences category within the Calculation Method group (see earlier section).

All analyses available under Simple calculations are available under Multi-Attribute calculations as well.
10.3 Roll back analysis options

Before dealing with multiple-attribute analysis methods, let’s look at some calculation preferences related to roll back.

Typically, roll back boxes display the expected value of each node, along with the path probability at terminal nodes. TreeAge Pro can display a variety of other calculated values during roll back; these are described below.

To change the quantity to be calculated during rollback:

- Select the tree and press the F11 key to open the Tree Preferences dialog.
- Select the category Calculation Method.
- Select an option from the group labeled Rollback calculates.

Here is a brief description of the other options:

- **Expected values**: Display the expected values (the default setting) at all nodes.
- **Payoffs only**: Display only the values of terminal nodes. Optimal paths will be indicated using hash marks and colored lines, but no expected values will be displayed.
- **Path probabilities**: Suppress the display of expected values. Path probabilities are calculated for all terminal nodes (does not take into account the optimal path). If there are any decision nodes, the sum of the path probabilities of all terminal nodes will be greater than 1.0.
- **Maximin**: Consider only the most pessimistic possibility at each uncertainty, regardless of probabilities. Then, at each decision point, the best option is selected. More details are provided in the following section.

10.3.1 Maximin and minimax roll back

Maximin calculations may be useful during early stages of certain models, before probabilities have been assigned to the tree. Here, specifically, is how a tree is rolled back under Maximin:

- The value assigned to every chance node is equal to the worst (least optimal) value of any of its potential outcomes. **Probabilities are ignored**, and may be left blank.
- The value assigned to every decision node is equal to that of the best alternative, as usual.

![Information Tip]

If you use the Options > Reverse Optimal Path command at selected decision nodes, these nodes will work like chance nodes, as described above.

Maximin calculations take a pessimistic view of events. They are based on the idea that one way to deal with risk is to identify the worst case scenario for each alternative and then select the strategy which yields the best of these worst case scenarios.

Below is a picture of the example file Rock Climber using Maximin roll back. The value of the Treat foot strategy is simply its worst outcome, which is the patient dying (utility = 0). The Amputate foot option has no uncertainty, and it is simply equal to its payoff. The decision then maximizes between the available options, as usual.

![Rock Climber - Roll back with Maximin](image)

In a Maximin roll back of a tree whose optimal path preference is set to High, the roll back boxes at chance nodes will be labeled MIN: at decision node the boxes will be labeled MAX:, in order to indicate the operation being performed. These prefixes are switched if the optimal path preference is set to low (minimization).

### 10.4 Regional/international numeric settings

By default, the regional numeric settings specified in your operating system determine which character TreeAge Pro will recognize as a decimal separator when you enter numbers — usually either a “.” or a “,” — and which character, if any, represents a thousands separator.

For example, your computer’s settings are used to decide whether the entered number:

1,375

should be interpreted with comma = decimal as

1 + 375/1000

or with comma = thousands separator as

1375
The operating system’s regional settings are also, by default, used by TreeAge Pro to determine what decimal and thousand separator characters are used in displaying calculated values.

However, TreeAge Pro includes preferences that enable particular trees to override the operating system’s regional numeric settings, allowing you to specify which characters to use for decimal and thousands separators.

To enable custom regional numeric settings in a tree:

- Select the tree and press the F11 key to open the Tree Preferences dialog.
- Select the category Regional Settings.
- Check the box Use custom regional numeric settings.
- Modify the regional settings options as necessary.

These settings will apply when this particular model is opened, modified, and analyzed on any computer, no matter what the operating system’s regional numeric settings.

These settings are particularly useful when sharing models with colleagues in other countries.

10.5 Overriding the optimal path at decision nodes

TreeAge Pro selects an optimal path at decision nodes based on the calculation method preferences covered in previous chapters.

At a selected decision node, you can force TreeAge Pro to apply the opposite optimal path criterion to that specified in the tree’s preferences.
To change the optimal path for a given decision node:

- Select the decision node.
- Choose Node > Change Optimal Path from the menu.

The decision node will reappear with an arrow inside it. The arrow will point upward if that decision node has been reset for maximization, or downward if the node has been reset for minimization. If you reverse the optimal path for an entire tree in which the optimal path of one or more nodes has been individually changed, the arrows in all of the individually changed nodes will reverse, signifying that they remain different from the rest of the tree.

To revert back to the original optimal path selection, simply repeat the steps above.
11. Selecting Subtrees and Multiple Nodes

While some tree-building tasks require that a single node be selected, other operations can, or must, be performed on multiple nodes. This chapter describes the different methods used to select multiple nodes.

11.1 Selecting a subtree

In decision trees, a subtree refers to a part of a tree. A node’s subtree is comprised of all nodes and branches to its right (its “descendants”), but *not including the original node* (the subtree’s root).

A few tree-building operations — copying, pasting, cutting, clearing, and cloning — require a special method for selecting a subtree.

To select a subtree:

- While holding down the *CONTROL* key, click on the subtree’s root node.
- ... OR ...
- Right-click on the subtree’s root node and choose “Select Subtree” from the context menu.

The figure below shows the result of selecting the *Risky Investment* node’s subtree. Note that the *Risky Investment* node itself is not selected.

![Select subtree](image)

11.2 Selecting multiple, unrelated nodes

TreeAge Pro offers several methods for selecting multiple, unrelated nodes. These techniques can be used when changing node types, entering payoffs, and a few other tasks.

To select a set of unrelated nodes:

- Select any node.
- While holding down the *SHIFT* key, select another node by clicking on it. Continue adding to the selection using the same shift-clicking operation.

**To remove nodes from the selection:**

- Hold down the *SHIFT* key and click, one after the other, on each of the selected nodes that you wish to deselect.

It is possible to select multiple nodes by dragging a selection rectangle around them.

**To select several adjacent nodes:**

- Click and drag to create a selection rectangle that encloses the adjacent nodes you wish to select.
- Release the mouse button.

**Select Multiple Adjacent Nodes**

Note that you must enclose the entire node line and label for each node you want to select via the selection rectangle.

### 11.3 Selecting multiple nodes by characteristic

TreeAge Pro allows you to automatically select sets of nodes that share a node type or a position in the tree.

**To select multiple nodes by characteristic:**

- Choose **Tree > Select Nodes If** from the menu.
- Choose a selection method in the left pane of the Select Nodes If Dialog.
- Select the options associated with that method in the right pane of the Select Nodes If Dialog.
- Click OK.

This Select Nodes If Dialog is presented below.
Select Nodes If Dialog
12. Making Changes to Tree Structure

Building a tree is often a process of frequent revision. Also, new tree projects can often make use of subtrees from existing models. This chapter starts with a review of the basic tree building commands from the Get Started - Build a Decision Tree Model Chapter, and then covers a set of features designed to help you move, remove, and duplicate parts of a tree (called “subtrees”).

12.1 A note on tree terminology

In tree models, familial terms are often used to help identify particular nodes and branches based on their relative locations.

- Nodes in its path back to the root node are its ancestors.
- Nodes in the paths to its right are its descendants.
- Branches of a parent node are its children.
- Branches of a parent node are also each other’s siblings.

12.2 Tree building and navigating the tree

Here is a quick review of some of the basic tree-building commands introduced in the Get Started - Build a Decision Tree Model Chapter.

To add branches:

- Select a node.
- Click the ‘Add branches’ toolbar icon which will add two branches.
- ... OR ...
- Drag a node from the Tree Diagram Editor Palette to the right of the existing node. A red line will appear indicating where the node can be placed. Release the mouse when the new node is visible as a branch of the existing node.
- ... OR ...
- Right-click on the node and select ‘Add Branch’ from the context menu.

To delete a branch:

- Select the node.
- Choose Edit > Cut from the menu to cut the node from the model.
- ... OR ...
- Right-click on the node and choose Cut from the context menu.

Note that branches can also be cut by performing the control + X keyboard shortcut.

To change a node’s type:
- Right-click on the node.
- Select Change Type from the context menu and select the new node type.
- ... OR ...
- Select a node.
- Click the "change node type" icon on the toolbar.
- Select the appropriate node type from the list.

To zoom in or out of the Tree Diagram Editor:

Use the palette within the Tree Diagram editor:

- Click on the zoom in or zoom out icons (magnifying glass) in the palette toolbar.
- Click on the model in the Tree Diagram Editor to recenter the model with the new zoom perspective.
- Click on the pointer/arrow in the palette toolbar again to turn off the zoom in/zoom out.

Navigating the tree using the keyboard:

In addition to using the mouse to select a particular node, it is also possible to use the keyboard to change the selected node.

Even if no node is currently selected, there is a keyboard shortcut that will select the root node.

To select the root node:

- Hold down the CONTROL key and press the HOME key.

To move the selection from the current node to an adjacent node, use the arrow keys. Try using the arrow keys to select the top branch.

To move the selection one node to the right:

- Press the right arrow key.

12.3 Editing a single node vs. subtrees

Many revisions to tree structure can be accomplished by inserting, deleting, or moving one node/branch at a time, or by changing the order of branches emanating from a node.

The Cut, Copy, and Paste commands described later in this chapter can be used to efficiently carry out similar, but more complex, tree modifications – including inserting, deleting, and reordering subtrees, as well as duplicating nodes or subtrees.
12 Making Changes to Tree Structure

12.4 Inserting nodes/branches

Nodes/branches can be inserted into a model in one of two ways - via the node context menu and via the Modeling Palette.

Note that inserted branches can be removed using the Undo command by selecting Edit > Undo from the menu or clicking CONTROL + Z on the keyboard.

12.4.1 Insert node via context menu

The Insert Branch options, in comparison to Add Branch, provide greater control over how and where new branches and nodes are created. In addition to the Add Branch functionality, Insert Branch can be used to add a sibling above or below a selected branch, or to make “generational” changes — i.e., inserting a node between a “parent” and its “children.”

To insert a new node into a model via the context menu:

- Open the Get Started tutorial example tree, Rock Climber.
- Right-click on the chance node “Treat foot”.
- Select Insert Node > To Left from the context menu.

Insert branch

A new branch, ending in a chance node, is inserted between the root, decision node and the "Treat foot" node. See below.
Repeat the menu command, but try different directions to see what happens.

- Right-click on the chance node "Treat foot".
- Select Insert Node > To Right from the context menu.

This time a new branch is inserted after the "Treat foot" node, whose existing branches are now attached to the new chance node. See below.

After inserting branch to right

- Right-click on the chance node "Treat foot".
- Select Insert Node > Above from the context menu.

In this case, the new node is added as a higher sibling of the "Treat foot" branch. See below.

After inserting branch above

If a new node were inserted below the "Treat foot" node, the new node would be added as a lower sibling of the "Treat foot" branch.

12.4.2 Insert node via Modeling Palette

Nodes can also be inserted into a model by dragging a new node from the Modelling Palette into the Tree Diagram Editor.

First select the node type you wish to insert from within the options in the Modelling Palette. See below.
Select node type in Modelling Palette

Then drag the new node into the model where you want the new node inserted. Release the mouse button when the node is in the correct place.

The four figures below show how to insert a new node to the left, right, above, and below the "Treat foot" node.

Insert/drag node to the left

Insert/drag node to the right
12.5 Moving/reordering nodes

In prior versions of TreeAge Pro, a separate dialog was used to reorder branches. However, starting with TreeAge Pro 2011, moving/reordering nodes is handled by drag and drop functionality within the Tree Diagram Editor.

The prior section described how to insert nodes by dragging new nodes from the Modelling Pallete. The same drag and drop options can be used with nodes that already exist within the model.

To move a node within a model:

- Click on an existing node.
- Drag it to a new location within the model.
- Release the mouse button when you reach the proper destination location.

For example, you can reorder the branches of the "Treat foot" node in the Rock Climber tree by dragging the "Foot saved" node below the "Infection not cured" node. See below.
After dragging the node, the branches are reordered. See below.

After move/reorder node

Be careful moving nodes that are not endnodes (furthest to the right). For example, if you move the "Infection not cured" node back below the "Foot saved" node, the subtree anchored at the "Infection not cured" node will not automatically move with the node.

To move a node and its subtree together, first collapse the subtree, then move the node (see below). Alternatively, you can select the node and all the nodes in the subtree, then move the node to its new location.

Move/reorder bode with subtree

12.6 Deleting nodes/branches

You can delete any node from the model.

To delete a node:

- Select the node.
- Right-click on the node and select Delete from the context menu.
- ... OR ...
- Choose Node > Delete from the menu.

Refer to the next section for information on deleting/cutting nodes that are not end nodes.
12.7 Cut, copy, and paste nodes and subtrees

Frequently, sections of a tree can be reused in another part of the same tree, or a different tree that you are working on. TreeAge Pro allows you to select a node, a set of nodes, or an entire subtree, copy or cut it, and then paste it to one or more nodes in any open tree.

In addition to being able to duplicate and move subtrees in the Tree Diagram Editor, it is also possible to manipulate subtrees using the mouse and CONTROL key in the Tree Explorer View. Refer to the Tools and Functions for Complex Trees Chapter for details on working in the tree explorer.

Besides text, tree nodes, and subtrees, other items that can be copied and pasted in TreeAge Pro include dependency diagram nodes, variable definitions, and links with Excel. Items that can be copied from, but not pasted into, TreeAge Pro include text reports, model images, and graph images.

12.7.1 Cut/copy/paste a single node

The Cut, Copy, and Paste commands are available for any node or set of nodes.

To copy a node:

- Select a node.
- Select Edit > Copy from the menu.
- ... OR ...
- Click CONTROL + C on the keyboard.
- ... OR ...
- Right-click on the node and select Copy from the context menu.

Once copied to the clipboard, the node can be pasted to any node as a new branch. It can be pasted to any non-terminal node (branches not allowed) in the same tree or a different one. All aspects of the node (i.e., probability, payoff, variable definitions, etc.) are included with the copy.

To paste a copied node:

- Select any single node that is not a terminal node.
- Select Edit > Paste from the menu.
- ... OR ...
- Click CONTROL + V on the keyboard.
- ... OR ...
- Right-click on the destination node and select Paste from the context menu.

After being pasted, the copied node remains in the clipboard, and can be pasted at additional locations. It will remain in the clipboard until something else replaces it in the clipboard — including from an application other than TreeAge Pro.
It is also possible to cut a node — i.e., remove it from its current location, in order to paste it in a new location.

To cut a node:

- Select a node.
- Select Edit > Cut from the menu.
- ... OR ...
- Click CONTROL + X on the keyboard.
- ... OR ...
- Right-click on the node and select Cut from the context menu.

Special care must be taken when cutting and/or pasting anything other than a single endnode (i.e., any node without branches, except the root node). These actions can sometimes cause unexpected shifts in the model structure.

Note that you can always use the Undo command (CONTROL + Z) to undo the last changes to the model.

Consider what happens if you cut a node that is not an endnode.

**Cut non-endnode**

If you cut the node "Infection not cured" in the model above, the cut node's branches all shift to the left to become descendents of the original node's parent, in this case the "Treat foot" node. See below.

**After cutting non-endnode**

The chance node "Infection not cured" can then be pasted elsewhere, but its descendents are not pasted with it. However, if you first collapse the subtree (Node > Collapse Subtree in the menu), then the subtree is copied with the node.
12 Making Changes to Tree Structure

12.7.2 Cut/copy/paste a subtree

Duplicating large tree structures, rather than building each one from scratch, can both save time and avoid errors. In many trees, some alternatives will be structural identical or closely similar, differing perhaps in particular probabilities or payoffs.

Before a subtree can be copied, it must be selected.

To select a subtree:
- Right-click on a single node that has branches attached (i.e., not an endnode) and choose "Select Subtree" from the context menu.
- ... OR ...
- Hold down the CONTROL key and click on a single node that has branches.

When the subtree is selected, all the descendents of the "subtree root" will be selected while the "subtree root" itself will not be selected as it is not considered part of the subtree itself. The collection of nodes in the selected subtree can then be copied or cut. In the figure below, the subtree eminating from the "Treat foot" node was selected.
Once a node’s subtree is selected, the Copy Subtree command becomes available.

**To copy a subtree:**

- Choose Edit > Copy from the menu.
- OR ...
- Click CONTROL + C on the keyboard.

Once copied to the clipboard, the subtree can be pasted to any non-terminal node — one with or without branches, in the same tree or a different one.

**To paste a subtree:**

- Right-click on any single non-terminal node and choose Paste from the context menu.
- OR ...
- Select any single non-terminal node and click CONTROL + V on the keyboard.

⚠️ If you want to carry all information (e.g., Markov, DES) from the source subtree to the pasted subtree, be sure the source and destination subtree root nodes have the same node type.

In the figure below, the "Treat foot" subtree was copied to the new node "Treat foot copied subtree".

![Tree Diagram](image)

**After pasting subtree**

Note that the node “Treat foot copied subtree” above was not created by the copy and paste subtree functions. That node was created separately.

To move a subtree, rather than duplicate it, use the Cut Subtree commands.

**To cut a subtree:**

- Select a subtree as specified above.
- Choose Edit > Cut from the menu.
- OR ...
- Click *CONTROL + X* on the keyboard.

This will cause the subtree (but not the subtree’s root) to be removed from the tree and placed on the clipboard. As with a copied subtree, when a subtree is cut to the clipboard, the Paste Subtree command becomes available.

### 12.7.3 Cut/copy/paste multiple nodes

When a subtree is cut/copied/pasted, the structure of the subtree is maintained to preserve the parent/child relationships among the nodes. When an assortment of nodes are selected, there may or may not be parent/child relationships among the nodes. Therefore, special care must be taken to ensure that the cut/copy/paste functions change the model as desired.

For example, if you select the three nodes as shown below, there is a parent/child relationship among the nodes. Therefore, those nodes could be copied and pasted to another location while maintaining those relationships in the pasted destination (i.e., the nodes "Patient dies" and "Leg amputated" will remain children of the node "Infection not cured").

**Select multiple nodes with parent/child relationship**

However, in the next figure, there is no parent-child relationship among the selected nodes. Therefore, the selected nodes would all be pasted as branches of the destination node.

**Select multiple nodes without parent/child relationship**

It is also possible to cut/copy/paste a set of nodes where there are parent/child relationships among some of the nodes and not among others. In such a case, existing parent/child relationships will still be maintained.
12.8 Cut, copy, and paste text

It is possible to cut, copy, paste, and delete text in node descriptions, as well as in probabilities, payoffs, and any other formulas or values you type in TreeAge Pro.

Before cutting, copying, or deleting text, you must select the targeted letters, numbers, or words.

To select individual characters of text or formulas:
- Either use the mouse to: a) click and drag from one end of the desired selection to the other; or b) click in front of one end of the selection, and then shift-click after the other end.

To select one or more words of text (or a formula):
- Use the mouse to either: a) double-click on the first word of the selection and drag to the last word; or b) double-click on the first word of the selection, and then shift-double-click on the last word.

Once the text is selected, then you can choose the appropriate command from the Edit menu.

To copy (duplicate) selected text:
- Choose Edit > Copy.
- ... OR ...
- Click CONTROL + C on the keyboard.

To cut (move) selected text:
- Choose Edit > Cut.
- ... OR ...
- Click CONTROL + X on the keyboard.

The Copy and Cut commands both place the selected text on the clipboard. The text on the clipboard can then be pasted into any TreeAge document, or into another program.

The Cut, Copy, and Paste commands can also be accessed by right-clicking on the selected text and choosing the command from the context menu.

The Paste Text command can be used to insert text or formulas both place the selected text on the clipboard. This text can then either be pasted into any TreeAge document, or into another program.

To paste (insert) text:
- Place the text cursor in the desired location.
- Choose Edit > Paste.
- ... OR ...
- Click CONTROL + V on the keyboard.
Selected text can be deleted without placing it on the clipboard by pressing the *DELETE* key or the *BACKSPACE* key.

**12.9 Multiple clipboards**

TreeAge Pro has four tree clipboards, where one is active at any one time. This means, in effect, that you can cut or copy subtree X without losing subtree Y that is currently on the active tree clipboard. *Prior* to cutting or copying another subtree, simply activate one of the empty tree clipboard’s by selecting it in the Edit menu.

*To select a different clipboard:*
- Choose Edit > Tree Clipboard > Clipboard # from the menu.

**12.10 Undo and Redo**

Each tree (and dependency diagram) retains in memory details of the last actions that you took. Beginning with the most recent action and working back one action at a time, you can remove most all changes to structure, values, preferences, etc.

*Note that the Undo “chain” is broken by some analysis and tree-building commands – TreeAge Pro will usually warn you also if a command cannot be undone.*

*To undo a change to your model:*
- Choose Edit > Undo.
- ... OR ...
- Click *CONTROL* + Z on the keyboard.

If you go back too far in undoing modifications to the model, you can use the Redo command, also found in the Edit menu. The Redo command essentially allows you to undo previous Undo action(s).

*To redo an undone change to your model:*
- Choose Edit > Undo [action].
- ... OR ...
- Click *CONTROL* + *SHIFT* + Z on the keyboard.

**12.11 Find and replace text, formulas, and values**

You can quickly search for and modify text and formulas at nodes in a tree using the Find/Replace tool. With some exceptions, this is often the best way to fix the spelling of a word used frequently in a
tree, or to change a formula that appears in many payoffs, definitions, or other expressions. It is also often useful for simply finding particular nodes.

12.11.1 The Search Tree Dialog

To open the Search Tree dialog:

- Choose Tree > Find from the menu.
- ... OR ...
- Click CONTROL + F on the keyboard.
- The search dialog will default to "Search Open Trees" tab with "Search active tree only" checked. This will search only the currently active model.

The Search Tree dialog allows you to find and/or replace specific text in certain portions of the model or throughout the entire model.

12.11.2 Find Text

To find text in a tree:

- Open the Search Tree dialog.
- Enter text in the box labeled "Find what".
- Choose the matching options ("Whole word only" and "Case sensitive").
- Choose one or more search location(s).
- Click the Search button.
If you check the "Whole word only" option, TreeAge Pro will not search for partial word matches. If "Case sensitive" is checked, matching text must have the same combination of upper and lower case letters as the search text that you specify.

The locations refer to portions of the tree which should be searched for the search text.

The search results are then presented in the Search View.

**Search Tree View**

In the above example, the search text was "0.65". The nodes that include that text are presented in the Search View. Each nodes can be expanded/collapsed. When expanded, the node property or properties that contain the search text are displayed. If you double-click on the node (or its property), the node will be selected in the Tree Diagram Editor.

### 12.11.3 Replace Text

*To replace text in a tree:*

- Open the Search Tree dialog.
- Enter text in the box labeled "Find what".
- Choose the matching options ("Whole word only" and "Case sensitive").
- Select one or more search location(s).
- Click the Replace... button.

The Replace Text Matches dialog will open to prompt you to enter the replace text.
Replace Text Matches Dialog

You then have two options for replacing text. If you click OK, all occurrences of the Search Text that fit both the matching options and search locations will be replaced.

If you click Preview, then a Replace Text Matches preview dialog shows all replacements that could be made by this action.

Replace Text Matches Preview Dialog

The Replace Text Matches preview dialog allows you to examine all the changes that would be made to the model, including the differences in the file structures between the "before change" and "after change" file states. You can select which of the changes you want made, then click OK to process the changes.

The Replace command is not recommended for changing a variable's name. Instead, edit the variable's properties in the Variables and Tables list.
12.12 Using the Probability Wheel View

A frequent problem encountered in decision analysis is the assignment of subjective probability assessments to chance events. Many people find it easier to use a graphical aid in assigning probabilities. One tool designed for this task is a probability wheel. TreeAge Pro provides this functionality through the Probability Wheel View.

The Probability Wheel View is a tool for assigning probabilities to each branch of a selected Chance node. The Probability Wheel View works whether or not you have already assigned probabilities to the branches. If you have assigned probabilities, they will be used as initial values for the wheel. Each branch will be assigned its own colored portion of the wheel.

As an example, the probability wheel could be used to aid in assigning relative weights to the two outcomes of the risky investment in the Get Started tutorial example tree, Stock Tree, used in earlier chapters.

To open the Probability Wheel View:

- Select a chance node with branches.
- Choose Views > Probability Wheel from the toolbar.

The probability wheel shows sections of the wheel to represent the probability associated with each branch. Drag the pointers around the edge of the wheel until the sizes of the section match your best assessment of the relative likelihood of outcomes.
If the selected node has three or more branches, you will see a check box named "Keep proportions". If checked, the probability bounded on the right side by the selected marker is changed independently, while ratios are maintained for the remaining probabilities.

Click the mouse button on any wedge to display the numeric value (probability) of that wedge. Right-clicking will display that wedge’s starting value.

Click the OK button to apply the probabilities from the Wheel to the branches of the selected Chance node. If you don’t want to use the new branch probability values, just close the Probability Wheel View or select another element in the Tree Diagram Editor.

The probability wheel should only be used to edit probabilities that are entered as numerical expressions. Other expressions can be converted to numerical expressions within the probability wheel to allow for editing.

Note that it is also possible to store the probability values from the probability wheel in variable definitions. To do so, you must first create the variable(s) via the Variable Properties View. After adding two variables $p_{\text{increaseLarge}}$ and $p_{\text{increaseSmall}}$ to the model and clicking off and back onto the Risky Investment node, additional options are shown in the Probability Wheel View. See the figure below with both the Probability Wheel and Variable Properties View displayed.
The new variables can now be selected for storage of the probability values from the wheel as shown below. Note that the complement "#" was selected for the third branch.

After clicking the Update Branches button, the variables are defined at the specific branches with the value from the probability wheel as shown below.
Variable definitions created by Probability Wheel

You might choose to move those variable definitions to the root node to make them accessible in other areas of a model.
13. Annotating the Tree

In addition to the basic ability to enter text labels at event nodes in the tree, TreeAge Pro includes a number of other options for annotating trees covered in this chapter.

The next chapter covers a variety of options for controlling the layout, formatting, and contents of decision trees.

13.1 Node label options

13.1.1 Text wrapping

Every node in a tree has a node label that is used to describe the purpose/function of a node. Entering node label text has been covered in earlier chapters. However, this section will describe how to control text wrapping of the node label.

In past versions of TreeAge Pro, node label text would not wrap unless you entered a carriage return (via the ENTER key). In TreeAge Pro 201x, the node label text wraps automatically based on the width of that node generation.

Also, in TreeAge Pro 201x, if you click the ENTER key when entering the node label, the currently entered node label text will be stored with the label and application control leaves the node label. You can still force wrapping at specific points in the text by clicking CONTROL + ENTER on the keyboard.

The keyboard command to force wrapping on a Mac is also CONTROL + ENTER.

Since the node no longer stretches to accommodate the length of the node label text, you can now stretch a node generation via the ruler at the top of the Tree Diagram Editor.

In the figure below, the top node's label forces the text to wrap several times.
Node label text wrapped - before stretching node generation

Note the “tab pointer” in the ruler that is highlighted above. By dragging the “tab pointer” to the right, the entire node generation is stretched to make more room to display node label text, variable definitions, etc. See below.

Node label text wrapped - after stretching node generation

A node generation represents the set of nodes that are aligned vertically within the model. The ruler can be used to stretch a node generation, but it cannot be used to shrink the node generation beyond the standard minimum length.
13.1.2 Text formatting

TreeAge Pro supports multiple fonts, font styles and font sizes. The Fonts category of Tree preferences control the default text formatting for specific elements of a tree (e.g., node labels, probabilities, etc.). However, you can also set text formatting to a specific node label.

To change the text formatting for a specific node label:

- Right-click on the node and choose Format > Font from the context menu.
- Set the formatting options for the node label using the following Font dialog.

13.2 Label nodes

A label node, which uses a simple black “zigzag” as its symbol, acts like a placeholder. Label nodes have no impact on calculations, and cannot have more than one branch. A label node (or a series of them) can be inserted between event nodes to more clearly identify additional steps in a particular path.

To add a label node before an event node:

- Right-click on the event node and choose Insert Node > To Left from the context menu.
- Right-click on the new node and choose Change Type > Label from the context menu.

You could also change an existing endnode to a label node, and then use the Add Branch or Insert Node command to add the one allowed branch to the label node. A node with more than one branch cannot be changed to a label node.

For calculation purposes, a label node behaves like a decision node with one branch, or a chance node with one branch having a probability of 1.0. The value of the label node is simply the value of the node immediatly to its right.
You can use a label node to separate dependent calculations. For example, you might have a tracker variable that is used in an expression, but the tracker needs to be assigned a new value before it is used in the expression. In such a case, you could insert a label node to the left of the node with the expression. Then you could assign the new value to the tracker in the label node. The tracker will then have the new calculated value when you reach the node with the expression the references that tracker.

13.3 Notes and arrows

Models often benefit from the use of longer explanations than are desirable in branch descriptions. Node comments, described in the previous section, are useful for the model builder, but not for someone looking at a printout or image of the model.

Using notes and arrows, you can provide the model's audience with an overview of the whole model, or specific nodes or subtrees.

13.3.1 Creating notes

Any number of notes can be created. Boxes are initially placed independent of any node, but can be bound to particular nodes if desired. Each box can use a different font, but all must use the same outline format (solid/dashed/none).

To draw a note in a tree:

- Click on Note in the Tree Diagram Editor Palette. The mouse cursor becomes crosshairs.
- With the mouse, click and drag somewhere in the Tree Diagram Editor. Make the box large enough to hold the text you wish to enter.
Create note

A yellow rectangular box is created that resembles a "Post-It" note. Within the box is a blinking text insertion caret, indicating that text can be entered in the note by typing. Text entered in the note will automatically wrap to the width of the box. If you enter text that does not fit into the box, the visible text will be truncated with an ellipsis (…) indicating that some text is not visible. Resize the note to display additional text (see next section).

After note is created and text is entered

The font of the active note can be changed. Each note can use a different font, but all text within a single note uses the same font.

To change the font of a note:
- First deselect the node by clicking elsewhere in the tree.
- Right-click near the edges of the note box (away from the text), and choose Format > Font from the context menu.
- Select the font options from the font dialog.

To see what the note will look like when printed, deselect it by clicking elsewhere in the tree.

The other options in the right-click context menu can be used to change the note's other visual characteristics, including text, fill, and line color.

To change the note outline:

- Right-click on the note and choose from the Format > Line Color or Line Type sub-menus.

### 13.3.2 Changing text in a note

To change the text in a note, you must first activate the text.

To activate the text in a note:

- Select the note box, and then press the F2 key.
- ... OR ...
- Click three times on the text in the note. (The first click selects the note shape, the second selects the text box within the note shape, and the third activates the text insertion caret within the text.)

Once the text is activated, you can modify the text by typing or using standard editing commands (BACKSPACE, DELETE, cut/copy/paste, etc.).

### 13.3.3 Moving, resizing, hiding and deleting notes

In order to move, resize, or delete a note, you must first select it. A note that is activated for text entry, displaying the blinking text caret, is not selected.

To select a note:

- Click once on the note.

The selected note will display a small square with "handles" at each of its four corners and on each of its sides. These handles are used to resize the note.

To resize a note:

- Move the mouse over one of the note's handles until the cursor appears as a double-sided resizing arrow.
- Click on the handle.
- Click and drag the handle to change the size and proportions of the note.

The corner handles allow you to resize both the height and width of the note, while the side handles only allow you to resize one or the other dimension.

To move a note:
- Click on the note and drag it to the desired location.

The right-click context menu can be used to cut, copy or delete a note.

To delete a note:
- Right-click on the note and select Cut or Delete from the context menu.

The context menu's Copy command can be used to copy a note into the clipboard. The main menu's Edit > Paste command can then be used to create a duplicate copy of the original note.

### 13.3.4 Displaying/Hiding all notes

When notes are placed in a model, it may sometimes be useful to hide all the notes which have been created.

- Open Tree Preferences > Display > Node Text/Comments.
- Check the box "Hide all notes" to either hide/unhide all notes.

### 13.3.5 Binding a note to a node

When a note is placed in a model, it remains fixed in place relative to the top left corner of the tree window, and will not adapt to changes made to the tree. If nodes are added or deleted, for example, an existing note may overlap another object. This problem can be avoided by binding a note to a node.

To bind a note to a node:
- Click on the note and drag it just above the node to which you want to bind your note.
- When the red line appears above the node, release the mouse button.
Bind note

The bound note will be aligned directly above the selected node, and will move with the node as the tree structure changes. The width of the note will be tied to the width of the bound node, and the text will automatically wrap to display all text.

After binding note

You can resize the node generation to better accommodate the contents of the bound note.
13 Annotating the Tree

A bound note box can still be cut/deleted via the right-click context menu.

13.3.6 Creating arrows

You can draw arrows in conjunction with annotating a tree. Arrows are generally used to associate an unbound note with one or more nodes.

To draw an arrow from a note to a node:

- Click on the Arrow in the Modeling Palette.
- Move the mouse to the note. When over the note, the cursor shape will be an arrow without the "not allowed" character.
- Click on the note and hold down the mouse button.
- Drag the mouse to the node.
- Release the mouse.

When the Arrow option is selected from the Modeling Palette, the mouse pointer will change to the shape of an arrow with a "not allowed" character. When the mouse is over an element in the Tree Diagram Editor that is valid for an arrow connector, the "not allowed" character will disappear.

By default, the arrow will be displayed as a dotted line with no arrow markers at either end. However, the arrow's format can be edited. The figure below shows a note with arrows to three nodes. The format of each arrow is different, and the formatting context menu (via right-click) is shown.
13.4 Node comments

Detailed comments can be assigned to the branches of a node and saved with the tree. Unlike notes and branch labels, the text of node comments is hidden.

Node comments are particularly useful for recording the basis on which probability assignments were made for the branches of a chance node.

To add node comments:

- Select a node that has at least one branch.
- Choose Node > Node Branch Comments from the menu.
- Enter node comments.
- Click Save.
Edit Node Comments Dialog

The dialog allows you to enter notes for each branch of the selected node. The notes can be formatted using the formatting toolbars. Formatted comments generate HTML output.

A red flag will appear above any node for which node comments have been entered. See below.

Node comments shown in Tree Diagram Editor and Node Properties View
Node comments can also be seen in the Node Properties View. Click on the ellipsis button to edit the node comments for the selected branch. See above.

To remove node comments, delete the text in the Edit Node Comments Dialog.
14. Tree Display Preferences and Options

This chapter covers a wide variety of options for controlling the layout, formatting, and appearance of trees. Some of these features apply to calculated values displayed following roll back, while others affect display of the tree’s structure.

14.1 Collapsing/hiding subtrees

The Collapse Subtree command can be used to temporarily hide any subtree (including the root node’s subtree). It is particularly helpful when working with or presenting large trees.

To collapse a subtree:

- Select a node with visible branches.
- Choose Subtree > Collapse Subtree (or \texttt{CONTROL} + \texttt{J} on keyboard).

Collapsed subtree

The subtree emanating from the selected node is hidden and a plus sign (+) is displayed in its place, to the right of the node. The plus sign will also appear in place of the hidden subtree in printouts and exported images of the tree. Collapsing a subtree does not affect calculations.

14.1.1 Expanding hidden subtrees

Hidden subtrees can be uncollapsed in two ways: showing one generation of branches; or unhiding the entire subtree.

To expand a collapsed subtree one generation at a time:

- Select a node with a plus sign to the right.
- Choose Subtree > Expand Subtree Once (or \texttt{CONTROL} + \texttt{SHIFT} + \texttt{J} on keyboard).

The branches of the selected node will be displayed, but any subtrees attached to these branches will remain hidden and plus signs are displayed in their place.

To expand an entire collapsed subtree:

- Select a node with a plus sign to the right.
- Choose Subtree > Expand Subtree Once (or \texttt{CONTROL} + \texttt{ALT} + \texttt{J} on keyboard).
14 Tree Display Preferences and Options

Visible clone copies (see Complex Trees Chapter) can be collapsed. Collapsing a subtree in the tree explorer pane does not collapse the subtree in the regular tree view.

14.2 Aligning selected nodes

TreeAge Pro includes two options for adjusting the vertical alignment of nodes in a tree. This section deals with the use of the Skip Generation command to make manual adjustments to the vertical alignment of selected nodes. It is also possible to specify that all terminal nodes be vertically aligned automatically; this is covered in a later section, on tree display preferences.

In many trees, asymmetry in intervening events results in the related nodes not lining up vertically. It is sometimes desirable to force these related nodes to line up, resulting in a more intuitive layout of the tree.

To align a selected node with a node in a different subtree:

- Select a node.
- Choose Node > Skip Generation (or \textit{CONTROL} + \textit{J}).

This will extend the length of the selected node by one node generation and moves the selected node’s subtree to the right.

Skip generation

Skipping one or more generations can be used to line nodes up vertically — for example, the multiple nodes representing a particular decision, in different paths. To skip more than one generation, simply select the menu command repeatedly.
To reverse the effects on the tree, simply un-skip generations at the node which skips a generation.

To remove an extra generation from the selected node:

- Select a node which is set to skip a generation.
- Choose Node > Unskip Generation (or CONTROL + [].

Skipping generations does not affect calculations.

14.3 Displaying terminal columns/roll back columns

When a tree is rolled back, TreeAge Pro normally displays next to each terminal node a roll back box containing the node’s calculated payoff and, in an optimal path, its path probability. Previous chapters described some of the customizations that can be made to the roll back display.

Instead of showing the standard roll back boxes at end nodes, a tree can be set up to display user-defined columns of values to the right of visual end nodes during roll back.

Calculated values and other information that can be displayed in roll back columns include:

- payoffs, including extra (non-active) payoffs
- individual components of a complex payoff formula
- path probabilities
- scenario (i.e., terminal node) numbers

Roll back column options

Some important features of roll back columns include:

- During roll back, the table of values can be copied to a spreadsheet or other applications for reporting or further analysis.
- A row will be displayed for every visual end node, even those that are not terminal nodes — for example, if a node’s subtree is collapsed (see above) or is a hidden clone copy (refer to the Complex Trees Chapter), a row is shown for the node at the base of the collapsed subtree.
- Calculated values can be displayed using custom numeric formatting.

Terminal column features

To add terminal columns in your model:

- Choose Tree > Tree Preference from the menu to open the Tree Preferences Dialog.
- Select the category Display > Terminal Columns.
- Check the "Show terminal columns" box.
- Click the "plus" button to add a terminal column.

Note that you can uncheck the "Show terminal columns" box later to return to regular payoff calculations without losing the terminal column preferences.
There are five columns in the terminal columns grid.

1. **Header**: Text to display above the column.
2. **Calculation**: Type of calculation to perform.
3. **Custom calculation**: Expression to calculate if Calculation value is "Custom".
4. **Numeric format**: Existing format option to apply to column.
5. **Custom**: Check to enter a custom format for this column

**Columns in terminal columns grid**

There are five Calculation options.

1. **Custom**: Enter any expression in the Custom calculation column.
2. **Expected Value**: The payoff value for the active payoff set.
3. **Incremental Value**: The difference in value between strategies.
4. **Path Probability**: The cumulative probability of reaching that terminal node. Only shows the recommended strategy.
5. **Scenario Number**: Counts from the top terminal node to the bottom.

**Calculation options**

The Special Features tutorial example tree “Terminal Columns” illustrates the use of terminal columns. Note the terminal columns from the tree preferences.

**Terminal Columns in Tree Preferences**

The terminal columns display...

1. **Expected Value** - the EV calculated for the active payoff (2).
2. **Custom** - Node(1) - calculate the EV for a non-active payoff (1).
3. Custom - Total_Cost - calculate the value of the variable at the terminal node.
4. Path Probability - the path probability for each terminal node of the recommended strategy.
5. Custom - PathProb() - the path probability for every terminal node.
6. Custom - PathProb() * Total_Cost - the EV multiplied by the path probability

When you roll back the tree, the terminal columns are displayed to the right of each terminal node.

Terminal Columns roll back

Terminal columns are a convenient way to show extra payoff values at each terminal node. Note that the "Calculate extra payoffs" tree preference must be checked to output additional payoffs.

When you roll back a model with terminal columns, you are given the option to export the terminal column data to a tab-delimited *.xls file in the same folder as the model.

Export terminal column data dialog

The file can then be opened in Excel. If you do not have excel, you can open the tab delimited file in a text editor.

14.4 Other tree display preferences

Each tree created in TreeAge Pro can be given its own distinct set of display preferences. Refer to the Tree Preferences Chapter for settings not covered here.
14.4.1 Hiding and boxing payoffs

By default, the active payoff formula is displayed at each terminal node when the tree is not rolled back. This information can be hidden if, for example, you want to simplify a visual presentation of the tree.

To hide terminal node payoff formulas:
- Choose Tree > Tree Preferences from the menu or press the F11 key to open the Tree Preferences dialog.
- Select the Terminal Nodes preference category.
- Uncheck the option labeled Display payoff names, and press ENTER or click OK.

Stock tree with payoffs hidden

Or, the tree’s payoffs can be displayed in boxes, even when the tree is not rolled back.

To enclose payoffs in boxes when the tree is not rolled back:
- In the Terminal Nodes preferences category, check the option labeled Display payoff names and the option labeled Boxed.

14.4.2 Hiding probabilities and branch labels

The numbers or formulas entered for probabilities can be hidden from view. Node branch labels can also be hidden.

To turn off the display of probabilities and/or node names:
- Choose Tree > Tree Preferences from the menu or press the F11 key to open the Tree Preferences dialog.
- Select the Node Text/Comments preference category.
- Check the option labeled Hide probabilities only, or the option labeled Hide all node texts. Press ENTER or click OK.

14.4.3 Displaying a "skeleton" tree

The skeleton tree display option has not yet been implemented.
14.4.4 Terminal node numbers

To show scenario/terminal node numbers:
- Choose Tree > Tree Preferences from the menu or press the F11 key to open the Tree Preferences dialog.
- Select the Terminal Nodes preference category.
- Check the option labeled Automatic node numbering.
- Enter the Numbering text format. The default entry will simply number the nodes.
- Press ENTER or click OK.

The text you enter for terminal node numbering must use the caret (“^”) as a placeholder for the node number. The caret can be used alone or with additional text, as in "Outcome ^". The terminal node number and text will be displayed whether or not the tree is rolled back.

14.4.5 Number all nodes

Instead of just numbering terminal nodes, TreeAge Pro can apply the numbering format you specify to all nodes in the tree.

To show node numbers for all nodes:
- In the Terminal Nodes preferences, check the option labeled Automatic node numbering. Refer to instructions in prior section.
- Also check the sub-option All nodes in tree.

14.4.6 Increasing or decreasing vertical white space

If two branches that are vertical neighbors appear too close together, there is a way to increase the space between them.

To increase the vertical spacing between two nodes:
- Click on the bottom branch’s text label, to the left of the first word in the label.
- Press CONTROL + ENTER one or more times, inserting carriage returns until you have created sufficient white space.
- Press ENTER to commit the text edits.
A tree can be compressed vertically, reducing white space and yielding a very compact tree.

To compress a tree vertically:

- Choose Tree > Tree Preferences from the menu or press the F11 key to open the Tree Preferences dialog.
- Select the Tree Editing/Layout preference category.
- Check the option labeled Minimize empty space. You must first ensure that Align endnodes is not selected.
- Press ENTER or click OK.

The figure below illustrates how TreeAge Pro compresses the display of the tree.

This tree preference does not yet account for the position of payoffs. Notice the payoff for the bottom strategy is presented on top of another node. You can increase vertical white space in conjunction with this tree preference to correct this error manually until this issue is resolved.

If the display of your tree looks broken when the Minimize empty space setting is turned on, review these potential conflicts:

- The Minimize empty space and Align endnodes settings are incompatible.
- Minimize empty space can cause problems when a tree is rolled back, because of a lack of space for roll back boxes.
- Using both the Minimize empty space and Branch lines at right angles settings can result in branch lines which slice through node symbols.
- Minimize empty space is likely to cause problems with the display of terminal node columns.

### 14.4.7 Vertically aligning terminal nodes

There is a quick way to align all terminal nodes in a tree with the right-most terminal node.

**To align all terminal nodes at the right edge of the tree:**
- Choose Tree > Tree Preferences from the menu or press the F11 key to open the Tree Preferences dialog.
- Select the Tree Editing/Layout preference category.
- Check the option labeled Align endnodes.
- Press ENTER or click OK.

![Tree with end nodes aligned](image)

For instructions on aligning specific nodes in the tree, refer to the Aligning selected nodes section at the beginning of this chapter.

### 14.5 Changing fonts

The font, size, and style of any text that appears in a tree can be easily changed. Fonts can either be changed for selected objects or globally, via a tree’s preferences.

#### 14.5.1 Changing the font of selected objects

You can change the appearance of text within the model. You can modify the node font for the following attributes: node label, probability, expected value and variables. Each attribute can use a different font.

For notes, the only attribute available is the node text.

**To change the font of the selected node:**
- Right-click on a single node.
- Choose Font > [Attribute] from the context menu.
  
  Each [Attribute] option refers to different text that can be associated with a node.
- Select the font preferences from the Font dialog and click OK.

Once a selected node’s font has been modified, it is independent of the tree’s global font preferences, described in the next section. Changes made to the tree’s font preferences will not affect the selected node.

Fonts can be changed for multiple selected nodes and/or subtrees in the same manner as above, using the right-click menu on one of the selected nodes.

Fonts can also be changed for notes by right-clicking and choosing Font from the context menu.

### 14.5.2 Changing font preferences

The Fonts Tree Preferences category makes it possible to specify, for the entire tree, the font used for node names, probabilities, expected value boxes, and (if displayed) definitions of variables. Each button calls up the standard font, size, and style dialog, but changes made in those dialogs apply only in the limited context that their names reflect.

The **Node Font** button will change the branch text font for nodes subsequently created in the tree. It is also applied to existing nodes in the active tree, with the exception of selected nodes and subtrees at which you have individually changed the font.

The **Prob Font** button will change the probabilities font for the active tree. Like the Node Font, this is used for new nodes and existing nodes in the active tree, with the exception of nodes and subtrees at which you have individually changed the probability field font.

The **EV Font** button allows you to change the font for roll back boxes displayed upon roll back of the active tree.

The **Variables Font** button allows you to change the font for variables displayed beneath nodes in the active tree, if you elect to display full variable definitions in the tree.
15. Introduction to Variables and Sensitivity Analysis

This chapter provides a basic tutorial on the use of variables and one-way sensitivity analysis in decision trees.

Subsequent chapters cover TreeAge Pro’s many useful tools for working with variables, as well as more complex, multi-way and probabilistic sensitivity analysis. In particular, refer to the first sections of both the Building Formulas Chapter (on defining variables non-numerically) and the More Sensitivity Analysis Tools Chapter (on avoiding sensitivity analysis problems).

Some users may wish to refer to the Index to find out more about special uses of variables in Markov microsimulation, user-defined Python functions, and clones.

15.1 Sensitivity analysis background

Sensitivity analysis was introduced in the Decision Analysis Primer Chapter as a means of assessing the extent to which a model’s calculations and recommendations are affected by uncertainty. Specific questions about the model that sensitivity analysis can help answer are:

1. Is a model sensitive to a particular uncertainty — e.g., does varying a parameter’s value result in changes in optimal strategy?
2. If a model is sensitive to a particular uncertainty, at what value(s) of the parameter does the model recommend a change in strategy?
3. Does the sensitivity analysis result make sense? (This is a model debugging question.)

The tutorial in this chapter shows how to prepare a tree for sensitivity analysis, how to perform a one-way sensitivity analysis, and how to interpret the results. The More Sensitivity Analysis Tools Chapter covers multi-way sensitivity analysis and tornado diagrams. The Monte Carlo Simulation Chapter covers the use of probability distributions and Monte Carlo simulation to analyze models with complex or numerous uncertainties.

The Working With Variables Chapter and the Building Formulas Chapter provide important details on working efficiently with variables in decision trees. The information in these chapters can help you improve your productivity when building complex decision trees, and also insure against costly modeling errors.

15.1.1 Variables and sensitivity analysis

Up to this point in the tutorial, decision trees have been analyzed on the basis of baseline, numeric values for payoffs and probability values. In order to perform sensitivity analysis on an uncertain quantity, however, its numeric value must be replaced with a variable — a named parameter.
In the investment decision modeled in the first few chapters, subjective estimates for probabilities and payoffs were used. The resulting tree is shown below, rolled back. The expected value calculations suggest that the CD investment is optimal.

The basic uncertainty is that, at the time of the decision, the investor cannot know what the price of the equity will be in one year. A simple probability distribution — a chance node with three branches — represents a range of possible changes in the risky investment’s value. Assuming that you have a mix of different expert opinions about the risky investment, it would be useful to be able to perform sensitivity analysis on the related parameter uncertainties. The extreme, 10th and 90th percentile values in the payoff distribution — a $600 decline or $500 rise in value — are possible candidates for sensitivity analysis. Another option is to vary the probabilities.

The next section of this chapter shows how to replace selected numeric values in the tree with variables. This is a prerequisite to performing sensitivity analysis in TreeAge Pro.

15.2 Using variables in a tree

In TreeAge Pro, a variable is a named parameter which functions as a placeholder for a numeric value (or a formula). Variables have a variety of functions in TreeAge Pro, including:

- representing uncertain or unknown values, usually in preparation for sensitivity analysis
- acting as placeholders for mathematical formulas that include functions, tables, spreadsheet links, and other variables (for example in defining a complex payoff)

The tutorial in this chapter focuses on the use of variables as a basis for sensitivity analysis. The Building Formulas Chapter will discuss the creation of payoff formulas using variables.

When building complex models, variables are often used from the outset. The investment decision tree has already been completed using numeric payoffs and probabilities, however, so this tutorial will take a different course, replacing existing numeric values with variables.

Some procedures explained in this chapter are not required steps for using variables in the investment tree. Optional steps will be identified as such.
15.2.1 Steps for using variables

There are three basic steps to remember when using a variable as a parameter in a decision tree:

1. **Declare name** — Based on its intended function in your model, decide on a clear name for the variable (following the naming guidelines outlined below). Add the name to the list of recognized variables in the tree.
2. **Define, assign** — Define the variable at a node, often the root, by assigning it a value (or a formula).
3. **Use** — Anywhere the corresponding value is used in the tree (e.g., payoffs or probabilities), in its place substitute the variable name.

TreeAge Pro offers multiple methods for each step; this chapter illustrates a few possible methods.

15.2.2 Guidelines for naming variables

Variable names must conform to certain rules (similar to Microsoft® Excel’s rules for cell names). Each variable name must:

- begin with a letter or underscore character (“_”)
- contain only letters, numbers, and underscore characters
- be no longer than 32 characters

TreeAge Pro will alert you if you try to use an invalid variable name.

It is recommended that you follow some kind of naming convention when creating variables in a particular model. For example, you could use the prefix “prob" or “p" for probability variables, “c" for cost variables, and so on.

Variable names are not case-sensitive. For example, the names probUp, PROBUP and probup are equivalent; prob_UP would be a different variable, however, since it includes an extra character.

15.2.3 Creating and defining variables

As explained at the beginning of this chapter, there are two apparent sensitivity analysis approaches in the investment tree: vary the extreme probabilities or the extreme payoff values.

The tutorial will start by using variables in the branch probabilities of the extreme outcomes, and after that in the payoffs. The tree will eventually look like the picture shown here.
It is a good idea, if you already have a working version of your tree without any variables, to keep a backup copy of the tree. For information about creating a project to store your test model, refer to the Example Models and Projects Chapter.

The first step is to create and define a variable that can be used to replace the numeric probabilities of the Large increase and Large decrease branches with a variable placeholder.

To create and define a new variable in a tree:

- Open the Variable Properties View.
- Click the "+" icon in the view toolbar. The Add/Change Variable or Function dialog will open.
- Enter the variable name `prob_extreme` in the name field.
- Enter description and comment information for the variable (optional).
- Enter 0.3 into the Root Definition - Build Expression field.
- Click OK.
Create new variable prob_extreme

The name “prob_extreme” has been added to the list of recognized variable names in the tree, and it has been assigned a default numeric value of 0.3 at the root node. You will see the definition beneath the root node in the Tree Diagram Editor.

Tree showing new variable prob_extreme

The assignment of a value (or formula) to a variable at a node is called a definition. Which node you define a variable at determines where the variable definition will apply in the tree (i.e., which payoffs and probabilities can use the variable name).

The root node definition of prob_extreme, for example, applies at the root node and everywhere to the right, including at the Large increase terminal and at the Large decrease node, both of which will be updated to use the variable.
15.2.4 Finding and fixing problems with definitions

The variable definition, prob_extreme = 0.3, should be visible at the root node of the tree. If the definition is not visible below the root node, as in the above picture, it does not mean that the definition does not exist. The first thing to check is whether the display of variable definitions has been turned on in the tree’s preferences.

To display variable definitions in the tree:

- Choose Tree > Tree Preferences from the menu or press the F11 key to open the Tree Preferences dialog.
- Select the category Display > Variables/Markov Info.
- Select "Show definitions" from the "Display definitions at node" options.
Variable display Tree Preferences

If the tree is set to display *variable definitions*, but the definition `prob_extreme=0.3` does not appear at the root node, determine whether the variable was created and defined.

Individual variables can also be hidden/shown in the tree using the Variable Property "Show in tree".

The list of named variables in the tree can be viewed and modified in a number of ways. A quick way to access the variables list is by right-clicking on a node (use the root node for now).

**To view the list of tree variables in a "quick" menu:**

- Right-click on the root node and choose Define.
- If any variables exist in the tree, their names will be listed (below the New… command).
Later, we will look at using the Variable Properties View and Variable Definitions View to manage a tree's variables.

To open the Variable Properties View:
- Choose Tree > Show View > Variable Properties from the menu.

To open the Variable Definitions View:
- Choose Node > Show View > Variable Definitions from the menu.

15.2.5 Placing variables in a tree

Previously in this documentation, quantities (payoffs, probabilities, etc.) in the tree were entered as numeric values. However, TreeAge Pro allows for the flexibility of entering quantities as expressions using numbers, variables, tables, functions and distributions. We'll start with the single variable that we created earlier. We'll use two different methods to place the new variable in two probability expressions.

To use the variable prob_extreme in the model:
- Select the Large increase terminal node and press SHIFT-TAB to edit the probability.
- Delete the numeric probability of 0.3, and in its place type a new variable name prob_extreme.
- Press SHIFT-TAB (or click outside the node) to have TreeAge Pro check the changes you made to the probability expression.
- Click with the mouse in the probability editor, below the Large decrease terminal node.
- Click on the function editor ("f(x)") to open the Formula Editor.
- Clear the 0.3 from the formula editor.
- Select variable in the formula editor's left pane, then double-click the variable prob_extreme in the right pane and click OK.

At this point, the variable prob_extreme has replaced two numeric value probability values 0.3 in the model.

Stock tree using new variable prob_extreme
15.2.6 Adjusting complementary probabilities

Our changes to the probabilities in the tree are not complete. If the value of the variable prob_extreme is changed, for example during sensitivity analysis, the probabilities at the chance node will no longer sum to 1.0 — unless a change is made to the 0.4 probability at Small increase.

The two options for Small increase’s probability are to:

- enter an expression in terms of the new variable (e.g., “1-prob_extreme*2”); or
- use TreeAge Pro’s automatic complement calculator (“#”).

Let’s use the second option, the "#". The benefit of using the "#" is that it recalculates if the value of prob_extreme is changed.

To assign a remainder expression to a probability:

- Delete the numeric 0.4 probability of the Small increase node.
- Replace it with # (a hashmark), which will still calculate as 0.4 unless the definition of prob_extreme changes.

Use complement calculator with variables

Now, if we change the value of prob_extreme to 0.25, the probability of Small increase will automatically be recalculated as 1 - 0.25 - 0.25, or 0.5, and the chance node’s probabilities will continue to be coherent (sum to 1.0).

Once prob_extreme has been defined and used properly, and the chance node’s probabilities have been adjusted appropriately, you could skip ahead to the section on performing sensitivity analysis, and try analyzing the impact of this uncertainty on your decision.

15.2.7 Create, define and use additional variables

At this point, we have introduced the variable prob_extreme into the model. Now we will introduce variables into the payoff expressions for the Large increase and Large decrease terminal nodes.

We will use the same method we used earlier for the first variable and a different method for the second.

To create and define a new variables in a tree:

- Choose Tree > Show View > Variable Properties from the menu.
- Within the Variable Properties View, click the "plus" icon.
15 Introduction to Variables and Sensitivity Analysis

- Enter the variable name (pay\_down), optional description and optional comment.
- Check the box "Define numerically at root" and enter the value -600 into the Value field.
- Click OK.
- Repeat these steps for the variable pay\_up with value 500.

Now, we will enter the new variables into the payoff expressions for the appropriate terminal nodes.

To update the payoff expression for Large increase (Method 1):
- Double-click on the payoff expression 500 to the right of the Large increase node.
- In the Edit Payoff dialog, replace the value 500 with the variable name pay\_up and click OK.

To update the payoff expression for Large decrease (Method 2):
- Right-click on the Large decrease node and select Edit Payoffs from the context menu.
- Click on the payoff expression -600 and delete it.
- Click on the ellipsis ("...") button to open the formula editor.
- Select variable in the formula editor's left pane, then double-click the variable pay\_down in the right pane and click OK.

The tree should now look like the figure below - with three variables defined and used in the mode.

**Stock tree with three variables**

The finished version is available as the Get Started tutorial example tree “Three Vars”.

15.3 Performing one-way sensitivity analysis

TreeAge Pro can perform sensitivity analysis at a selected node using a range of values for a single variable (one-way sensitivity analysis) or across ranges of values for two or three variables simultaneously (multi-way sensitivity analysis). This chapter covers one-way sensitivity analysis. Multi-way sensitivity analysis, and other advanced sensitivity analysis topics, are described in the More Sensitivity Analysis Chapter.

In the previous section, variables were created at the root node. We have the variables prob\_extreme, pay\_up and pay\_down all with numeric definitions. All these variables would be valid choices for one-way sensitivity analysis as independent model inputs. That is: they are defined only once at the root
node as a fixed value or parameter distribution. There are examples of the warning/error messages which you will receive if you choose an invalid parameter for sensitivity analysis.

Start by analyzing the sensitivity of the decision to changes in the probability variable, prob_extreme.

To perform a one-way sensitivity analysis:

- Open the Three Variables tree you created in the previous section (or open the Get Started Tutorial example tree "Three Vars").
- Select the decision node.
- Choose Analysis > Sensitivity Analysis > 1 Way..., or click the toolbar button (see below).
- In the Sensitivity Analysis dialog, click on the Variable column to see a dropdownlist and select the variable prob_extreme.

If you specified a low and high value in the variable’s properties, that range will be shown. Otherwise, the range will be set using default values (0 to baseline value). In this example, the saved range is 0 to 0.5.

The checkboxes related to Microsimulation allow you to run a set of trials through the model for each value within the variable range. Refer to the Individual-Level Simulations Chapter for details.

As noted above, you will receive a warning if the variable you have selected for Sensitivity Analysis is not a variable defined at the root node, as a number or as a distribution. The figures below show these two warnings.
Warning if the variable selected for 1-Way Sensitivity Analysis is not a Variable defined at the root node

Warning if the variable selected for 1-Way Sensitivity Analysis is not a number or a distribution

Before we run the One-way Sensitivity Analysis consider how to set the range.

15.3.1 Setting the sensitivity analysis range

This section will explain the different ways you can set the range of a variable for sensitivity analysis.

The current definition of prob_extreme is 0.3. Recall from earlier in the chapter that our initial interest in sensitivity analysis with the Stock Tree is to test different probability assumptions for the risky investment. For instance, we would like to vary the probability estimates for the extreme outcomes testing values from 0.25 to 0.3.

It is important to remember that prob_extreme is used in two out of three branches, with the remainder (or complement) assigned to the middle branch. If we set prob_extreme to 0, the remainder calculated for the Small increase branch will be 1.0. So, prob_extreme = 0 can be the minimum value for the sensitivity analysis.

If we try to set prob_extreme to anything above 0.5, probability coherence errors will occur: for example, at prob_extreme = 0.501 the extreme branches sum to greater than 1.0. The maximum possible value for the variable therefore is 0.5. The key estimates for prob_extreme, 0.25 and 0.3, are found within this range, and so the model will not create an error for this range.

*How to enter the range of sensitivity analysis values:*
The sensitivity analysis range can be entered in three ways. When you select One-way Sensitivity Analysis, the entries in the Type column can be selected from a dropdown menu. The following list explains those different options:

- **Values**: Enter low and high values for the range directly.
  - Low entry of 0, high entry of 0.5 would be used directly as the sensitivity analysis range values.

- **Adj%**: Enter percentages to be applied to the baseline value to calculate the low and high values for the range.
  - Low entry of 10%, high entry of 20% would be applied to the baseline 0.3 value.
  - Low value would be: \(0.3 \times (100\% - 10\%) = 0.27\)
  - High value would be: \(0.3 \times (100\% + 20\%) = 0.36\)

- **Adj#**: Enter numeric adjustments to be subtracted from and added to the baseline value to calculate the low and high values for the range.
  - Low entry of 0.1, high entry of 0.2 would be applied to the baseline 0.3 value.
  - Low value would be: \(0.3 - 0.1 = 0.2\).
  - High value would be: \(0.3 + 0.2 = 0.5\).

**Example of running the sensitivity analysis**:

- Select the Decision node and then Analysis > One-way Sensitivity Analysis (as above).
- In the dialogue, once the variable prob_extreme is selected, select the Type: Values.
- In the Low value column, enter 0, and in the High value column, enter 0.5.
- Change the number of intervals to 10. Dividing the range into 10 intervals results in 11 recalculations at the decision node, for prob_extreme equal to 0, 0.05, 0.1, 0.15, 0.2, 0.25, 0.3, 0.35, 0.4, 0.45, and 0.5.
- Press enter or click OK to run the analysis.

TreeAge Pro should immediately begin the analysis. If the analysis were a long one, you could monitor its progress in the status bar at the bottom of the TreeAge Pro window. When it is complete, a graph is displayed.
If the analysis does not complete due to errors, read the error message and make note of the node where TreeAge Pro reports a problem. Most likely, the problem is either to wide a range for the uncertain variable, or a problem with the assignment of probability variables in the chance node branches.

If a tree is saved after running sensitivity analysis, the sensitivity analysis range for each variable is saved in the Variable Properties.

15.3.2 The sensitivity analysis graph and report

Because the analysis was done at the decision node, there should be two lines corresponding to the two alternatives, Risky investment and CD paying 5%. Each alternative’s expected value is plotted as a function of the increasing value of prob_extreme.

Each strategy’s line is composed of line segments connecting the line marker symbols that identify that alternative’s expected value at successive intervals of the analysis. A legend to the right identifies the symbol assigned to each particular alternative.

Deviations of a line from the horizontal indicate that strategy’s sensitivity to the variable. An alternative represented by a horizontal line in the graph, such as the "CD paying 5%" option in the example, is unaffected by the changes in the variable. In contrast, the payoff represented by the "Risky investment" line is a decreasing function of the variable.

The analysis text report, showing the underlying calculated values, can be opened by clicking the Text Report link to the right of the graph.
1-way sensitivity analysis text report

This text report essentially mirrors the output from the Rankings text report, except with a separate group showing separate results for each variable value specified by the sensitivity analysis range/ intervals. Note the strategies are sorted within each grouping based on the value (lowest to highest) by default. With this presentation, the incremental value can be used to determine the optimal strategy. However, you can also choose to override the default sort via the option "Change order of strategies" to the right of the report.

Select the option "Change order of strategies" to choose a custom order of strategies.

With this option you can choose the strategy order you want. The same order will be applied to all values of the parameter. The text report can be exported to Excel using the "Open in New Excel Spreadsheet"
icon to the far right of the report toolbar. There are two export options - one showing each strategy in its own row and one showing all strategies in the same row.

Thresholds are described in the next section.

If the trend of a line in the graph does not make intuitive sense, this may indicate a problem with the definition or use of the variable in the model. Sensitivity analysis can be used to look also for errors in complex formulas, which might be indicated if changing the value of a parameter (even one that is certain) does not have the anticipated effect on calculations. The visual elements of the one-way sensitivity analysis graph, like other line graphs, can be customized in a number of ways, as described in the Graphs Chapter. This includes changing graph size, texts, line markers, and numeric formatting.

15.4 Sensitivity analysis thresholds

The sensitivity analysis results can be interpreted graphically.

If two lines in the graph intersect, at the corresponding value of the variable these two alternatives have the same expected value. Crossing points that represent a change in the optimal strategy are called thresholds. From the standpoint of expected value, the decision maker should be indifferent between the two options at a variable’s threshold value.

15.4.1 Threshold lines

At each threshold, you will see a dotted vertical line. The line stretches up from the x-axis through the crossing point for optimal strategies. The variable value associated with the threshold is shown next to the threshold line.

In the previous section’s example, the threshold line marks a crossing point when prob_extreme = 0.17. For values higher than that, including the baseline 0.3 probability, the CD has a higher return and is therefore optimal. For values of prob_extreme less than 0.17, Risky investment is optimal.

In this analysis, the threshold is not close to our two best estimates, 0.25 and 0.3, so perhaps the model is not sensitive to this particular uncertainty.

Among other options for formatting graphs, you could change the numeric formatting of the x-axis to calculate the threshold to a greater degree of accuracy.
15.4.2 Thresholds Report

You can also pull threshold information from the analysis by clicking on the “Thresholds Report” link to the right of the Sensitivity Analysis output graph. This report focuses on the variable value and strategies associated with each threshold in the analysis. See below.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Variable</th>
<th>Var Value</th>
<th>Strategy 1</th>
<th>Strategy 2</th>
<th>Exp Value</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>prob_extreme</td>
<td>0.387</td>
<td>Bold Investment</td>
<td>DD Paying 50%</td>
<td>50</td>
</tr>
</tbody>
</table>

Sensitivity Analysis Thresholds Report

Note that the report shows the variable, its threshold values, the strategies that are equivalent at the threshold and the EV value for the strategies at that threshold.

15.4.3 A caveat on thresholds

If all of the lines in a sensitivity analysis graph are straight, the threshold analysis in the graph will be exact. However, if any lines appear curved, the threshold analysis is a linear approximation, and its accuracy will increase as the width of the intervals decreases.

The analysis performs calculations only at the ends of the N number of intervals specified when running the analysis. The lines plotted on the graph are accurate at these N+1 discrete points, but not necessarily in between (e.g., if an alternative’s expected value is an exponential or other non-linear function of the variable’s value).

The sensitivity analysis graph will not recognize a threshold if the optimal strategy is the same at both ends of the interval, but changes back and forth within the interval. The likelihood of this error can be reduced by increasing the number of intervals, thus reducing their width.

A more sophisticated, non-graphical form of threshold analysis is described in the More Sensitivity Analysis Tools Chapter. This chapter also includes more information on one one-way sensitivity analysis and other kinds of sensitivity analysis.
16. Working With Variables

This chapter expands on the aspects of TreeAge Pro’s variables interface introduced in the previous chapter, and also introduces a number of important windows, dialogs, and other tools that facilitate working with variables in trees.

For information on managing tables, refer to the Tables Chapter. Also refer to the Building Formulas Chapter for information on building complex variable definitions and using functions.

Users of the Excel Module can refer to the Using the Excel Module Chapter to learn about features available for managing variables in Excel.

Note that the methods used to manage variable properties and definitions have changed significantly in TreeAge Pro 201x. This chapter will describe the new methods.

16.1 Variable Properties View

The Variable Properties View is used to manage variable properties. Unlike variable definitions, variable properties apply to the entire tree. Therefore, the Variable Properties View is a tree-level view rather than a node-level view.

To open the Variable Properties View:

- Choose Views > Variable Properties from the toolbar.

Below is an image of the Variable Properties View from the Get Started tutorial example model Three Vars.

![Variable Properties View](image)

The main grid contains a list of the tree’s variables along with a few of the key variable properties. These properties can be edited within the grid. If you change the variable name, all references to that variable within the tree will be modified as well.

The Variable Properties View toolbar provides additional functions.

![Variable Properties View toolbar](image)

The functions associated with the icons are presented below. Each function is described in subsequent sections.
16. Working With Variables

1. Edit Variable
2. Add Variable
3. Add Multiple Variables
4. Delete Variable
5. Convert Variable to Tracker
6. Copy Variable
7. Paste Variable
8. Edit in Excel
9. Generate Variables Report
10. Highlight
11. Find References in Tree
12. Filter Text/Clear
13. Show Categories Tree/Group Variables by Category

Variable Properties View toolbar functions

16.1.1 Edit Variable

This function is used to edit the properties of the selected variable. Only one variable can be selected. The Add/Change Variable or Function Dialog will open with the properties of the selected variable displayed.
Add/Change Variable or Function Dialog

Within this dialog, you can edit the variable's properties - name, description, comment. You can also enter a variable definition at the root node either by entering the definition or via the formula editor or content-assist.

Within the Root Definition section, there are two main areas Build Expression and Add to Expression.

1. **Build Expression**: The expression that is being modified by the Formula Editor.
2. **Add to Expression**: The elements to add to the expression are found here and are:
   1. **Group**: Element type to display in the Element section.
   2. **Element**: Individual item to add the the expression.
   3. "+": A Button to add the selected Element to the Build Expression editor. An

When the changes are complete, click OK to save.

Note that the Add/Change Variable or Function dialog contains three property categories.

1. **General** - Maintains main variable properties as described above.
2. **Sensitivity Analysis** - Maintains sensitivity analysis range and correlations. Refer to Sensitivity Analysis Variable Properties Section.
3. **Categories** - Maintains Variable Categories associated with the variable. Refer to Variable Categories Section.

### 16.1.2 Add Variable

This function is used to add a new variable to the model. The Add/Change Variable or Function Dialog (see prior section) will open with a default variable name and default properties (mostly blank). If you have selected to add a variable and you are not at the Root node, you will be able to select where you want to Create the Definition either: **Root Node** or **Selected Node**. A Variable should either be added at the Root node or at the Selected node.

Enter the new variable's name and properties within the dialog.

Add/Change Variable or Function prompting to define at either the Root or the Selected node.

Click OK to save the new variable.

### 16.1.3 Add Multiple Variables

This function works the same as Add Variable except that you can add a number of variables at a time.
16.1.4 Delete Variable

This function is used to delete one or more selected variables from the tree. Deleting variable(s) will also delete all definitions for the affected variable(s).

Expressions that reference deleted variables will no longer function correctly. These expressions will need to be updated.

16.1.5 Convert Variable to Tracker

This function converts the variable into a tracker. Trackers are used in Microsimulation to store and retrieve data associated with individual trials. Refer to the Individual-Level Simulation and Markov Models Chapter for details on the use of trackers.

When executed, this function opens the Add/Change Tracker Dialog to allow you to create the tracker from the existing variable.

![Add/Change Tracker Dialog]

After you click OK, the variable is converted to a tracker.

16.1.6 Copy and Paste Variable(s)

These functions copy one or more variables (including names and root node definitions) and paste them into another model.

To copy a variable:

- In the variable properties view, select the row to copy by clicking anywhere in the row. The 'copy' icon will become active.
- Select the copy icon, as highlighted in the figure below.
To paste a variable

- Open the destination model, and select the 'paste' icon in the Variable Properties view.

To copy multiple variables, select one variable, then hold down the \textit{Ctrl} key while selecting other variables. Then use the steps outlined above to copy the selected variables for pasting in the destination model.

The copy/paste icons are used to copy/paste the entire model input (row).
To copy/paste specific entries within the variable row, such as the variable name or root definition, use the \textit{Ctrl+C (Command+C on Mac)} to copy and \textit{Ctrl+P (Command+P on Mac)}.
Individual entries can then be copy/pasted into different expressions in this or another model.

16.1.7 Edit in Excel

This function exports the tree’s variables to an Excel worksheet. You can then edit the variables within the worksheet and send the new properties/values back to TreeAge Pro.

This function requires the optional Excel Module. It is described in the Using the Excel Module Chapter.

16.1.8 Generate Variables Report

This function creates a report listing...

1. A complete variables list for the the tree including each variable’s name and selected properties.
2. For a single selected node, a list of variables defined at or to the left of the node and their properties.
The Variables Report can be useful in determining which variables are unused (and might be deleted). It can also be used to retrieve calculated values based on the applicable variable definition (at the selected node or closest one to the left).

Similar to other reports, the Variables Report can be exported to a number of external formats including HTML and Excel.

16.1.9 Highlight

When this option is depressed, the selected variable is highlighted within the model in the Tree Diagram Editor. See below.

16.1.10 Find References in Tree

Click this icon to trigger an immediate search within the model for that variable. The Search will find all variable definitions and all references to the variable.

16.1.11 Filter Text/Clear

The Filter Text field allows you to filter the list of variables to show only variable names that match the Filter Text. For example, if you entered "pay" into the Filter Text, the variables pay_up and pay_down would be displayed, but not prob_extreme.

Enter an asterisk before the expression to look for text in the middle of the variable name rather than the front. For example, if you entered "*down" into the Filter Text, the variable pay_down would be displayed, but not pay_up or prob_extreme.
16.1.12 Show Categories Tree/Group Variables by Category

The Show Categories Tree toggle switch splits the Variable Properties View into two panes, adding a left-side pane for managing Variable Categories. Click the icon again to hide the category pane. Refer to the Variable Categories section for details.

The Group Variables by Category function changes the display within the Variable Properties View to group the variables within the assigned categories.

16.2 Variable Definitions View

The Variable Definitions View is used to manage variable definitions at different nodes within the tree. Variable definitions are created at specific nodes, so the Variable Definitions View is a node-level view. The contents of the view reflect the context of the selected node.

Several Views, such as Variable Definitions View, are node specific. If you have not selected a node or are not on the correct node type, a warning will appear in the View.

To open the Variable Definitions View:

- Choose Views > Variable Definitions from the toolbar.

Below is an image of the Variable Definitions View from the Get Started tutorial example model Climber Cost with the root node selected.

The main grid contains a grouped list of variable definitions. Groups can be collapsed and expanded. Two of the groups are described below.

- **Defined** contains variable definitions at the selected node.
- **Undefined** contains variables that are not defined at the selected node.
As previously mentioned, the Variable Definitions View is a node-level view. Note how the display changes if we select a different node, specifically via the path *What is appropriate... > Use standard antibiotic > Foot saved.*

![Variable Definitions View at the Foot Saved node](image)

At the *Foot Saved* node, only two variables are defined, while others are listed in the *-- Undefined --* group.

In addition, you can now see the *--Inherited--* group that contains variable definitions that are "inherited" from nodes to the left of the selected node. The *Foot Saved* node’s immediate parent node is *Use standard antibiotic*, which has no variable definitions. Moving one more step to the left, you see the *What is the appropriate...* node (the root node), which has several variable definitions.

The Filter Text field allows you to filter the list of variable definitions to show only variable names that match the Filter Text.

The Variable Definitions View toolbar provides additional functions.

![Variable Definitions View toolbar](image)

The functions associated with the icons are presented below. Each function is described in subsequent sections.

1. Add Variable Definition
2. Edit Variable Definition
3. Delete Variable Definition
In addition, a section below describes how to edit variable definitions directly in the view’s grid.

### 16.2.1 Add Variable

This function is used to add a new variable to the model. This function is the same as the function from the Variable Properties View.

Adding variable definitions is done within the views grid.

### 16.2.2 Edit Variable Definition

This function is used to edit the selected variable definition. Only one variable definition can be selected.

The Define Variable Dialog will open with the selected variable definition displayed.

![Define Variable Dialog](image)

**Define Variable Dialog**

Edit the variable definition in the Build Expression element and click OK to save the changes.

Note that you can select and edit an *Inherited* variable definition as well. This will edit the variable definition at the node where the definition currently exists.

### 16.2.3 Delete Variable Definition

This function is used to delete one or more selected variable definitions from the tree. Deleting variable definition(s) will not delete the variable(s) from the tree.

Only definitions at the currently selected node can be deleted.
To delete variable definitions in the Variable Definitions View:

- Select one or more variable definitions for the currently selected node.
- Click the "X" delete toolbar button.

### 16.2.4 Edit Variable Definitions in grid

Variable definitions can also be added or edited directly in the Variable Definition View's grid.

For example, if you enter a new definition into one of the `--Undefined--` variables, a new definition is created for that variable at the selected node.

Below is an image of the grid contents before adding a definition.

![Variable Definitions View - Before adding definition](image)

Next, a new definition for the variable `cAntibiotics` is typed into the grid.

![Variable Definitions View - Adding definition](image)

After the new variable definition is added, it can be seen in the `--Defined--` group.

![Variable Definitions View - After adding definition](image)

Similarly, you can type a new definition into the `--Defined--` group to replace the existing definition.

### 16.2.5 Cut/Copy/Paste Variable Definitions

You can cut/paste variable definitions to move them from one node to another. You can also copy/paste variable definitions to copy them from one node to another.

**To cut a variable definition in the Variable Definitions View:**

- Right-click on a variable definition.
- Select Cut from the context menu.

**To copy a variable definition in the Variable Definitions View:**

- Right-click on a variable definition.
- Select Copy from the context menu.

To paste a variable definition:

- Select the destination node in the Tree Diagram Editor.
- Right-click on the top row of the Variable Definitions View (refers to variables defined at the selected node).
- Select Paste from the context menu.

16.3 Defining a Variable at a Specific Node

The easiest way to define a new or existing variable at a specific node is to select the node and then right-click. This lets you define a new variable or define an existing variable at the Specific Node from the dropdown menu, as in the figure below.
Defining a variable at the "Foot saved" node by right clicking

In the figure above it indicates both cTreatment and numDays are both defined at the node selected.

To define an existing variable at a specific node, select the variable to define (we use "numDays" in the figure) and the Define Variable Dialog opens. The Define Variable Dialog has been used several times in this and prior chapters. Some additional information on this dialog is provided here.
The Define Variable Dialog is used to add or update a Variable Definition within the context of a specific node. It tells you the Node where you are defining a variable: in this case, Foot saved. The read-only Variable Info at the bottom of the dialogue is populated from the the Variable properties. The Build Expression and the Add Expression fields are described in detail in earlier chapters.

The Definition info field is free text that can be used to describe the definition itself.

Another method to define an existing variable at a specific node is via the Variable Definitions View. The Variable Definitions View is node specific and the information presented in this view changes depending on which node you have selected in the model. More information of the Variable Definitions View is given in the above section.

To define a new variable at a specific node, right-click on the node and choose Define Variable > New Variable... from the dropdown menu. This will open the Add/Change Variable or Function dialog. Note that the "Create definition at" option will default to "Selected node", which you can override to create the definition at the root node.

Another method to define a new variable at a specific node is via the Variable Definitions View. Once you have selected the node where you want to add a new definition, use the toolbar associated with

The Add/Change Variable or Function dialogue for defining a new variable at a specific node with the default variable definition set to "Selected node"
the Variable Definitions View and select the "+". The Add/Change Variable or Function dialogue will appear. This dialogue will be the same for both methods of adding a new variable, as shown in the figure above.

16.4 Variable Sets

You can create multiple variable sets to store different model input scenarios within a model. Each variable set contains a different set of root node variable definitions. No definitions at other nodes or other model inputs are affected by variable set selection.

We will use the Get Started tutorial example model Investment Vars.trex to examine variable sets.

![Investment Vars.trex and its variable list]

Note the designation of this set of root node variable definitions as **Variable Set: Default** at the right of the Variable Properties View toolbar.

**To create a new variable set:**

- Click the down arrow to the right of "Variable Set: Default".
- Choose the option Add/Rename Set.
- Click the "+" icon.
- Use the default name "Variable Set 2" (or provide a new name).
- Click the down arrow to the right of "Variable Set: Default".
- Choose the new variable set "Variable Set 2".

Note that nothing has changed in the model because the root node variable definitions in the new set match the ones in the original set. Once you change any variable definitions in the new set, it becomes
a separate set of definitions. If you then return to the Default set, all the variable definitions return to their prior values.

The Special Features tutorial example Investment Variable Sets already has two variable sets - Optimistic and Pessimistic. Switch between the two sets to see the payoff variables change.

<table>
<thead>
<tr>
<th>Variable</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>down_big</td>
<td>-500</td>
</tr>
<tr>
<td>pHigh</td>
<td>0.25</td>
</tr>
<tr>
<td>pLow</td>
<td>0.20</td>
</tr>
<tr>
<td>up_big</td>
<td>600</td>
</tr>
<tr>
<td>up_small</td>
<td>200</td>
</tr>
</tbody>
</table>

**Optimistic variable set**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>down_big</td>
<td>-500</td>
</tr>
<tr>
<td>pHigh</td>
<td>0.25</td>
</tr>
<tr>
<td>pLow</td>
<td>0.20</td>
</tr>
<tr>
<td>up_big</td>
<td>500</td>
</tr>
<tr>
<td>up_small</td>
<td>100</td>
</tr>
</tbody>
</table>

**Pessimistic variable set**

### 16.5 Variable Categories

You can use variable categories to help organize long lists of variable definitions in a tree. Use the Variable Properties View to create a hierarchical structure of variables via variable categories.

The categories can be used both in the display of variable definitions in the tree window (under nodes), as well as in the Variable Properties View.

We will use the Get Started tutorial example tree Three Vars as an example. We will categorize the pay_down and pay_up variables under the category "Payoffs" and the prob_extreme variable under the category "Probabilities".

**Variable Properties View**

To create a variable category:
- Click the "Show Categories Tree" button. The categories pane within the view will be displayed to the left of the variables list.
- Click the "plus" icon in the categories pane. A new category "Category1" will be created.
- Click the new category in the categories grid and rename it. In this case, enter "Payoffs".
- Repeat the prior two steps to create the category "Probabilities".

Variable Properties View - Categories Pane

Once the categories have been created, you can assign each variable to one or more categories by dragging the variable onto the category name to the left. You can also assign categories via Categories property category within the the Add/Change Variable Dialog using the Edit Variable function.

Add/Change Variable Dialog - Categories property category

In the figure above, the variable pay_down has been assigned to the variable category Payoffs.

The Variable Properties View then shows the categories assigned to each variable. Note that the "Group items by category" toggle icon is also depressed.

Variable Properties View - Categories assigned

You can create a hierarchical structure of variable categories by creating subcategories within other categories using the "Add sub-category" icon in the categories pane. Variables can be assigned to one or more categories, regardless of each category's position in the hierarchy. To assign variables to sub-categories, drag the variable from the main window into the subcategory. The categories and sub-
16 Working With Variables

categories the variables are listed in will appear in the Category column in the main Variable Property pane.

16.5.1 Categories for other inputs

Categories are most-commonly used for variables. However, other model inputs (distributions, trackers, tables) can also be categorized in the same way.

16.5.2 Variable Category Tree Preferences

The tree’s variables display preferences allow you to display variable definitions in the model by category.

Tree Preferences - Variable Categories

When checked, the tree shows categories for variable definitions under each node. See below.
16.5.3 Variable Categories in the Variable Report

If variable categories are used in the model then the variable report will also show the categories including any subcategories, as in the Figure below.

Variable Report showing the Categories and sub-categories.

If you select to "Group items by categories" in the Variable Properties view before generating the Variable Report, the Variable Report will show the variables grouped by categories too.

16.6 Sensitivity Analysis Variable Properties

Variable Properties include information related to Sensitivity Analysis. This information is maintained in the Sensitivity Analysis category of the Add/Change Variable dialog.

Add/Change Variable dialog - Sensitivity Analysis category
The "Low value", "High value" and "Range type" properties are the defaults used when running sensitivity analysis using the specific variable. If the values are changed when running sensitivity analysis, the variable properties are automatically updated to reflect the values used for analysis.

16.7 Sensitivity analysis correlations

Correlations can be set up between any number of pairs of existing variables. When a sensitivity analysis is performed on a variable correlated to another variable, the option is presented to simultaneously vary correlated variables over their own value ranges.

To define variable correlations:
- Open the Add/Change Variable Dialog.
- Choose the Sensitivity Analysis tab.
- Select from the list of available variables.
- Click the "+ >" button for a positive correlation or the "- >" button for a negative correlation.
- Click OK to save the changes.

The linked variables will now be listed to the right of the Correlations buttons, with plus or minus symbols indicating the type of correlation. The identical correlation will show in the properties of the two correlated variables. The correlation can be modified or removed from either variable’s Properties dialog.
To remove a correlation:

- Open the Add/Change Variable Dialog.
- Choose the Sensitivity Analysis tab.
- Select from the list of correlated variables (the list to the right).
- Click the "<" button.
- Click OK to save the changes.

You can also click the "<<" button to remove all correlations. To change a correlation’s type (e.g., from negative to positive), you must remove the existing correlation and recreate it with the proper correlation.

Sensitivity analysis using variable correlations is described in the More Sensitivity Analysis Tools Chapter.
16.8 Variables testing tools

In addition to using TreeAge Pro’s Analysis menu commands to see the results of node calculations, TreeAge Pro also provides tools for testing individual variables.

16.8.1 Debugging variable calculations during analysis

The Calculation Trace Console can be used to report on every variable calculation during an analysis. This feature can be used to search for problems in complex formulas.

Please look at the Chapter Model Debugging and Validation for more details.

16.8.2 The Evaluator View

The Evaluator View is designed for testing variables and formulas - like a calculator. Any valid expression can be entered into the Evaluator View. The expression is calculated within the context of the currently selected node.

To calculate a variable or formula at the selected node:
- Select the node at which you want to perform the calculation.
- Click on the "=" icon in the application toolbar to open and/or activate the Evaluator View.
- Enter the expression you want to calculate into the top pane of the Evaluator View.
- Click on the "Calculator" icon in the Evaluator View. The calculated value will appear in the bottom pane of the Evaluator View.

In the following model Climber Cost, from the Get Started tutorial examples, the variable Total_cost is calculated at the selected node, Amputate foot. Note that the calculated value is $24,000.
Evaluator view in action

Tree Preferences were set to show internal calculations, so the Calculation Trace Console shows the inputs that contributed to the value of Total_cost.

Note that the Evaluator View includes formula editor lookup frames to the right and also supports auto-fill.

16.9 Formula Editor

The Formula Editor in TreeAge Pro helps you create expressions consisting of variables, functions, distributions and all other quantity values in a tree. The formula editor specifically includes the option to select variables to include in your expression.
The Formula Editor is described in detail in the Building Formulas Using Variables and Functions Chapter.

16.10 Variable Definition Arrays

Variable definitions can consist of an array of expressions that can be referenced by index. For example, you could create a variable definition like this...

\[ \text{myVarArray} = [10; 20; 30; 40] \]

Then any reference to the variable myVarArray would require an integer index value between 1 and 4, to reference one of the four expressions in the array. For example, \[ \text{myVarArray}[3] \] would return the value 30.

The individual expressions within the array can reference any other variables, trackers, tables, distributions, functions, etc. However, the array cannot refer recursively to itself.

The Special Features tutorial example model, Variable Definition Array, demonstrates this technique.

**Note** that when you look at the root node definition for varArray in the Define Variable dialog, it is automatically presented in grid format.
Define Variable Dialog in Grid mode

The "+" button adds another row to the grid. The "Flat View" button presents the variable definition as an array with the individual expressions presented together within square brackets and separated by semicolons.
Define Variable Dialog in Flat mode

Use the Flat mode to eliminate rows by deleting an expression and a semicolon.

### 16.10.1 Using Variable Definition Arrays with Tables

Suppose you wanted to reference different complex expressions within a table. This is not possible with a table alone because tables support only numeric expressions. A variable definition array alone might not be sufficient if you wanted to be able to associate the expressions with specific lookup index values as is done with tables. However, a combination of tables and variable definition arrays provides a possible solution.

For example, let's say you wanted to use different expressions in a Markov model for different age ranges as presented below.

<table>
<thead>
<tr>
<th>Age</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>0-10</td>
<td>cEarly * rr1</td>
</tr>
<tr>
<td>11-20</td>
<td>cTeen * rr2</td>
</tr>
<tr>
<td>21-40</td>
<td>cAdult * rr3</td>
</tr>
<tr>
<td>41-60</td>
<td>cOldest * rr4</td>
</tr>
</tbody>
</table>

Expressions for variable array
You could first setup a variable definition array to cover all the individual expressions. The array is shown below in Flat view.

\[ \textit{myVarArray} = [\textit{cEarly} \ast \textit{rr1}; \textit{cTeen} \ast \textit{rr2}; \textit{cAdult} \ast \textit{rr3}; \textit{cOldest} \ast \textit{rr4}] \]

You could then setup a table that returns the proper variable array index for each age range (using interpolation).

<table>
<thead>
<tr>
<th>Index</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>10</td>
<td>1</td>
</tr>
<tr>
<td>11</td>
<td>2</td>
</tr>
<tr>
<td>20</td>
<td>2</td>
</tr>
<tr>
<td>21</td>
<td>3</td>
</tr>
<tr>
<td>40</td>
<td>3</td>
</tr>
<tr>
<td>41</td>
<td>4</td>
</tr>
<tr>
<td>60</td>
<td>4</td>
</tr>
</tbody>
</table>

\textbf{myTable table data}

The expression would then use the table to determine the proper expression within the variable array as follows.

\[ \textit{myVarArray[ myTable[age] ]} \]
17. Building Formulas Using Variables and Functions

This chapter focuses on how to use variables to build complex formulas for any expression in the model, including payoffs, variable definitions, probabilities, etc.

The Introduction to Variables and Sensitivity Analysis Chapter covers using variables for the purposes of sensitivity analysis on parameter uncertainties in the model.

17.1 Quantity expressions in a model

Quantities must be included in a model in order to analyze the model. Some of the quantities in models are:

1. Payoffs/rewards
2. Probabilities
3. Variable definitions
4. Distribution parameters
5. Function arguments

Although these quantities can be entered for as simple numbers, TreeAge Pro allows the entry of numeric expressions, consisting of any or all of the following elements.

1. Numbers
2. Variables
3. Table lookups
4. Distributions
5. Functions
6. Operators
7. Keywords

There are different reasons to use specific elements within an expression. This chapter does not discuss the reasons. Rather, this chapter focuses on how to construct simple and complex expressions.

17.2 Formula Editor

The Formula Editor is a tool to create expressions from expression elements.

Within TreeAge Pro, there are many inputs where an expression is required. In most of those inputs, you can open the the Formula Editor to help build the expression. You open the Formula editor by clicking on the "+fx" button within the expression entry. Below are a few examples using the Get Started tutorial example model Climber Cost.
17 Building Formulas Using Variables and Functions

Open Formula Editor from Payoff entry dialog

Open Formula Editor from Probability entry

Once the proper expression has been built using the Formula Editor, the expression is placed back in the tree based on the original expression input from which the Formula Editor was opened.

The Formula Editor itself is split into two sections which have different elements in them.

1. **Build Expression**: The expression that is being modified by the Formula Editor.
2. **Add to Expression**: The elements to add to the expression are found here and are:

   1. **Group**: Element type to display in the Element section.
   2. **Element**: Individual item to add to the expression.
   3. "+": A button to add the selected Element to the Build Expression editor. An alternative is to double-click the left mouse key.
Formula Editor: The window tells you what you are editing, in this case "Edit Probability"

If you click on an item in the Group section, the Element section will show elements that match the selected type.

If you double-click on an item in the Element section, that item is added to the expression. Alternatively you can use the "+" button.

Click OK to close the Formula Editor and replace the original expression in the tree with the new expression from the Formula Editor.

Click Cancel to close the Formula Editor and leave the original expression in the tree unchanged.

17.3 Content-Assist

Many expressions in TreeAge Pro allow you to use the content-assist feature. Content-assist is available whenever you see the small light bulb to the left of the expression field. The figure below shows the content-assist indicator in a probability expression field within the Get Started tutorial example tree, Climber Cost.

Content-assist option in probability expression

Content-assist attempts to help you complete any partially-typed element in the expression.
To trigger content-assist:
- Select a field with content-assist enabled.
- Begin typing an element.
- Press Control + Space on the keyboard.

For example, if you click on the probability expression in the figure above, type the letter "n", then trigger content-assist, you are presented with options to complete the element starting with "n". See below.

Using content-assist in probability expression

Note that you are presented with several possible elements starting with "n" - the numDays variable from the tree and the node and npv functions built into the software. A brief description of each available item is presented in the off-white panel. In the figure above, you can see that the variable numDays has the value 4 at this node. If you select one of the content-assist options, it becomes part of the expression.

If no text is entered prior to triggering content-assist, then all possible options are presented.

Content-assist works with any element within the expression. It is not limited to the expression as a whole. If no prompt is entered before pressing Control + Space, you will see recently entered expressions within the list of options.

17.4 Function Helper

The Function Helper attempts to provide guidance on how to use built-in functions. The Function Helper is available within the Formula Editor and in most expression inputs.

In the Formula Editor, when a function is added to the expression via double-click, micro-help related to that function is immediately presented. In addition, placeholders are added as function arguments. The first argument placeholder text is selected, so you can immediately replace it with the appropriate data/expression for that argument.
Function Helper from Formula Editor

After entering the first argument, press the tab key or enter a semi-colon argument separator, and the next argument placeholder is selected for entry. This continues until all arguments are entered. Shift-tab will return to the prior argument.

If you choose a function via content-assist, the same Function Helper micro-help will appear with the argument placeholders.

If you type a function into an input field or into the formula editor, the same Function Helper micro-help will appear, but without the argument placeholders, after you enter the open parenthesis after the function name.

17.5 Summation nodes

A summation node can be used to add together the values from portions of a tree. During calculations, the expected value (EV) of a summation node is equal to the sum of the EVs of all branches.

A chance node's EV is equal to the weighted average of its branches EVs. The summation node functions similarly except that the "weight" of each branch would be 100%.

The Legal tutorial example tree, LegalTreeSummation, illustrates the use of the summation node.
Legal tree with summation node

Note that the EV of the legal case if negligence is proven is the combined EV of compensatory damages and punitive damages, less legal fees. The summation node allows you to present the three value elements separately and explicitly, while combining them for the total value of winning in court.

When the tree is rolled back, you can see that the EV at the Combined damages node is equal to the sum of the EVs for its three branches.

Legal tree with summation node - rolled back

Note that some analyses are not supported for summation nodes - specifically probability distribution graphs. You can still run Roll Back, Rankings, Sensitivity Analysis and Probabilistic Sensitivity Analysis.

17.6 User-defined python functions

User-defined functions can be created within variable definitions, using the Python script language.
User-defined functions are entered as variable definitions, using a regular variable and the Define Variable Dialog. Python functions require indenting and carriage returns, so the Define Variable Dialog window’s behavior changes slightly when it recognizes you are entering/editing a user-defined function.

Refer to the Tools and Functions for Complex Trees Chapter for more details.

17.7 Variable formula examples

This chapter will continue the tutorial on variables by explaining, in detail, the logic that dictates where variables should be defined in a tree and how variables are evaluated during tree calculations. Provided a basic understanding of how TreeAge Pro searches for variable definitions, it will become easier for you to identify the best location for each variable definition you create.

17.7.1 Building a complex cost formula

The example model used in this chapter is based on the following medical treatment scenario. The assumption is that you are evaluating a new pharmaceutical treatment used in your hospital for advanced infections in an diabetic population. Initially, the modeling of the new intervention is being done on a cost basis, looking only at foot infections.

Previously, the treatment decision was between prompt amputation of the foot, and a course of high-dose, intravenous antibiotics. The new intervention is an antibiotic that works much faster that the old drug, so you will know sooner if it is going to halt the infection and save the foot; soon enough to have complete certainty that performing an amputation below the knee will avoid any mortality risk. For this reason, the new drug has already been adopted.

However, the new drug actually halts fewer infections over its shorter course of treatment, which results in a higher number of amputations. Based on the experience of your medical center, you estimate the costs and probabilities and put them into a decision tree, shown below.
The figure above is of the Special Features tutorial example tree, Cost Formula. As shown in the model, the original high-dose, intravenous antibiotics combined with surgical debridement (removal of tissue) offers a 65% probability of curing the infection and saving the foot. If the antibiotics do not stop the infection, there is an 15% probability of death with the remaining 85% surviving and requiring amputation at the knee.

The new, experimental antibiotic has a different set of outcomes. It has a 62.5% probability of curing the infection, with the remainder having amputation at the knee.

With the immediate amputation of the foot option, the outcome is assumed to be certain: the patient will survive. With immediate amputation of the foot, or later amputation at the knee, a prosthesis will be fitted and physical therapy will be required.

The following table contains the component costs that are used to calculate total cost for each scenario.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Regular antibiotic</td>
<td>$500</td>
</tr>
<tr>
<td>New antibiotic</td>
<td>$500</td>
</tr>
<tr>
<td>Inpatient cost per day*</td>
<td>$1,000</td>
</tr>
<tr>
<td>Foot amputation</td>
<td>$5,000</td>
</tr>
<tr>
<td>Foot prosthesis</td>
<td>$2,000</td>
</tr>
<tr>
<td>Loss of foot, physical therapy</td>
<td>$10,000</td>
</tr>
<tr>
<td>Leg amputation</td>
<td>$10,000</td>
</tr>
<tr>
<td>Leg prosthesis</td>
<td>$10,000</td>
</tr>
<tr>
<td>Loss of leg, physical therapy</td>
<td>$25,000</td>
</tr>
<tr>
<td>Life saving measures</td>
<td>$10,000</td>
</tr>
</tbody>
</table>

Cost formula parameters

* To calculate the basic cost of the hospital stay associated with the various scenarios, the number of inpatient days for each is also estimated and multiplied by the per diem cost.

The numeric cost payoffs specified for each outcome in the Cost Formula tree have been hand-calculated using a formula combining the appropriate costs for each particular scenario, including costs of hospitalization, drugs, surgery, prosthetics, physical therapy, and other care.

As reflected in the rolled back tree, shown on a previous page, the least costly option is to treat with the standard antibiotic. A Ranking analysis can be used to calculate the additional cost per patient of the experimental antibiotic, $3427.
17.7.2 Implementing a cost formula using variables

The baseline information may be useful in a budget impact calculations. However, you may want to analyze the model on the basis of different estimates of component costs, some of which are uncertain. To do this kind of analysis manually would be tedious, so you decide to implement the cost calculations using a cost formula and perform sensitivity analysis on the component variables.

Start by making a copy of the tree:

- Open the Special Features tutorial example tree, Cost Formula.
- Save a copy of the tree, changing the name to Cost Variables, and save it in a separate project.

To save some time, a list of definitions of the cost component variables has already been pasted into the tree, at the root node.

Open the Variable Definitions View to see these definitions:

- Select the root node.
- Choose Node > Show View > Variable Definitions from the menu.

Much of the work required to make the tree more flexible has already been accomplished. All necessary variables have been created in the tree, and each has at least one definition.

The remaining tasks to be done in the tree are:

- assign Total_Cost as the payoff of every terminal node;
- redefine the variable (i.e., not fixed) components of Total_Cost for each outcome, as necessary.

The tree below illustrates how and where to add definitions of the variables used in the Total_Cost formula (other solutions are possible, as will be seen later in this chapter). Compare the tree you have opened to the picture of the completed tree.
17 Building Formulas Using Variables and Functions

17.7.3 Variables with multiple definitions

Note that, in the solution, several variables have multiple definitions. Note that, in the solution, several variables have **multiple definitions**. However, with the exception of numDays, no single variable has more than one numeric definition. As a general rule, it is advisable to avoid giving a single variable more than one numeric definition – for example, to represent the probability of two or more distinct events. It is important to follow this rule if you want to be able to perform sensitivity analysis on the variable in question.

⚠️ The quantity represented by numDays, used in calculating cHospital, is not intended to be used in sensitivity analysis. If it were, separate variables would be used for each scenario.

17.7.4 Incorporate the formulas into the tree

Start by assigning the Total_Cost variable to all of the payoffs. Instead of deleting the existing numeric cost payoffs that are found in payoff #1, however, switch to payoff #2 and assign Total_Cost there.
To switch to payoff #2:
- Choose Tree > Tree Preferences from the menu or press F11.
- Navigate to the Tree Preferences category Calculation > Calculation Method > Simple.
- Change the Active payoff to 2.

All terminal nodes should now indicate that no payoff has been assigned. Now, update all the terminal nodes to use Total_Cost as the formula for payoff #2.

To change the payoffs:
- Double-click on the payoff expression next to the top terminal node.
- Enter "Total_Cost" as the expression for Payoff 2.
- Repeat for the remaining terminal nodes.

At this point, although the tree can calculate without causing errors, it will not calculate costs correctly because most of the components of Total_Cost are still defined equal to 0.

Examine the tree to see where and how variables are currently used and defined in the tree, and where definitions need to be added or modified.

To calculate the payoff of any node in the tree, TreeAge Pro must evaluate Total_Cost. To do this, it will search start searching for a definition of Total_Cost at the terminal node, and work leftward until it finds a definition. In this case, the first definition it will find is the default definition of Total_Cost from the root node, which accumulates the following components:

\[
\text{(cost of inpatient care)} + \text{(cost of treatment)} + \text{(cost of prosthetic)} + \text{(cost of physical therapy)}
\]

The component variables cHospital, cTreatment, cProsthetic and cPhysTher need to be evaluated. TreeAge Pro restarts the search for each variable’s definition at the terminal node which is being calculated. This right-to-left search is restarted for each variable encountered in the calculation. (The same process occurs for probability formulas, with a search rooted at the branch being calculated.)

Therefore, for every path in the tree, each variable in the cost formula must have an appropriate definition. Note that for some outcomes, some components do not apply. For example, there are three terminal nodes which represent non-amputation scenarios, and which therefore have no prosthetic or therapy costs. These components should have 0 values in these paths.

Incorporate the remaining variable definitions into the model. For example, at the Amputate foot node, you will need to add three additional variable definitions (for variables cTreatment, cPhysTher and cProsthetic).

You should confirm that, when rolled back, the Cost Variables tree provides the same results as the original tree. You can test this by changing the active payoff back and forth from 1 to 2.
There are two important exceptions to the right-to-left search rule. One involves the recursive definitions of variables, which will be covered at the end of this chapter. The other exception involves the evaluation of tracker variables; refer to the Healthcare Module documentation for details.

All payoff values are set to the variable Total_Cost, but the value are different for each terminal node. Let's examine one of the payoff calculations in detail, specifically at the Amputate foot node.

The Variable Definitions View for the node shows all the definitions we need to calculate the value of Total_Cost.

<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Defined</td>
<td>Undefind</td>
</tr>
<tr>
<td>physTher</td>
<td>physTher</td>
</tr>
<tr>
<td>physTher</td>
<td>physTher</td>
</tr>
<tr>
<td>physTher</td>
<td>physTher</td>
</tr>
<tr>
<td>physTher</td>
<td>physTher</td>
</tr>
<tr>
<td>numDays</td>
<td>7</td>
</tr>
</tbody>
</table>

Variable definitions at Amputate foot node

Based on the right-to-left lookup rule, Total_Cost is first defined at the root node.

\[
\text{Total Cost} = c\text{Hospital} + c\text{Treatment} + c\text{Prosthetic} + c\text{PhysTher}
\]

In order to do that calculation, the individual components need to be calculated based on their closest definitions.

cHospital is calculated from the cPerDiem definition at the root node and the numDays definition at the current node.

\[
c\text{Hospital} = c\text{PerDiem} \times \text{numDays} = 1,000 \times 7 = 7,000
\]

cTreatment is calculated from its definition at the current node, which in turn requires a definition of cFootAmpu from the root node.

\[
c\text{Treatment} = c\text{FootAmpu} = 5,000
\]

cProsthetic is calculated from its definition at the current node, which in turn requires a definition of cFootProsth from the root node.

\[
c\text{Prosthetic} = c\text{FootProsth} = 2,000
\]
cPhysTher is calculated from its definition at the current node, which in turn requires a definition of cFootPhys from the root node.

\[ c\text{PhysTher} = c\text{FootPhys} = 10,000 \]

Now we can see the full calculation of the Total_Cost value.

\[ \text{Total_Cost} = 7,000 + 5,000 + 2,000 + 10,000 = 24,000 \]

If you run roll back and check the payoff at the Foot amputated node, the value is $24,000.

17.8 Using mathematical, statistical, and other functions

TreeAge Pro includes a wide variety of functions which make it easier to perform some commonly-used mathematical operations, or in some cases to provide access to special features in TreeAge Pro.

- TreeAge Pro’s built-in functions are case-insensitive, with the name followed by parentheses, and in most cases take arguments in the parentheses.
- Functions that have multiple arguments must use semicolon (";") separators.
- In most cases, any valid expression can be used as an function argument (with the exception of MatrixMult).
- In the tree window, use the Formula Editor for help in assigning the correct parameters to each functions.
- Functions which here indicate an argument named “LIST” take a flexible number of arguments. For example, Average( ) returns the arithmetic mean of all of its arguments, so Average(1;4;8;13) = 6.5.
- To test a function, use the Calculator/Evaluator tool described in Chapter 13.
- The Distributions Chapter covers a special set of functions used in Monte Carlo simulation.
- The Excel Linking Chapter covers a special set of functions that take text string arguments, instead of numeric or variable expressions.
- The Markov Modeling Tools Chapter covers a special set of functions used in Markov modeling, for example in calculating transition probabilities.

Notes on using functions in formulas

17.9 Arithmetic functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abs(x)</td>
<td>Absolute value of x</td>
</tr>
<tr>
<td>Average(LIST)</td>
<td>Arithmetic mean of a LIST of values/expressions</td>
</tr>
<tr>
<td>Ceiling(x)</td>
<td>Smallest integer greater than or equal x</td>
</tr>
<tr>
<td>Exp(x)</td>
<td>“e” to the xth power</td>
</tr>
<tr>
<td>Floor(x)</td>
<td>Greatest integer smaller than x</td>
</tr>
<tr>
<td>GammaFn(x)</td>
<td>(n-1)! for integers less than 19; Stirling’s approximation otherwise.</td>
</tr>
<tr>
<td></td>
<td>For factorial use GammaFn(x+1)</td>
</tr>
<tr>
<td>Int(x)</td>
<td>Integer component of x</td>
</tr>
<tr>
<td>Ln(x)</td>
<td>Natural (base “e”) logarithm of x</td>
</tr>
<tr>
<td>Log(x)</td>
<td>Base 10 logarithm of x</td>
</tr>
<tr>
<td>Max(LIST)</td>
<td>Maximum, or highest value, of a LIST</td>
</tr>
<tr>
<td>Min(LIST)</td>
<td>Minimum, or lowest value, of a LIST</td>
</tr>
<tr>
<td>Modulo(x; y)</td>
<td>Remainder of x divided by y</td>
</tr>
<tr>
<td>Prod(LIST)</td>
<td>Product of a LIST</td>
</tr>
<tr>
<td>Root(x; y)</td>
<td>yth root of x</td>
</tr>
<tr>
<td>Round(x)</td>
<td>x rounded to the nearest integer</td>
</tr>
<tr>
<td>Round(x;y)</td>
<td>x rounded to the number of decimal places specified by y</td>
</tr>
<tr>
<td>Sqrt(x)</td>
<td>Square root of x</td>
</tr>
<tr>
<td>Stdev(LIST)</td>
<td>Standard deviation of a LIST of numbers</td>
</tr>
<tr>
<td>Sum(LIST)</td>
<td>Sum of a list</td>
</tr>
</tbody>
</table>

**Arithmetic functions**

In the arithmetic functions, “e” represents the base of the natural logarithm (approximately 2.718.)
### 17.10 Financial/discounting functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Explanation</th>
</tr>
</thead>
</table>
| Annuity(rate; periods) | To calculate the net present value of a series of equal future payments, multiply this function times the amount of a single payment.  
  \[(1 - (1 + rate)^{-periods})/rate\] |
| Compound(rate; periods) | Returns the compound interest rate (effective yield) at a fixed rate over a fixed number of periods. If used as a multiplier, this function can be used to calculate future value; if used as a divisor, it can be used to calculate discounted, present value.  
  \[(1 + rate)^{periods}\] |
| Discount(value; annual_rate; time_period) | Discounts a specific value (cost or utility) to account for the discounting of the present value of future values.  
  \[util/((1 + rate)^{time})\]  
  The value is the value to be discounted. The annual_rate is the annual discount rate. The time_period is the future time when the value is applied in the model in years. Note in a Markov Model the time_period is usually a function of _stage_. |
| DiscountCont(util; rate; time_start; time_end) | Discounts a specific value (cost or utility) at the specified rate on a continuous basis for DES models. DiscountCont requires that you provide the start and end time in years. DiscountContDES uses the defaults of _prior_time and _time for the start and end time. This only works correctly if the time measurement is annual. |
| DiscountContDES(util; rate) |  |
| FV(pmt; pv; rate; payments) | Returns the future value of a series of equal, periodic payments. The “pv” parameter represents an initial payment.  
  \[pmt * (1 + rate)^{payments} - 1)/rate + pv * (1 + rate)^{payments}\] |
| NPV(rate; LIST of flows) | Returns the net present value of periodic cash flows, discounted.  
  \[(f_i/(1 + rate)^t)\] |
| PMT(principal; rate; term) | Returns the size of equal, periodic payments required to pay off a loan, given the principal, interest rate, and term of the loan.  
  \[principal * (rate/(1 - (1 + rate)^{-term}))\] |
| PV(pmt; fv; rate; payments) | Returns the present value of equal, periodic payments at a fixed interest rate. The “fv” parameter represents a final payment.  
  \[pmt * (1 - (1 + rate)^{-payments})]/rate + fv/((1 + rate)^{payments})\] |
### Financial/discounting functions

In functions, a “rate” argument can be entered as either a percent or a decimal. For example, eight percent can be represented as either “8%” or “.08,” but not simply as “8.” Do not enter a very small percentage as “.08%”. However, it is OK to enter “0.08%”. References to periods/payments specifically mean the number of periods/number of payments.

<table>
<thead>
<tr>
<th>Function</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>UtilDiscount()</td>
<td>Obsolete. See Discount(), above.</td>
</tr>
</tbody>
</table>

### 17.11 Miscellaneous functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bilink(index)</td>
<td>Returns the value associated with a dynamic link. Refer to the Excel Linking Chapter.</td>
</tr>
<tr>
<td>BranchProb()</td>
<td>Returns the calculated branch probability for the node being calculated. Unlike PathProb(), this function only includes the probability at the specific branch node.</td>
</tr>
<tr>
<td>Choose(index; LIST of values)</td>
<td>Returns a value based on its location in the LIST, as specified by the index. The index must be a positive integer; an error is reported for fractional or out-of-range values. For example, “Choose(2;100;200;300)” returns 200, because the index is 2, and 200 is the second value in the list. This function can often be used to replace complex nested If functions.</td>
</tr>
<tr>
<td>erf(x)</td>
<td>Error function, also known as Gauss error function for a given value of x.</td>
</tr>
<tr>
<td>If(condition; trueval; falseval)</td>
<td>Evaluates a condition and returns “trueval” if the condition is true or “falseval” if the condition is false. For example, “If(x&lt;0;50;75)” would return 50 if x were negative and 75 if x were non-negative.</td>
</tr>
<tr>
<td>Inf()</td>
<td>Returns infinity (#). Although no arguments are accepted, you must type the left and right parentheses.</td>
</tr>
<tr>
<td>Link(index)</td>
<td>Returns the value associated with a DDE link. See Bilink() above.</td>
</tr>
<tr>
<td>Pi()</td>
<td>Returns #, or approximately 3.1416.</td>
</tr>
<tr>
<td>PathProb()</td>
<td>Returns the cumulative path probability for the node being calculated. In a Markov subtree, PathProb() returns the cumulative path probability from the Markov state to the node being calculated. In a non-Markov tree, you can use this function to calculate the percentage of an overall cohort that reaches a specific node.</td>
</tr>
<tr>
<td>Function</td>
<td>Explanation</td>
</tr>
<tr>
<td>----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Probit(x)</td>
<td>Calculates the inverse of the cumulative distribution function of the standard normal distribution (mean 0, standard deviation 1) for a given probability x. Also known as a quantile function.</td>
</tr>
<tr>
<td>StateProb(A; B)</td>
<td>Returns the state probability of one or more states at the start of the current cycle. Refer to the Markov Modeling Tools Chapter for details on this Markov modeling function.</td>
</tr>
<tr>
<td>Sub(index)</td>
<td>Obsolete. See Bilink() and Link(), above.</td>
</tr>
</tbody>
</table>

**Miscellaneous functions**

*Choose() function tip:* Performing a sensitivity analysis on a variable used as the index of the Choose() function, from 1 to the number of list items, can show the impact on calculations of the different values specified in the list.

*Nesting functions:* All functions can be nested. The If( ) function is frequently used nested within another If( ) function call. This is because the If( ) function tests for one condition, and can return either of two values, normally. However, by using another If( ) function as one of the return values, it is possible to perform two tests and return any of three values (and so on).

*String functions:* The Tools and Functions for Complex Trees Chapter covers a special set of functions that take text string arguments, instead of numeric or variable expressions.

*Markov functions:* The Markov Modeling Tools Chapter covers a special set of functions used in Markov modeling, for example in calculating transition probabilities.

**17.12 Using mathematical, statistical, and other functions**

- TreeAge Pro’s built-in functions are case-insensitive, with the name followed by parentheses, and in most cases take arguments in the parentheses.
- Functions that have multiple arguments must use semicolon (";") separators.
- In most cases, any valid expression can be used as an function argument (with the exception of MatrixMult).
- A separate section at the end of the chapter covers the special set of functions that take text string arguments, instead of numeric or variable expressions.
- Functions which here indicate an argument named "LIST" take a flexible number of arguments. For example, Average( ) returns the arithmetic mean of all of its arguments, so Average(1;4;8;13) = 6.5.
- In the tree window, use the Function Helper (see Chapter 13) for help in assigning the correct parameters to each functions. The functions are described
17.13 Recursive variable definitions

A recursive variable definition means a definition in which the variable being defined also occurs in the definition. Recursive definitions can be an effective way to build complex cost formulas, like those in the Cost Variables tree. Rather than creating one or more long formulas, you can gradually build the formula, adding components as events occur in each particular scenario.

17.13.1 How recursive definitions work

During calculation of a probability, payoff, or Markov reward, when the standard right-to-left search for a definition of a particular variable (e.g., “costX”) first locates a definition (e.g., “costX=1,000”), TreeAge Pro stops looking for additional definitions of that variable. However, when the first definition TreeAge Pro encounters in the search is a self-referential, recursive definition (e.g., “costX=costX+1,000”), the variable (e.g., “costX”) is flagged as a recursive variable, and TreeAge Pro continues searching for additional definitions of that variable to the left of the node where the first, recursive definition was found. Open the Special Features tutorial example tree Recursive Variables, shown below, to see an example of this process.

Recursive Variables model

All payoffs in the tree reference the same variable, costX, which has no default definition. The decision node’s topmost subtree, labeled Good Recursion, illustrates a valid recursive definition. When calculating the payoff of the first terminal node in the Good Recursion subtree, labeled High, the normal,
right-to-left search for a definition of costX finds the self-referential definition costX=costX+10 at that terminal node.

For the purposes of the current terminal node payoff calculation, costX is now identified as a recursively defined variable. The search for additional definitions of costX is now continued one node to the left, at the Good Recursion node. There, the non-recursive definition costX=10 is found, the search is complete, and the payoff calculation can be carried out.

Select the terminal node labeled High in the Good Recursion subtree, and choose Analysis > Expected Value. The calculated value is 20.

A non-recursive definition of the recursive variable, like costX=10 at the Good Recursion node, must eventually be found; definitions can’t be infinitely recursive.

Look at the second branch of the decision node, labeled Bad Recursion. In this subtree, when either terminal node’s payoff is evaluated, TreeAge Pro’s variable definition search locates a recursive definition. In both cases, the search for additional definitions is started one node to the left, at the Bad Recursion node. No non-recursive definition of x has been made there or at the root node. Therefore, if you try to calculate the Bad Recursion subtree, an error message will be shown. To see this, select the Bad Recursion node or either of its terminal nodes and choose Analysis > Expected Value command.

Multiple recursions, using a series of recursive definitions of a variable, will work, as shown in the Multiple Recursion subtree. Simply ensure that a numeric definition of the recursive variable will eventually be found. For example, in calculating the payoff of the terminal node labeled Middle in the Multiple Recursion subtree, the variable definition search locates the recursive definitions costX=costX+10 and costX=costX+5, and finally the non-recursive definition costX=0. Thus, the calculated value of the Middle terminal node is 15.

17.13.2 Complex recursion

Other variables may be referenced in a recursive definition. To see how TreeAge Pro’s variable definition search works with a combination of recursive and non-recursive variables, open the tutorial example tree "Multi-Variable Recursion".
Multi-Variable Recursion

To better explain this complex example, the text will illustrate the incremental changes in the payoff calculation formula during TreeAge Pro’s variable definition search.

All payoffs in the Multi Variable Recursion tree use the same variable, costX (payoff = costX). When the terminal node labeled Z is evaluated, the variable definition search finds the recursive definition costX=costX+costZ at the terminal node (payoff = costX + costZ).

Before a recursive search for costX is continued one node to the left, TreeAge Pro looks for a definition for costZ. The variable costZ is evaluated as a normal variable, which means that the search for a definition of costZ is started at the node being calculated, the terminal node Z. A normal right-to-left search locates the non-recursive definition costZ=1000 at the root node (payoff = costX + 1000).

The recursive search for additional definitions of costX is then continued at the Low Y chance node, which is one node to the left of the node where the initial, recursive definition of costX was found. Another recursive definition, costX=costX+costY, is found at the chance node labeled Y (payoff = [costX + 1000] + costY).

As above, before the recursive search continues, a normal variable definition search for costY is initiated at the terminal node being calculated, Z. At the chance node Low Y, the non-recursive definition costY=200 is located (payoff = [costX + 1000] + 200).

TreeAge Pro proceeds with the search for additional definitions of costX, starting at the root node. A non-recursive definition of costX is required, and found: costX=100. The final payoff formula for node Z, therefore, is [100 + 1000] + 200. Calculating an expected value for the Z terminal node returns the value 1300.

Before using complex recursion in your models, it is important that you be thoroughly familiar with the logic underlying both standard and recursive variable definitions in TreeAge Pro. You are also urged to test your model to make sure it appears to be calculating correctly.

In summary, the payoff value is costX ...

\[ payoff = costX \]
Based on the recursive definition at node Z, the expression changes to...

\[ \text{payoff} = \text{cost}\, X + \text{cost}\, Z \]

Substituting in the recursive definition for costX at node Y, the expression changes to...

\[ \text{payoff} = (\text{cost}\, X + \text{cost}\, Y) + \text{cost}\, Z \]

Now the right-to-left definitions for each variable can be resolved...

\[ \text{payoff} = 100 + 200 + 1,000 = 1,300 \]

The expected value at node Z is, in fact, 1,300.

### 17.14 Operators

Mathematical expressions used in TreeAge Pro necessarily contain operators (such as addition or multiplication signs). This section describes operators available in creating expressions.

#### 17.14.1 Arithmetic operators

These operators perform arithmetic on the values that surround them. TreeAge Pro uses the traditional syntax for expressions, known as infix notation. For example, an expression that adds three and seven would be written \(3 + 7\), rather than \(3, 7 +\).

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>(x + y)</td>
<td>Addition. Returns the sum of (x) and (y).</td>
</tr>
<tr>
<td>-</td>
<td>(x - y)</td>
<td>Subtraction. Returns the difference between (x) and (y). (Also used for negation, i.e., to denote negative numbers.)</td>
</tr>
<tr>
<td>*</td>
<td>(x \times y)</td>
<td>Multiplication. Returns the product of (x) and (y).</td>
</tr>
<tr>
<td>/</td>
<td>(x / y)</td>
<td>Division. Returns the quotient of (x) and (y).</td>
</tr>
<tr>
<td>^</td>
<td>(x ^ y)</td>
<td>Exponentiation. Returns (x) to the (y)th power.</td>
</tr>
<tr>
<td>()</td>
<td>(x \times (y+z))</td>
<td>Grouping. Returns the product of (x) and the sum of (y) and (z).</td>
</tr>
</tbody>
</table>

#### 17.14.2 Relational operators

These operators return a true or false value, depending on the veracity of the expression in which they appear. A true value is represented by a numeric 1, a false value receives a numeric value of 0. Relational operators are useful in many settings: in If() and Choose() functions, in expressions evaluated at logic nodes, and in a Markov termination condition.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>(x &lt; y)</td>
<td>Less than. Returns true if (x) is less than (y), and false if (x) is greater than or equal to (y).</td>
</tr>
</tbody>
</table>
### 17 Building Formulas Using Variables and Functions

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;=</td>
<td>x &lt;= y</td>
<td>Less than or equal to. Returns true if x is less than or equal to y, and false if x is greater than y.</td>
</tr>
<tr>
<td>&gt;</td>
<td>x &gt; y</td>
<td>Greater than. Returns true if x is greater than y, and false if x is less than or equal to y.</td>
</tr>
<tr>
<td>&gt;=</td>
<td>x &gt;= y</td>
<td>Greater than or equal to. Returns true if x is greater than or equal to y, and false if x is less than y.</td>
</tr>
<tr>
<td>=</td>
<td>x = y</td>
<td>Equals. Returns true if x equals y, and false if x is not equal to y.</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>x &lt;&gt; y</td>
<td>Not equal to. Returns true if x is not equal to y, and false if x equals y.</td>
</tr>
</tbody>
</table>

#### Relational operators

It is also possible, using the appropriate relational expression syntax, to test one value in terms of two others. There are a number of acceptable forms, with the two basic ones being:

- \( y < x < z \) - Returns true if x is both (a) greater than y and (b) less than z.
- \( y > x > z \) - Returns true if x is both (a) less than y and (b) greater than z.

Other valid forms of this syntax can be created by substituting \( \geq \) for \( > \) or \( \leq \) for \( < \) (for example, expressions of the form \( y \leq x < z \) and \( y > x \geq z \) are valid). These are the only valid substitutions, though (for example, expressions of the form \( y < x > z \) are not valid). Failure to follow these rules when creating relational expressions of this kind will likely result in unintended calculation results.

#### 17.14.3 Logical operators

Three logical operators are also available: logical AND, logical (inclusive) OR, and logical NOT.

AND is represented by the ampersand (\&), OR by the vertical bar (\|), and NOT by the exclamation mark (!). Like the relational operators (which return 1 if a comparison is true and 0 if not), these logical operators are zero-centric. That is, any operand that is non-zero is treated as true, and only a zero operand is treated as false. The returned value is 1 if the evaluation is true, and 0 if false.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;</td>
<td>w&lt;x &amp; y&lt;z</td>
<td>Logical AND. Returns true if w is less than x AND y is less than z.</td>
</tr>
<tr>
<td></td>
<td>w&lt;x</td>
<td>y&lt;z</td>
</tr>
<tr>
<td>!</td>
<td>!(w&lt;x)</td>
<td>Logical NOT. Returns true if w is not less than x.</td>
</tr>
</tbody>
</table>

#### Logical operators
17.14.4 Operator precedence

In most situations, you will not need to know the details of which operators bind most tightly. However, when formulas do not appear to calculate correctly, you should check this section to see if precedence is a factor.

Operator precedence is how TreeAge Pro decides where you intended to put parentheses. Consider the following example:

\[ A + B \times C + D \]

A quick check of the precedence list below indicates that multiplication has higher precedence (binds more tightly) than addition. TreeAge Pro will therefore interpret your expression as:

\[ A + (B \times C) + D \]

This process is continued until all uncertain bindings are resolved.

The table below lists the operators available in TreeAge Pro in order of precedence. Operators with higher precedence will bind more tightly. Adjacent operators having the same precedence value will be applied from left to right.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Character</th>
<th>Precedence Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unary minus</td>
<td>-</td>
<td>8</td>
</tr>
<tr>
<td>Logical NOT</td>
<td>!</td>
<td>8</td>
</tr>
<tr>
<td>Exponent</td>
<td>^</td>
<td>7</td>
</tr>
<tr>
<td>Multiplication</td>
<td>*</td>
<td>6</td>
</tr>
<tr>
<td>Division</td>
<td>/</td>
<td>6</td>
</tr>
<tr>
<td>Addition</td>
<td>+</td>
<td>5</td>
</tr>
<tr>
<td>Subtraction</td>
<td>+</td>
<td>5</td>
</tr>
<tr>
<td>Comparators</td>
<td>&lt;, &lt;=, etc.</td>
<td>4</td>
</tr>
<tr>
<td>Logical AND</td>
<td>&amp;</td>
<td>3</td>
</tr>
<tr>
<td>Logical OR</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Parentheses, Brackets</td>
<td>()[],</td>
<td>1</td>
</tr>
<tr>
<td>Functional argument separator</td>
<td>;</td>
<td>1</td>
</tr>
</tbody>
</table>

Operator precedence

Notice that parentheses are at the bottom of the list. This simply means that the operators inside the parentheses will bind tightly to stay within the parentheses. They are your most useful tool for indicating your particular precedence requirements.
### 17.15 Keywords

Keywords are reserved values auto-generated by TreeAge Pro that can be accessed within your model.

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>_stage</td>
<td>Markov cycle counter (starts with 0)</td>
</tr>
<tr>
<td>_tunnel</td>
<td>Markov cycle-in-state counter (starts with 1), requires state to be configured with tunnel max value</td>
</tr>
<tr>
<td>_state_index</td>
<td>Index for the Markov state counting down from the top (top state is 1, next down is 2, etc.)</td>
</tr>
<tr>
<td>_strategy</td>
<td>Returns the number of the strategy, defined as a branch directly coming from a decision node (numbered top to bottom). The value is undefined to the left of the first decision node or if the model has no decision node.</td>
</tr>
<tr>
<td>_trial</td>
<td>Index for the trial/iteration being processed in the Microsimulation loop of a simulation (always 1 when not running Microsimulation)</td>
</tr>
<tr>
<td>_trial_size</td>
<td>Number of trials/iterations for the Microsimulation loop</td>
</tr>
<tr>
<td>_sample</td>
<td>Index for the sample/iteration being processed in the sampling/PSA loop of a simulation (always 1 when not running PSA)</td>
</tr>
<tr>
<td>_sample_size</td>
<td>Number of samples/iterations for the PSA simulation loop</td>
</tr>
<tr>
<td>_voi_sample</td>
<td>Index for the value of information (VOI) iteration being processed, the outer most simulation loop in EVPPI analysis (always 1 when not running EVPPI)</td>
</tr>
<tr>
<td>_voi_sample_size</td>
<td>Number of iterations for the outer most simulation loop in EVPPI analysis</td>
</tr>
<tr>
<td>_node_id</td>
<td>Returns the numeric identifier for a specific node</td>
</tr>
<tr>
<td>_node_label</td>
<td>Returns the label for a specific node</td>
</tr>
<tr>
<td>_thread_index</td>
<td>Index for the thread which is running all or a portion of the overall simulation (simulations can run as multiple threads to increase the speed of the simulation)</td>
</tr>
<tr>
<td>_parallel_trials_clock</td>
<td>The current _clock value during a parallel trials discrete event simulation that uses the _CLOCK value to keep the trials synchronized.</td>
</tr>
<tr>
<td>_parallel_trial_creator</td>
<td>If you turn off probability coherence, you can create individuals in a parallel trials simulation. This keyword can be used by a new trial to get the number of the trial that created it (i.e., via a transition/chance event with non-coherent probs).</td>
</tr>
<tr>
<td>_parallel_trials_set</td>
<td>The index for the current set of parallel trials.</td>
</tr>
<tr>
<td>_parallel_trials_sets_size</td>
<td>The number of sets of parallel trials in the simulation.</td>
</tr>
<tr>
<td>Keyword</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>_cache_level</td>
<td>When using the Node() function to access parts of the tree, this returns the &quot;depth&quot; of the calls from nested Node() functions.</td>
</tr>
</tbody>
</table>
18. More Sensitivity Analysis Tools

The last 3 chapters provided detailed instructions on representing uncertain values using variables and performing one-way sensitivity analysis. This chapter covers sensitivity analysis options, multi-way sensitivity analysis, and special variations on one-way sensitivity analysis.

18.1 Analyzing variables with multiple definitions

While first learning how to use variables, it is not uncommon to unintentionally end up with a variable defined numerically at multiple nodes. While there are good reasons why TreeAge Pro allows the same variable to be defined at multiple nodes — as described in prior chapters — this situation is usually neither necessary or desirable with a variable intended for sensitivity analysis, as it may result in errors.

⚠️ It is strongly recommended that sensitivity analysis be limited to parameters defined at the root node with a numeric value. Variables that are defined by other variables, functions, etc. or that are defined at multiple nodes are generally not good candidates for sensitivity analysis. It is almost always possible to restructure variable definitions in such a way that the variable in question can be isolated as a numeric value at the root node.

We recommend that you avoid running sensitivity analysis on a variable with multiple definitions. However, this technique is shown for illustration only. If you must run sensitivity analysis on a variable with multiple definitions, you must specify which definitions should be used/changed within the sensitivity analysis.

We will look at running sensitivity analysis on the Get Started tutorial example tree, Climber Cost, specifically on the variable *numDays*. 
Note that there are several definitions for the variable numDays. You might want to run sensitivity analysis specifically on the number of days in the hospital associated with leg amputation. In such a case, you would only want to use the numDays variable definitions at the two nodes labeled Leg amputated.

A better and safer way to achieve this result would be to define separate numeric parameters numDaysLegAmpu, numDaysFootAmpu, etc. at the root node. Then you could set the generic numDays variable equal to the appropriate numeric parameter at different nodes in the tree.

Then you could run sensitivity analysis on the specific numeric parameter in question.

After selecting the variable numDays for sensitivity analysis in the One-Way Sensitivity Analysis Setup Dialog, click on the elipsis in the Definitions column.
18 More Sensitivity Analysis Tools

Sensitivity analysis setup dialog

You are then presented with another dialog to select the specific nodes where you want the variable definitions used for sensitivity analysis.

Sensitivity analysis setup - select nodes

Note that only the two Leg amputated nodes are selected. When sensitivity analysis runs, only the definitions at those two nodes will be altered.

18.2 Tornado diagrams

Tornado diagrams study the impact of any number of individual parameters, then present them together in a single analysis. Essentially, it is a consolidated set of one-way sensitivity analyses.

As a reminder from previous chapters, any variable which is defined at the root node as a fixed value or parameter distribution, is a valid choice for sensitivity analysis. There are examples of the warning/error messages which you will receive if you choose an invalid parameter for sensitivity analysis.

In the graph, a horizontal bar is generated for each variable being analyzed. Expected (or incremental) value is displayed on the horizontal axis, so each bar represents the selected node’s range of expected (or incremental) values generated by varying the related variable. A wide bar indicates the associated variable has a large potential effect on the expected value of your model (given the range provided for each variable).
The graph is called a tornado diagram because the bars are arranged in order, with the variable with the biggest impact at the top and the variable with the smallest impact at the bottom, resulting in a tornado-like appearance.

⚠️ Tornado diagrams were improved in the 2017 R2.0 release. This section refers to Tornado diagrams in versions of the software after and including 2017 R2.0. For editing Tornado Diagrams in versions prior to 2017 R2.0 refer to both sections Cost Effectiveness Tornado Diagrams (Legacy) and Customizing Tornado Diagrams (Legacy).

🔍 This section considers Tornado diagrams for models using the Simple Calculation Method. For Cost-Effectiveness models, refer to Sensitivity Analysis on Cost-Effectiveness Models.

The Business Tutorial example tree, Airline Problem, is used to generate a tornado diagram. The model uses the Simple Cost Calculation method and each of the inputs may be varied to see how it affects the expected value.

Airline Problem Tree

To create a tornado diagram:

- Select the decision node.
- Choose Analysis > Sensitivity Analysis > Tornado Diagram. OR select the Run Tornado Diagram icon in the tool bar (in Analyze mode).
- In the Tornado Diagram setup dialog, select each variable to analyze and enter the variable's low and high values and intervals (see figure below).
- If model calculations requires Microsimulation, check the box "Run microsimulation rather than EV". This is unlikely for non-healthcare models.
- Click OK to start the analysis.
Tornado diagram setup

You will receive a warning if the variable you have selected for Sensitivity Analysis is not a variable defined at the root node and a variable defined as a number or as a distribution. You will receive a warning if you select a variable that does not appear to be a parameter. See figures below.

Warning if any of the variables selected for Tornado Analysis are not a variable defined at the root node

Warning if the any of the variables selected for Tornado Analysis are not a constant or a distribution (i.e., Total_Cost, Total_Revenue)

The option to choose the Tornado diagram based on the Rewards or Incremental Rewards will be show, as in the figure below. We will examine both.
Choose the appropriate Report Option to present the Tornado Diagram as either Reward or Incremental Reward.

### 18.2.1 Reward Tornado

Select Reward, then click Open Report. The Tornado Diagram with the Reward report options for the Airline decision is shown below.

**Reward Tornado Diagram with Chart Settings and Actions**

There are three areas in the Tornado graph editor, which we will describe in detail:
- The Tornado Diagram and text report
- The Chart Settings (on the left-hand side)
- Secondary reports (Actions) (on the right-hand side)

The bars on the Tornado graph represent individual one-way sensitivity analysis performed at the selected node for each variable. The tornado diagram includes a vertical dotted line indicating the expected value. You can use this as a visual fulcrum, to view the impact of each variable relative to the original (baseline) expected value.

Tornado diagrams can be created at chance nodes and decision nodes. At a decision node, any threshold (i.e., change in strategy) will be identified in a variable’s tornado bar with a heavy vertical line. Threshold lines are drawn at the expected value on the x-axis at which the optimal path changes. Note the heavy vertical line at the left end of the Cap_Sched bar of the Tornado Diagram (top bar on the left-hand-side). This indicates a change in strategy to the Money Market strategy as the Expand Airline strategy value drops below the value of the Money Market strategy (optimal is the highest value). Since the Money Market strategy is fixed at $4,200, none of the bars can extend lower than that.

The heavy vertical line indicating a strategy change can be turned on and off via the Chart Settings, checking the box 'Show Thresholds'.

If a threshold appears at either end of a bar, this usually indicates that an alternative which is optimal for part of the analysis range has an unchanging expected value in that range. More details about the change in strategy indicated by the threshold line can be seen from the corresponding One-Way Sensitivity Analysis graph, which can be opened via the links.

To better understand the threshold for the Hours Flown parameter, click on the One-Way Sensitivity Analyses secondary report for "Hours flown" to generate the following graph.
One-Way Sensitivity Analysis on Hours Flown

Since the tornado diagram only shows the optimal strategy (highest value), the bar's low end is at the Expected Value of 4,200 where there is a strategy change.

If you click on the Tornado Text Report link to the right of the Tornado graph (in the Actions section), you will see the input and output range for each parameter.

Tornado Diagram Text Report

The variable range columns (Variable Low and Variable High) show the range you entered for each variable. The Low and High columns show the lowest and highest expected value for the cost (in this model) based on the optimal strategy at each point. Note that none of the values in the low value can reach below $4,200, since that is the fixed value for the Money Market strategy.

The Tornado Diagram Text Report also includes:

- **Spread**: This is the width of the bar (i.e., High EV minus Low EV).
- **Spread^2**: The spread value, squared. Adding the Spread^2 values to calculate a net risk value, two additional measures of uncertainty are then calculated for each variable: Risk % and Cumulative Risk%.

- **Risk %**: This is a measure of how much of the total uncertainty is represented by the specified bar (equal to: SpreadSqr / NetRisk). The Risk% values sum to 1.0 across all the variables.

- **Cum Risk %**: A cumulative version of Risk %, making it easy to scan the bars and say “to address 90% of the risk, I must consider the uncertainty represented by the following variables….”

The Chart Settings allow modification of the Tornado diagram easily. The figure below shows the elements of the Chart Editor and they are described in more detail below.

![Chart Settings for a Tornado diagram](image)

- **Show title**: Check this box to show/hide the title. The title can be changed using the text box below the Show Title check box (currently ‘Tornado Diagram’).

- **Show legend**: Various options for show/hide variables names and descriptions. The Numeric format of these variables is changed via selecting the button ‘Numeric formatting...’ to change: number of decimal places; add trailing zeros and use thousand separators.
- **Show variable range**: This is included in the Show Legend grouping above:
  - **Order by EV impact**: This orders the variable description by their EV impact. This allows you to see from the key whether the the EV increases or decreases as the variable changes.
  - **Order by parameter value**: This orders the variable description by their parameter value from lowest to highest.
  - **Include base case**: This includes the base case parameter value prior to the parameter's uncertainty range.
  - The figure below shows the differences in these two options specifically for the impact of the Insurance parameter. The 1-way sensitivity analysis graph shows how increasing Insurance, decreases the EV.

- **Axis**: Change the label, range and numeric formatting on the horizontal axis.
- **Show EV Line**: Check box to show the EV line and edit the text and numeric formatting via ‘Numeric formatting…’ button.
- **Show thresholds**: This turns on and off the Threshold where there is a change in strategy (see above for further explanation).
- **Extend bars using threshold info (NMB Tornado Only)**: Tornado diagrams include calculations at specific points in the variable parameter range based on the number of intervals. TreeAge Pro interpolates between each pair of calculations to draw graph lines and identify CE thresholds. Occasionally, the CE threshold identified through interpolation will be beyond the edges of the calculated values themselves to the left or right. This option extends the width of the bar to include the interpolated threshold value for the parameter.
- **Bar colors**: Edit the colors of the bars or select grey scale colors for each variable.

Use the double arrow at the top to hide or view the Chart Settings.

After making any changes, use the Apply button to make the changes to the Tornado diagram.
Compare differences in Legend for the Tornado diagram. This figure highlights the Insurance parameter: "Order by EV impact"; "Order by parameter value"; 1-way sensitivity analysis output.

The 1-way sensitivity analysis graph is a great way to understand the impact of any parameter on the EVs.

### 18.2.2 Incremental Reward Tornados

A Tornado diagram can report the sensitivity of the incremental/marginal value calculated between two strategies.

To create an incremental tornado diagram:

- Run a regular tornado diagram as described above.
- In the first section, select "Incremental Reward".
- Then select the pair of strategies, setting one as the Comparator and one as the Base line.
- Then Open Report.

Note that every combination of strategies will be an option, including each pair switching the comparator and baseline. Incremental values are calculated as Comparator - Baseline.
Choose the appropriate Report Option to present the Incremental Tornado Diagram, selecting which strategies are Comparator and Baseline. These options generate the Incremental Reward Tornado shown in the figure below.

Incremental Reward Tornado Diagram with Chart Settings and Actions

The incremental tornado may actually be of more value because it shows how the difference between the two strategies changes with the changes in each parameter.

Note that the EV line in the middle represents the incremental value between the two strategies using the base case value for each parameter. As the parameters deviate from their base case values, the incremental value changes.
For the top parameter Capacity, the incremental value increases as the parameter increases with the blue bar section representing the parameter range from the low uncertainty value to the base case, while the red bar section represents the parameter range from the base case to the high uncertainty value. In contrast, the Insurance parameter moves the other direction - the incremental value decreases as the parameter value increases.

If the parameter bar passes through the zero point on the x-axis, then that parameter's uncertainty range includes a strategy change. These can be highlighted using the option on the left to "Show 0 line" which is not visible above due to scrolling. Note that the three parameters with thresholds - Capacity, Hours, Charter Price - are the same three parameters that showed thresholds in the Reward Tornado graph.

The secondary reports and report options here are similar to those for the Reward Tornado.

18.2.3 Including correlated variables in the tornado diagram

As in all sensitivity analyses, if you select a variable for the tornado diagram which has correlations, the correlated variables will vary together. The Analyzing correlated variables section contains additional information related to sensitivity analysis on correlations. The names of the correlated variables are shown in the list of variables available for inclusion in a Tornado Diagram. A pair of correlated variables cannot both be selected for the Tornado Diagram as they would have identical results.

18.3 Two-way sensitivity analysis

Two-way sensitivity analysis is used to examine the impact on a decision of simultaneous changes in the values of two variables. One method is to run a series of one-way analyses, each time incrementing the value of a second variable.

Another method available in TreeAge Pro is to automate this series of analyses and present the results in a region graph. The region graph very efficiently identifies changes in the optimal policy as the values of the two variables change.

The two-way sensitivity analysis setup dialog resembles the one-way dialog, except that you must specify two variables and a range of values for each. A decision node must be selected in order to perform a two-way sensitivity analysis.

To perform a two-way sensitivity analysis:

- Open the Get Started tutorial example tree, Three Vars.
- Select the root node.
- Choose Analysis > Sensitivity Analysis > Two-Way.
- For one variable, select pay_up, and specify the range from 200 to 800 with 6 intervals.
- For the second variable, select `prob_extreme`, and specify the range from 0 to 0.5 with 5 intervals.
- Do not check the box to "Run microsimulation" because this is a cohort model. This is an option for Patient Level Simulation models.
- Click OK to run the analysis.

Two-Way Sensitivity Analysis Setup

Be careful not to select variables that are formulas, rather than numeric parameters defined at the root node. A warning will alert you to this issue if you have selected such a variable.

The resulting graph is shown below. It identifies which strategy is optimal in regions of values of the variables; thresholds are simply the border between two regions.

Two-Way Sensitivity Analysis Graph

The first variable in the setup dialog (`pay_up`) forms the horizontal axis of the graph, while the second variable (`prob_extreme`) forms the vertical axis.

It is recommended that you use two-way analysis only when the two variables are independent. If the two variables are a correlated pair, be sure to turn off the correlation.
18.3.1 Choosing intervals

Based on the selecting X intervals for one variable, and Y intervals for the other, TreeAge Pro recalculates the tree \((X+1) \times (Y+1)\) times, for the different combinations of values of the two variables. In the example on the previous page, 42 \((7 \times 6)\) recalculations occur, creating a grid of sensitivity analysis results.

You may find that a two-way analysis requires more intervals per variable to attain a reasonable level of accuracy than a one-way analysis. This is because a two-way analysis graphically represents only the threshold values – the optimal path crossings. The one-way analysis may show significant details which are simply not shown in the two-way analysis.

The graphical representation of the results of two-way sensitivity analysis has some unavoidable limitations; this also applies to three-way analysis.

- The accuracy of threshold lines may be compromised around the edges of the graph. The unavoidable result of using approximation techniques to identify thresholds is the appearance of distortion when two edges of a region of optimality draw closer together than one-half the width of an axis interval. Accuracy can be enhanced by running the analysis using more intervals.
- Threshold lines represent points of indifference. Regions of indifference, however, are not shown. Areas of the graph where indifference exists are instead assigned to one alternative.
- You should use the text report (accessed via the Actions > or Graph > Text Report… command) to identify any areas of indifference by comparing the expected values at each interval. Isocontours (next section, but not yet implemented.) of small magnitude may also help identify where indifference ends.

18.3.2 Two-way sensitivity analysis text report

The region graph's text report is accessible from the "Text Report" link to the right of the graph. There are two other options of text reports "Text Report (Flat)" and "Text Report (html)" with different formats of the same report. The text report displays a grouped matrix of results.
Two-Way Sensitivity Analysis Text Report

The text report’s layout is based on the graph axes. There are two columns for each variable, one for pay_up and one for prob_extreme. The third column gives the strategy and the forth column the value of the strategies, depending on which combination of variables have been selected.

There are two chart options:

- Change order of variables: This changes the order of the variables between column 1 and 2.
- Change order of strategies: The changes the outputs in the value column based on the new order of the strategies.

The variable in the first column can be used to group the outputs by using the ‘+’ and ‘-’ buttons. By changing the order of the variables or strategies (using the links on the right hand side) you can present the results as required.

18.3.3 Custom iscontours

Isocontours were not implemented in TreeAge Pro 201x.
18.4 Three-way sensitivity analysis

The three-way sensitivity analysis dialog looks the same as the to the two- and one-way sensitivity analysis dialog except that three variable ranges are entered.

Three-Way Sensitivity Analysis Setup

Three variables cannot be presented clearly in a two-dimensional graph. Therefore, the results of a three-way sensitivity analysis are presented as an animated two-way sensitivity analysis region graph. The third variable is represented not with its own axis, but rather using a series of two-way graphs — if four intervals are specified for the third variable, then five graphs will be created, and shown in series.

Three-way sensitivity analysis

Use the Animate button or the scroll bar to cause the third variable to cycle through its range. The successive frames of the three-way analysis shows how the two-way region/optimality graph for the first two variables is affected by varying the value of the third variable.

18.4.1 Three-way sensitivity text report

The three-way version of the region graph now allows viewing and exporting the text report for all combinations of variables.

The three variable inputs, strategies and the corresponding output (value) are displayed in columns. The grouping is based on the first, second and then third variable.
Three-way sensitivity analysis text report

There are two chart options:

- Change order of variables: This changes the order of the variables between columns 1, 2 and 3.
- Change order of strategies: The changes the outputs in the value column based on the new order of the strategies.

18.5 Threshold analysis

This specialized form of sensitivity analysis offers the ability to search more thoroughly and accurately for threshold information. The result of this analysis is a detailed, textual description of how the optimal strategy is affected by changing the value of a single variable across a designated range.

In a standard one-way sensitivity analysis, the user designates the number of intervals into which the range is to be divided; actual calculations occur only at these intervals. As a result, the accuracy of the associated threshold analysis is limited to values determined by linear interpolation.

In contrast, threshold analysis has been designed to maximize accuracy of the analysis in situations where accuracy is more critical than speed. The specified range is iteratively searched until a specified minimum tolerance is reached.
This section will use the Get Started tutorial example tree Three Variables to illustrate threshold analysis.

To run threshold analysis:

- Choose Analysis > Sensitivity Analysis > Threshold Analysis from the menu.
- In the Threshold Analysis dialog, specify a variable and range, a tolerance and a degree of linearity. See below.

![Threshold Analysis Dialog](image)

The variable selection is the same as for one-way sensitivity analysis.

The tolerance is stated in the same units of value as the variable in question; it is not a percentage. The tolerance is related to the value of the variable, not to expected value. Thus, entering a tolerance of 0.1 means that the actual location of any threshold will be within plus or minus 0.1. For example, if TreeAge Pro indicates finding a threshold at Var=0.391, this means that the threshold definitely occurs somewhere between 0.381 and 0.401. Because TreeAge Pro applies linear interpolation after it meets your tolerance, you can expect the actual reported value to be even more accurate than the tolerance.

The Degree of non-linearity is used to try to avoid missing thresholds by dividing up the range into smaller intervals for the first pass. See note at the bottom of this section for more details.

The resulting Threshold Analysis Report is presented below.

![Threshold Analysis Report](image)
The threshold analysis report shows the thresholds (rows) and information about each threshold (columns) in a table. The columns include:

- **Attribute**: The value for which thresholds were identified. This is usually EV for expected value.
- **Variable**: The variable for which the value was varied to identify thresholds.
- **Var. Value**: The value of that variable at the threshold.
- **Strategy 1, Strategy 2**: The strategies with equal expected value at that threshold.
- **Exp. Value**: The expected value of the two strategies at that threshold.

A sensitivity analysis may indicate multiple threshold values. However, this series of changes in policy will be identified correctly by TreeAge Pro only if the thresholds appear in different intervals in the first iterative pass. Since linear interpolation is used to find thresholds in a sensitivity analysis, only one threshold can be found per analysis interval.

For example, suppose that two thresholds exist in the same analysis interval, with optimality switching between the same decision options. Since the same policy is optimal at both ends, notwithstanding the intervening thresholds, TreeAge Pro will assume that no thresholds occur in that interval. There is no way to avoid this problem entirely. TreeAge Pro could subdivide a range into 100 intervals and still miss policy changes within an interval if the same optimal policy is specified at both ends. Even if different strategies are optimal at either end of an interval, and TreeAge Pro identifies a threshold in that interval, it is still possible that one or more additional thresholds in that same interval will have been missed.

For example, three alternatives, A, B, and C, might be compared using a sensitivity analysis; A is optimal at the beginning of an interval, B in the middle, and C at the end. Although you know that two thresholds (A to B, then B to C) actually occur, TreeAge Pro will find just one (a nonexistent one, A to C) from looking at the optimal alternative at the ends of the interval. The non-linearity hint is an attempt to minimize the likelihood this will occur. The more non-linear you describe the graph to be, the smaller the interval used by TreeAge Pro, so as to ensure catching any double thresholds.

### 18.6 Analyzing correlated variables

Linkages (i.e., perfect positive or negative correlations) between pairs of variables can be specified, for use during sensitivity analysis. These value linkages are set up in the Variable Properties View, Sensitivity Analysis Tab as described in the Working With Variables Chapter.
Correlated variables

Once created, the correlation is identified in the properties of both variables. Thus, when you choose to perform a sensitivity analysis on either member of a correlated pair of variables, TreeAge Pro will auto-adjust the correlated variable at the same time.

To perform a sensitivity analysis using correlated variables:

- Open the Special Features tutorial example tree, Correlated Variables. This tree already includes a positive correlation specified between the variables utilLoseFoot and utilLoseLeg. See above.
- Select the root, decision node.
- Choose Analysis > Sensitivity Analysis > One-Way… from the menu.
- In the Sensitivity Analysis dialog, select the variable utilLoseFoot. Specify 10 intervals and a range of 0.4 to 0.9. Click OK.

As the selected variable utilLoseFoot moves within its range (0.4 to 0.9), the correlated variable utilLoseLeg will move within its range (0.3 to 0.7).
18 More Sensitivity Analysis Tools

Sensitivity Analysis with Correlated Variables

Note that the Treat Foot strategy's EV rises with the value of $\text{utilLoseFoot}$ even though $\text{utilLoseFoot}$ is not referenced by that strategy. This change is a result of the change in the correlated variable $\text{utilLoseLeg}$.

18.7 Additional sensitivity analysis topics

Other chapters cover additional software features which can be useful in testing the sensitivity of your trees, but whose use is not restricted to performing sensitivity analysis.

- Creating analysis sequences (Stored Analysis Abstracts and Sequences Chapter)
- Using variable sliders (Working With Variables Chapter)
- Linking trees (Tools and Functions for Complex Trees Chapter)
- Probabilistic sensitivity analysis (Probabilistic Sensitivity Analysis Chapter)

18.7.1 Sensitivity analysis on variables with non-numeric definitions

A sensitivity analysis can be performed on any variable in your tree, whether it has a numeric value definition (e.g., $X=1$ or $X=\text{Exp}(2)$) or a variable expression (e.g., $X=\text{Rate}^*\text{Util}$). When performing a sensitivity analysis on a variable defined as a formula, you have multiple options. You can perform a sensitivity analysis on the component variables (e.g., Rate and Util) using variable correlations or a multi-way sensitivity analysis. Alternatively, you can perform a one-way sensitivity analysis on the original variable (e.g., $X$) based on an estimated numeric value range.
If you treat X as the independent variable, however, the formula will be ignored during the course of the analysis. Definitions of Rate and/or Util at different points in your tree will not be used during this analysis.

It is advisable to focus sensitivity analysis on the finest-grain parameters. In the example above, X is no longer “finest-grain,” as it has been defined in terms of its two component variables. In general, models should be designed to ensure that the sensitive variables have a single numeric definition.

18.7.2 Checking probability coherence

Most forms of sensitivity analysis offer an option labeled Check coherence. When this option is selected, TreeAge Pro will ensure that, at each interval, (i) all probabilities sum to 1.0 and (ii) no probabilities are negative. The analysis will be halted if at any time either rule is violated.

If the subject variable is used to define a probability, you are encouraged to leave this option selected. This will ensure the validity of your model over the range of the analysis. This is particularly important in the initial stages of testing your model’s validity. The downside is that calculation time is increased. If calculation speed is a concern, and you are not including any probability variables in the sensitivity analysis, you may want to turn off coherence checking.

Also see the section on probability non-coherence in the Advanced Chance Node Techniques and Options Chapter.

18.7.3 Analyzing a single option

Normally, when performing a sensitivity analysis, a decision node is selected and TreeAge Pro displays one line for each of the alternative scenarios rooted at the selected node. It is possible to focus a one-way sensitivity analysis on a single scenario, rather than on all of the scenarios emanating from a decision node.

If the node you select prior to performing the sensitivity analysis is not a decision node, TreeAge Pro will assume that the results should be presented as a single line. This will represent the changing expected value of the scenario rooted at the selected node. (Healthcare module users: Note that this option is not available for cost-effectiveness sensitivity analyses, which must be performed at a decision node.)

If, however, you select a decision node which is an immediate descendant of a decision node, TreeAge Pro will give you the option of drawing one line for the selected node (as a branch of its parent), or multiple lines for the branches emanating from the selected decision node.
19. Monte Carlo Simulation, Distributions and Probabilistic Sensitivity Analysis

This chapter provides instructions on creating and referencing sampling distributions, performing Monte Carlo simulation, and interpreting the results.

The Distribution Functions, Options and Types Chapter provides details on functions for accessing distributions, options/customizations, and other usage details related to the built-in distributions available in TreeAge Pro. Instructions on creating custom, table-based distributions are found in the Creating and Using Tables Chapter.

For detailed information on using the Healthcare module to perform probabilistic sensitivity analysis and microsimulation on Markov and cost-effectiveness models, see the Cost-Effectiveness Simulation Reports and Graphs Chapters and the Individual-Level Simulation and Markov Models Chapter.

19.1 Uses of Monte Carlo simulation in modeling

The first section of this chapter summarizes some common applications of Monte Carlo techniques and tools in TreeAge Pro. The rest of the chapter focuses on setting up distributions in your model, and running probabilistic sensitivity analysis.

For tutorials on performing individual-level simulation (in particular, on Markov models), refer to the Individual-Level Simulation and Markov Models Chapter.

19.1.1 Monte Carlo overview

Each of the analyses described in previous chapters, including sensitivity analysis, is deterministic. There is no randomness in these types of expected value (EV) calculations: each parameter uses a specified point value, and every path through the model has a deterministic weight in the EV calculation based on its path probability (no matter how unlikely). If roll back or another analysis is repeated using the same parameters and tree, results do not change.

In contrast, there are many situations where it is useful to introduce random, or stochastic, elements into some part of the analysis. In such situations, Monte Carlo techniques can be applied.

A decision analysis model is a way of visualizing a potentially very complex equation. One level of uncertainty in a particular problem and its corresponding model is made visible with chance nodes: our uncertainty about the current and future state(s) of a modeled individual or experimental outcome. Discrete (or micro-) simulation can be used to explore this 1st-order uncertainty (perhaps better labeled as variability). In decision analysis, the goal of such a simulation is generally still to calculate an expected value for each strategy being compared (in this case, an approximation based on long-run averaging of many random walks).
A separate, distinct level of uncertainty about a problem is, of course, *parameter uncertainty*. In this case, a parameter refers to some aspect of the system or world in which all our subjects, individuals, or experiments will operate (as opposed to some variable characteristic/state of a single subject). In some models and some systems, selected parameters (e.g., gravitational constant) may be known with precision, based on experimentation. In most decision analysis models, important system parameters (e.g., failure or survival rates) have not yet, or may never be, defined precisely through experimentation. Monte Carlo probabilistic sensitivity analysis (PSA) can be used to calculate an expected value over 2nd-order uncertainties for a particular strategy.

Of course, in addition to reporting simple mean values, simulation “experiments” can be performed: individual-level, discrete simulation and/or probabilistic sensitivity analysis. Simulation output can be examined to account for uncertainty, calculating standard deviations/errors, percentiles or credible intervals, and a wide variety of other statistics.

Finally, multi-dimensional expectations can be carried out (when required), in which case the 2nd-order/parameter uncertainties (or value of information) are of primary interest and placed in an outer loop, while each repetition of the PSA expected value calculation may be approximated using a separate, inner, discrete simulation expectation/loop.

Additional overview of different Monte Carlo applications follows.

---

**19.1.2 Discrete (or micro-) simulation**

Discrete simulation (microsimulation or 1st-order trials) is commonly used in the analysis of complex survival/failure models. Such simulation applications are covered in detail in the Individual-Level Simulation and Markov Models Chapter.

A much simpler, non-Markov discrete simulation, using the Stock Tree, is illustrated in the Analyzing Decision Trees Chapter. As described in the example, one way to look at a discrete simulation is as an approximation to expected value (EV) calculations in a decision tree. Simulation basically approximates EV calculations by sampling a representative distribution of paths through a model’s chance events. A discrete simulation of a complex model will often repeat as many “trials” as time allows, in order to improve the EV approximation.

In a single discrete simulation trial, a random walk (i.e., a series of uniform, pseudo-random numbers) selects a path through the chance nodes in the tree, with higher probability paths being more likely.
Running \(n\) simulation trials results in a list of \(n\) randomly-chosen outcomes, for example 10,000 “individuals” and their 20-year costs and life expectancy.

Although discrete simulation has less relevance in the average tree than in typical Markov projects, it is possible for very unwieldy trees to be greatly simplified or made more realistically by substituting probability distributions (e.g., Normal, Gamma, Exponential, etc.) for chance nodes, which are basically just discrete “distributions.” The required model changes are simple; the main sacrifice would be the requirement to use simulation instead of familiar EV analyses (like 1-way sensitivity analysis).

For example, the investment tree from the Analyzing Decision Trees Chapter could be revised with the risky investment chance node removed, and payoffs updated to include a likelihood distribution (e.g., Normal) representing change in investment value. Repeated investment decisions could also easily be modeled.

So, in discrete simulation models, variability can have two sources: chance node probabilities and parameterized distributions. In addition to possibly replacing event nodes in the tree, distributions have another, more common, application in simulation models. While simulation models sometimes assume a “homogenous cohort,” and include no initial variability in the characteristics of trials/entities, other models sample initial characteristics/states from probability distributions.

For example, a trial’s age might be sampled from a 1st-order distribution describing the population age distribution. Or, individuals might be bootstrapped from a table. (In an EV/cohort analysis model, in comparison, an initial series of chance nodes would explicitly separate subgroups based on patient characteristics, e.g., a few age groups.)

When parameterizing a distribution which represents 1st-order variability, simply change the sampling rate behavior from the default setting (for 2nd-order uncertainty) to instead sample per individual/1st-order trial.

19.1.3 Probabilistic sensitivity analysis

Like deterministic, \(n\)-way sensitivity analysis, Monte Carlo probabilistic sensitivity analysis (PSA) recalculates expected values in a tree multiple times, and is used to understand the impact of parameter uncertainties on the model results. One advantage of PSA is that any number of parameter uncertainties can be incorporated into an analysis. Sampling also enables greater weight to be placed on likely parameter values and combinations of parameters. PSA results estimate the total impact of uncertainty on the model, or the confidence that can be placed in the analysis results.

Probabilistic sensitivity analysis is covered in detail in the subsequent sections of this chapter.

19.1.4 Parameter distributions and model non-linearity

During a non-sampling analysis like rollback, all distributions in your model are fixed at their mean values. In some cases, taking an expected value from roll back will be equivalent to taking the sampling
mean from a probabilistic sensitivity analysis. However, this is not the case with all models and all parameters.

In a probabilistic sensitivity analysis on an uncertain rate in a survival model, for example, the sampling mean outcomes may differ significantly from the simple roll back “expected values” based on the point/mean value for the parameter. In such cases, the Monte Carlo PSA sampling means are the correct and preferred “expected values” for the model (assuming the likelihood distributions for the parameters are well-formed).

To support the complex, potentially lengthy types of analysis described in this chapter, TreeAge Pro can utilize up to eight processors on a single computer when performing Monte Carlo simulation.

19.1.5 EVPI/value of information analysis

Monte Carlo simulation can be used to perform various kinds of “value of information” analysis, similar to the structural form of EVPI described in the Analyzing Decision Trees Chapter.

The Analysis > Expected Value of Perfect Information command in TreeAge Pro calculates the difference between the baseline expected value of a decision, and the expected value when a chance node is temporarily shifted to the left of the decision. In a Monte Carlo simulation, the calculation of EVPI is done differently.

For example, if the optimal strategy changes depending on the values sampled for critical parameter uncertainties, then there would be some benefit to having “perfect information” about the uncertainty prior to the decision. The average of the values of each recalculation’s best option is the expected value with perfect information; it will either be equal to or greater than the best average value for any single alternative. Calculating the difference gives the expected value of perfect information.

Earlier versions of TreeAge Pro added EVPI reporting and charting options to the Monte Carlo simulation output window’s Graph popup menu. EVPI (and partial EVPI) are described later in this chapter.

19.2 Creating distributions

This section describes the basic steps for performing probabilistic sensitivity analysis:

- Define distributions for your parameters;
- Use the distributions in the tree;
- Run a Monte Carlo simulation, to repeatedly: A) sample from distributions and B) recalculate expected values.

As detailed in the previous chapters on performing deterministic, \( n \)-way sensitivity analysis in TreeAge Pro, parameters targeted for analysis must be defined using variables. Similarly, before using Monte
Monte Carlo simulation to perform probabilistic sensitivity analysis in TreeAge Pro, uncertain parameters must be defined using distributions.

Probability distributions can be employed in any formula in a tree, including variable definitions, payoffs/rewards, probabilities, and even parameters of other distributions. TreeAge Pro includes 20 built-in distribution types (Normal, Beta, etc.), as well as enabling sampling from custom, discrete “table” distributions. The Distribution Functions, Options and Types Chapter describes the functions and options available with distributions.

In TreeAge Pro, the distributions that you define are stored in a list in the tree like variables. Unlike variables, distributions are assigned an integer index (and a name, optionally). A distribution can be referenced in the tree with the Dist(n) function (where n is the distribution’s index) or alternatively by the distribution’s variable-type name. To illustrate the basic steps for probabilistic sensitivity analysis, the simple Stock Tree will be used. The tree – with variables but no distributions yet – is shown below.

![Stock Tree Diagram]

**Three Variables Model**

### 19.2.1 Defining a parameter using a distribution

The first steps are to change the payoff of the Large increase terminal node from a point estimate of 500 to a Normal distribution with a mean of 500 and a standard deviation of 100.

To define a distribution in the tree:

- Open the Get Started tutorial example tree “Three Variables”.
- Save a copy named “Stock Simulation”.
- Choose Views > Distributions from the menu.
- In the Distribution Properties View, click the "plus" toolbar icon to create a new distribution. The Add/Change Distribution dialog will open.
- Enter the new distribution’s properties (type, name, description) and parameters (mean, std dev). Leave 'override mean' blank. The values are presented in the screen print below. After clicking OK, the new distribution will be listed in the Distribution Properties View (see below).
When a model references a parameter distribution (Sample per EV), it will use a distribution sample for each recalculation of the model within the PSA analysis. When not running PSA analysis, references to the distribution will use the distribution mean by default. If you want non-PSA analyses to use a different value than the distribution mean, enter an expression into the "Override mean" field in the dialog below. Overriding the mean handles the case where the distribution represents uncertainty that is not "centered" around the base case parameter value - meaning the uncertainty suggests the is more likely to be either greater than or lesser than the original parameter base case value.

Add/Change Distribution Dialog

Use the Help icon in the Add/Edit Distributions Dialog to access the formulas TreeAge Pro uses for each distribution.

Distributions View

At this point, you have created the distribution, but it has not been integrated into the model. The new distribution represents the value for a high return from the risky investment. Therefore, it could be
entered directly as the payoff value for that terminal node, or it could be used in the definition for the variable pay_up. We will use the second option.

To use the distribution in the pay_up variable definition:

- Right-click on the root node.
- Choose Define Variable > pay_up from the context menu.
- Clear out the existing definition (500).
- In the Group list, choose Distributions then double click on the distribution in the Element list.

Define pay_up with distribution dNorm_500_100

You could also have used the syntax Dist(1) instead of the distribution name since the distribution's index is 1.
Distribution notes:
During roll back and other non-sampling analyses, a distribution is equal to its mean value. In the example, pay_up will still equal 500 during expected value calculations, because this was specified as the mean value of the Normal distribution.
To override the mean value in non-sampling analyses, use the 'override mean' function in the Add/change Distribution.
The Dist() function in TreeAge Pro is equivalent to the DistSamp() function in DATA and earlier versions. Other versions of the distribution function, including DistForce() and DistKids(), are described in the next chapter.
During a single iteration of a sampling simulation, all references to a particular distribution return the same sample value because the default sampling rate (Once per EV) was used. The sampling rate can be set to resample more frequently, for example in Markov microsimulations.
Each named distribution can be presented in a list at the root node of the tree. To show the list on the face of the tree, turn on the "Show named distributions" option within the Display > Variables/Markov Info category of Tree Preferences.

19.2.2 Distributions View
Distributions are managed (added, edited and deleted) through the Distributions View. This is a tree-level view since distributions are "global" within the context of a tree (like variable properties, but not like variable definitions).
Below is a screen print of the view showing one of each of the possible distribution types supported by TreeAge Pro.

Distributions View

The toolbar executes the following functions within this view.

- **Edit**: Open the Add/Change Distribution Dialog to edit the properties and parameters of a single distribution selected in the list.
- **Add**: Add a new distribution via the Add/Change Distribution Dialog.
- **Add new distributions**: Add multiple distributions via the Add/Change Distribution Dialog.
- **Delete**: Delete the distribution(s) selected in the list.
- **Copy distribution**: Select the row with the Distribution(s) you wish to copy. Click the copy icon to copy the Distribution(s) into the clipboard. See the Variable Properties View for details about copying/pasting.
- **Paste distribution**: Copy distribution(s) (as above from another model) and click the paste icon to paste the distribution(s) into the active model. See the Variable Properties View for details about copying/pasting.
- **Group by Category**: Show the distributions list grouped by category.
- **Edit in Excel**: Output the distribution properties and parameters to Excel, where they can be edited and returned to TreeAge Pro.
- **Report**: Generate a report showing parameters and EV values for each distribution.
- **Graph It**: Sample from the distribution and create a graph displaying the sampled values.

WE STRONGLY RECOMMEND USING THE GRAPH IT OPTION TO VALIDATE EVERY DISTRIBUTION AFTER IT IS CREATED.

- **Highlight**: Highlight the distribution within the model in the Tree Diagram Editor.
- Search: Find all references to the distribution in the model.

Distributions View Functions

The next chapter contains additional information on managing distributions.

The Edit in Excel button can be used to export selected distributions to a table in a new Excel worksheet where they can be edited. From Excel, the Add or Update Distributions command in the TreeAge Add-In menu can be used to update the active tree with any changes. Refer to the Graphing, Reporting and Modeling Using Excel Chapter for details.

19.3 Performing probabilistic sensitivity analysis

After defining and using distributions in your tree, you can run a Monte Carlo simulation to see how resampling parameter values affects calculations at a selected node. Simulations can be run at any node except a terminal node, making it possible to analyze only part of a tree.

To perform a probabilistic sensitivity analysis/Monte Carlo simulation:

- Select the root node of the "Stock Simulation" tree built in the prior section.
- Choose Analysis > Monte Carlo Simulation > Sampling (Probabilistic Sensitivity)...from the menu. The Monte Carlo Simulation Dialog will open.

Monte Carlo Simulation Dialog

If you have defined distributions in the Distributions View (even if they are not used anywhere in the tree), the Monte Carlo Simulation Dialog will present a variety of options for the analysis. In this case, you simply specify the desired number of distribution samples and corresponding model recalculations.

Now, specify the settings to use for this simulation:

- Change the number of distribution samples to 500.
- Click Begin to start the simulation.
In running this simulation, TreeAge Pro will randomly sample 500 values from the distribution defined in the tree and recalculate expected values for the branches of the selected decision node based on each parameter sample.

Monte Carlo Simulation Progress Dialog

The simulation output window shows the progress of the simulation. During long running simulations, it may be helpful to run the analysis in the background to allow you to continue working in TreeAge Pro. You can also click the Cancel button to stop the analysis.

Once the simulation is complete, a final statistical summary will be displayed. The summary includes mean, standard deviation, and other summary statistics for each strategy.

Probabilistic Sensitivity Analysis Output

If a simulation is performed at a decision node, the summary statistics for each branch are presented from left to right starting with the top branch. The statistics report can be exported to several formats (HTML, Excel, Word, etc.) by clicking the "Export Report As..." toolbar icon in the simulation output window. See the section Probabilistic Sensitivity Analysis Reports for more details on all the reports.

Note that the mean value above for the Risky investment strategy is close to but is not equal to 10 (the expected value without simulation). If more iterations (samples) were selected for the simulation, that mean would move closer to the expected value. Note that there is no variance in the CD Paying 5% strategy since it does not reference a distribution.
Since there is only one symmetrical distribution (normal) in the model, the mean from the simulation should approach the mean from expected value analyses. However, the mean from simulations will not always approach the mean from expected value analyses as noted in the non-linearity section.

Unless you use “seeding,” there should be statistical variation from one simulation to the next.

19.3.1 Probability coherence

Sampled probabilities can sometimes generate a set of branch probabilities that do not sum to 100%. This will cause the PSA simulation to fail. There are a few options to correct the non-coherent probabilities:

1. Use beta distributions for probabilities; Beta distributions always generate samples between 0 and 1.
2. Use Dirichlet distributions for chance nodes with more than two branches. A single Dirichlet distribution will generate all branch probabilities, guaranteeing that the sum is 100%.
3. Normalize probabilities to force non-coherent probabilities to sum to 100%.

Correcting non-coherent probabilities

19.4 Probabilistic Sensitivity Analysis Reports

In the section Performing Probabilistic Sensitivity Analysis, the model generated a report which has a number of different categories of reports we can examine.

Cost-effectiveness probabilistic sensitivity analysis generates additional output. These outputs are described in the Cost-Effectiveness Simulation Reports and Graphs Chapter.

The following sections look at the reports within each category, as in the figure below.
19.4.1 Data Reports

The Data Reports are organised into a list of key reports and then a list of Other reports. The key reports are:

- **Summary Report**: Displays aggregated data for the simulation outputs. The report headings are the same as for the All Data Report, see figure below.
- **All Data Report**: Displays the complete output from each iteration of the simulation. For PSA simulations, each iteration represents a recalculation of the model based on its parameter distribution samples. The report lists the Iteration, the values for each Strategy and values for each Distribution, see the figure below.

![PSA: All Data Report](image)

**PSA: All Data Report**

- **All Data Report Export**: Creates a report which is exactly the same as the All Data Report but will export directly to *.xls/*txt format. This is more efficient than creating the All Data Report first and then exporting.

- **The Other Reports are**:
  - **Strategy Values**: This report shows the calculated expected value for each sampled iterations of the simulation. The report window is broken down into pages for viewing and can also be exported to external reports.
  - **Identifying variables**: This report allows you to review the specific values the variables were set to when you ran the simulation. This is useful if you run/save multiple simulations with different variable values. For details about setting Identifying Variables, see the Identifying Variables section (LINK) later in this Chapter.
  - **Expected Values**: This report is a subset of the All Data Report and presents the mean values for the enabled or active payoff sets.
  - **Distributions (by name)**: This report lists the sampled distribution values from the simulation by name.
  - **Distributions (by index)**: This report lists the sampled distribution values from the simulation by index.

### 19.4.2 PSA Outputs

Expanding the PSA Outputs, there are two reports:
- **Acceptability at WTP**: This generates the *Strategy Selection Frequency* graph which shows the percentage of iterations for which each strategy is optimal. You will be promoted for an indifference threshold which specifies the minimum significant difference between strategies such that one is optimal. The graph is presented below.

![Monte Carlo Strategy Selection](image)

**Strategy selection graph**

- **EVPI/EVPPI Summary Report**: More details about the EVPI/EVPPI can be found in the following section called Expected Value of Perfect Information (EVPI/EVPPI) Reports and Charts.

### 19.4.3 Expected Value of Perfect Information (EVPI/EVPPI) reports and charts

Probabilistic sensitivity analysis simulations performed at decision nodes include a detailed EVPI report and summary chart. Both the report and chart are included under the "PSA Outputs" heading of the simulation output.

1. The EVPI reported for a microsimulation (versus a sampling simulation) might be interpreted as the value of being able to predict all chance nodes’ outcomes. Using the Stock Tree, for example, compare the Analysis > Expected Values of Perfect Information result at the single chance node in the model to the simulation EVPI report/chart in a simulation performed at the decision node.

2. Please refer to the section in the Cost-Effectiveness simulation Chapter for details about performing EVPI in cost-effectiveness models.

The calculation of EVPI in simulations is relatively straightforward:

1. Determine the *overall optimal strategy*, using the Net Monetary Benefits based on the specific ICER threshold.
2. Determine the *optimal strategy for each sample iteration* in the simulation.
3. For each iteration, if the optimal strategy is not the overall optimal strategy, calculate its *incremental net benefits value* (i.e., iteration optimal minus overall optimal), which will be $\geq 0$.

4. Report the *average (expected) value of perfect information* over all iterations.

**Steps for EVPI calculation in simulation**

This process hypothetically eliminates the simulated uncertainties by suggesting that the parameters for each iteration are perfect. This process estimates the value of what is lost by making suboptimal decisions for some of the simulation iterations.

The simulation run earlier in this chapter generates an *EVPI/EVPPI Summary Report* link. Clicking on this link generates the following report.

**EVPI/EVPPI Summary Report**

The EVPI value reflects the total EVPI from each iteration divided by the number of iterations as described above. To see the details from the individual iterations, click the EVPI/EVPPI Details link.

**EVPI/EVPPI Details Report**

To perform partial EVPI (or EVPPI), usually a two-level sampling loop is required. To handle this analysis robustly, in case of any nonlinearity in model parameters, TreeAge provides a 3-dimensional simulation option (3rd dimension can be a microsimulation loop).

When choosing Analysis > Monte Carlo Simulation > EVPPI Sampling, you will be prompted to enter:

- **VOI Samples**: This is the number of samples (Value of Information) for EVPPI;
- **Second Order parameter samples**: Number of samples for PSA; and
- **1st Order Simulation trials**: Number of trials required for Microsimulation (if required).
In an EVPPI two-level sampling loop, use the Distribution Sampling options to select the distributions to sample in the outer sampling loop. The remaining distributions will be sampled in the inner sampling loop. In the example below, Distribution 1 is sampled in the outer loop and Distribution 2 is sampled in the inner loop. The figure below shows the

As in the figure below, a warning will appear to remind you to select the distributions to use in EVPPI. If you do not select any distributions to use in EVPPI, a screen prompt will remind you no distributions are selected.

![Warning message to remind you to select distributions to use in the EVPPI analysis.](image)
Monte Carlo Distribution Sampling. Expand the appropriate section to select when the distributions are sampled.

The parameter(s) of interest are sampled in the outer sampling loop N times; for each outer iteration, an inner loop samples the remaining uncertainties (and recalculates expected values) M times, in case of non-linearities in these remaining distributions.

For more information on EVPI/EVPPI simulation options in TreeAge Pro, refer to the current recommendations on performing EVPPI and related analyses found in the journal of the Society for Medical Decision Making (and elsewhere):

http://www.smdm.org/

19.4.4 Histograms

The Histograms are split into two sections: Sampling Distributions and Output Distributions.
19.4.4.1 Sampling Distributions

Following the Sampling Distributions link takes you to a list of all the distribution samples associated with the model. In this model, only one distribution has been sampled, but when more distributions are sampled additional links would be available.

Selecting a link for a given distribution will allow you to generate a probability distribution graph (histogram) for each of the distributions sampled in the analysis. In this case, there is only one - Dist(1) dNorm_500_100. When you click on a link for a distribution, you are prompted for an approximate number of bars to include in the probability distribution. After entering a value, the probability distribution is displayed, as in the figure below.

![Monte Carlo Probability Distribution](image)

Probability Distribution generated from the Sampling Distribution

19.4.4.2 Output Distributions

This group generates probability distributions for outputs from the model. In this case, there is a single subgroup - EV (expected value) with an item for each of the two strategies (Risky Investment and CD Paying 5%). Other models/simulations can include other types of outputs. See the figure below.
Options under Output Distributions, expanding EV for the two strategies in the model.

The graph below shows the probability distribution for the Risky Investment strategy’s expected value.
Note that the Redo Histogram link (for both Sampling and Output Distributions) allow you to regenerate the graph with more or fewer bars. For a discussion of the options available in TreeAge Pro for working with and customizing distribution graphs, refer to the Graphs Chapter, specifically the Customizing Histograms section.

19.4.5 Report Options

This section provides you with options to customise your reports as show from the categories in the figure below.

Options available under Report Options

TreeAge graph files can also be created as Excel charts. In some cases, Excel charts have different/additional functionality. Refer to the Graphing, Reporting and Modeling Using Excel Chapter for details.

Numerous additional graphs and reports are available in cost-effectiveness simulations performed using the Healthcare module for TreeAge Pro. For example, in a cost-effectiveness simulation, the Acceptability Curve is used in place of the Strategy Selection graph. Refer to the Cost-Effectiveness Simulation Reports and Graphs Chapter for additional details.

19.5 Saving Monte Carlo Simulations

Depending on the complexity of the model, and the number of samples and recalculations you specify, running a simulation can be time consuming. For this reason, the simulation output window can be saved separately from the tree as a report output (*.rptx) file. Saving the simulation output will allow you to share the complete results with other TreeAge Pro users, or to generate graphs and reports from the simulation at a later time.

To save the Monte Carlo output window:
- Select the Monte Carlo output as the active view.
- Choose File > Save As… from the menu or click the Save toolbar icon in the simulation output window.
- Select the appropriate project/folder, enter a file name and click OK.
- The *.rptx file will be saved in the project/folder.

You will notice the extension *.rptx will be added to the title of the tab displaying the simulation output. You can open the *.rptx file later to reopen the output file.

Monte Carlo simulation output files grow relative to the number of rows and columns. Sizes of ~1 GB would be achieved with 1 million rows and 150 output columns. Use a Zip compression program to shrink file size.

Output *.rptx files contain database tables holding the report output data. Refer to the Technical Details Chapter for information on querying the data using an external tool.

19.6 Simulation options

This section describes options you can select when running simulations.

19.6.1 Multi-threading

To better handle lengthy simulations, TreeAge Pro will use multiple processors on a single computer when performing Monte Carlo simulation.

If you are running simulations on a dual-processor computer, you can instead specify to use only one simulation thread, which will leave one processor idle during the simulation (allowing other programs to run quickly while the simulation is running). If you are running a multi-threaded simulation, it is recommended that you leave the Optimize all expressions… setting on.

19.6.2 Distributed simulations

TreeAge Pro provides a mechanism to run Monte Carlo simulations on multiple computers. This can help speed up long simulations. Distributed "slave" computers are setup in Application Preferences for use with any model.

To setup distributed computers:
- Choose Window > Application Preferences from the menu.
- Select the category Analysis Tools > Monte Carlo - Distributed Processing
- Check the box labeled Use distributed computers.
- Click the Add button and enter the slave's computer name or IP address. Click OK.
- Check the boxes next to the slaves you want to use for the simulation.
- Click OK to save the Application Preferences changes.

**Setup distributed computers**

You can enter an IP range to scan for available distributed computers on your network. For example, enter 192.168.1.100-192.168.1.200 to search for distributed computers within that IP address range.

Once a set of slave computers is added, the list will look like the image below.

![Application Prefs - Distributed Computers](image)

**Distributed Simulation Licensing/Software Versions:**

- Master computers must have active Maintenance to use distributed slave computers.
- Slave computers require no TreeAge Pro license.
- Master and slave computers must be running the identical software build version. If the versions do not match, the slave computer will not be used for the analysis. You can check the version in the Application Preferences.

To use slave computers, the "Use distributed computers" box must be selected and individual computers must be selected. *The master computer must be selected in the list of Distributed Computers in order to use it for simulation batches.* This allows you to choose whether to utilize the master computer's system resources.

When you then run a Monte Carlo simulation, the master computer will send batches of iterations to each slave computer. The slave computers will return the iterations back to the master computer, where they are collected and eventually reported back through the user interface.
Note that there is overhead associated with passing data back and forth among computers, so you will not see the simulation speed double by adding a second identical computer for iteration batches.

On the slave computers, you can see that batches are being processed within the Object Interface Console. See below.

Object Interface Console - Distributed Analysis Output

19.6.3 “Seeding” the random number generator

Normally, Monte Carlo simulations use dynamic information from the computer’s clock to initialize a sequence of pseudo-random numbers. If you ever need to force the same set of samples and/or trials for several different simulations of the same model, you can specify to use the same, predictable sequence of pseudo-random numbers.

To seed a simulation:

- In the setup dialog for a Monte Carlo simulation, click the "Seeding..." button. This opens the Tree Preferences Dialog to the Analysis Settings > Monte Carlo Options > Random Number Seeding Options category.
- Check the Seed random number generator box, and specify an integer seed value (from 1 to 64,000).
- Select a seeding behavior (described below).
- Click OK to save the Tree Preferences.
- Then run your model as intended.
Monte Carlo Simulation Setup to run - select Seeding to change the options

Random Number Seeding Options in Tree Preferences

The seeding behavior options are described below.

- **Seed random number generator**: Check this box to stabilize the overall model results from one simulation to the next.
- **Seed**: If the prior option is checked, you set the initial seed for the random number sequence. Changing this value will generate a different but repeatable set of results.
- **Stabilize Microsimulation when run as inner loop within PSA**: This option applies only to Microsimulation when running within the context of PSA. Checking this box ensures consistency among sets of patients within the Microsimulation as the outer loop PSA sampled inputs change.
- **Stabilize PSA sampling when run as an inner loop with EVPPI.** This option applies only to EVPPI simulations, which have two PSA loops. Checking this box ensures that the same set of samples are drawn from the PSA-level distributions while the outer-loop PSA sampled inputs change.

- **Stabilize Microsimulation when run as inner loop within Sensitivity Analysis.** This option applies only to Microsimulation when running within the context of deterministic sensitivity analysis (1-way, 2-way, 3-way, tornado). Checking this box ensures consistency among sets of patients within the Microsimulation as the input parameters vary within their respective ranges.

**Seeding options**

All seeding should be used cautiously. Seeding generates repeatable results from analysis to analysis or from inner loop to inner loop. It is not a substitute for running a representative number of iterations to stabilize the overall mean results from any analysis.

### 19.6.4 Turning off sampling of selected distributions

You have the option of specifying that only a subset of the distributions should be sampled during a simulation. Non-sampled distributions will be set at their mean.

To sample from selected distributions during a simulation:

- In the setup dialog for a Monte Carlo simulation, click the Distributions… button. This opens the Tree Preferences Dialog to the Analysis Settings > Monte Carlo Options > Distribution Sampling Category.

- There are three options:
  - Sample all;
  - Sample none; and
  - Sample some (make selections below).

- If the option "Sample some" is selected, use the left/right buttons to move the appropriate distributions between the available list on the left to the sample list on the right.

- Click OK to save the Tree Preferences.
19.6.5 Identifying simulations

It can be useful to associate identifying information with simulation output, especially when you have more than one simulation output window open at once, or if you are saving and reopening or sharing the Monte Carlo simulation files. Simulation output can be "labeled" with identifying variable values and with a simulation comment.

Identifying variables
Simulation output windows can be labeled using the values of variables in your tree. The resulting simulation output window will display a list of the variables and their default values.

Monte Carlo simulation identifying values are particularly useful in combination with the stored analysis features in TreeAge Pro (Stored Analysis Abstracts and Sequences Chapter).

To add identifying variable values in the simulation window:

- In the setup dialog for a Monte Carlo simulation, click the Identifiers… button. This opens the Tree Preferences Dialog to the Analysis Settings > Monte Carlo Options > Identifying Variables Category.
- Use the left/right buttons to move the appropriate variables between the available list on the left to the identifier list on the right.
- Click OK to save the Tree Preferences.
Identifying Variables Tree Preferences

Note that the pay_up variable was not selected because its value is defined using a distribution, and those distribution values would already be included in the simulation output.

The Identifying Variables are stored in the Tree Preferences, so that you do not need to re-select them for each new simulation.

After the simulation is executed, the values of the identifying variables are available through the simulation output's "Identifying Variables" link.

Monte Carlo Simulation Identifying Variables

<table>
<thead>
<tr>
<th>VARIABLE</th>
<th>VALUE</th>
<th>NOTES</th>
</tr>
</thead>
<tbody>
<tr>
<td>pay_down</td>
<td>-500</td>
<td></td>
</tr>
<tr>
<td>prob_extreme</td>
<td>0.3</td>
<td></td>
</tr>
</tbody>
</table>

Monte Carlo simulation output - Identifying Variables
19.6.6 "Downstream" decision nodes during microsimulations

If your tree includes decision nodes to the right of the node where a simulation is being performed, each trial must select a single path when it encounters such embedded decisions. For simulations using only expected value calculations (e.g., PSA with no trials), TreeAge Pro always re-evaluates the optimal path at the embedded decision, and utilizes the optimal strategy’s expected value.

For trials, however, embedded decision nodes can be handled in three ways:

1. based on expected values calculated prior to the simulation, a single optimal policy can be followed for all iterations;
2. select the topmost branch;
3. if any parameter uncertainty (e.g., PSA) distributions are used in the tree, the optimal policy can be re-evaluated for each sample iteration based on the current distribution sample values.

**Downstream Decision Options**

To set the downstream decision algorithm for a simulation:

- Open the Tree Preferences dialog.
- Choose the category Analysis Settings > Monte Carlo Options > Downstream Decision Options.
- Select the option that is appropriate for your model.
- Click OK to save the Tree Preferences.

![Tree Preferences - Downstream Decision Options](image)

The Special Features tutorial example model Downstream Decisions illustrates the three options.
### Downstream Decisions tree

Note that the root node is not a decision node, so the Choose node is a downstream decision node. Therefore, the downstream decision options selection will control which investment is selected for each trial.

The payoffs for the two investments are both distributions sampled by EV/set of trials. The investment 2 option has a larger mean value, but the two distributions' standard deviations are large enough that some PSA iterations will favor investment 1.

If the "Use the same policy for all iterations (best expected value)" option is selected, then all trials select investment 2 because it has a larger mean value.

#### Downstream decisions simulation - option 1

If the "Use the same policy for all iterations (top branch)" option is selected, then all trials select investment 1.

#### Downstream decisions simulation - option 2

If the "Re-evaluate optimal path for each iteration" option is selected, then all trials will select the investment with the larger sampled value. Note that in iterations 8 and 10, the trials selected investment 1 rather than investment 2.
19.6.7 Distribution options

Each distribution created in a tree can be extensively customized. Refer to the Distribution Functions, Options and Types Chapter for complete details on distribution types, functions, and sampling behavior options.

19.7 Customizing simulations

The previous section described the various simulation options that can be explicitly set prior to running the simulation. For more complex situations, there are additional methods at the modeler’s disposal for customizing the behavior of simulations.

19.7.1 The TreeAgeProLib (Excel add-in)

The TreeAgeProLib library enables writing macros to control setup and execution of simulations via the Object Interface. Refer to the Using the TreeAge Pro Object Interface Chapter for more details.

19.7.2 Keywords

A variety of simulation keywords (built-in counters) can be used in expressions (e.g., tracker modifications, rewards, probabilities) during simulation. The table below describes each keyword.

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>_stage</td>
<td>Markov cycle counter (starts with 0)</td>
</tr>
<tr>
<td>_tunnel</td>
<td>Markov cycle-in-state counter (starts with 1), requires state to be configured with tunnel max value</td>
</tr>
<tr>
<td>_state_index</td>
<td>Index for the Markov state counting down from the top (top state is 1, next down is 2, etc.)</td>
</tr>
<tr>
<td>_strategy</td>
<td>Returns the number of the strategy, defined as a branch directly coming from a decision node (numbered top to bottom). The value is undefined to the left of the first decision node or if the model has no decision node.</td>
</tr>
</tbody>
</table>
### Simulation keywords

The most useful will be: `_trial` and `_sample`. These allow you to reference the trial index and/or sample index in expressions within the tree.

For information on the parallel trials keywords, refer to the Individual-Level Simulation and Markov Models Chapter.

#### 19.7.3 Monte Carlo keywords

Normally, the only calculations that are done between iterations of a microsimulation or probabilistic sensitivity analysis are distribution resampling. However, you can force user-defined expressions to be executed at strategic points between simulation iterations.
Special variables differ from keywords in that you have to define them as variables. Once you define the variable with the proper name, it’s definition will be executed at the appropriate time in the model.

Create a variable with one of the following names and define it at the root node with the appropriate expression. At the appropriate time in the simulation, the expression will be executed. This can be useful for working with Global matrices or using Debug commands.

For example:

```plaintext
_monte_pre_trial_eval = DebugWriteForce("--- Starting Trial " + Str(_trial) + " ---")
```

would write text marking the beginning of the trial to the Calculation Trace Console.

<table>
<thead>
<tr>
<th>Special Variable</th>
<th>Expression is executed...</th>
</tr>
</thead>
<tbody>
<tr>
<td>_monte_pre_trial_eval</td>
<td>Before each trial is run.</td>
</tr>
<tr>
<td></td>
<td>Not executed for parallel trials.</td>
</tr>
<tr>
<td>_monte_post_trial_eval</td>
<td>After each trial is run.</td>
</tr>
<tr>
<td></td>
<td>Not executed for parallel trials.</td>
</tr>
<tr>
<td>_monte_pre_cycle_eval</td>
<td>Before each cycle starts.</td>
</tr>
<tr>
<td></td>
<td>Only executed for parallel trials.</td>
</tr>
<tr>
<td>_monte_stop_cycle_eval</td>
<td>After trials reach stop or terminal node and before trials</td>
</tr>
<tr>
<td></td>
<td>continue from a stop node.</td>
</tr>
<tr>
<td></td>
<td>Only executed for parallel trials.</td>
</tr>
<tr>
<td>_monte_post_cycle_eval</td>
<td>After each cycle finishes.</td>
</tr>
<tr>
<td></td>
<td>Only executed for parallel trials.</td>
</tr>
<tr>
<td>_monte_pre_cycle_trial_eval</td>
<td>Before each trial starts a cycle.</td>
</tr>
<tr>
<td></td>
<td>Only executed for parallel trials.</td>
</tr>
<tr>
<td>_monte_post_cycle_trial_eval</td>
<td>After each trial finishes a cycle.</td>
</tr>
<tr>
<td></td>
<td>Only executed for parallel trials.</td>
</tr>
<tr>
<td>_monte_pre_sample_eval</td>
<td>Before each sample is run.</td>
</tr>
<tr>
<td>_monte_post_sample_eval</td>
<td>After each sample is run.</td>
</tr>
<tr>
<td>_monte_pre_info_sample_eval</td>
<td>Before each VOI sample is run.</td>
</tr>
<tr>
<td>_monte_post_info_sample_eval</td>
<td>After each VOI sample is run.</td>
</tr>
<tr>
<td>_pre_analysis</td>
<td>Before the analysis is started.</td>
</tr>
<tr>
<td>_post_analysis</td>
<td>After entire analysis is complete.</td>
</tr>
</tbody>
</table>

Monte Carlo Special Variables

To use they keywords in your simulations, just define a variable with the same name as the keyword. The Add/Change variable dialogue makes this easy by showing a list of keywords to the right of the Name editor, as in the figure below.
These keywords can be used to initialize and output global matrices at specific times during the simulation. For example, you can output trial-level data within a two-dimensional simulation where the standard simulation output would only provide mean values for the trial sets.

Use the _post_analysis keyword to output data when the entire analysis is complete. Note that the _post_analysis keyword can be run for other analyses, while the other keywords are only executed within the context of Monte Carlo simulation.

19.8 Two- and three-dimensional simulations

In most models, a probabilistic sensitivity analysis should recalculate expected values for each new set of parameter samples to see the effects of parameter uncertainty.

However, there is an alternative method for recalculating the tree after each set of parameter samples: estimating an expected value by averaging many first-order trials. This process – estimating expected values by averaging a sufficiently large number of random, individual outcomes – is sometimes called microsimulation.
19.8.1 Recalculate using first-order trials (microsimulation)

In most models, two-dimensional simulation for the purposes of probabilistic sensitivity analysis is unnecessary. It is normally preferable to run a 1-dimensional loop that recalculates EVs for each set of randomly sampled parameter values — except in the case of certain types of models, for example:

1. Markov models using tracker variables to follow detailed event history. Refer to the Individual-Level Simulation and Markov Models Chapter for details on trackers.
2. Trees using distributions to represent variability among individuals (much like a chance node does) rather than just parameters whose values are uncertain. Refer to the Distribution Functions, Options and Types Chapter for more information on sampling rates.

Scenarios requiring two-dimensional simulation for PSA

Both of these situations call for microsimulation (described at the beginning of this chapter).

Depending on the complexity of the model, each microsimulation may require thousands of first-order trials in order to adequately approximate an expected value. Therefore, in the context of a probabilistic sensitivity analysis, using a microsimulation for each recalculation of the tree (for a new set of samples) can be very time consuming. This is why two-dimensional simulation is generally avoided unless a model requires microsimulation to calculate an expectation.

To perform probabilistic sensitivity analysis using first-order microsimulation trials for model recalculations:

- Select the root node of your tree, or a node to the right, to set the context for analysis.
- Choose Analysis > Monte Carlo Simulation > Sampling + Trials…from the menu.
- Enter the number of samples for the 2nd-order parameter loop.
- Enter the number of trials for the 1st-order trials loop.

Specify a sufficient number of 1st-order trials to get a good average for each new sample value (or set of values). Initially you should experiment with smaller number of iterations in both the sampling loop as well as the inner, microsimulation loop.
In the context of Markov models using trackers with microsimulation, refer to the Individual-Level Simulation and Markov Models Chapter for more information on two-dimensional simulations.

### 19.8.2 Two-dimensional simulation details

In microsimulation models also requiring probabilistic sensitivity analysis, a two-dimensional (or two-loop) approach to is used:

1. \( N \) number of parameter samples and \( I \) number of microsimulation trials are specified.
2. Draw one set of samples for the parameter distributions.
3. Holding the sampled parameter values constant, a group of \( I \) microsimulation trials are performed. The mean of the results from the trials is reported (e.g., cost and/or effectiveness values, as well as tracker values).
4. Steps 2 and 3 are repeated for each of the \( N \) sets of parameter samples.

**Two-dimensional simulation detailed steps**

Once the simulation is complete, the final report will include \( N \) rows, showing each set of parameter samples and the corresponding mean values for \( I \) microsimulations. The distribution of these results reflects the total uncertainty resulting from the parameter distributions.

Note that the detailed results for each of the \( I \) trials within each sample are not reported.

### 19.8.3 Three-dimensional, value of information simulations

To perform partial EVPI (or EVPPI), usually a two-level sampling loop is required. TreeAge provides a 3-dimensional simulation option to handle these more complex values of information simulations. In this case, the innermost loop or “dimension” allows for a set of microsimulation/individual trials to be used in the innermost expectation step of the EVPPI simulation (if required).

More information can be found about EVPI in the Chapter about Analyzing Decision Trees in the section Expected Value of Perfect Information (EVPI).

Information about performing EVPI in Cost-Effectiveness models can be found in the Chapter about Cost-Effectiveness Simulation Reports and Graphs in the section Cost-Effectiveness Value of Information (EVPI).

Click here to review seeding options for stabilizing inner loops within a multi-dimensional analysis.

Obviously, as noted in the previous section, multi-level/multi-dimensional Monte Carlo simulations can be very time consuming. Distributed simulation can divide the required processing time among multiple computers. And, if carefully used, special microsimulation error reduction seeding options can be used to reduce, to some extent, the number of sampling iterations required to get stable 2nd-order uncertainty measures.
20. Distribution Functions, Options and Types

This chapter provides information about each of the built-in sampling distribution types available in TreeAge Pro.

Derivations and detailed explanations of the distribution formulae provided here may be found on many math/statistics web sites, and in most texts on probability theory. See, for example, Christensen, Ronald; Data Distributions: A Statistical Handbook (2nd Ed.); Lincoln, Massachusetts: Entropy Limited, 1989.

Refer to the following chapters for information on using distributions in trees.

- More Sensitivity Analysis Tools
- Monte Carlo Simulation, Distributions and Probabilistic Sensitivity Analysis
- Advanced Chance Node Techniques and Options
- Individual-Level Simulation and Markov Models Chapter

20.1 Distribution functions

Distributions can be referenced in two different ways: by name (if an optional name is defined in the distribution properties) or by index. The following functions employ the argument index to reference a distribution defined for the tree. With the exception of DistKids(), they are intended primarily for use during Monte Carlo simulation.

Most distribution functions can reference the distribution index or the distribution name. If using the distribution name, place the name within quotation marks to treat this name as a string and not a numeric expression to be calculated.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dist(dist_index)</td>
<td>During expected value calculations, this function returns the indexed distribution’s mean. During Monte Carlo simulations, this function returns the most current random sample for the distribution (unless the distribution is flagged to not sample).</td>
</tr>
<tr>
<td>Dist(dist_index; column)</td>
<td>For a multi-variate distribution (i.e., a Dirichlet, Multivariate Normal or multi-column table distribution), returns the sample value (or mean, if not sampling) from the designated value column.</td>
</tr>
<tr>
<td>Dist(dist_index; 1)</td>
<td>For a univariate distribution (i.e., not Dirichlet, Multivariate Normal or multi-column table), forces a sample from the distribution, even during non-sampling analyses. It is recommended that you use the DistForce function rather than this function (see below). For a table distribution, use the first value column for probabilities.</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Dist(dist_index; 2)</td>
<td>For a univariate distribution (i.e., not Dirichlet, Multivariate Normal or multi-column table), returns the stored sample value for a virtual branch created using the DistKids() syntax, below. For a table distribution, use the second value column for probabilities.</td>
</tr>
<tr>
<td>DistForce(dist_index)</td>
<td>Unlike the Dist function, DistForce() always samples a value, even during non-sampling analyses such as roll back. DistForce(index; column) also works for multi-variate distributions. Note that DistForce(index; 1) must be called first in order to trigger a new set of sample values for all columns; then the stored sample values for the other columns can be referenced.</td>
</tr>
<tr>
<td>DistForce(&quot;dist_name&quot;)</td>
<td></td>
</tr>
<tr>
<td>DistForce(dist_index; column)</td>
<td></td>
</tr>
<tr>
<td>DistForce(&quot;dist_name&quot;; column)</td>
<td></td>
</tr>
<tr>
<td>DistProb(dist_index; val)</td>
<td>For the specified distribution, returns the approximate cumulative probability of the specified value.</td>
</tr>
<tr>
<td>DistProb(&quot;dist_name&quot;; val)</td>
<td></td>
</tr>
<tr>
<td>DistSampleCond(dist_index; lower_bound; upper_bound)</td>
<td>Draw a sample from the appropriate distribution that is bounded by the lower_bound and upper_bound values provided. The upper_bound argument is optional.</td>
</tr>
<tr>
<td>DistSampleCond(&quot;dist_name&quot;; lower_bound; upper_bound)</td>
<td></td>
</tr>
<tr>
<td>DistTransProb(dist_index; time_cycle_start ; time_cycle_length)</td>
<td>Calculate transition probabilities from a time-to-event distribution. For further details are available in the Markov Modeling Tools and Techniques Chapter.</td>
</tr>
<tr>
<td>DistTransProb(&quot;dist_name&quot;; time_cycle_start ; time_cycle_length)</td>
<td></td>
</tr>
<tr>
<td>DistTrim(dist_index; min; max)</td>
<td>Same as the Dist() function, except it will resample (up to a maximum of 10 times) until a sample is returned that falls between the specified minimum and maximum values.</td>
</tr>
<tr>
<td>DistTrim(&quot;dist_name&quot;; min; max)</td>
<td></td>
</tr>
<tr>
<td>DistValue(dist_index; prob)</td>
<td>For the specified distribution, returns the approximate value at the specified cumulative probability.</td>
</tr>
<tr>
<td>DistValue(&quot;dist_name&quot;; prob)</td>
<td></td>
</tr>
<tr>
<td>DistSamp(dist_index)</td>
<td>Obsolete. Use the Dist() function.</td>
</tr>
<tr>
<td>DistSurv(&quot;dist_name&quot;)</td>
<td>Used with time-to-event distributions, particularly in Partitioned Survival Analysis models. Returns the complement of the cumulative probability that an event has occurred at any given time. If a distribution represents progression, then DistSurv returns the probability that the progression has not yet occurred. DistSurv(&quot;DistributionName&quot;) = 1-DistProb(&quot;DistributionName&quot;;_time) The second argument allows you to specify the probability at a specific time. DistSurv(&quot;dist_name&quot;; 5)</td>
</tr>
<tr>
<td>DistSurv(&quot;dist_name&quot;; _time)</td>
<td></td>
</tr>
</tbody>
</table>
### Distribution Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The second argument can also convert the time units for the appropriate units within a model. For example monthly distribution to annual model: DistSurv(&quot;dist_name&quot;;time/12)</td>
</tr>
</tbody>
</table>

#### Distribution Functions

The DistTrim will usually generate a value between the min and max arguments. However, it is possible for 10 consecutive samples to fall outside this range. This function can be used in conjunction with the Min and Max functions to guarantee a value within the range.

\[ \text{Min}(\text{maxValue}; \text{Max}(\text{minValue}; \text{DistTrim}(\text{distIndex}; \text{minValue}; \text{maxValue}))) \]

### 20.2 Distribution options

Some special options can be used to make distributions more flexible.

#### 20.2.1 Changing sampling rate for microsimulation models

While most distributions are used to sample possible values of uncertain parameters for probabilistic sensitivity analysis, distributions can also be used to instead represent individual variability/patient characteristics. These two different classes of distributions should be identified via the TreeAge Pro distribution’s sampling rate property. This is particularly important if a model includes both types of distributions.

To change the sampling frequency for a particular distribution:

- Open a model with at least one distribution.
- Choose Views > Distributions from the toolbar.
- Select a distribution from the list.
- Click the "edit" toolbar button to open the Add/Change Distribution dialog.
- Select the Sampling rate option "Once per individual trial".
Add/Change Distribution Dialog - set sampling rate

This option will be of interest in specific models:

1. Markov models using tracker variables to follow detailed event history, including discrete event models.
2. Trees using some distributions to represent variability among individuals (in the same way that a chance node could).

Characteristics of models that might use distributions that sample once per trial

By default, distributions are set to sample once per tree EV recalculation. In a two-dimensional simulation, this would be per “group of trials”. By default, a simple microsimulation resamples only distributions set to sample per 1st-order trial or Markov stage.

It is also possible to set a distribution’s sampling frequency to generate a new sample value at each Markov cycle/stage during first-order trials and/or cohort/EV calculations. The DistForce() syntax can be used to resample more frequently.

20.2.2 Sampling during non-simulation, EV calculations

During non-simulation analyses, such as roll back and sensitivity analysis, a reference to a distribution normally returns the mean value every time it is referenced. If ‘Override mean’ is used, this value would be the override value. The Dist() function can, however, override this behavior and return a randomly sampled value from the referenced distribution during any EV calculation.
To cause a random distribution sample to be returned by the Dist() function during expected value (EV) calculations, simply add a second parameter to the function with a value of 1. The formula DistForce(n), or Dist(n;1), will sample a new value from distribution number \( n \) each time the distribution is referenced in a tree calculation.

This also means that at each place in the tree where the distribution is referenced, a different sample value will be returned.

### 20.2.3 Defining distribution parameters non-numerically

Distribution parameters can be defined using variables or formulas, instead of fixed numeric values. This makes it easier to modify a distribution's parameters and it may also help someone viewing the model understand the significance of a particular distribution.

#### Using variables for distribution parameters

Clicking on the button to the right of a distribution parameter’s text box will open an expression editor dialog. This dialog, like a variable definition window, makes it easier to set up a complex expression, including existing variables, functions, and even other distributions, to represent a distribution parameter.

Variables that are referenced in the parameter of a distribution must be defined with a default value for the tree, at the root node.

Distributions are "global" within the context of the model. Therefore, the root node variable definition will be used to define the distribution properties. You cannot define a variable differently in other portions of the model and expect the parameters of the distribution to change.

Microsimulation tracker variables (refer to the Individual-Level Simulation and Markov Models Chapter) can be used in the parameters of a distribution; however, the distribution must either be set to sample per Markov stage, or use DistForce() syntax, in order for a sample to be generated based on an updated value of the tracker.

Finally, it is possible to use one distribution ("X") in defining the parameters of another distribution ("Y"). TreeAge Pro requires that the dependent distribution have a higher numeric index than the input distribution – e.g., \( X = \text{Dist}(1), Y = \text{Dist}(2) \).

A distribution cannot reference itself recursively as a parameter.
20.2.4 Approximating distribution parameters from statistical information

Some of the built-in distribution types supported in TreeAge Pro use parameters that may be difficult to find. For example, the Log-normal distribution is parameterized using the “mean of the logs” and the “standard deviation or error of the logs”.

TreeAge can approximate some distributions’ parameters from more straightforward statistical summary values. Distributions that support parameter approximation will include a list box allowing you to approximate the distribution parameters. Supported distributions include the real-number form of the Beta, the Log-normal, and the Gamma distribution.

In the example below, beta distribution parameters are required.

After choosing Pick approximation > From Mean, Std Dev..., the appropriate approximation inputs are presented for input entry. After entering the mean and standard deviation, the approximated distribution parameters are displayed.
In a later section of this chapter, some of the details of these approximations are provided.

### 20.3 Distribution Formulas

Click here to view the formulas TreeAge Pro uses to generate distributions.

If you are unable to access the distribution formulas via the link above, click here to access the formulas in PDF format.

### 20.4 Sampling from tables during Monte Carlo simulation

If it is not feasible or desirable to use one of TreeAge Pro’s built-in distributions to represent the particular probability distribution you need, there are at least two ways to create custom sampling distributions. These methods use built-in distributions and tables.

- **Table distributions** can be helpful in defining individual characteristics (i.e., gender, ethnicity) to trials during microsimulation based on the probability of each value within the cohort.
- **TableProb distributions** can be helpful for drawing time-to-event samples for Discrete Event Simulation based on a table of probabilities (like a mortality table).
20.4.1 Creating a Table distribution

One way to sample values from a custom distribution is to create a new table in TreeAge Pro describing the distribution’s discrete probability function (not the data set). This table can then be assigned to a Table distribution.

Each row of the table defines a distribution value (entered in the index column) and its probability (entered in the value of a table entry). The probabilities in the value column must total 1.0.

To create a Table distribution from an existing empirical data set:

- Use the Table Properties View to create a table and populate it with data that represents the custom distribution function. Refer to the Creating and Using Tables Chapter for details (see below).
- Within the Distribution Properties View, click the "add" toolbar icon to create a new distribution.
- In the Add/Change Distribution Dialog, select the distribution type "Table".
- Under "Distribution parameters", select the table from the list of the model's tables.
- Enter a name and description for the distribution.
- Click OK to save the distribution and close the Add/Change Distribution Dialog.
To randomly sample from the Table distribution, simply reference the distribution in the standard way: use either the distribution’s name or the Dist(n) function using the distribution’s index within the model.

- Sample values will only be drawn from exact table entry indexes, regardless of which lookup method you specify. TreeAge will not interpolate in a Table distribution.
- The mean value of the Table distribution will be used as the distribution’s expected value in non-Monte Carlo calculations.
- Use the Dist(index; 2), Dist(index; 3), etc. distribution reference sequence to sample based on probabilities in the second, third, etc. value column.

### 20.4.2 Creating a TableProb distribution

TableProb distributions allow you to use a table of probabilities as the basis of a distribution for drawing time-to-event samples. This is particularly useful for integrating background mortality into a DES model since background mortality frequently does not conform to a parametric distribution (like Weibull or Gompertz).

A TableProb distribution uses a table as its primary parameter. The table can be either a probability table or cumulative probability table. Typically, a TableProb distribution would use a published mortality probability table.

We will use the DES Tutorial Example, TableProb Distribution.trex model, which has examples of two TableProb distributions, one from a probability table and one from a cumulative probability table.

#### 20.4.2.1 Review the probability tables (mortality)

In the example model there are two tables:
- `tMortBackground`: A probability table with sparse index entries. The first value starts at 0 and last value ends at 1, see `tMortBackground` in the figure below.
- `tMortBackground_CumInt1`: The cumulative probability table (from `tMortBackground`).

For both types of probability table, the first and last rows in the table must have values 0 and 1, respectively. The index for these tables represents time in cycles (typically years).

![Image of probability table]

The background mortality (probability) table with value entries starting at 0 and ending at 1.

### 20.4.2.2 Converting between probability tables and cumulative probability tables

Depending on the data available you may want to convert between probability and cumulative probability tables.

- In the Table Properties View select the table to convert.
- Select the icon "Convert Table".
- Using the Convert Table dialogue, as per the figure below, give the new table a name.
- If converting from a probability distribution with sparse indices, choose the option "interpolate the interval size = 1" which will create an entry at every index.
- Select OK to close and create the new Table.

![Convert Table dialogue]

Convert Table dialogue to convert between probability and cumulative probability tables.
The interval size of 1 mimics interpolation in a standard table lookup. Using this interval, the resulting cumulative probability table will include index values for every year with the cumulative probability interpolated from the closest rows in the probability table.

The same conversion logic used to create a cumulative probability table directly is used implicitly when you create a TableProb distribution using a probability table.

### 20.4.2.3 Create a TableProb Distribution

To create a TableProb distribution from a standard probability table (e.g., mortality):

- Use the Table Properties View to create a table and populate it with data that represents a Mortality Table. Refer to the Creating and Using Tables Chapter for details. In the Example model, this table is called tMortBackground.
- Within the Distribution Properties View, click the "add" toolbar icon to create a new distribution.
- Enter a name and description for the distribution (the model uses TimeToDeath_ProbTable_Int1).
- In the Add/Change Distribution Dialog, select the distribution type “TableProb”.
- Under "Distribution parameters", select the table (tMortBackground) from the list of the model's tables.
- Select table type: Probability (Mortality) Table; and select: Interpolate to interval size =1, if your table does not have a row for each Index.
- Select Sampling Rate: Resample per individual trial.
- Click OK to save the distribution and close the Add/Change Distribution Dialog.
Create TableProb distributions from probability (mortality) table

TableProb distributions using cumulative probability tables perform no interpolation. If you want better control than linear interpolation between rows of a probability table, you can convert to a cumulative probability table, then modify the data for a better fit for your parameter.

To create a TableProb distribution from a cumulative probability table:

- Use the Table Properties View to create a table and populate it with data that represents a Mortality Table. Refer to the Creating and Using Tables Chapter for details. In the Example model, this table is called tMortBackground_CumInt1.
- Within the Distribution Properties View, click the "add" toolbar icon to create a new distribution.
- Enter a name and description for the distribution (the model uses TimeToDeath_CumTable_Int1).
- In the Add/Change Distribution Dialog, select the distribution type "TableProb".
- Under "Distribution parameters", select the table (tMortBackground_CumInt1) from the list of the model's tables.
- Select table type: Cumulative Probability Table.
- Select Sampling Rate: Resample per individual trial.
- Click OK to save the distribution and close the Add/Change Distribution Dialog.
20.4.2.4 Sampling from a TableProb distribution

You can reference the distribution anywhere in your model to use a sample during simulations. The internal mechanism performed during the sampling is described below.

When a TableProb distribution is sampled, a random number between 0 and 1 is drawn. That random number is then used for a reverse lookup in the values in the cumulative probability table, returning the appropriate index value.

If the TableProb distribution references a probability table, that table is internally converted to a cumulative probability distribution (with or without interval interpolation) prior to the reverse lookup described above.

20.4.3 Using a distribution to lookup values in a table

There are situations where distributions cannot be easily represented using a standard distribution type, or a regular Table distribution as described above.

For instance, perhaps you have a table of age-dependent probabilities or costs that you want to do a probabilistic sensitivity analysis on. Or, you might have a set of observed parameter values that you want to bootstrap from with each row’s value given an equal probability (or even selected in order).
In these cases, you could populate the table and then use a separate distribution to sample row indexes and/or columns indexes.

For example, you could fill a table with observed data, numbered from 1 to N, and then pick values randomly from the table using a uniform distribution with a range equal to the range of table indexes. In this case, use the integer form of the Uniform distribution (to return only integers in the index range).

To sample from a table using a Uniform distribution:

- Enter/paste your data set into a TreeAge Pro table, using consecutive integer indexes in the index column and the data set's values in the value column.
- Within the Distribution Properties View, click the "add" toolbar icon to create a new distribution.
- In the Add/Change Distribution Dialog, select the distribution type "Uniform".
- For the low value, enter the lowest integer index from your table (i.e., 0 or 1). For the high value, enter the highest integer index from your table.
- Enter a name and description for the distribution.
- Click OK to save the distribution and close the Add/Change Distribution Dialog.

The actual reference in a tree formula should look something like the following:

\[ TableX[Dist(1)] \]

where “TableX” is the name of the custom distribution table, and inside the square brackets is the reference to the Uniform distribution (assumed to have the index 1 in the example above). During a second-order simulation, the Uniform distribution will be resampled within its range, causing different rows from TableX to be drawn randomly with an essentially equal likelihood if done correctly.

It may also be possible to pick rows from the table in order during a simulation by using the keyword _sample (for sampling, use _trial for microsimulation) in place of the Uniform distribution. The _sample counter corresponds to the current iteration of the probabilistic sensitivity analysis simulation, incrementing by one at each resampling iteration.

To pick from a particular column in a multi-column table, simply add the appropriate column parameter to the table reference, such as:

\[ TableX[Dist(1); 2] \]

To convert a time-dependent table of values for sampling, you might add additional columns that represent percentiles or bounds of each row. Then, you would use a distribution to sample a column index (i.e., between 2 and 3):

\[ TableX[_stage; 2+Dist(1)] \]
20.5 Correlated Inputs - MultiNormal Distribution

Model inputs can be correlated such that changes in one input are related to changes in other input(s). If you sample these inputs from independent distributions, this correlation is ignored. If correlations are ignored within the context of probabilistic sensitivity analysis, it can lead to more variance in your results than is realistic.

Input correlation can range from -1 to 1.

- 1 represents 100% correlation between inputs
- 0 represents no correlation between inputs
- -1 represents 100% correlation in the opposite direction between inputs

To incorporate correlations when sampling values, you can use a MultiNormal distribution. MultiNormal distributions include multiple correlated variates and generate correlated samples for each of those variates. For example, if you have three correlated inputs, you would create a single MultiNormal distribution with three correlated variates, generating three sets of correlated samples.

The rest of this section describes how to create and use MultiNormal distributions for parameters in the context of Probabilistic Sensitivity Analysis (PSA). But you could also use MultiNormal distributions for patient characteristics in the context of Patient Simulation (Microsimulation).

In 2019 R2.0, the MultiNormal distribution was re-implemented to make it easier to use. If you open a model with the older version of a MultiNormal distribution, TreeAge Pro will convert the distribution to the current format. Note that the conversion is not backward compatible.

20.5.1 Correlation Example Model

The Healthcare tutorial example model TreeAge MultiNormal Distribution Correlation.trex is a Cost-Effectiveness decision tree comparing two treatments.

Decision tree with MultiNormal distribution
In each strategy, the patient pathways depend on the probability of eradicating the tumor. The probabilities in the two strategies are different – as represented by the variables pEradicateRad and pEradicateRadSurg.

For Probabilistic Sensitivity Analysis (PSA), those variables reference distributions. The model is set up to sample probabilities either with or without correlation between the two probability inputs. That way we can examine the impact of correlation on the PSA results.

- No correlation – set variable correlatedSw = 0. The two probabilities are sampled from independent normal distributions.
- Correlation – set variable correlatedSw = 1. The two probabilities are sampled from a single MultiNormal distribution which generates two correlated samples.

We will examine the results from PSA with and without correlation later in this section.

Note that typically beta distributions would be used for probability parameters, but normal distributions are used in this example.

### 20.5.2 Creating a MultiNormal Distribution

Although the example model *TreeAge MultiNormal Distribution Correlation.trex* used in this chapter already has the MultiNormal distribution created, this section describes how to create one.

*Creating a MultiNormal Distribution:*

1. Open the Distributions View.
2. Click the “+” button to create a new distribution.
3. Enter the name of the distribution.
4. Scroll down the list of distribution types to select MultiNormal.
5. Click the Edit Matrix & Options button (See figure Screenshot #1). A second dialog “Edit Matrix & Options” will open (See figure Screenshot #2)
6. Enter the number of variates (minimum 2).
7. Select the appropriate Matrix type based on the form of your correlation data. This likely depends on the software used to generate the correlations.
8. Click on the column headings above the matrix and enter names for each variate within the MultiNormal distribution (optional) (See figure Screenshot #2 where Radiation and Rad_Surg have been entered as the column headings).
9. Enter the correlation data into the matrix grid.
10. Enter mean values for the individual variates.
11. Enter standard deviation (or scaling) values for the individual variates. Note that matrix types have variance built-in, so you would not enter the variate standard deviations.
12. If you have the matrix, mean and standard deviation data in Excel, you can copy and paste the data directly into the Matrix dialogue. Use the copy and paste buttons above the matrix.
13. Click OK to return to the Add/Change Distribution dialog.
14. In this example, the resampling rate is “Resample per EV” for use in PSA, which is what we want in this context.
15. Click OK to save the distribution.

Screenshot #1: Add/Change Distribution dialog for the MultiNormal distribution

Screenshot #2: Edit Matrix & Options dialog for the MultiNormal distribution

For the top two matrix types shown in Screenshot #2 above – Variance/Covariance and Correlation – TreeAge performs the Cholesky decomposition prior to sampling. Use the "Show Cholesky" button to show the calculated Cholesky Matrix as per TreeAge.
For the second two matrix types – Cholesky (Var/Covar) and Cholesky (Correlation) – the Cholesky decomposition has already been incorporated into the matrix, so TreeAge Pro does not apply it again. Depending on the software you have used to generate the correlations, you can enter data in any of these 4 formats.

Once your MultiNormal distribution is created, select the distribution in the Distributions View and click the "Graph It" icon within the Distributions View toolbar to see the samples generated for each variate of the MultiNormal distribution. Note that you can’t see the correlation between the variates via these independent graphs.

![Samples from MultiNormal Variates](image)

### 20.5.3 Referencing the MultiNormal Distribution in the Model

Although the Healthcare tutorial example model *MultiNormal Distribution Correlation.trex* used in this chapter already has the MultiNormal distribution incorporated, this section describes how it is referenced.

As with any distribution, it must be referenced within the model to have any impact on results. Many distributions just return a single value each time they are sampled, and these would be referenced directly, that is $p_{\text{Variable}} = \text{dist_for}_{\text{pVariable}}$. Distributions such as MultiNormal and Dirichlet that have variates (that is they can return several values) must be referenced differently, so you can specify the variate you want. The two forms are presented below.
- By name: \( \text{Dist}(\text{"DistName"}; \text{"VariateName"}) \)
- By index: \( \text{Dist}(\text{DistIndex}; \text{VariateIndex}) \)

You can also reference the distribution by name, and the variate by index or vice versa. Note that name entries are always placed in quotes, while index entries are not.

In our example model, the MultiNormal distribution is referenced with the first form above, but it is used only when \( \text{correlationSw} = 1 \). Therefore we see the following definitions:

- \( p_{\text{EradicateRad}} = \text{if}(\text{correlatedSw}=1; \text{Dist}(\text{"dist_pEradicateBoth"};\text{"Radiation"}); \text{dist_pEradicateRad}) \)
- \( p_{\text{EradicateRadSurg}} = \text{if}(\text{correlatedSw}=1; \text{Dist}(\text{"dist_pEradicateBoth"};\text{"Rad_Surg"}); \text{dist_pEradicateRadSurg}) \)

When running PSA with the variable \( \text{correlationSw} = 0 \), samples for the probabilities are assigned from two independent Normal distributions – \( \text{dist_pEradicateRad} \) and \( \text{dist_pEradicateRadSurg} \). When running PSA with \( \text{correlationSw} = 1 \), samples for the probabilities are assigned from two variates of the MultiNormal distribution.

### 20.5.4 Impact of Correlation on PSA Results

To see the impact of parameter correlation, we can run PSA on the model first without correlation \( (\text{correlationSw} = 0) \), then with correlation \( (\text{correlationSw} = 1) \). In this model there is a high correlation between the parameters \( (0.8) \), so we expect the probabilities to change in a similar manner from sample to sample.

We specifically look at the ICE Scatter plot to illustrate the impact of parameter uncertainty – first without correlation, then with correlation.
PSA results - ICE Scatterplot with no correlation (correlationSw = 0)

Without correlation, incremental effectiveness variance ranges from around 0.6 to 2.3.

PSA results - ICE Scatterplot with correlation (correlationSw = 1)

In the figures above, with correlation, incremental effectiveness variance ranges from around 0.9 to 1.8.

With high correlation between the sampled probabilities, the effectiveness values for the two strategies change together. This reduces the incremental effectiveness between the strategies' results. The
reduction in the incremental cost range is less visible because incremental cost is also affected by a separate distribution dist\_cSurgery.
21. Creating and Using Tables

This chapter provides instructions on creating tables of numeric values for use in custom sampling distributions and other tree calculations.

21.1 Creating and editing tables

TreeAge Pro can store indexed tables of numeric values that represent parameters in your model. Here are some basic facts about tables:

- Tables are typically created and stored with models in *.trex files. This is similar to how *.pkg files worked in previous versions.
- TreeAge Pro supports the use of global tables. However, the default location for global tables is no longer in a "Tables" folder in the TreeAge Pro application folder. Rather, each TreeAge document/project workspace includes a "Global Tables" project. This is the default location of example global tables (e.g., "tMort.tblx"), as well as *.tblx files automatically converted from a previous version's global *.tbl files.
- In TreeAge Pro, each tree has its own preferences related to the use of Global Tables. It is possible to create sub-folders in the Global Tables project specifically for one or a group of tree models, and to use tree preferences to point to the appropriate sub-folder. Or, a tree can be set to ignore the Global Tables project and only utilize tables contained within the model.
- Every table has an index column and a value column. A table can have additional value columns (up to 512) and from one row of values up to tens of thousands of rows.
- Each row's index value must be unique, but indexes are not required to be consecutive integers. TreeAge automatically numbers the value columns with integers (starts at 1).
- Tables can linearly interpolate values for missing indexes/rows, as well as columns.
- Only numeric values (no variable names or formulas) can be entered in a table.
- In Markov models, tables are often used to represent probabilities that vary over time (or other dimensions). Refer to the Building and Analyzing Cost-Effectiveness Models Chapter.
- A table can represent a parameter's empirical probability distribution to sample from during Monte Carlo simulation. (Refer to the Distribution Functions, Options and Types Chapter for details on sampling from tables and other distribution types.)
- Table Values can be loaded into a table in a variety of ways, including: paste tab-delimited text; edit via the Excel add-in; query an ODBC database; manually enter index-value combinations.

Facts about tables

21.1.1 Tables View

Tables are created and maintained via the Tables View.

To open the Tables View:
- Choose Views > Tables from the toolbar.

Within the Tables View, there are two sets of data and associated controls

1. List of tables and table controls to the left.
2. List of table entries and table entry controls to the right.

When a table is selected in the list, the table entry data and controls apply to that selected table.

![Tables View](image)

The table property toolbar controls are described below from left to right.

- **Edit**: Edit the selected table from the list.
- **Add**: Create a new table.
- **Delete**: Deleted the selected table(s) from the list.
- **Duplicate**: Create a copy of the selected table and edit it as a new table.
- **Copy table**: Select the row with the table(s) you wish to copy. Click the copy icon to copy the table(s) into the clipboard. See the Variable Properties View for details about copying/pasting.
- **Paste table**: Copy table(s) (as above from another model) and click the paste icon to paste the table into the active model. See the Variable Properties View for details about copying/pasting.
- **Import**: Import table(s) from a global table file (*.tblx) into the model.
- **Export**: Export table(s) from the model to a global table file.
- **To Excel**: Copy the selected table and its data to Excel for editing.
- **Graph It**: Create a graph from the selected table’s data.
- **Report**: Create the Tables Used Report.
- **Highlight**: Highlight the table within the model in the Tree Diagram Editor.

The table data toolbar controls are described below from left to right.

- **Delete**: Delete the selected table entries from the table.
- **Add**: Add a new table entry to the table.
- **Copy**: Copy table data with headers and rows to clipboard.
- **Paste**: Paste table data with headers and rows from clipboard to table. Existing data is replaced.
21.1.2 Creating a new table

Before entering values into a table, you must first create a table.

To create a new table:

- Open the Tables View.
- Click the "add" toolbar button. This will open the Add/Change Table Dialog.
- Enter the table name and properties into the dialog (see below). The specific property options will be described later in this chapter.
- Click OK to save the table and close the dialog.

Add/Change Table Dialog

After the table is created, it will appear in the tables list within the Tables View. You can then edit the properties of the new table.

To change the properties of a table:

- Select a table in the list.
- Click the "edit" button in the toolbar.
- Change the table properties in the Add/Change Table Dialog.

21.1.3 Entering values in a table

To populate a simple table, use the table entries toolbar and table data grid.

To enter table data:

- Select the table in the tables list.
- Click the "Add Row" button in the table entries toolbar. A new table row will appear in the table data grid.
- Change the values for the data row as needed.
- Repeat prior two steps to add more data rows.

This method of entering data can be time consuming. There are other methods available for loading table data. Those methods are described in subsequent sections.

### 21.1.4 Loading/copying tab-delimited table data

To modify the values in an existing TreeAge Pro table, it may be more efficient to copy the table rows into a spreadsheet or text file for editing. Or, if you have a new, empty TreeAge Pro table, you can create the rows in a spreadsheet, and then copy and paste into the Table Rows list editor.

To edit table data in Excel or a text editor:

- Select the table in the Tables view.
- Click the Copy button in the Table Rows editor, as shown above.
- Paste the rows into a spreadsheet or text document.
- Edit the data as tab-delimited text.
- Copy the table data, including headers, into the clipboard.
- Click the Paste button in the Table Rows editor.

Take note of the following requirements:

- A column title row is not required. If one is not included, they will read: Index, Value1, Value 2 etc. Otherwise you can select any column heading (Index or Value columns) and rename them.
- The selected range of cells should use either General, Text, or Number formatting (avoid accounting formats using parentheses for negatives numbers).
- The copied range should not include empty columns or rows.
- Note that the Paste Table command first removes existing rows from the table. However, the command is Undo-able.
- If the Paste command is not available, or does not work, see the bulleted list of suggestions above on proper cell formatting in the source document. If all else fails, try first pasting the spreadsheet data into a plain text file to remove formatting, and then copy the text file data into TreeAge.

21.1.5 Editing index and value column headers

You can enter custom column headers for the index and value columns by clicking on the header. You can then enter the custom column header into an input dialog.

![Edit value column header]

21.1.6 Editing table data in Excel

Users with the optional Excel Module can export table data to Excel, edit the data in Excel, then import the edited data back into TreeAge Pro. This technique is described in the Excel Module Chapter.

21.2 Referencing tables in formulas

There are two basic ways to use tables:

1. In order to look up a value in the table from a payoff, probability, or other calculation, you will need to use the proper syntax (below).
2. If a table is used as a sampling distribution, simply select its name from a list of tables when setting up the distribution (described later in this chapter).

### 21.2.1 Table lookup syntax

In a table composed of index-value pairs (i.e., one column with an index and a value column), a value can be retrieved with the following syntax:

```
TableName[index]
```

The table’s variable-type name (`TableName`) is followed immediately by square brackets containing an index used to pick a table row. The index expression can be a number, a variable, or even another table reference.

If a table has more than one column of values, you will need to specify the number of the column you want to pick from. The syntax will now required row index argument first and then column number:

```
TableName[index; value_column]
```

The `value_column` expression can also be a number, variable, etc. However, this expression normally resolves to an integer value <= the number of columns in the table. Note that when looking at the table, the first value column is actually the second column in the table because the first column contains the index.

For tables with more than one value column, table lookups without a `value_column` provided will use the default value column defined in the table properties.

---

### Reverse table lookups

Special syntax for the Command() function enables reverse table lookups. This is designed to facilitate, for example, using a uniform[0,1] random number to "sample" age-at-event table from an age-indexed table whose value columns describe one or more inverse "survival" functions, or "cdfs". The syntax is:

```
Command("TABLES"; "t_events"; "ReverseLookup"; prob; value_column)
```

Other methods are: "ReverseLookupInterpolate", "ReverseLookupTruncate", and "ReverseLookupCeiling". Refer to the Tools and Functions for Complex Trees Chapter for additional information.

---

### 21.2.2 Table lookup methods

During tree calculations, if a formula references a table using an index value that matches a row index in the table exactly, TreeAge simply returns the value from the appropriate column in that row. However, when a reference is made to a non-existent row/index, the table’s missing row lookup method determines what is returned.
The missing row/column lookup methods are:

- **Truncate**: If rows with lower indexes exist, returns the value from the row with the highest index that is less than or equal to the requested index; otherwise, returns the value from the first row (i.e., the lowest index value).

- **Use linear interpolation**: Returns a value calculated by linear interpolation between existing indexes. This is the default lookup method.

- **Error**: Report an error if an index value is provided that is not in the table.

### Table lookup methods

Each table also has an “Index off edge is error” option. If this option is left unselected, a table that uses truncation or interpolation will allow references to indexes above or below the table’s actual range. In these cases, the table will return the value associated with the closest existing row or column. If this option is checked, on the other hand, an error will be reported.

TreeAge Pro supports interpolation of both rows and columns. The table below is used to show how TreeAge Pro handles table lookups with interpolation.

### Table interpolation example

Interpolation starts with the value for the index below the provided value. Then it adds the difference between the next higher value and the lower value based on the proportion of the way from the lower index to the higher index.

\[
\text{TestTable}[14;1] = \text{TestTable}[10] + \left(\frac{14-10}{20-10}\right) \times (\text{TestTable}[20]-\text{TestTable}[10])
\]

\[
\text{TestTable}[14;1] = 1,000 + (\frac{4}{10}) \times (1000) = 1,400
\]

\[
\text{TestTable}[30; 1.3] = 3,000 + \left(\frac{1.3-1}{2-1}\right) \times (30,000-3,000) = 11,100
\]

TreeAge Pro supports simultaneous interpolation of both rows and columns. First interpolation is done on the row values and then those row interpolated values are used for the column interpolation.

\[
\text{TestTable}[16;1] = 1,600
\]

\[
\text{TestTable}[16;2] = 16,000
\]

\[
\text{TestTable}[16;1.4] = 1,600 + \left(\frac{1.4-1}{2-1}\right) \times (16,000-1,600) = 1,600 + (\frac{.4}{1}) \times 14,400 = 7,360
\]

### 21.3 Model tables and global table files

By default, tables are stored within the model document (extension *.trex). We recommend that you leave the tables within the model. However, it is still possible to create and use Global Table files to store the tables separately.
Global Table files (extension *.tblx) store tables, which can then be referenced by multiple models. During analysis, TreeAge Pro will first look for a table within the model. If the table is not found, it will look for the table in a Global Table file. The name of the Global Table file does not matter, but the location of that file is key.

You can choose whether to look for table data in Global Table files and specify the location of Global Table file(s) for a specific model via Tree Preferences. If the default path is not stored in Tree Preferences, TreeAge Pro will search for Global Table files in the following locations.

1. <workspace>/Global Tables
2. <workspace>/Example Models/Special Features/Global Tables

If a Global Tables file is found in the first location, it will not search the second location.

Open the Special Features tutorial example tree, Global Tables Model.trex to see a model which references a table from a Global Table file in one of the default locations.

The next sections demonstrate how to export tables to and import tables from a global table file.

**21.3.1 Exporting tables from a model to a global table file**

*To export tables:*

- Open a model with tables.
- Choose Views > Tables from the toolbar.
- Select the tables you wish to export.
- Click the "Export Global Tables" icon from the Table Properties toolbar.
- In the Export Tables dialog, specify the tables file and select the tables you wish to export.

![Export tables to global tables file](image)
The global tables file can then be opened as you would open a tree document. When opened, the global tables file will appear in the Tree Diagram Editor. However, its appearance will be very similar to the Tables View for the original model.

21.3.2 Importing tables from a global table file to a model

To import tables:

- Open a model.
- Choose Views > Tables from the toolbar.
- Click the "Import Global Tables" icon in the Table Properties toolbar.
- In the Import Tables Dialog, select the global tables file.
- Select the specific tables from the global tables file that you want to import.
21 Creating and Using Tables

The tables will then be included in the model and can be referenced in expressions.

21.4 Importing tables from older versions of TreeAge Pro (2009 and earlier)

You may have TreeAge Pro tables that were created in TreeAge Pro 2009 or an earlier version. Rather than re-entering the table properties and data, the table data can be imported into the current version of TreeAge Pro.

If you look in the FilesView, there should be a Global Tables project. This may contain *.tblx files created by automatically importing older *.tbl files found in a previous version's "Tables" sub-directory. (Each time a new workspace is created, #2 below is automatically performed.)

A *.trex model can utilize the tables contained within a *.tblx Global Table for analysis purposes. These tables can be edited by double-clicking on the *.tblx file to open a tables editor.

There are a number of other options for importing table data into a tree model or a Global Tables project or folder, for example:

1. Import directly into *.trex model from a v200x *.pkg packaged tree, or from a previous version's "Tables" sub-directory.
2. Create a single *.tblx file containing all global tables from a v200x *.pkg, or the v200x "Tables" sub-directory.
3. Create individual *.tblx files for each global tables from a v200x *.pkg, or the v200x "Tables" sub-directory.

In TreeAge Pro 2009 and earlier, by default, tables were written to global table files (*.tbl) stored in a specific folder on your computer. You also had the option of saving your model as a package file (*.pkg), which would include the tables used by the model within the model document itself.

If you open an older package file in the latest version of TreeAge Pro, it will convert both the model and its tables into a current TreeAge Pro model file (*.trex). No specific action is required for the tables because the tables that were included with the original 2009 package file are also included with the current model file.

However, when you open a v200x tree file (*.tre), any referenced tables will not be converted with the model because the tree file does not contain table data. However, the required *.tbl files may already have been imported as *.tblx files in the Global Tables project in your workspace. If this is the case, analyses of the imported tree may work immediately without further action. If required *.tbl files were not accessible (e.g., previous version was on a different computer), you have two options: save the v200x tree file as a package file before conversion, or manually import the global *.tbl table files required by the tree file.
You can import all the 2009 table files (*.tbl) at once from the 2009 global table directory or you can import the tables contained within a 2009 package file (*.pkg). In either case, the tables can be imported either directly into the active tree document, or into a global table file.

To import 2009 tables:

- Click the "Import Tables" button in the Tables view toolbar, and then click the button labeled "Import v200x Tables"; or
- Choose File > Import/Export > Tables Import...
- The Import TreeAge Pro 200x Tables dialog will open.

**Import TreeAge 200x Table Files Dialog**

This dialog provides options for selecting the location of the table's source, the list of tables, and the target to receive the tables.

Let's say you want to import some or all of the global tables from your previous TreeAge Pro 2009 installation into the currently open tree document, which perhaps was imported earlier from a v200x *.TRE file. In the dialog you would...

1. Browse to a Tables folder from a previous TreeAge Pro v200x installation. (The default path, if it exists on the computer, will be entered for you.)
2. Select the desired tables to import.
3. Use the default, selected target, which will import into the currently active tree.

After you click Finish, the open tree document's list of tables will be updated to include the imported tables.
Or, instead, you can choose to import the tables into a new or existing Global Tables file for modification and eventual re-import into a Tree Document. After you click the Finish button, the import is executed; if necessary, a new Global Tables project will be created in your TreeAge Pro Workspace. Within the Global Tables project, the *.TBLX files will be updated/created.

Global Tables project with imported tables

To make changes to the imported tables, open the Tables document file (e.g., "04-Feb-10.TBLX") in the Global Tables project. When tables contained in the Tables document are needed for a particular tree, simply go to the tree document's Tables view and import tables from the tables document.

Variations on the import described above include:

- Import 2009 tables from a 2009 package file (*.PKG) rather than the v200x Tables folder.
- Import 2009 tables to an existing global tables document (*.TBLX) rather than a new tables document.
- Import 2009 tables to a folder rather than a single tables document; each table is contained in a separate Global Tables document within the folder.
21.5 The All Tables Report

The All Tables Report displays all the tables that exist and/or are referenced in the tree.

The "Unused" column indicates that a table exists in the tree but is never referenced. The "Missing" column indicates that a table is referenced in the tree, but does not exist.

21.6 Managing tables using the Excel module

Users with the Excel/COM module can utilize the TreeAge add-in menu in Excel to update TreeAge with changes made to tables stored in a spreadsheet. Refer to the Graphing, Reporting and Modeling Using Excel Chapter.

It is also possible to use the TreeAgeProLib to script changes to tables. Refer to the Using the TreeAge Pro Object Interface Chapter.

21.7 Linking a table to an ODBC data source

TreeAge Pro includes the option to link a table to an existing database or other data source that has an ODBC driver. Linking a table to a database is an easy way to make table updates automatic.

TreeAge Pro tables can use ODBC to access most commercial and open-source database formats, including: MySQL, SQL Server, Access, Firebird, as well as Excel spreadsheets, text-format files, and XML files. A standard SQL SELECT query is used to select columns and rows from a table in the data source, which then replace the contents of the target TreeAge Pro table.

21.7.1 Using ODBC data sources in Windows

Before you can attach a TreeAge Pro table to an ODBC data source, you must first create the ODBC connection to the data source. Microsoft has published instructions for on ODBC data sources on their website (Windows XP, Windows 7).
Creating ODBC data sources has become more complex with Office 2007 and Windows 7. Please refer to Microsoft documentation regarding creating ODBC data sources. Note that this example uses the 32-bit ODBC driver setup on a Windows 7 computer since no Office ODBC drivers were listed under the 64-bit Data Sources entry in the Control Panel.

In this document, we will create an ODBC data source in Windows XP that connects to the following Excel worksheet saved on the computer.

Excel data source

Note that the data is contained within the named range `DataNamedRange`.

To open the ODBC Data Source Administrator in Windows 7 via the 32-bit drivers:

- Open the 32-bit ODBC Data Source Administrator by executing the program C:\Windows \SysWOW64\odbcad32.exe.

System data source names (DSN) are available to all users of the computer, so we will create a System DSN.

To create a System DSN:

- Select the System DSN tab.
- Click the Add button.
- Select the Microsoft Excel driver from the list presented in the Create new Data Source Dialog (see below).
- Enter a data source name and select the workbook in the ODBC Microsoft Excel Setup Dialog (see below).

After creating the System DSN, it will appear in the ODBC Data Source Administrator Dialog.

Now that the ODBC data source is ready, we can connect it to a TreeAge Pro table.
To connect a TreeAge Pro table to an ODBC data source:

- Create a table via the Tables View.
- In the Add/Change Table dialog, click on the SQL Query option in the Table data provider area.
- For Data source, enter the value "ODBC 2.1".
- For Database, enter the name of the data source from the ODBC setup.
- Click Test to verify that the connection can be established.

Setup table with ODBC data source - 1

To connect a TreeAge Pro table to an ODBC data source (continued):

- Click on the Query tab.
- Enter the query expression into the appropriate field. This example refers to the name data range in the Excel document. You can also refer to a worksheet within the document.
- Use the other options as needed.
To connect a TreeAge Pro table to an ODBC data source (continued):

- Click on the Options tab.
- Enter options for when to load data and what to do with missing data from the data source.
Setup table with ODBC data source - 1

The table is now available for use in your model.
Model with ODBC table
22. Stored Analysis Abstracts and Sequences

TreeAge Pro allows you to store the settings used to perform many types of analyses. This chapter provides instructions on saving and using stored analyses. It also describes how to create simple stored analysis sequences that, for example, runs a series of simulations or sensitivity analyses.

For more complicated tasks, such as batching lengthy analyses, automating export of analyses to spreadsheets, or retrieving analysis parameters from a database or spreadsheet, you can use TreeAge Pro's Object Interface.

22.1 Using stored analyses

It is possible to save and reuse the parameters for most of the analyses available in the Analysis menu. This includes Monte Carlo simulation and all forms of sensitivity analysis. Analyses that cannot be stored include Graph Risk Preference Function, Show Optimal Path, Verify Probabilities, and Roll Back.

22.1.1 Create a stored analysis

To create a stored analysis, you must first run a regular analysis. TreeAge Pro can only save the last analysis, so you must save the stored analysis before running a second analysis on the model.

Only certain analysis types can be stored - Monte Carlo simulation, sensitivity analysis and tornado diagrams.

For this example, we will save a stored analysis for a Monte Carlo simulation with trials on the Three Vars Get Started tutorial example model.

To store the parameters of an analysis:

- Open the Three Vars example model.
- Select the root node.
- Choose Analysis > Monte Carlo simulation > Microsimulation (Trials) and start the simulation.
- Either cancel the analysis or allow it to complete.
- Select the tree in the Tree Diagram Editor.
- Choose Analysis > Stored Analyses from the menu. This opens the Tree Preferences category Stored Analyses.
- Click the Save Analysis button.
- Change the default name to something meaningful (see warning below) and click OK.
- Save the model.

Use only letters, numbers and spaces in your stored analysis name if you want to use the analysis in a stored analysis Sequence. Sequences cannot handle punctuation.
If you are storing a Monte Carlo simulation to reuse, you do not have to let the simulation run to completion.

The instructions that TreeAge Pro needs in order to perform the exact analysis are stored in the Tree Preferences (the results of the analysis are not).

![Tree Preferences - Stored Analyses](image)

The top of the dialog shows a list of stored analyses and sequences. The bottom of the dialog shows the parameters used by the selected stored analysis.

### 22.1.2 Run a stored analysis

Once an analysis is stored, it is saved with the tree, and can be run as long as no significant structural changes are made where the analysis was originally run.

**To run a stored analysis:**

- Open the tree in which you have stored an analysis.
- Choose Analysis > Stored Analyses from the menu. This opens the Tree Preferences category Stored Analyses.
- Select a stored analysis from the list.
- Click Run.

Many analyses are dependent on the structure and variable definitions of your tree. For instance, the location (relative to the root node) of the node at which you originally performed a sensitivity analysis.
must be unchanged from when you stored the analysis, and all analyzed variable definitions must be present in the same locations. If TreeAge Pro is unable to reconcile the different structures, it will not run the analysis.

### 22.1.3 Edit/maintain stored analyses

The Tree Preferences category Stored Analyses allows you to edit, rename, delete or copy a stored analysis.

*To edit a stored analysis:*

- Select an existing stored analysis.
- Edit the comment if desired.
- Click the pencil icon to edit the stored analysis parameters if desired.

Be very careful when editing stored analysis parameters since they are not labeled. In the example above, you could safely change the 100 to a different number of trials. In the case of a sensitivity analysis, you could edit a variable and/or its range.

You can also rename or duplicate an existing stored analysis using the appropriate buttons to the right of the stored analysis list.

### 22.2 Sequencing stored analyses

In TreeAge Pro, sequences of stored analyses can be defined and stored, like a batched analysis, for future use. Analysis sequences can greatly simplify tasks like batch processing a series of lengthy analyses, such as Monte Carlo simulations. Sequences can also be used, if you frequently do manual kinds of sensitivity analyses, by repeating any of TreeAge Pro’s built-in analyses over a range of variable values.

#### 22.2.1 Creating an analysis sequence

This section provides a simple illustration of how the sequencing feature can be used to automate running a series of separate Monte Carlo simulations, each using a different value of a variable. We will assume that you already created the original Microsimulation stored analysis described earlier in this chapter.

*To create a sequence of stored analyses:*

- Choose Analysis > Stored Analyses from the menu.
- Click the New Sequence button.
- Enter a name for the new sequence (Simulations with var change).
- Select the new sequence in the stored analysis list.
- Click in the first line of the Content input list.
- Press `CONTROL+SPACEBAR` to use autofill to bring up a list of existing stored analyses.
- Select the Monte Carlo simulation stored analysis.

At this point, you will have a sequence that simply runs a single stored analysis (see below).

**Stored analysis sequence**

In addition to stored analyses, you can also make minor modifications to the tree via sequence commands. The most common modification is to change the value of a variable at the root node. This is achieved through the following command:

```plaintext
Tree.defineRootVariable(variable, definition)
```

Autofill can help create the sequence command.

The Special Features tutorial example model, Three Vars with Stored Analyses, contains four stored analyses and three sequences.
22.2.2 Run/maintain analysis sequences

You can run, rename and delete a stored analysis sequence using the same buttons as for individual stored analyses.

Stored analysis sequences can be edited by selecting the sequence, then editing the Content field.

Stored analysis sequence

Note that two sequences "Run_analyses_to_screen" and "Run_analyses_to_RPTX". Both sequences run the three stored analyses "Rankings", "Monte_Carlo_1000_trials", and "Sensitivity_on_prob_extreme". However, the "Run_analyses_to_screen" sequence presents the analysis output within TreeAge Pro, while the "Run_analyses_to_RPTX" sequence suppresses that output from the screen and instead writes the output to a RPTX file, which can be opened later. Saving analysis results rather than displaying them can be helpful when you want to run a large number of analyses that could exceed your system resources if all results remain open.
23. Linking with Excel and Other Applications

This chapter covers dynamic linking, a powerful tool for integrating a decision tree and an Excel spreadsheet.

23.1 BiLinks to connect with Excel

BiLinks facilitate communication between your model and an Excel workbook. This communication can take several forms.

- Pull parameters from Excel data
- Calculate values in Excel based on data passed from TreeAge Pro
- Pass analysis results from TreeAge Pro to Excel

This chapter will focus on each of the above.

23.2 Pull parameters from Excel via BiLinks

The most common use of BiLinks is to pull parameters specified in Excel into TreeAge Pro. This allows you to gather key parameters in Excel from individuals who are more comfortable with Excel, but then use TreeAge Pro for the actual model and analyses.

To illustrate this use of BiLinks, consider the BiLinks tutorial example tree LegalTreeVars-Bilink.trex. See below.
This is a simple legal model with 6 variables. Note that the variables do not have values directly in the tree. Instead, those values are pulled from Excel using the Bilink function. The Bilink function references an index that points to a specific Excel cell (or range). The Excel references are set up in Tree Preferences.

Bilink Tree Preferences

A TreeAge Pro model can only connect to a single Excel worksheet. That worksheet is selected and displayed at the top of the dialog. Note that if no path is provided, the worksheet must be placed in the same folder as the model.

Note that there are three sections to the Dynamic Links category of Tree Preferences.

1. Inputs - TreeAge Pro to Excel
2. Outputs - Excel to TreeAge Pro
3. Post-analysis Statistics Inputs to Spreadsheet

This example only uses the second section to pass data from Excel to TreeAge Pro as follows.

- **Index** - simply an index counter for reference via the Bilink function within the model.
- **Linked to** - reference to the named cell or range in Excel referenced by this link
- **Preview** - the current value of the cell or range from Excel
- **Description** - optional text to describe this link
TreeAge Pro references named cells within Excel via the Bilink(index) function or the BilinkName(name) function. When the TreeAge Pro model is analyzed, the data is pulled from Excel and placed in the variables defined with the Bilink function.

The figure below shows the model rolled back using the data from Excel.

![LegalTreeVars-Bilink.trex rolled back](image1)

The figure below shows a similar model "LegalTreeVars-BilinkName.trex", which uses the BilinkName function instead of the Bilink function.

![LegalTreeVars-BilinkName.trex](image2)

### 23.3 Dynamic linking with Excel via BiLinks

Dynamic linking provides you with a more robust connection between TreeAge Pro and Excel. Essentially, there is a flow of data between the two programs in the following order.

1. Pass data from TreeAge Pro to Excel based on the analysis context (node context, simulation iteration, etc.)
2. Recalculate the Excel workbook, and pass updated data from Excel back to TreeAge Pro.
3. After analysis is complete, send results from TreeAge Pro to Excel.
Steps 1 and 2 above can be useful if you have developed a complex set of cost or utility calculations in a spreadsheet. Step 3 above can be useful if you want the key analysis outputs to be presented in Excel and not just in TreeAge Pro.

Dynamic links work during any type of analysis (e.g. roll back, sensitivity analysis, and Monte Carlo simulation).

To illustrate the basic workings of dynamic links, consider the Bilinks tutorial example tree BiLink-Dynamic.trex pictured below.

BiLink-Dynamic.trex

Note that the Cost_with_tax variable referenced in each terminal node’s payoff is defined using the BilinkName function. Let's examine the Bilink Tree Preferences and the associated Excel workbook to see how this will function when the model is analyzed.

BiLink-Dynamic.trex - Bilink Tree Preferences

The above Tree Preference settings show the three communication levels between TreeAge Pro and Excel.
1. TreeAge Pro variables *Num_days*, *Per_diem*, and *tax_rate* are defined within TreeAge Pro. Those values are passed to Excel cells with the same name ("Linked to" column above). Note that *Num_days* and *Per_diem* are defined differently in different parts of the model.

2. The Excel cell *Cost_with_tax* is passed back from Excel to TreeAge Pro based on each of the two contexts. For the top and bottom terminal node payoff expression, it uses the appropriate definitions for variables *Num_days* and *Per_diem*, so the values returned by Excel for *Cost_with_tax* are different.

3. After the analysis is complete, the mean value for each strategy is returned to Excel and placed in cells *result_opt1* and *result_opt2*.

Communication between TreeAge Pro and Excel

Let's now examine the Excel Worksheet after analysis.

![Excel Worksheet](Bilink-Dynamic-Worksheet.xlsx)

While the transfer of data during the analysis was performed twice, the worksheet will reflect the most recent transfer (for the second terminal node). Note that the values *Num_days*, *Per_diem*, and *tax_rate* all reflect the appropriate values as they would be used in the second payoff expression. Those values are combined in the formula for cell *Cost_with_tax*, which is then returned to TreeAge Pro.

Finally, the post-analysis mean values for the two strategies is then passed from TreeAge Pro to Excel in cells *result_opt1* and *result_opt2*, and the process is complete.

23.4 Creating a BiLinks report

A BiLinks report is useful if you have many dynamic links in your model. The BiLinks report details inbound BiLinks from Excel and outbound BiLinks to Excel.
The report provides the following information about inbound BiLinks from Excel:

- BiLink Index
- Linked Excel cell name
- Value from Excel
- TreeAge variable, if the variable is defined at the root node
- Description, if a description is provided from the BiLink entry.

The report provides the following information about the outbound BiLinks to Excel:

- Linked TreeAge Pro variable
- Linked Excel cell name
- Value to Excel
- Description, if a description is provided from the BiLink entry.

Using the BiLinks tutorial example, BiLinks-after.trex, use the following steps to generate a BiLinks report:

- Open Tree Preferences > Spreadsheet > Dynamic Links, as indicated in the Figure below.
- Select the button "Create BiLinks report" to generate the report.
- To change any of the outputs to and inputs from the spreadsheet, see the next section Calculating payoffs using Dynamic links.

![Tree Preferences - Generating the BiLinks report](image-url)
23.5 Calculating payoffs using dynamic links: a simple example

This section describes how to create dynamic links to Excel. First open the BiLinks tutorial example, BiLink-before.tre and BiLink-worksheet.xls.

Once you have opened the tree and spreadsheet, there are three steps to setting up the dynamic link between them:

1. Link the tree to an output cell (or range of cells) in the spreadsheet.
2. Assign tree variable inputs to cells in the spreadsheet.
3. Define a payoff variable or other parameter in the tree to use the spreadsheet output.

23.5.1 Naming a spreadsheet cell

Before TreeAge Pro can connect to any input or output cells in the spreadsheet, these cells must be named. The BiLink tutorial example Excel file BiLink-worksheet.xls already has names assigned to the output cell (Cost) and the two input cells (Per_diem and Num_days).

To assign a name to a cell in Excel:

- Select the cell (or range of cells).
- Click in the Name box (see below) and type a one word name (like a TreeAge variable name).
- Press the ENTER key to save the name.
23.5.2 Linking to a spreadsheet cells

Once an output cell has been named, it can be linked to a TreeAge Pro tree as an input cell or an output cell (not both). In our model, we want to create two input cells for Days of treatment and Cost per day and one output cell for Total cost.

Both input and output cells are created via the Tree Preferences.

To create the dynamic links:

- Choose Tree > Tree Preferences from the menu or press the F11 key to open the Tree Preferences dialog.
- Navigate to the category Spreadsheet > Dynamic Links.
- Click Browse to select the Excel spreadsheet (which must be saved).
- In the "Outputs from Spreadsheet" section, click the Add button. This should add the named cell Cost, which is the first named cell when sorted alphabetically.
- In the "Inputs to Spreadsheet" section, click the Add button. This should add the named cell Cost. Using the dropdown list within the Variable and Linked to columns, select Num_days in place of Cost.
- Repeat the above to create a link for the named cell Per_diem.
If you remove the path to the worksheet, TreeAge Pro will look for the worksheet in the same folder as the model. Use the Edit button to remove the path.

The links are now set up to send the Num_days and Per_diem values from TreeAge Pro to Excel, recalculate in Excel, and then receive the Cost value back. The inputs to Excel are already linked to TreeAge Pro variables in the Tree Preferences via the Linked to columns. We still need to link the output from Excel value Cost to our tree. This is done via the Bilink function using the index value listed in the "Outputs from Excel" section of the Dynamic Links Tree Preferences.

To define a TreeAge Pro variable using the Excel output cell:

- Right-click on the root node.
- Choose Define Variable > Cost from the context menu.
- Enter the definition $\text{Bilink}(1)$ for the definition.

The argument 1 refers to the index value of 1 for the Cost dynamic link in the Tree Preferences.
The inputs and outputs are now ready for calculation.

23.5.3 Calculate using dynamic links

Now, roll back the tree to verify that different values have been recalculated for each terminal node using the spreadsheet formula.

Bilink tree rolled back

Once the dynamic link is created, all calculations will utilize the linkage, not just roll back.

Excel must be running with the appropriate workbook open in order to create and/or use the dynamic links.

If the named linked cell is moved within the spreadsheet, the links will not be affected so as long as the linked cells’ names are not changed or lost.

The Bilink tutorial example model BiLink-after.trex already has the appropriate links. However, they will not work on your computer until the path to the workbook is fixed in the Tree Preferences.

23.6 Using a single link to a range of cells

If a link is created to a named range of cells, the Bilink() function's index argument is followed by two more integer arguments — the row and column of the desired cell within the range. For example...

\[ \text{Bilink}(1; 10; 2) \]

... will retrieve the value from row 10, column 2 of link #1’s region of cells.

This feature is demonstrated in the Bilink tutorial example Bilink-range.trex and Bilink-range.xls. See below.
Blink tree with range

The tutorial examples Excel model Bilink-range.trex will not work on your computer until the path to the workbook is fixed in the Tree Preferences.
24. Tools and Functions for Complex Trees

This chapter focuses on a number of features in TreeAge Pro that can be indispensable aids to both building and reviewing large and/or complex trees.

24.1 Working with very large trees

Many of the modeling exercises and examples in this manual are based on simple, small trees. The trees required in your own projects may be much more complex, perhaps including hundreds of variables, thousands of nodes, scores of distributions, etc. (Which is not to suggest that a bigger model is a better model, generally.)

Previous chapters detailed some of TreeAge Pro’s many productivity features designed to make it easier to work with large trees:

- Copy and paste subtrees.
- Collapse/hide subtrees.
- Use the zoom feature to see more/less of the tree structure in the editor.
- Use preferences that compress the tree.

This chapter focuses on additional productivity features relevant to complex modeling projects:

- Use the Explorer View and Model Overview for navigation
- View/edit the tree document's XML
- Clone subtrees (rather than copying/pasting)
- Creating user-defined functions with Python
- Link calculations to other trees/subtrees
- Using special functions to perform specialized tasks automatically during calculations (e.g., run a macro, enable debugging, or export the Global matrix)

24.2 TreeAge Pro Workspace, Tree Explorer and Model Overview

The TreeAge Pro Workspace is highly customizable, allowing you to move, resize, hide and maximize views and editors based on the task at hand. If you have a very large model, you might consider customizing the workspace in different ways. To rearrange your workspace for greater efficiency when working in complex models, you might try reducing one of the arrangements shown below.
You can save these customized workspace presentations in Perspectives. Existing perspectives are shown at the top right corner of the workspace. Click the add button to create a new one.
Within the workspace, two views in particular, the Tree Explorer and Model Overview, can be especially helpful when working with large trees.

24.2.1 The Tree Explorer View

The *Tree Explorer* shows a collapsible text view of the model.

You can use the Tree Explorer to navigate to specific nodes. When you select a node in the Tree Explorer, focus is set on the same node in the Tree Diagram Editor. You can also open the node-specific context menu by right-clicking on a node in the Tree Explorer.

24.2.2 The Model Overview View

The *Model Overview* presents a high-level view of the overall model, highlighting the portion of the model that is currently visible in the Tree Diagram Editor.
Model Overview

Within the Model Overview, drag the highlighted area to a different area of the model to view a different area of the model in the Tree Diagram Editor.

24.3 Viewing/editing document XML

TreeAge Pro documents are stored in XML format. TreeAge Pro provides the option to edit the document's XML in an XML editor or a text editor.

Unless you are quite familiar with the XML syntax used by TreeAge models, it is recommended that you use the TreeDiagram Editor to make all edits in models (in particular, adding/deleting nodes), rather than editing the XML text file itself. It is easy to render a model unreadable by making bad edits to the file XML.

However, it is simple to manually create copies/backups of *.TREX files before editing the XML. The Files view also supports robust text compare/local history features, via the right-click menu. This makes it possible to track and remove/reverse selected edits to any of your project files (whether changes are made in the Tree Diagram editor or a text/XML editor).

Finally, the powerful Search/Find/Replace functionality used in combination with the Files view allows regular expression search/replace within the XML (and any other text-based project documents).

To open a tree in an XML editor:

- Right-click on a model in the Files View.
- Choose Open With > Text Editor.
The "default" method of opening the selected model will change when opened in this way. This means that next time you simply double-click on the file, it will again use the "Text Editor" to open. Therefore, it is necessary to right-click and choose Open With > Tree Diagram Editor in order to restore the original, default opening method.

To open a tree in an XML editor:

- Right-click on a model in the Files View.
- Choose Open With > XML Editor.

Open "Cost formula.trex" with XML Editor

The tree will appear in an XML editor within the workspace. You can also open the tree in a Text Editor, which shows the XML in plain text format.

The Special Features tutorial example tree "Cost Formula" is shown below in the XML editor.
XML Editor

XML consists of a hierarchical structure of textual data. In the XML editor, each level of the structure can be expanded or collapsed.

A portion of the basic XML structure of a TreeAge Pro tree is presented below.

```xml
Document
  - tree:Tree
    - - Node
      - - - Definition
      - - - Node (child)
      - - - - Node (child)
      - - Variable
      - - - Sensitivity Range
      - - Categories
      - - Preferences
      - notation:Diagram
```

XML structure

Some notes on the XML format:

- The highest-level elements within the tree document structure are tree and notation.
- The `tree` element includes the building blocks of a model - variables, nodes, preferences, etc.
- The *notation* element contains details related to presenting the model in the Tree Diagram Editor.
- *Variable* elements are nested within the *tree* element because variables exist at the tree level.
- *Definition* elements are nested within a specific *Node* element because variable definitions are defined at the node-level.
- Some XML elements are not presented above (Markov info, payoffs, etc.), but they do exist within the XML structure.

A more complete, but not exhaustive, list of XML elements is presented in the following table:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
<th>Parent Element</th>
</tr>
</thead>
<tbody>
<tr>
<td>tree</td>
<td>Highest level of the tree structure.</td>
<td>&lt;top level&gt;</td>
</tr>
<tr>
<td>notation</td>
<td>Controls presentation of the model in an editor.</td>
<td>&lt;top level&gt;</td>
</tr>
<tr>
<td>Variable</td>
<td>Variable name and properties.</td>
<td>tree</td>
</tr>
<tr>
<td>Sensitivity Range</td>
<td>Sensitivity analysis range for a variable.</td>
<td>Variable</td>
</tr>
<tr>
<td>Node</td>
<td>Node and its properties. Nested according to its location within the tree.</td>
<td>tree or Node</td>
</tr>
<tr>
<td>Definition</td>
<td>Variable definition associated with a node.</td>
<td>Node</td>
</tr>
<tr>
<td>CategoriesRoot</td>
<td>Variable categories for the tree.</td>
<td>tree</td>
</tr>
<tr>
<td>PreferenceSet</td>
<td>Tree preferences.</td>
<td>tree</td>
</tr>
<tr>
<td>Termination</td>
<td>Termination condition for a payoff set/calc methods</td>
<td>Node (type Markov)</td>
</tr>
<tr>
<td>Prob</td>
<td>Branch probability.</td>
<td>Node (with parent chance node)</td>
</tr>
<tr>
<td>MarkovData (state)</td>
<td>Collection for Markov information associated with Markov State (state rewards).</td>
<td>Node (with parent Markov node)</td>
</tr>
<tr>
<td>MarkovData (transition)</td>
<td>Collection for Markov information associated with Markov Transition (transition rewards, jump state).</td>
<td>Node (in transition subtree)</td>
</tr>
<tr>
<td>Payoff</td>
<td>Payoff expression for a specific payoff set at that terminal node</td>
<td>Node (type Terminal)</td>
</tr>
</tbody>
</table>

**XML Elements**

**24.3.1 Editing XML data**

You can edit the structure of the model or properties of a model element within the XML view of the document (although this is not recommended). Consider the following image of a tree both in the Tree Diagram Editor and the XML Editor.
Consider the *Value* attribute within the *Payoff* element for the *Node Foot Saved*. If we change the Value from 4500 to 5500, then save the file in the XML editor, the Tree Diagram Editor will reflect the same change.
Be sure to save all changes in the Tree Diagram Editor before opening the XML Editor for changes. Otherwise, you run the risk of overlaying your editor changes with a freshly updated version from the XML Editor.

Additional notes on XML editing:

- You can delete XML elements or move elements around within the XML structure.
- You can add new elements to the XML structure, but the xml:id must have a unique value for the new item.
- The File Search (Control + F) results are listed in XML format, so some knowledge of the XML format can be useful.

### 24.4 Cloning subtrees

Cloning subtrees allows you to reuse portions of the model structure without having to create or maintain the duplicated structure.

While you can duplicate existing subtrees by copying and pasting, subtree clones provide the advantage of keeping the original structure and the cloned structure synchronized, so any changes you make to the original clone master subtree are also automatically integrated into the cloned copy subtree.

- Copy/paste: copied structure is independent and can be edited.
Clone: cloned structure cannot be edited because it remains synchronized with master structure.

Clone copies function exactly like their associated clone master. However, variables within the clone master (and copy) can reference different variable definitions. This allows you to use different values for those variables within the clone master and copy. See cloning example below.

A few notes on clones:

- Multiple clone masters can be used in a tree, and can be nested.
- Each clone master can have multiple associated clone copies.
- Variables (and state bindings) referenced within a clone master can calculate differently in clone copies if the variables are defined differently outside the master/clone.
- Cloning only works within a single model tree.

### 24.4.1 Creating clone masters and attaching copies

The first step in the cloning process is to select a clone master subtree for the purpose of being replicated at another location in the tree. The clone master does not have to be a finished structure; all that is required is a single branch. The master subtree can continue to be updated after copies of it have been attached to other nodes in the tree.

In addition to the standard method described below for creating/attaching/detaching clones, TreeAge Pro also supports handling most of these operations in the Clone Master/Copies view as shown here. This view lists the tree’s clone masters and all of the clone copies for a selected clone master. See the end of the section for more details.

Each subtree that is a designated clone master can be identified by a heavy bar beneath the branch leading to its root node. Like a copied subtree, what will be "cloned" will not include the root master node - only its subtree.

The remainder of this section uses the Health Care tutorial example model, Cloning Example.trex, shown below with existing clone masters/copies listed in the Clone Master/Copies View.
Cloning Example tree

*To create a clone master:*

- Identify the master subtree and select the "anchor" node to the left of that subtree.
- Choose Subtree > Create Clone Master from the menu.
- Provide a short, descriptive name to identify this clone master (survival).
Create clone master

Clone masters are also assigned a numeric index which appears next to the clone master node.

Clone master identified by heavy bar and index number

Note that the clone master above is anchored at the complications node, which is not actually part of the clone master subtree. However, all nodes to the right of that anchor node are part of the clone master subtree.

Once the clone master has been created, the next step is to attach the clone copies at the appropriate node(s).

Clone copies can only be attached to nodes which have no branches. The nodes where you attach a clone copy should have the same node type as the root node of the master subtree. Attaching a clone copy to a node will not automatically change the type of the node to match the clone master’s root node. This change can be made manually, if necessary, either before or after attaching the clone copy.

In our example, we will attach the new clone master to the no complications node (note that its subtree has been deleted before the attach clone steps below.

To attach a clone copy:

- Select an appropriate "anchor" node (i.e., a node with no descendants) where you want to attach the clone copy subtree.
- Choose Subtree > Attach Clone.
- If you have only a single clone master in the tree, it will be attached to the selected node automatically. Otherwise, you must select the name of the appropriate clone master from a list, and click OK.

**Attach clone copy**

Currently, clone copies are always hidden, showing only references to the clone masters. In the future, the "Hide clone-copy subtrees" option in the Tree Preferences will be enabled so that you can uncheck the option. See below.
Tree Preferences - Show/hide clone copies

The "Hide clone-copy subtrees" option is currently checked and disabled. In the future, the option will be enabled to allow you to uncheck it to see the entire clone copy subtrees, which will be done in gray in order to distinguish them from editable subtrees.

To see a clone copy displayed prior to this tree preference being fixed:

- Save a temporary copy of the model.
- Detach the clone copy.
- When prompted, choose to create an editable copy of the clone master.

Currently, with the "Hide clone-copy subtrees" option always checked, you see a reference to the clone copy in the tree, but not the entire subtree. This reduces the overall size of the displayed tree. Showing/hiding clone copies does not affect calculations in any way.

Clone copies hidden
Reducing the tree size by hiding clone copies enhances the clarity of the tree. The essential features of the replicated subtree can be seen by examining the clone master, which is the only instance of the subtree being displayed. In addition, the cloning linkages within the model, which might otherwise be missed, are clearly visible as each clone copy indicates the master to which it is linked to.

### 24.4.2 Destroying and detaching clones

If you want to remove clone copies from a tree, you can either destroy the current clone master (automatically detach its clone copies) or detach the selected clone copies one at a time.

There are two ways to destroy a clone master.

**To eliminate a clone master in the tree:**
- Select the clone master subtree or the subtree's root node.
- Choose Subtree > Destroy Clone Master from the menu.

**To eliminate a clone master using the Clones dialog:**
- Select the clone master in the list, and click the Delete ("Trashcan") toolbar button.

Destroying a clone master will “un-publish” the subtree. The subtree which was formerly the clone master will remain in the tree; all of its clone copies will be removed. You will be prompted with the option to replace those clone copies with independent copies of the clone master.

**To detach clone copies:**
- Select the clone copy subtree or the subtree's root node.
- Choose Subtree > Detach Clone Copy from the menu.

You will be asked if you want to keep an editable copy of the cloned subtree at the selected node. If you answer Yes, then the clone copy subtree is replaced by an independent copy of the clone master subtree. If you answer no, the clone copy subtree is simply removed.

### 24.4.3 The Clone Masters/Copies View

The Clone Masters/Copies View allows you to view and edit clones within the tree.

**To open the Clone Masters/Copies View:**
- Choose Views > Clone Masters/Copies from the toolbar.
Clone Masters/Copies View

The arrows in the figure above demonstrate the relationships between the clone masters/copies in the view and in the model.

Clone masters are listed in the left pane of the view. When one is selected, the clone copies associated with that view are listed in the right pane.

Both clone masters and clone copies can be deleted through this view with the same options and restrictions associated with deleting these elements in the Tree Diagram Editor, as described in an earlier section.

The arrows in the two toolbar of the Clones View can be used to move directly to either a clone master or a clone copy in the Tree Diagram Editor.

24.4.4 Nesting Clones

An important aspect of clones is the ability to nest clone masters. In other words, a single subtree may be comprised of multiple independent clone masters and also include various clone copies.

The tree shown below in the next section has three nested clone master subtrees. Clone masters 2 and 3 are nested within other clone masters and their copies.

You cannot attach a copy of a master subtree to itself. To create recursion, use a Markov node instead.
24.4.5 Using variables within clones

Calculations in clone copies are performed as if a full copy of the master subtree existed at the location of the clone copy. This is true even if you have turned off the display of clone copies in the tree.

Since clone copies are identical to the clone master, variables must be used in the clone master if you want its copies to have different probabilities and values. The probability, reward, and payoff expressions in the clone master and its copies will all use the same variables. However, each will be able to use different values for these variables based on how the variables are defined outside the clones. Variables referenced within the clones can be defined outside the clones. By defining variables differently to the left of the clone master and its clone copies, different values can be used by the same variable references within the clone master and copies.

The Health Care tutorial example tree "Cloning Example" provides a relatively simple example of using variables with clones.

Clones referencing a variable with different definitions

Note that the variable `pCompl` is used in the clone master, meaning it is also used in the clone copies. However, at the root of the clone master and clone copies, the variable is defined differently. This allows a different probability to be used for each of the subtrees.

24.5 User-defined Python functions

If there is no built-in function that does what you require, you can write a user-defined function using Python script and simply embed it in a regular variable definition in your tree.

Refer the the Python Chapter for more details.
24.6 Node(), Tree(), User(), Global() and other special functions

TreeAge Pro includes a variety of special functions which can be useful in complex models; several of these functions use string arguments. These functions are described in the next several sections of this chapter.

24.6.1 String-arguments and concatenation

Most TreeAge Pro functions accept only numeric arguments, although those numeric arguments can be provided via variables and expressions. However, a variety of functions use text/string function arguments. For example, the Tree function requires string arguments.

Tree("myTree_1.tre";"Node(1;0)")

Most string arguments can be constructed using concatenation; in other words, text and calculated values can be combined into a new string. For example, the filename in the Tree() function could be concatenated (with a variable called “pick”, in this case):

Tree("myTree_"+pick+".tre";"Node(1;0)")

Similarly, the worksheet name in the function...

Command("Excel";"ExportGlobalMatrix";Workbook;SheetName;CellName;LabelText)

... could be concatenated with a variable:

Command("Excel"; "ExportGlobalMatrix";"Outfile.xls";"sheet_"+_trial+"_"; ...)

24.7 The Node() function

The Node() function can act as an internal linking function within a particular tree, allowing a node in one part of a model to retrieve calculated data from another part of the model. Some possible uses for the Node() function include:

- Access calculated expected values in non-active payoff sets (only use in terminal columns).
- Reuse a subtree at different locations in a tree for the active payoff set (similar to the way cloning is used, but with additional flexibility.

Note that the Node() function can be called from within another Node() function.

The simplest form of the function is presented below...

Node( attribute )

...where attribute is an integer referring to a payoff set. This value must be a positive integer referring to an enabled (not necessarily active) payoff set. The Terminal Columns model described in the Tree
Display Preferences and Options Chapter uses this Node() function syntax to display the expected value from a non-active payoff set in a terminal column.

The more complete function syntax is presented below:

\[ \text{Node( attribute; method; branch list )} \]

- The argument `attribute` refers to the payoff set to use for the calculation.
- The argument `method` refers to the type of calculation to perform.
- The argument `branch list` refers to the node at which to perform the calculation.

The different forms of the Node function are described in the following table.

<table>
<thead>
<tr>
<th>Function Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>Node(Attribute)</code></td>
<td>Returns the stored expected value of the current node. <code>Attribute</code> is a positive integer corresponding to the number associated with an enabled payoff as specified in tree preferences. This syntax can be used to report extra payoffs in Terminal Columns only.</td>
</tr>
</tbody>
</table>
| `Node(Attribute; 0; LIST)` | Returns the expected value as above, but from a node whose path is defined by LIST. `Attribute`: `Attribute` is a positive integer corresponding to an enabled payoff. In a cost-effectiveness tree, you can retrieve cost and effectiveness values via the Attribute values listed below:  
  - Use -1 to perform CE calculations and return the new cost calculation  
  - Use -2 to return a stored effectiveness calculation without recalculation after previously using -1  
  - Use -12 to perform CE calculations and return the new effectiveness calculation  
  - Use -11 to return a stored cost calculation without recalculation after previously using -12  
  
  `Method`: The `method` argument 0 returns data from an expected value calculation rather than microsimulation. See below for Microsimulation option.  
  `LIST`: The `LIST` argument is a reference to the path from the root node to the node where you want calculations performed. Refer to the figure below for a description of how the path `LIST` is defined. |
<p>| <code>Node(Attribute; trials; LIST)</code> | Runs a series of <code>n</code> microsimulation trials at the node whose path is defined by <code>LIST</code>. Returns the average of the trials results. <code>Attribute</code> and <code>LIST</code> arguments function the same as for the <code>Node(Attribute; 0; LIST)</code> syntax described above. The <code>trials</code> argument defines the number of trials for the microsimulation. |</p>
<table>
<thead>
<tr>
<th>Function Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>It is important to note some differences in behavior in Node() function trials, as compared to regular Monte Carlo microsimulation trials. The Node() function does not reset tracker variables to their default values before each trial (allowing trackers to be used to track information across the group of trials). By default, distributions do not resample per trial. To force distribution sampling, use tracker variables set equal to the DistForce(n) function, for example.</td>
<td></td>
</tr>
</tbody>
</table>

**Node function syntax**

The figure below includes node labels that match the appropriate *LIST* value for the Node() function to use when referring to each node.

![Node function syntax diagram](image)

**LIST values for the Node function**

The Special Features tutorial example model Node Function Syntax illustrates the use of the Node function in a simple tree.

![Node function syntax - simple model diagram](image)

**Node Function Syntax - simple model**

The top two terminal nodes’ payoffs use the Node function to reference the *Lottery* node via the LIST value of 2. The top payoff returns the expected value, which is always 500. The second payoff returns
the value calculated by running 1000 trials at the *Lottery* node. This will return a different value near the mean of 500 each time you roll back the tree. The rolled back tree is presented below.

Node Function Syntax - simple model rolled back

The Special Features tutorial example model "Node Function Syntax CE" illustrates the use of the Node function in a cost-effectiveness tree.

Node Function Syntax - simple model

The top two terminal nodes' payoffs use the Node function to reference the *Survival* node via the LIST value of 2. The top cost and effectiveness payoff return the expected value for cost and effectiveness, which are always 5000 and 5. The second cost payoff returns the cost value calculated by running 1000 trials at the *Survival* node, while the effectiveness payoff returns the stored effectiveness value associated with that set of trials. This will return different cost and effectiveness values near the means each time you roll back the tree, but the cost and effectiveness values will be generated from means that are from the same set of trials. The rolled back tree is presented below.
If the cost and effectiveness payoff sets were reversed (1 vs. 2), then you would use -11 and -12 for the attribute arguments for the Node function.

### 24.8 The Tree() function

The Tree() function allows you to return a calculated value from another tree. For example, you could have two separate Markov models defined for specific strategies for treating a disease. You could then have a third tree with a decision node that uses the Tree() function to refer to each strategy tree.

The Tree() function is one of a number of TreeAge functions available which take double-quoted string arguments rather than just arguments that can be evaluated numerically. Like all functions, however, the Tree() function returns a numeric value.

For the purposes of this documentation, the tree relationship is described as a calling tree, using the Tree function to access a target tree.

It is recommended that Tree() functions be carefully tested in simple models before being used in complex models.

The Tree() function syntax is described in the table below:

<table>
<thead>
<tr>
<th>Function Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tree( &quot;target tree&quot;; &quot;calculation&quot; )</td>
<td>Opens a hidden copy of the specified tree or package file, and returns the results of the specified calculation. The target tree remains open for additional Tree() function calls. The &quot;target tree&quot; argument specifies the path and filename of the target tree to open for calculation. However, if the file is in the same directory as the calling tree, only the filename is needed. The &quot;calculation&quot; argument defines the calculation to be performed on the target tree. Usually the Node() function will be used here, in order to calculate a specific node in the target tree. Example usage: <code>utilXYZ = Tree( &quot;c:\my docs\projects\xyz.tre&quot;; &quot;Node(1;0)&quot;)</code> The Node() function, in this case, performs a simple expected value calculation at the root node of the target tree.</td>
</tr>
<tr>
<td>Tree( &quot;target tree&quot;; &quot;calc&quot;; 1 )</td>
<td>Same as above, but if the target tree is already open and visible, the linkage is left intact after the calculation; this allows analysis commands like rollback to be used on the visible target tree for debugging purposes. Note that if you use this option, the variables passed to the target tree will remain in place for further calls to that tree. If you are calling the target tree with other variable definitions later in the model, do not use the third argument.</td>
</tr>
<tr>
<td>Tree( &quot;calculation&quot; )</td>
<td>Can be used during an ongoing Tree() function evaluation in order to perform the given calculation at the root node of the current target tree.</td>
</tr>
<tr>
<td>Function Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
</tr>
<tr>
<td><code>Tree(integer 0)</code></td>
<td>Closes any open, hidden target trees. Use this, for example, if you open a target tree using the File menu and save changes to it. This will cause the next Tree() function call to reload the target tree file from disk.</td>
</tr>
</tbody>
</table>

**Tree function syntax**

When the function opens/accesses a target tree, normally a temporary linkage is created; the target tree’s root node becomes the “child” of the calling node. The power of the Tree() function is that a target tree can use variable definitions from the calling tree or to the left of the calling node. This works very much like variables in cloned subtrees. The trick is that the variable can be referenced in the target tree while having no definitions; the definitions can instead be in the calling tree. Note that the variable name must be declared in the target tree’s Variables list, although it would not be defined in the target tree. The target tree must be opened before the roll back to create this active connection.

The function’s primary use is for modularization of complex trees. For example, it might offer an alternative to memory-intensive models in which hundreds or thousands of cloned copies of a Markov model are created. For example, 1000 terminal node payoffs could use the Tree() function to calculate the same Markov model, just with different variable definitions (rather than attaching 1000 clones of the Markov subtree). Calculation speed in most models will be better if the Tree() function is not used, and clones are used instead; expressions in the hidden tree that reference a variable defined in the calling tree cannot be optimized. However, using clones (or regular copies) can sometimes result in a tree whose memory requirements exceed available physical memory, resulting in an extreme decline in calculation speed. Building smaller trees linked by the Tree() function would be a good solution in this case.

The following example uses three Special Feature tutorial examples: Tree Function Syntax, Node Function Syntax and Node Function Variable.

- **Tree Function Syntax**: Calling tree that uses the Tree function to call the other two trees.
- **Node Function Syntax**: Self-contained tree referenced at the Lottery node.
- **Node Function Variable**: Same as above except that it needs to receive a definition for the variable `GetDefFromParent` from the Tree Function Syntax tree.

Let’s look at the Tree Function Syntax tree - both its syntax and the roll back results.
The Tree 0 terminal node calls for the expected value of the Node Function Syntax tree at the Lottery node, yielding a value of 500.

The Tree 1 terminal node runs 100 trials on the Node Function Syntax tree at the Lottery node, yielding a value near, but not equal to 500.

The Tree 2 terminal node runs 100 trials on the Node Function Variable tree at the Lottery node. The variable definition for GetDefFromParent (10,000) is passed from that node to the Node Function Variable tree. This yields a value near, but not necessarily equal to 5,000.

The Tree 3 terminal node calls for the expected value of the Node Function Variable tree at the Lottery node. The variable definition for GetDefFromParent (1,000) is passed from that node to the Node Function Variable tree. This yields a value of 500.
The *Tree 4* terminal node calls for the expected value of the Node Function Variable tree at the *Lottery* node. The variable definition for `GetDefFromParent (100,000)` is passed from that node to the Node Function Variable tree. This yields a value of 50,000. Because the Tree function contains a third argument (1), the connection from the tree to the target tree is maintained, allowing you to roll back the Node Function Variable Tree with the `GetDefFromParent` variable definition intact.

In the figure above, the payoff expression at the Win node is `GetDefFromParent`. This evaluates to 100,000 based on the intact variable definition from the Tree Function Syntax tree.

A simpler and perhaps more realistic example is found in the Legal tutorial example models Legal-MainTree.trex and Legal-Subtree.trex. In this example, the subtree is used to determine the probability of proving negligence. The main tree then pulls that probability into the larger legal model considering damages.
Legal Model using Tree Function

The subtree returns the 0.56 probability of proving negligence, which is then used for the variable pWin in the main tree.

### 24.9 The Command() function

The Command() function can be used to perform specialized commands.

<table>
<thead>
<tr>
<th>Function syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command( &quot;TABLES&quot;; &quot;table name&quot;;</td>
<td>Returns index of row which matches &quot;value&quot; in specified column.</td>
</tr>
<tr>
<td>&quot;REVERSELOOKUP&quot;; value; column)</td>
<td>If value not found, base function, truncate version and ceiling version return an interpolated index, the next lower index and the next higher index, respectively.</td>
</tr>
<tr>
<td>Command(&quot;TABLES&quot;; &quot;table name&quot;;</td>
<td></td>
</tr>
<tr>
<td>&quot;REVERSELOOKUPTRUNCATE&quot;; value; column)</td>
<td></td>
</tr>
<tr>
<td>Command(&quot;TABLES&quot;; &quot;table name&quot;;</td>
<td></td>
</tr>
<tr>
<td>&quot;REVERSELOOKUCEILING&quot;; value; column)</td>
<td></td>
</tr>
<tr>
<td>Command( &quot;GLOBALMATRIXN&quot;; N; &quot;GetTable&quot;; &quot;myTable&quot;)</td>
<td>Load data from a table into a Global matrix.</td>
</tr>
<tr>
<td>Command(&quot;GLOBALMATRIXN&quot;; N; &quot;GetTable&quot;; &quot;myTable&quot;;</td>
<td>N is the matrix index.</td>
</tr>
<tr>
<td>startRow)</td>
<td>GetTable is required for this command syntax.</td>
</tr>
<tr>
<td>Command(&quot;GLOBALMATRIXN&quot;; N; &quot;GetTable&quot;; &quot;myTable&quot;;</td>
<td>myTable is the table name.</td>
</tr>
<tr>
<td>startRow; startCol)</td>
<td>startRow is the matrix row to start loading data (optional).</td>
</tr>
<tr>
<td>Function syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>startCol is the matrix column to start loading data (optional).</td>
<td></td>
</tr>
</tbody>
</table>
| **Command**("EXCEL"; "Open"; "Path&Workbook")  
**Command**("SPREADSHEET"; "Open"; Path&Workbook) | Open a workbook/spreadsheet with the provided path & filename. |
| **Command**("EXCEL"; "Macro"; "myMacro") | Run an EXCEL macro within the opened workbook. |
| **Command**("EXCEL"; "ExportGlobalMatrix")  
**Command**("EXCEL"; "ExportGlobalMatrixN"; index) | Export the non-indexed or an indexed global matrix to a new Excel workbook. Note that only one matrix can be exported to a new workbook. To export additional matrices, use an existing workbook. |
| **Command**("EXCEL"; "ExportGlobalMatrixN"; index; "Path&Workbook"; "NewSheetName"; "obsolete"; "Text_label") | Export Global matrix referenced by its index to an existing worksheet with the provided path & filename. The data will be placed in a new worksheet with the name provided. The sixth argument is not used. The Text_label argument will be presented below the data as a label. |
| **Command**("GLOBALMATRIXN"; 1; "ColumnLabels"; "Col1"; "Col2"; "Col3"; "Col4"; etc.) | Set custom column labels for the global matrix. Usually done prior to export. |

**Command function syntax**

References to the workbook path must use a forward slash "/" between folders rather than a backward slash.

The Special Features tutorial example model Command Function Syntax illustrates the supported uses of the Command function. To use this example, you will need to change the path to the workbook Test Command Function.xlsm. Also, run the commands one at a time via **CONTROL+E** starting at the top.
24.10 The Debug() functions

Details about the Debug() functions and the Tree Preferences for turning Debug() on can be found in the section within the Model Debugging and Validation Chapter.

24.11 The Global() and GlobalN() functions

These advanced functions can be very powerful tools for accomplishing complex calculations and reporting tasks. It is recommended that they be tested in simple models before being used in complex models.

We recommend using the Global/GlobalN functions that are specifically designed to store, retrieve, increment, initialize and export data rather than the generic Global/GlobalN functions.

<table>
<thead>
<tr>
<th>Function syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GlobalSet(row; col; value)</td>
<td>To store and retrieve values globally, use Global() and GlobalN() to calculate &quot;value&quot; and set a cell in a matrix equal to the result (also returns the calculated value). Anywhere &quot;value&quot; is currently used in an expression, it can instead be &quot;wrapped&quot; in the Global function in order to save the calculated value to the matrix (for reporting purposes, for example). A value saved to a global matrix can be referenced using the second form of the Global() function; see below. The entire content of the global matrix can be dynamically saved to a text file using the third form of the function. Excel Module users: a simple Command(&quot;Excel&quot;;...) syntax allows you to output a matrix to a spreadsheet. GlobalN() has an extra parameter matrix (integer &gt; 0) which picks a matrix to use/create, while Global() simply uses a single, default matrix (i.e., matrix 0, not matrix 1 from GlobalN). Usually a few matrices at most will be required, but thousands can be created. The first cell in a matrix is at row=1, column=1. Matrix size increases dynamically as cells are assigned values. Attempting to lookup a cell that is out of range, however, will result in an error. Currently, the maximum total number of cells for all matrices in the tree is 100 million (e.g., 10000x10000, 50x2000000, or 4x5000x5000). Take note of memory usage with very large numbers of matrix cells. If you are exceeding this limit, try saving/dumping a matrix to a file periodically. <em>If both row and col are specified as 0</em>, the calculated value is instead applied to the entire existing matrix, allowing it to be dynamically reset during calculations. If an argument (including row or col) is an expression, it is evaluated at the node being calculated just as if the expression were not inside the Global() function. Global matrices are deleted when the tree is closed, and emptied automatically at the start of each analysis.</td>
</tr>
<tr>
<td>GlobalNSet(matrix; row; col; value)</td>
<td></td>
</tr>
<tr>
<td>Global(matrix; row; col; value)</td>
<td></td>
</tr>
<tr>
<td>GlobalN(matrix; row; col; value)</td>
<td></td>
</tr>
<tr>
<td>Function syntax</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><code>GlobalGet(row; col)</code></td>
<td>Retrieves the value at a specified cell in a global matrix for use in a tree calculation. The first cell in the global matrix is at row=1, column=1. See information on <code>GlobalN</code> syntax, above.</td>
</tr>
<tr>
<td><code>GlobalNGet(matrix; row; col)</code></td>
<td></td>
</tr>
<tr>
<td><code>Global(row; col)</code></td>
<td></td>
</tr>
<tr>
<td><code>GlobalN(matrix; row; col)</code></td>
<td></td>
</tr>
<tr>
<td><code>GlobalIncr(row; col; incr)</code></td>
<td>This syntax is equivalent to: &quot;GlobalN(n;row;col; incr + GlobalN(n;row;col))&quot;. If &quot;; incr&quot; is omitted, the increment = 1. Returns the incremented value (fourth argument).</td>
</tr>
<tr>
<td><code>GlobalNIncr(matrix; row; col; incr)</code></td>
<td></td>
</tr>
<tr>
<td><code>GlobalExport(suffixNo)</code></td>
<td>If <code>suffixNo</code> evaluates to a non-zero number, the matrix is silently saved to a text file (even if a simulation is running). If <code>suffixNo</code> evaluates to zero, no file is created. If <code>suffixNo</code> is less than zero, the matrix is also reported in the Debug pane (if Text-only analysis debugging setting is on). Always returns a value of 1.</td>
</tr>
<tr>
<td><code>GlobalNExport(matrix; suffixNo)</code></td>
<td></td>
</tr>
<tr>
<td><code>Global(matrix)</code></td>
<td></td>
</tr>
<tr>
<td><code>GlobalN(matrix)</code></td>
<td></td>
</tr>
<tr>
<td><code>GlobalExport(path + &quot;custom_file_name.txt&quot;)</code></td>
<td></td>
</tr>
<tr>
<td><code>GlobalNExport(matrix; path + &quot;custom_file_name.txt&quot;)</code></td>
<td>Text files are saved in the same directory as the tree, using the tree filename followed by the word &quot;<em>globals</em>&quot; and the integer part of <code>suffixNo</code>. A calculation in &quot;c:\trees\mytree.tre&quot; of the function &quot;GlobalN(3; 103)&quot; would save the current matrix #3 to a text file called: &quot;c:\trees \mytree_globals_103.txt&quot;</td>
</tr>
<tr>
<td><code>Command(&quot;ExportGlobalMatrixN&quot;;n;&quot;ColumnLabels&quot;; &quot;Label 1&quot;; ...)</code></td>
<td>Can be used to pre-set column labels. Excel Module users: The <code>Command(&quot;Excel&quot;;&quot;ExportGlobalMatrixN&quot;;&quot;ColumnLabels&quot;; &quot;Label 1&quot;; ...)</code> function can be used to export a matrix to a spreadsheet instead. See the previous section on the <code>Command()</code> function syntax.</td>
</tr>
<tr>
<td><code>GlobalInit()</code></td>
<td>Global matrix is emptied; size becomes 0. (Occurs automatically at the start of an analysis, or when the tree is closed. After a simulation/analysis finishes, however, matrices are still available via the above syntax.)</td>
</tr>
<tr>
<td><code>GlobalNInit()</code></td>
<td></td>
</tr>
<tr>
<td><code>GlobalInitN()</code></td>
<td></td>
</tr>
<tr>
<td><code>Global()</code></td>
<td><code>Global()</code> and <code>GlobalN() empty only one matrix while GlobalN()</code> and <code>GlobalInitN()</code> empties all created matrices.</td>
</tr>
<tr>
<td><code>GlobalN(n)</code></td>
<td></td>
</tr>
<tr>
<td><code>GlobalN()</code></td>
<td></td>
</tr>
</tbody>
</table>
It is important to consider where to place Global matrix commands within the model. If you are running Microsimulation, you can use a tracker modification to execute the global matrix command at any node. If you are running EV calculations, you can add the global matrix call to an existing expression in a probability expression or a payoff expression. However, be sure to multiply the Global matrix call by zero to prevent the call from changing the value of the expression.

Most of the Global/GlobalN syntax options are used in Special Feature tutorial example models called Demo Global Functions.trex (action-specific Global functions) and Demo Global Function.trex (generic Global functions).

(Note: During multiprocessor simulations, Global/GlobalN refers to a set of matrices in the main thread. Separate, simultaneously processing threads evaluating a particular expression which modifies a particular matrix n will take turns updating matrix n; each thread does NOT have its own copy (except in the unusual case of a distributed simulation which divides batches among different computers.)

24.12 Custom Functions

Custom functions allow you to create a single commonly used commands/formula, which can then be used with different arguments for different contexts within the tree. We give two examples below both which show how to create custom formula.

24.12.1 Custom formula to delay Discounting using the Discount function

When using the Global Discount method and an associated discount rate, set at the beginning of the model calculation, it is not possible to change the discount rate dependent on the cycle.

The Special Features example, Custom Function Discount.trex, demonstrates how to delay the discounting by applying a custom function when using the Manual Discount function. This function delays discounting into the future for 5 cycles and then starts discounting as though it is the first stage.

Let value be the variable we want to discount. Define the following:

\[
CustomDiscount(value) = \text{Discount}(value; \text{if}(_\text{stage} < \text{discount\_stage}; 0; 0.01); _\text{stage} - \text{discount\_stage} + 1)
\]

\[
\text{discount\_stage} = 5
\]

\[
\text{int\_rate} = 0.01
\]

Combined, this function will return the value argument discounted at 1% delayed for 5 years. You can run the Markov Cohort Analysis to check the numbers in the model provided.
24.12.2 Custom formula to store variables via the Global Matrix functions

The DES tutorial example, Osteo DES Model.trex, demonstrates this technique.

Custom Functions

Note the variable zgStoreColFunction. The variable name itself includes a reference to arguments within parentheses, which designates this variable as a custom function. This function specifically stores data in a global matrix based on the input parameters inMatrix, inCol and inValue.

Note the variables zgStoreCol01_patient, zgStoreCol02_event_no, etc. Each of those variables calls the zgStoreCol function, with each passing the appropriate values for the input parameters.

24.13 The TrackerIncr() function

Tracker values are normally set by simply providing a new value for the tracker via a tracker modification. A tracker could be incremented at a specific node with a tracker modification like the following.

```
tracker_name = tracker_name + 1
```

If you needed to increment a tracker within a separate expression outside a tracker modification, like using a Monte Carlo Special Variable/Keyword, then you can use the TrackerIncr function to increment a tracker value. The syntax for the function is shown below.

```
TrackerIncr( "tracker_name"; incr)
```

This command adds the value "incr" to a current trial's value of "tracker_name", and returns the updated value.
24.14 List function

The List function, \( \text{List( LIST )} \), is used to contain a parameter list for a multivariate distribution, for example in the Dirichlet distribution.

In any tree, open the Distributions View and select a Dirichlet distribution. The list of Alphas (parameters defining the Dirichlet function) is set using the List(LIST) function. LIST is a set of values separated by semi-colons used to define the Dirichlet distribution. See Distribution Functions, Options and Types for more details about Distributions.

24.15 String Processing

Certain functions within TreeAge Pro use string arguments. Specifically, you might use the DebugWrite or DebugWriteForce functions to output text to the Calculation Trace Console. The following table illustrates a few things you can do with strings to generate helpful debug output.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \text{Str(number)} )</td>
<td>Converts numeric data to a string.</td>
</tr>
<tr>
<td>+</td>
<td>Operator to concatenate two strings together.</td>
</tr>
</tbody>
</table>

String Processing

For example, the following variable definition would use the _monte_pre_trial_eval simulation keyword to output the current _sample and _trial values to the calculation trace console.

\[
_{\text{monte_pre_trial_eval}} = \text{DebugWriteForce}("_{\text{sample}}=\text{Str}_{\text{(sample)}}\), \_\text{trial}=\text{Str}_{\text{(trial)}}\)
\]
25. Python

The Python programming language can be used to extend the functionality of TreeAge Pro. For example, a Python script could perform complex calculations that are not easily handled in a native TreeAge Pro variable definition formula. This can include logical syntax like extended if/then/else logic and processing loops which have no equivalent within TreeAge Pro. This chapter will illustrate examples of using Python and the syntax required to build your own Python scripts.

25.1 A Simple Python Function Example

While Python would typically be used to extend TreeAge Pro, we will start with a simple example that does not actually require Python. Specifically, we will create a Python Discount function that we can then validate against the built-in Discount function.

The Special Features/Python tutorial example model, "Python Example – Discount.trex" contains two strategies.

When you open a model with a user-defined Python function, you will be prompted to enable Python scripts. This allows you to review Python scripts in any model you receive from an unknown source (search the model for “def ” and "python”).

The types of Python commands useful in trees are not a security concern, but the core language does have file and Internet access methods which could theoretically be misused. To turn off the "Do you want to enable python scripts?" dialog, go to Window > Application Preferences then navigate to Analysis Tools > Python and check the box "Do not show enable Python question".

The top strategy’s payoff references the Python function PythonDiscount, while the bottom strategy’s payoff references the built-in TreeAge function Discount(). Rolling back the model shows the values are equivalent.
A Python function is created within a variable definition. In this example, a variable called PythonDiscount has been defined at the root node in the Variable Properties View. The figure below shows how the Add/Change Variable dialogue can be used to edit Python functions.

In the Add/Change variable dialogue, you will see the Python Editor option selected above the Build Expression. TreeAge Pro identifies the definition as a Python function because it starts with the keyword `def`. If you are creating your own function, select this editor option yourself. The Python Editor mode helps you write Python code by allowing required indentation and recognizing Python keywords.

A Python function must begin with the function declaration `def` followed by the name of the function, then parentheses, and finally a colon. If the function requires arguments, they are placed within the parentheses separated by commas.

```python
def PythonDiscount(val, years, rate):
    # This function returns the discounted value based on
    # the interest rate and years past
    # Create the denominator value based on the rate and years past
    denom = (1 + rate)**years;
    # Return the discounted value to TreeAge Pro
    return val/denom;
```
Note the Python function name must match the variable name in the tree, and Python is case sensitive. The PythonDiscount function requires three required arguments that must be provided when the function is called.

Python code following the function declaration must be indented using tabs or spaces, indicating that this code is included within the overall Python function. Python uses indentation to identify blocks of code. Additional indentation would be used to place a block of code within a logical condition as well.

Each line of code should end with a semicolon, although this is optional. To comment your code, enter “#” at the start of a comment line. The return statement is used to return a value from the function. In this case, the discounted value is returned. The end of the function is implicit.

In the tree view, user-defined function definitions are prefixed with “(F)”. Only the declaration line will be shown unless wrapping is turned on under Variables Display preferences.

For more information on the Python language and syntax, go to http://www.python.org/.

25.2 Python Access to Model Data

Python functions can directly access data from within the model. The Special Features/Python tutorial example model “PythonExample – Discount.trex” from the prior section used data passed to the Python function via function arguments. Instead, the example model “Python Example – GetTreeAgeData.trex” pulls data directly from the model into the Python function via the treeage object.

If performance is critical in your model, try to use the Python interpreter efficiently. For example, a treeage.eval() call is slower than passing an argument to the function.

The expression sent via treeage.eval can be any valid expression that can be calculated in the model, including variables, trackers, distributions, etc. Note that variables are calculated based on the node context from where the Python function was called. For special Monte Carlo keywords (e.g., _monte_pre_trial_eval), the root node context is used.

The treeage object has many methods/functions, but this example model uses the two most common ones listed below.

- treeage.eval("expression") executes the expression in the model and returns the calculated value to the Python function.
- treeage.debug("title", "message") sends debugging output to the TreeAge Pro Calculation Trace Console.
The `treeage.debug` function is useful when debugging functions by allowing you to send text related to code syntax and/or calculated values to the Calculation Trace Console. The following example shows how to comment the Python code and how to use the eval and debug syntax.

Example Python model “Python Example - GetTreeAgeData.trex” (showing the Variable Properties View below)

Example Python script for the function `PythonFunctionGetTreeAgeData()` (from the Build Expression field in the Add/Change variable dialogue)

The comment lines (starting with "#") provide information about the code within the Python function. Additional information is provided here:

- `def PythonGetTreeAgeData():` This is the function declaration of `PythonGetTreeAgeData()` which is a function with no arguments passed to it. The function uses `treeage.eval()` to get the information it needs from the model.
- `treeage.debug("PythonFunctionGetTreeAgeData", "Start function")`. This sends the text in quotes to the Calculation Trace Console. The comma separating the quotes marks the start of a new line. In the console, you would know that this function has been called.
- `var1 = treeage.eval("myVar1");` Python uses this syntax to calculate and return the value for `myVar1` from the TreeAge model and places that value in the internal variable `var1` within the
Python model. The subsequent line does the same - assigning var2 the TreeAge Pro value for myVar2.
- \( \text{product} = \text{var1} \ast \text{var2}; \) The expression assigns the internal variable product the value equal to the product of the two variables var1 and var2.
- \( \text{treeage.debug("PythonGetTreeAgeData","End of function, return value "+ str(\text{product})}); \) This sends text to the console, specifically the value of product which is the value returned by the Python function to the model.
- \( \text{return product;} \) This final command returns the value for product back to the expression that calls the function.

The Calculation Trace Console will show the debug outputs based on the commands described (above) as in the figure below.

Calculation Trace Console with debug output from "Python Example - GetTreeAgeData.trex"

The \text{treeage} object provides several other functions listed in the table below.

<table>
<thead>
<tr>
<th>Treeage object function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>\text{treeage.eval(&quot;expression&quot;)}</td>
<td>Returns the value of \text{expression} from the tree.</td>
</tr>
<tr>
<td>\text{treeage.debug(&quot;title&quot;,&quot;msg&quot;)}</td>
<td>Output to trace console view for tree (if detailed debugging preference is on).</td>
</tr>
<tr>
<td>\text{treeage.loadTable(&quot;TableName&quot;, python_array)}</td>
<td>Load data from an array in Python to a table within a TreeAge model</td>
</tr>
<tr>
<td>\text{pt = treeage.getParallelTrials()}</td>
<td>Creates an object within Python with access to parallel trials info.</td>
</tr>
<tr>
<td>\text{pt.getTrialNTracker(trial_number, &quot;tracker_name&quot;)}</td>
<td>Gets the current tracker \text{tracker_name} value for trial number \text{trial_number}.</td>
</tr>
<tr>
<td>\text{pt.setTrialNTracker(trial_number, &quot;tracker_name&quot;, value)}</td>
<td>Sets the tracker \text{tracker_name} equal to \text{value} for trial number \text{trial_number}.</td>
</tr>
<tr>
<td>\text{treeage.getGlobalTracker(&quot;GlobalTrackerName&quot;)}</td>
<td>Gets the current value of a global tracker \text{GlobalTrackerName}.</td>
</tr>
<tr>
<td>Treeage object function</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>treeage.setGlobalTracker(&quot;GlobalTrackerName&quot;, value)</td>
<td>Sets global tracker <em>GlobalTrackerName</em> equal to <em>value</em>.</td>
</tr>
<tr>
<td>matrix = treeage.getGlobalMatrixN(n)</td>
<td>Sets a reference to one of the global matrices, whose data can then be accessed/changed. Within Python the matrix is represented as a Python array. See following set of rows.</td>
</tr>
<tr>
<td>matrix.getRows()</td>
<td>Get the current number of rows, columns in the matrix.</td>
</tr>
<tr>
<td>matrix.getCols()</td>
<td>Get the current number of rows, columns in the matrix.</td>
</tr>
<tr>
<td>matrix.getElement(int row, int col)</td>
<td>Get the value from a cell in the matrix at row <em>row</em>, column <em>col</em>.</td>
</tr>
<tr>
<td>matrix.setElement(int row, int col, double val)</td>
<td>Set the value of a cell in the matrix to <em>val</em> at row <em>row</em>, column <em>col</em>.</td>
</tr>
<tr>
<td>matrix.incrElement(int r, int c, double val)</td>
<td>Increment the value of cell in the matrix by the amount <em>val</em>.</td>
</tr>
<tr>
<td>matrix.fill(double val)</td>
<td>Populate the entire matrix with the <em>val</em> provided.</td>
</tr>
<tr>
<td>matrix.fillCol(double val, int col)</td>
<td>Populate all cells in column <em>col</em> with the <em>val</em> provided.</td>
</tr>
<tr>
<td>matrix.fillRow(double val, int row)</td>
<td>Populate all cells in row <em>row</em> with the <em>val</em> provided.</td>
</tr>
<tr>
<td>matrix.fillCol(double val, int col, int rowsUpperLimit)</td>
<td>Populate the cells in column <em>col</em> with the <em>val</em> provided from row 1 to row <em>rowsUpperLimit</em>.</td>
</tr>
<tr>
<td>matrix.fillRow(double val, int row, int columnsUpperLimit)</td>
<td>Populate the cells in row <em>row</em> with the <em>val</em> provided from column 1 to column <em>columnsUpperLimit</em>.</td>
</tr>
<tr>
<td>matrix.getIndex()</td>
<td>Returns the index of the matrix.</td>
</tr>
<tr>
<td>matrix.clear()</td>
<td>Empties the matrix of all data.</td>
</tr>
</tbody>
</table>

**Python treeage object syntax**

### 25.3 Using External Python and Importing Python Libraries

Python is a widely used, high-level programming language which is very rich. TreeAge Pro has basic Python functionality built into the software. There are many additional Python Libraries available which allow your calculations to support high-level mathematical functions by using pre-built expressions. Using these libraries will extend the expressions and functionality of Python in TreeAge Pro.

To take advantage of these additional complex functions, it is necessary to install additional Python libraries. For example NumPy and Sci Py support high-level mathematical functions for operating multi-dimensional arrays.
For more details on NumPy and SciPy see the websites: http://www.numpy.org/ and https://www.scipy.org/

Installation of Python and Python libraries can be tricky. TreeAge Software cannot support the installation of Python, NumPy, SciPy, py4j or any other external Python modules. Please use Python resources at www.python.org for support.

When any additional Python libraries are installed, it is necessary to install the py4j library. This library allows communication between TreeAge and the externally installed libraries to work.

To install the py4j library, enter the following command into a command prompt:

```
python -m pip install --user py4j
```

We will use the Special Features tutorial example model, "Python Example – ExternalNumPy.trex" to demonstrate how to enable external python and then use the external libraries. This model uses a NumPy function for multiplication. Clearly, NumPy is not required for multiplication, but if this model runs, you will know you have a successful connection to external Python, including the NumPy library.

When you open a model with Python script, you will be prompted "Do you want to enable python scripts?".

Select "yes" when prompted to enable python scripts.

If you select "No" and later need to enable Python scripts, you will need to save and close the model, re-open and then select enable Python scripts as above.

Once you have selected to enable python scripts you will be directed to Application Preferences. If you are using External Libraries - such as NumPy - then select "Use external Python installation".
TreeAge Pro Application preferences which need to be activated to use external Python installation.

To run "Python Example – ExternalNumPy.trex" we need to make sure the steps above are followed which are:

- Set Application Preferences to use external Python.
- External Python is installed including the communication package: py4j.
- The numpy package is installed.

The figure below shows a simple variable definition using the external python library numpy.
The function PythonImportNumpy reads in 4 arguments from the model and then does two things:

1. It imports the external Python library numpy and gives it the name `np`.
2. It uses one of the functions in numpy, `product`, to calculate the product of the 4 arguments and send them back to TreeAge Pro via the `return` command.

Rolling back to model will give you the product of the four arguments in the function. In the model, that is: $1 \times 2 \times 3 \times 4 = 24$.

If this model runs, you will be able to use other special functions within NumPy and probably also SciPy within your own models.

### 25.4 Python Example with Logical Syntax

A primary reason for using Python in a model is to allow you to introduce logical syntax into your model, including if/then and loop syntax. The Special Features tutorial example model “Python Example – Loop.trex” is a simple illustration of logical syntax within a Python function.
Consider the following elements of the Python function

- The Python function expects a numeric argument called `resample_sw`. A single argument must therefore be provided within parentheses whenever the Python function is called within the model.
- The function includes a `for` loop to repeat a code block multiple times. The syntax `for dist_index in range(1,5):` designates that the loop should be repeated 4 times with `dist_index` values 1, 2, 3, 4 (1 at start is inclusive, 5 at end is exclusive, so 5 is not run). The indented code block is then executed 4 times, once for each iteration in the loop.
- Similarly, `if/then/else` logic syntax with its own indented code.
- Python `treeage.debug` statement reports information back to the TreeAge Pro Calculation trace console.
- The `return` statement passes the calculated value back to the model wherever the Python function is called.

Roll back the model and the Calculation Trace Console will show the "for loop" cycling through distributions 1 to 4 and then adding them (`sum = sum + dist_sample`) before returning the value for Strategy 1 (`resample_sw = 0`) and Strategy 2 (`resample_sw=1`).

Note that in the Python function declaration, arguments are separated by commas; however, when calling the function within TreeAge Pro, those arguments are separated by semicolons.
25.5 Python Syntax Errors

Models which use Python will also return error messages if there is an error in the Python script.

The example in the Special Features tutorial example model, "Python Example – SyntaxError.trex", has invalid Python code within the variable definition for function PythonFunctionSyntaxError. Specifically, the internal Python variable `missing_input` is not declared within the function or passed as an argument to the function. Therefore, when `missing_input` is referenced, an error is thrown.

Function definition of PythonFunctionSyntaxError with comments

Rolling back the model creates the error message shown in the figure below identifying where the error in the Python function is, specifically line 5 where `missing_input` is referenced but was never defined.

The error message from rolling back "Python Example - Loop.trex".

If your Python function has invalid syntax, an error like the one above should help you resolve the issue.

25.6 Python-initiated Access to TreeAge Pro models

The TreeAge Pro Object Interface provides computer programs the ability to open, edit, analyze, save, and close models. Python is one of many programming options (Java, Visual Basic, etc.) that can use the Object Interface to interact with models.

Note this method of using Python to interact with models is different other parts of this chapter where a model calls Python for specific calculations during analysis.
To initiate Python scripts outside of a TreeAge Pro model, you must first setup a local Python environment including "COMTYPES" library. TreeAge Software cannot support this setup. Please go to www.python.org for details on setting up Python.

25.7 Calling Python via the User function (Pre-2018)

Prior to TreeAge Pro 2018, any user defined Python functions that required arguments could not be called directly and were instead called via the User() function. Whilst this syntax is still supported for backward compatibility, it is no longer necessary to include User() when calling Python functions with arguments.

In the Special Features tutorial example model, "Python Example – Discount-User.trex", we show the equivalence of the Python functions with and without User(). Rolling back the model shows the values are equivalent.

In this example, the payoffs are set equal to two different Python functions. The first branch lets you reference PythonDiscount directly as discussed in section 1 of this chapter. The second branch provides the syntax required prior to TreeAge Pro 2018 and might still be found in some legacy models.

However, if you want to set a variable equal to the Python defined PythonDiscount, you could use the following:

\[
myDiscountedVariable = \text{PythonDiscount}(5000; 2; 0.04)
\]

where the numeric values could also be defined as variables in the model and passed in as arguments.

Prior to TreeAge Pro 2018 you would have used:

\[
myDiscountedVariable = \text{User("PythonDiscount"}; 5000; 2; 0.04)
\]

25.8 Other Python syntax options

TreeAge Pro supports several syntax options for calling Python functions. The standard ones previously mentioned as well as others are described in the following table.
<table>
<thead>
<tr>
<th>Function Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>myPythonFunction</td>
<td>Call Python functions that require no arguments by simply referencing the function name.</td>
</tr>
<tr>
<td>User( &quot;myPythonFunction&quot;; argument1 ... )</td>
<td>User command to call Python function and pass arguments to the function.</td>
</tr>
<tr>
<td>Python( &quot;expression&quot; )</td>
<td>If the current Python can successfully evaluate the variable name, expression, or function, the Python() function will return that value. If it cannot evaluate it, an error is returned. The Python() function returns a numeric value. Example: Python( &quot;10+1&quot;) returns 11 Example: Python(&quot;int('0xff', 16)&quot;) returns 255</td>
</tr>
<tr>
<td>The Python syntax below is not yet supported in TreeAge Pro</td>
<td>Not available.</td>
</tr>
<tr>
<td>PythonFunc( &quot;module&quot;; &quot;function&quot;; argument1 ... )</td>
<td>Execute a function from an imported module. This will only work if the module has already been imported. Example: PythonFunc( &quot;random&quot;; &quot;normalvariate&quot;; mu; sd) returns a random number from Normal(mu,sd) where mu and sd are numbers</td>
</tr>
<tr>
<td>PythonGetList( &quot;list&quot;; &quot;treeage table&quot; )</td>
<td>The PythonGetList() function copies a two-dimensional Python nested list into a TreeAge table. The Python expression can be a literal list (as seen below), a variable containing a list, or a function returning a list. Example: PythonGetList(&quot;[[0,.1,.2],[1,.15,.25]]&quot; ; &quot;myTable&quot;) loads myTable and returns the number of rows (2)</td>
</tr>
<tr>
<td>PythonRun( &quot;command&quot;; ...)</td>
<td>Returns 0 for failure or 1 for success. Specify a valid Python statement. To run a series of scripts or modules, separate multiple double-quoted paths using semicolons. If Python successfully runs the last specified statement, the PythonRun() function will return a value of 1. If Python encounters an error evaluating your commands, the PythonRun() function returns a 0 value -- not an error. To force a TreeAge Pro error, use the result as the denominator of a division operation. To return the value of variables or functions created or modified by the executed commands, use the Python() function. Example: PythonRun( &quot;from random import &quot;; &quot;seed(1); &quot;x=random()&quot; ) = 1 value = Python(&quot;x&quot;) = .134364...</td>
</tr>
<tr>
<td>PythonRunFile( &quot;scriptfile&quot;; ... )</td>
<td>Returns 0 for failure or 1 for success. Specify the full path and filename of a valid Python script text file or...</td>
</tr>
<tr>
<td>Function Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>module to run; or, specify just the file name if it is stored in the Python default path. To run a series of scripts or modules, separate multiple double-quoted paths using semicolons. (Note that forward slashes can be used instead of backslashes in the path specification.) Example: <code>PythonFile( &quot;C:\Python24\lib\TransplantQueue.py&quot; )</code> Using PythonRunFile() to execute a file is equivalent to having Python evaluate the <code>execfile()</code> function: <code>PythonRun( &quot;execfile( 'C:\Python24\lib\TransplantQueue.py')&quot; )</code> If the script/module executes successfully, use the Python() function to return the value of variables: <code>queueWait = Python(&quot;now()&quot;)</code></td>
<td></td>
</tr>
</tbody>
</table>

Python syntax options
26. Advanced Chance Node Techniques and Options

This chapter provides information on a number of features which can be used to customize chance nodes in decision trees.

26.1 Using non-coherent probabilities

TreeAge Pro normally requires the branch probabilities of each chance node to sum to 1.0. Probabilities that meet this requirement are referred to as “coherent.” However, there are some situations where it may be useful to relax or remove this restriction (i.e., dynamic cohort analysis, parallel trials).

TreeAge Pro provides options to override the normal chance node functionality - either for the entire tree or for a specific chance node.

⚠️ You are urged to employ these options cautiously after giving careful consideration to the potential hazards of overriding normal chance node functionality. Do not use this option simply because your probabilities are not summing to 100%. This is usually an error condition caused by probability expressions and/or distribution samples. Such an error must be corrected to generate valid analysis output.

26.1.1 Allowing non-coherent probabilities for the entire model

A Tree Preferences option allows non-coherent probabilities for the entire model. However, it is recommended that non-coherent probabilities be allowed at specific nodes instead. See next section.

To disable errors when using non-coherent probabilities:

- Choose Tree > Tree Preferences from the menu or click F11 to open the Tree Preferences Dialog.
- Navigate to the preference category Calculation > Other Calculation Settings.
- Check the option "Allow probabilities to not sum to 100%".
As precautions against unintended use, the status bar at the bottom of the TreeAge Pro window displays text to notify you that this setting is active.

Non-coherent probabilities are not compatible with microsimulation (first-order trials) unless integer values are used for the probabilities for parallel trials, but can be used in probabilistic sensitivity analysis using expected value calculations.

26.1.2 Allowing non-coherent probabilities at a specific node

You can also allow non-coherent probabilities at specific chance and Markov nodes in the model; other node types do not allow this option. This is a better approach since TreeAge Pro will still reject non-coherent probabilities at other nodes in the model.

To change the probability coherence option for a node via the context menu:

- Right-click on a chance node or a Markov node.
- Within the context menu, choose Change Coherence > your desired option.

To change the probability coherence option for a node via the main menu:

- Select a chance node or a Markov node.
- Choose Node > Probability Coherence > your desired option.
The coherence options available are:

- *Use Tree Preference setting*: Do not override for this node. Use the option from tree preferences.
- *Allow < > 100% for this node*: Allow non-coherent probabilities at this node.
- *Do not allow < > 100% for this node*: Do not allow non-coherent probabilities at this node.
- *Normalize probabilities*: Normalize probabilities to force them to sum to 100%.

**Probability coherence options**

If the probabilities are allowed to be non-coherent, you will get odd expected values. This is not recommended, except when you need to add/subtract from the cohort size (dynamic cohort modeling).

Normalization will take the probabilities that do not sum to 100% and normalize them to make them sum to 100%. For example, if you had probabilities 0.3, 0.4 and 0.5, the total sum would be 1.2. By dividing each probability by 1.2, the probabilities would be normalized.

<table>
<thead>
<tr>
<th></th>
<th>Original</th>
<th>Normalized</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prob1</td>
<td>0.3</td>
<td>0.25</td>
</tr>
<tr>
<td>Prob2</td>
<td>0.4</td>
<td>0.333333</td>
</tr>
<tr>
<td>Prob3</td>
<td>0.5</td>
<td>0.416667</td>
</tr>
<tr>
<td>Sum</td>
<td>1.2</td>
<td>1.0</td>
</tr>
</tbody>
</table>

**Prob normalization**

The Special Features tutorial example model ProbabilityNormalization demonstrates this technique.
Probability normalization tree

The first 6 strategies alternate between probabilities sampled from a distribution and the normalized probabilities. The *Raw 1* strategy simply reports the first probability sampled from a distribution. The *Normalized 1* strategy returns the probability after it has been normalized at the chance node.

The bottom strategy is excluded from the analysis because it would fail since the probabilities are not normalized.

Note the red flags above the nodes with probability coherence overrides. This indicator helps identify when a node will function differently from the rest of the model. Node branch comments are automatically created with the text "(Node Probability Override)", which in turn causes the flags to be presented.

Run Monte Carlo Simulation/Sampling on the model to see the original and normalized probabilities. The summary mean values below illustrate the normalization.
Normalization tree analysis results

Note that the original mean value for probabilities 1, 2 and 3 are 0.57, 0.21 and 0.30, while the normalized mean values are 0.53, 0.19 and 0.27.

Contrast this with results from the Special Features tutorial example model ProbabilityNonCoherence. In that model, no normalization is done; the bad probabilities are simply allowed. This is not recommended.

26.1.3 Reporting future net present values in the tree

Discounting is normally used to generate the net present value of future values. In nearly all cases, the net present value of future values is less than the future value itself due to inflation. Decision analysis is then performed using the net present values for all values in the model.

If a decision is to be made at an intermediate node in the tree which occurs in the future (e.g., options valuation), it may be necessary to calculate the net value at the time of the future decision rather than the present time. This would require discounting from the distant future value back to the less distant decision point rather than back to the present.

In situations where it is appropriate, it is possible to use non-coherent probabilities to perform the discounting instead of discounting each terminal node payoff. Net present value discounting is generally performed by dividing by \((1+\text{discount\_rate})^{\text{time}}\). By turning off probability error checking, this division could instead be performed on each branch probability. If done correctly, the expected values calculated at the root node of the tree will be unchanged from a standard, payoff discounting model. See the TreeAge web site for more information.

As with other uses of probability non-coherence, care must be taken to ensure that hidden probability errors are not unknowingly introduced.

26.1.4 Discrete and dynamically-sized Markov cohorts

Normally, decision trees are used to calculate an expected, or average, value. In budget-oriented or population-based modeling, however, the ultimate goal may be to determine not an average, but an
overall cost or benefit. In some cases, this can be accomplished simply by multiplying the expected value by some number (e.g., the number of projects, or the size of a population). If TreeAge Pro’s probability coherence requirement is turned off, an equivalent option would be to do the multiplication via tree “probabilities.”

Non-coherent probabilities might be used to model a population whose size changes over time. For example, in a Markov model built using the Healthcare module, the starting population can be initialized — sized and distributed among possible health states — prior to the Markov calculation. Then, during Markov calculations, non-coherent probabilities could be used to change the size of the population, modeling entry from other populations (i.e., from uninfected to infected) or internal population growth (births). For an example of this technique, please refer to the Dynamic Cohort Models Chapter.

When allowing non-coherent probabilities, a sub-option to randomize “discrete” individuals is available that will maintain integer probabilities at subsequent chance nodes — in effect, keeping individuals whole by randomizing them at chance nodes (during any analysis, not just simulation). This might be relevant, for example, where small probability events are critical (i.e., in a vaccination model where continued transmission of a contagious disease requires a “whole” carrier).

### 26.2 Sampling probabilities from a Dirichlet distribution

If a chance node has more than two branches, performing a sensitivity analysis or Monte Carlo simulation that changes the values of these probabilities can be problematic.

One option is to write expressions that normalize the chance node’s probability expressions. For example, let’s say the node has three outcomes: A, B, and C. Rather than assigning variables to two probabilities, and using the # remainder calculation in the third, you could do the following: assign three expressions that always sum to 1.0, like $pA/(pA+pB+pC)$ and $pB/(pA+pB+pC)$ and $pC/(pA+pB+pC)$.

No matter what values ($\geq 0$) are assigned to $pA$, $pB$, and $pC$, the three normalized probabilities will always sum to 1.0. (The # remainder could still be used in place of one of these.)

TreeAge Pro offers another solution using a special multivariate form of the beta probability distribution, the Dirichlet distribution. This distribution can be used to represent the uncertainty in all of the probabilities of a chance event. During Monte Carlo simulation, the distribution can sample probabilities for each branch, while ensuring that probabilities sum to 1.0.

Open the Healthcare tutorial example model, Dirichlet SImple, to follow this section through.
Dirichlet distribution

If the distribution is parameterized with a list of N alpha values, N independent Gamma[alpha_n, beta=1] distributions will be sampled and the samples normalized to create a list of N probabilities which are guaranteed to sum to 1.0.

Note that using a larger total sum of the alpha values will reduce the variation of each probability from its mean. For example, List(200; 750; 50) generates the same three mean values as List(20; 75; 5), but the sample sets will tend to be closer to the mean values.

Note that you can use a Dirichlet distribution without sampling to normalize probabilities for a deterministic sensitivity analysis (not PSA). The mean values for each value generated from a Dirichlet distribution is equal to the individual List argument divided by the sum of all the List arguments. Therefore, if you adjust one of the List values for deterministic sensitivity analysis, the other values will adjust proportionally to keep the overall probabilities coherent.

To utilize the sampled probabilities in the model, the Dist function is used with a second argument indicating which branch (i.e., alpha) to use, as shown below.
Rolling back the tree shows the mean values of the probabilities, which are simply the normalized alpha parameters.

Performing a simulation in the example tree shows the effect of sampling independent Gamma distribution values, based on the list of alpha parameters, and then normalizing. For each iteration of the simulation, a different set of Gamma random variates is drawn. Each iteration results in a different sum, as well as different ratios of the Gamma random variates to the sum (i.e., the probabilities). Normalization ensures that the resulting probabilities sum to 1.0.

Running PSA on the model yielded the following results.

<table>
<thead>
<tr>
<th>Monte Carlo Summary Text Report</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Statistic</strong></td>
</tr>
<tr>
<td>Mean</td>
</tr>
<tr>
<td>Std Deviation</td>
</tr>
<tr>
<td>Minimum</td>
</tr>
<tr>
<td>2.5%</td>
</tr>
<tr>
<td>10%</td>
</tr>
<tr>
<td>Median</td>
</tr>
<tr>
<td>90%</td>
</tr>
<tr>
<td>97.5%</td>
</tr>
<tr>
<td>Maximum</td>
</tr>
<tr>
<td>Sum</td>
</tr>
<tr>
<td>Size (n)</td>
</tr>
<tr>
<td>Variance</td>
</tr>
<tr>
<td>Variance/Size</td>
</tr>
<tr>
<td>SQRT(Variance/Size)</td>
</tr>
</tbody>
</table>

**Dirichlet tree PSA**

Note that the mean value from the 100 iterations is close to the roll back expected value. However, the variance among the iterations reflects the different probabilities that are generated by the Dirichlet distribution. The All Data Report shows the three individual probabilities generated from the distribution for each iteration. Note that the first, second and third values from the distributions are near 0.2, 0.75 and 0.05 respectively as expected.
In TreeAge Pro, simulation text reports and graphs only report the first sampled Dirichlet probability. However, it is possible to use either a tracker variable or TreeAge Pro’s Global() matrix function to store and report each sampled probability. For example, to create a table of a branch’s sample values, wrap the Dist() function reference in the Global() function, as in:

```
Global(_sample; branch; Dist(1; branch))
```
27. Bayes' Revision in Decision Trees

This chapter shows how, in the tree window, TreeAge Pro can assist you in performing the calculations that implement probability revision using Bayes' theorem.

27.1 An introduction to Bayes’ revision

If your model includes imperfect tests or forecasts followed by decisions, you may wish to utilize TreeAge Pro's Bayes' revision feature. TreeAge Pro can automatically perform probability revisions using Bayes' theorem. The process occurs once during the initial construction of the model; based on your answers to a few questions, TreeAge Pro will generate a set of variable definitions that calculate the revised probabilities. The probability expressions will be recalculated every time the model is evaluated and results can change as your estimates of prior and likelihood probabilities (see below) change.

Bayes' revision is implemented in both the tree and influence diagram windows. Bayes' revision in the tree window is able to revise probabilities automatically based upon a single test. The process can be performed more than once within a model for different tests.

There are two methods of applying Bayes’ theorem on your model, each of which is described later in this chapter:

1. For test results using sensitivity and specificity.
2. For a general m-by-n grid.

27.1.1 Probability revision using Bayes' theorem

Bayes' revision allows decision makers to calculate decision probabilities from likelihood probabilities. Likelihood probabilities, or forecast likelihoods, are answers to questions such as, “If this test is performed on a part known to be faulty, what is the probability of a positive result indicating a problem?” This type of probabilistic information is often available, but is not immediately useful in making decisions. What's needed are the decision probabilities, which address questions such as, “If a particular part tests positive, what is the probability that is really faulty?”

The decision probabilities are so named because, in the real world, they are the probabilities upon which decisions are based. These are also sometimes called posterior (or a posteriori) probabilities.

The basic formula for revising probabilities is:

\[ P(H \mid E) = \frac{P(E \mid H) \times P(H)}{P(E)} \]

where \( H \) is the hypothesis (e.g., faulty or not faulty) and \( E \) is the evidence (e.g., test result). The formula is applied once for each hypothesis-evidence combination — for example, P(not faulty positive), or the
Bayes’ Revision in Decision Trees

27 Bayes’ Revision in Decision Trees

probability not faulty given a positive test result. \( P(H) \) represents the prior (or a priori) probability of the condition. \( P(E) \) is a marginal probability, calculated as part of the revision.

27.1.2 A simple numeric illustration

The following example is designed to offer a sense of the potential usefulness of Bayes’ revision. If you are already familiar with the types of applications that require Bayes’ revision, you may want to skip this section.

Consider an automated test for a defect in a semiconductor. The defect is present in 1% of the items under scrutiny. It has been demonstrated that the available test will detect 98% of the faulty materials, meaning that 2% of those pieces with the defect will not be picked up by the test. Also, the test is known to incorrectly identify as faulty 3% of those pieces that are without defect.

You have considered installing a machine to perform this test in your facility. What is the likelihood that a part which tests positive actually has the defect? How certain can you be of parts that tested negative don’t have a defect? The information about the accuracy of the testing equipment provided above does not directly answer these crucial questions.

Bayes’ Revision illustration - part 1

Let’s say we have a batch of 10,000 items to be tested.

If the estimated prior probability of defect is 1%, we would expect 100 items in the batch to have the defect. Of these, about 98 should test positive. Of the 9,900 pieces without the defect, we said approximately 3% (297) would test positive.

Thus, a total of 395 (297 + 98) test subjects would test positive (this is one of the marginal test probability).

The Bayes’ revision formula is intuitive when illustrated and worked out using a tree, as shown below.

The first revised decision probability is the ratio 98/395, or approximately 25%. This is the probability that a positive test actually indicates the presence of the defect. In this case, 75% of the positive tests are in error. The other decision probabilities are similarly calculated. With this information, a decision maker could compare the performance of the new test with existing methods or competing technologies.
27.2 Bayes' Revision - Sensitivity/Specificity

The most common form of Bayes' revision performed in healthcare models relates to imperfect tests using sensitivity and specificity. In a typical model, you screen for a condition, but the test yields some false positives and false negatives. Reported data on the sensitivity and specificity of a test and the prevalence of the disease can be integrated into a model as parameters, which are revised to generate dependent probabilities required for the model.

- **Sensitivity** (also called the true positive rate) measures the proportion of actual positives which are correctly identified as such (e.g. the percentage of sick people who are correctly identified as having the condition).
- **Specificity** (also called the true negative rate) measures the proportion of negatives which are correctly identified as such (e.g. the percentage of healthy people who are correctly identified as not having the condition).

For this version of the Bayes' revision, you must first create the model structure to mirror the test results and actual condition. This structure can be anywhere in the tree, but it must follow the structure of a chance node with two branches that are each also chance nodes with two branches.

The Health Care tutorial example model, BayesSensSpec-start.trex, is presented below.
The model contains the standard test and condition node structure as well as the three variables prevalence, sensitivity and specificity.

To initiate the Bayes’ revision using sensitivity and specificity:

- Select the Give test chance node.
- Choose Subtree > Bayes’ Revision > Sensitivity, Specificity from the menu.

You are then presented with a wizard dialog to walk you through the revision process. In the first step, you simply select the test positive node. Then select the two condition positive nodes that follow the positive and negative test nodes. The dialog uses the node label text to guide you through the process. Then click Next.

The radio button for the top branch is always selected in the dialog below. Do not assume that this is the correct selection for your model.

Bayes’ sensitivity/specificity wizard - select nodes

Then you select variables to for the prevalence, sensitivity and specificity values required for the revision. The wizard includes a "Show variable definitions" link if you need to create/define these variables on the fly. In our example, these variables were already defined, so they can simply be selected.

Note that if you create variables on the fly through the mini Variable Definitions View within the Wizard, definitions will be placed at the "root" of the revision, which may not be where you want them. You might choose to create the three required variables first, so you can simply reference them within the wizard.
The wizard also contains a "Show Bayes grid" link to allow you to see the calculated values that will be used in the model.

Bayes' sensitivity/specificity wizard - select probability variables

When you click Finish, the revised probability variables are then defined at the "root" revision node with references to the three independent variables. The revised variables are then placed into the tree's branch probabilities. The revision variables are set to be hidden in the tree structure.
The Health Care tutorial example model BayesSensSpec-end.trex includes the final set of revised probabilities. Roll back shows all the calculated revised probabilities in the model.

Revised model rolled back

27.3 Bayes’ Revision - Grid

The grid approach to Bayes’ revision also revises the known probabilities to create the probabilities needed for the model. However, it differs in two significant ways:

1. It supports any m-by-n sized grid.
2. It generates the tree structure rather than referring to an existing tree structure.
To use the grid Bayes’ revision, you should first obtain numeric values for the likelihood probabilities associated with the test and the *a priori* probabilities for the hypotheses. Then, use the grid revision wizard to create the model’s structure and probabilities.

This chapter will examine the contents of an oil well and a test for seismic soundings. We will assume that we have knowledge about wells in a target area based on prior success in the immediate region. Based on that knowledge, we estimate the likelihood that the well has no oil, some oil or lots of oil as shown below.

<table>
<thead>
<tr>
<th>Condition</th>
<th>Probability</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Oil</td>
<td>5/10 (50%)</td>
</tr>
<tr>
<td>Some Oil</td>
<td>3/10 (30%)</td>
</tr>
<tr>
<td>Lots of Oil</td>
<td>2/10 (20%)</td>
</tr>
</tbody>
</table>

Based on prior experience, a table is constructed showing what we can expect for test results (test neg, test pos moderate, or test pos high) based on a well’s actual state (no oil, some oil, or lots of oil) as shown below.

<table>
<thead>
<tr>
<th>Condition</th>
<th>Test Low</th>
<th>Test Med</th>
<th>Test High</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Given No Oil</td>
<td>0.6</td>
<td>0.3</td>
<td>0.1</td>
<td>1.0</td>
</tr>
<tr>
<td>Given Some Oil</td>
<td>0.3</td>
<td>0.4</td>
<td>0.3</td>
<td>1.0</td>
</tr>
<tr>
<td>Given Lots of Oil</td>
<td>0.1</td>
<td>0.4</td>
<td>0.5</td>
<td>1.0</td>
</tr>
</tbody>
</table>

This example uses the default 3x3 grid. Please note that the grid does not need to be symmetrical.

The starting point for your Bayes’ revision is a chance node with no branches. The subtree generated by the process can then be copied or moved later as needed. The Oil tutorial examples model, BayesGrid-start.trex, is a quick starting point for working with the grid Bayes’ revision.

To start the grid Bayes’ revision:

- Open the BayesGrid-start.trex model.
- Select a chance node with no branches.
- Choose Subtree > Bayes’ Revision > M by N grid from the menu.

The Wizard then opens.
Bayes' revision grid wizard

Note the two spinners at the top that can be used to change the shape of the grid.

The wizard provides entry fields to the left for the condition descriptions (for node labels), for condition short names (for variable names) and variable definitions (for values). It also provides entry fields for test results (for node labels), for test result short names (for variable names) and given conditions (for values).

Based on the information provided earlier, the grid could be filled out as seen below. The "Show Bayes Grid" link has been clicked to show all the Bayes' revision calculated values.
Bayes' revision grid wizard with values

Then click Create Bayes Subtree to create the subtree with all independent, conditional and calculated variables created and defined.
BayesGrid-end.trex

Note the following elements of the subtree that is created.

- The tree structure is built automatically based on the M by N grid.
- The node labels are populated based on the Condition Description and Test Result labels entered in the grid.
- The independent variables are named based on the short names entered for the condition and test results and are defined based on values in the grid.
- The revised probability variables are named starting with an underscore and are not "shown in tree." They are defined using Bayes' revision theorem.

The Oil tutorial example, BayesGrid-end.trex, is a tree after the revision with the end nodes changed to terminal nodes to display the path probabilities, as shown below while rolled back.

BayesGrid-end rolled back

Note that the path probabilities, conditional probabilities and test result probabilities match the values presented in the grid.

The names and values entered in the last Bayes grid are stored with the model. This allows you to create another Bayes subtree using the same data. The Oil tutorial examples model BayesGrid-start-populated.trex is pre-populated with the Bayes grid data described above.
28. Utility Functions and Risk Preferences

TreeAge Pro allows you to set up a risk preference utility function in a tree, which can be used to account for a decision maker’s aversion to risk.

28.1 Risk preference: an illustration

Most decision makers are risk-averse to some degree. They are willing to pay a premium, small or large, to avoid risk. The decision maker’s risk preference can be incorporated into a decision tree.

Assume that a rich uncle offers you an opportunity to win some money. He proposes to flip a coin giving you the opportunity to receive either $10,000 or $1,000, depending on whether you correctly predict the outcome. If you call the flip correctly, you will receive $10,000, and if you are wrong you will receive $1,000.

To make this game more interesting, assume that your uncle complicates matters by offering an alternative opportunity. The alternative is also a coin flip. Under this one, you will receive $50,000 if you are correct, but you will have to pay him $5,000 in the event you lose on the coin flip. There will be only a single coin flip; it is up to you to choose between the two. As you will see, it may not be wise to base your decision solely on traditional expected value calculations.

The tree in Business tutorial examples, Risk Illustration, models your uncle’s offer.

Risk Illustration tree

As the tree illustrates, there are two lotteries. Both provide the same (50 - 50) odds of winning, but they have different outcomes. You must choose one of them. On the basis of expected value, you should choose lottery #2. Its expected value ($22,500) is more than four times that of lottery #1 ($5,500).

However, what about the risk posed in lottery #2 that you could actually end up losing $5,000? At least in lottery #1 there is no risk of being out-of pocket – you are guaranteed to win something. How one responds to the downside risk posed by lottery #2 involves a subjective analysis of the decision maker’s aversion to risk.
28.1.1 Certainty equivalents and risk aversion

Consider lottery #1 described above. The expected value is $5,500. Would you sell the opportunity to play this lottery for $4,000? If you were offered $3,000 by a third party who wanted to buy into the lottery, would you sell?

The minimum value for which you would sell the lottery is your certainty equivalent for this lottery. The certainty equivalent of a lottery can be perceived as the expected value of that lottery, adjusted for risk preference (the risk-adjusted expected value).

A certainty equivalent is similar to an expected value, in that it is a single numeric quantity which represents the value of an uncertain event. The certainty equivalent is a subjective measure; it is the answer to the question, “What is the minimum (or maximum) value for which I would trade this uncertainty?”

Now consider a situation which is undesirable from the start. Lottery #3 is a coin flip in which you will either owe your uncle $2,000 or you will owe him $12,000. In this situation, we are interested in finding the maximum amount that you are willing to pay to a third party to assume your obligation under the lottery. Would you pay $4,000? Or $5,000? Your answer to this question is your certainty equivalent for that lottery.

The certainty equivalent for a lottery is usually in the same numeric range as the expected value. The gap between the certainty equivalent and the expected value is a measure of risk aversion.

Most decision makers are risk-averse to some degree. They are willing to pay a premium, small or large, to avoid risk. Their certainty equivalent for any lottery will be lower than the lottery’s expected value. In contrast, a risk-seeking decision maker is one whose certainty equivalent for a lottery is higher than the lottery’s expected value. The risk taker is willing to pay a premium in order to participate in the lottery.

28.2 Risk preference curves

A straight-line risk-preference curve represents a decision maker who is risk-neutral. This type of decision maker bases decisions on expected values rather than certainty equivalents.

A risk-averse decision maker will have a curve with a decreasing slope, meaning that certainty equivalent is less than expected value. The curve will typically be steeper in the low value range, where aversion to risk is weak, and will grow progressively flatter as the values get larger (both positive and negative), where aversion to risk becomes stronger. The more risk-averse you are, the more your curve will deviate from the 45° straight line representing risk neutrality.

If you encode a curve that includes some unexpected bumps when graphed, this means that some of your responses were inconsistent. You should repeat the process. Don't be discouraged; developing a meaningful non-constant risk utility curve takes hard thinking and careful consideration.
For further reading on risk preference, refer to the general texts on decision analysis listed at the end of Chapter 1.

Risk preference functions can be used only if the calculation method is set to Simple.

### 28.3 Creating a risk preference function

TreeAge Pro is able to record your risk function as a mathematical curve and apply this curve to the expected value of an uncertainty. Recommendations are then made based on your derived certainty equivalents, rather than on expected values.

There are two types of curves, or risk functions, which TreeAge Pro can use. The constant risk aversion function is calculated using the formula:

$$U(x) = 1 - e^{(-x/R)}$$

where U is an arbitrary utility scale, and R is a risk preference coefficient, described below. The utility scale is used only for internal calculations; the formula’s inverse is later applied to find certainty equivalents.

The non-constant risk function is tailored to fit your specific model, and so is superior to the constant risk aversion function in many respects, except that it takes a little longer to set up initially. TreeAge Pro will ask you a series of questions about your certainty equivalents for the model you are working on. It will then create a curve made up of line segments approximating your true risk function.

Both types of risk functions are entered via Tree Preferences.
To use risk preferences when analyzing a model, check the Use risk preference function box and select either Constant risk aversion or Non-constant risk.

### 28.3.1 Constant risk aversion

If constant risk aversion is selected, you will be asked to supply a single value. Specifically, you will be shown a generic lottery in which you have a 0.5 probability of winning $X$ and a 0.5 probability of losing one-half $X$, and asked to specify the largest value of $X$ for which you would be willing to take part in the lottery. This value is used as the risk preference coefficient in the above formula.

The lottery might represent an investment in a biotech company which is about to get a judicial ruling on the validity of an important patent. If the ruling is favorable (0.5 probability), the investment will double in value; if unfavorable (0.5 probability), the investment will fall in value by 50%.

What is the most you would invest under these circumstances? This amount is referred to as your risk preference coefficient.

### 28.3.2 Non-constant risk aversion

Non-constant risk aversion allows you to enter utilities (value to you) for different values in the model. These utilities are used to create a non-constant risk function that is applied to your model.
29. Using the Excel Module

The optional Excel Module enhances TreeAge Pro's ability to communicate with Excel. The major features of the Excel Module are:

1. Edit model inputs (variables, trackers, distributions and tables) in Excel.
2. Create a Tree Workbook to output the model inputs to Excel.
3. Output reports and graphs to Excel.
4. Access models programmatically through the Object Interface.

Features of the Excel Module

Each of these features are described within this chapter.

Dynamic bi-directional links with Excel are supported by the base TreeAge Pro product and do not require the Excel Module.

Note that Excel's presentation of add-in options changes with each new version of Excel. Excel for Mac also presents add-ins differently. Despite the presentation differences, the functions should work the same way.

29.1 Edit model inputs in Excel

When you want to edit a large number of model inputs, it is often most efficient to do so via Excel. The process works as follows:

1. Export the desired inputs from TreeAge Pro to an Excel worksheet.
2. Edit the values in the Excel worksheet.
3. Import the new values back from Excel to the TreeAge Pro model.

Editing model inputs in Excel

This option is available for variables, trackers, distributions and tables. Each input is described in the next few sections. The Bilink tutorial example model TreeWorkbookTest.trex.

Updates from Excel are applied to the active model. Therefore, you must select the correct model in the Tree Diagram Editor before sending updates back from Excel to TreeAge Pro.

29.1.1 Edit variables in Excel

If you have the Excel Module licensed, the Variable Properties View toolbar's To Excel icon/function will be enabled.

To edit variables in Excel:

- Open the Variable Properties View.
- Click the Open in New Excel Spreadsheet toolbar icon.
The tree's variables are then exported to an Excel worksheet. In the worksheet, the original variables are identified by hidden column I. This allows you to rename variables based on the current name. Hidden column H is used to determine which variables have been modified. We recommend that you do not modify the data in either hidden column.

Note that if you add new variables, you will not want to copy the original name in the hidden column. If you do, the existing variable will be replaced by the new variable.

Within the worksheet, you can change the variable properties and the default definitions (at the root node).

To send the new properties/values back to TreeAge Pro:

- Select the correct tree in the Tree Diagram Editor.
- In Excel 2007 or later, choose the Add-ins ribbon then choose TreeAge Eclipse > Add or Update Variables from the Excel menu.
- In Excel 2003 or earlier, choose TreeAge Eclipse > Add or Update Variables from the Excel menu.
Update variables in Excel 2007

Note that Excel's presentation of add-in options changes with each new version of Excel. Excel for Mac also presents add-ins differently. Despite the presentation differences, the functions should work the same way.

The variables in TreeAge Pro will be updated with the new properties/values from the Excel worksheet. There is no need to keep the Excel worksheet after the updates are complete as it can be regenerated at any time.

To refresh the data in the worksheet from the values in TreeAge Pro:

- In Excel 2007 or later, choose the Add-ins ribbon then choose TreeAge Eclipse > Refresh Variables from the Excel menu.
- In Excel 2003 or earlier, choose TreeAge Eclipse > Refresh Variables (from Tree) from the Excel menu.

Refresh will update the existing list of variables with the current values from TreeAge Pro. If you have added new variables within TreeAge Pro, please generate a new list via Edit in Excel from within TreeAge Pro.

If you export variables to Excel at a node other than the root node, you are asked whether to include an additional column of data for the variable definitions at the selected node. If you answer "yes", then the variable definitions at the selected node can also be updated and sent back to TreeAge Pro.
29.1.2 Edit trackers in Excel

Editing trackers in Excel works the same as editing variables, although tracker properties are different from variable properties.

If you have the Excel Module licensed, the Tracker Properties View toolbar’s To Excel icon/function will be enabled.

To edit trackers in Excel:

- Open the Tracker Properties View.
- Click the Open in New Excel Spreadsheet toolbar icon (highlighted below).

![Tracker Properties View - To Excel function](image)

The tree's trackers are then exported to an Excel worksheet.

![Trackers worksheet in Excel](image)

Within the worksheet, you can change the tracker properties and the initial values. Hidden columns are used in the same way as the variables worksheet. See note in prior section.

To send the new properties/values back to TreeAge Pro:

- Select the correct tree in the Tree Diagram Editor.
- In Excel 2007 or later, choose the Add-ins ribbon then choose TreeAge Eclipse > Add or Update Trackers from the Excel menu.
- In Excel 2003 or earlier, choose TreeAge Eclipse > Add or Update Trackers from the Excel menu.
The trackers in TreeAge Pro will be updated with the new properties/values from the Excel worksheet. There is no need to keep the Excel worksheet after the updates are complete as it can be regenerated at any time.

To refresh the data in the worksheet from the values in TreeAge Pro:

- In Excel 2007 or later, choose the Add-ins ribbon then choose TreeAge Eclipse > Refresh Trackers from the Excel menu.
- In Excel 2003 or earlier, choose TreeAge Eclipse > Refresh Trackers from the Excel menu.

Hint: Refresh will update the existing list of variables with the current values from TreeAge Pro. If you have added new variables within TreeAge Pro, please generate a new list via Edit in Excel from within TreeAge Pro.

If you export trackers to Excel at a node other than the root node, you are asked whether to include an additional column of data for the tracker modifications at the selected node. If you answer "yes", then the tracker modifications at the selected node can also be updated and sent back to TreeAge Pro.

29.1.3 Edit distributions in Excel

If you have the Excel Module licensed, the Distributions View toolbar's To Excel icon/function will be enabled.

To edit distributions in Excel:

- Open the Distributions View.
- Click the Open in New Excel Spreadsheet toolbar icon (highlighted below).
Distributions View - To Excel function

The tree's distributions are then exported to an Excel worksheet. See note on hidden columns in Variables section above.

Distributions worksheet in Excel

Within the worksheet, you can change the distribution properties and parameters. Note that the Help/Explanation column provides details on how the parameters are used for the appropriate distribution type.

To send the new properties/parameters back to TreeAge Pro:

- Select the correct tree in the Tree Diagram Editor.
- In Excel 2007 or later, choose the Add-ins ribbon then choose TreeAge Eclipse > Add or Update Distributions from the Excel menu.
- In Excel 2003 or earlier, choose TreeAge Eclipse > Add or Update Distributions from the Excel menu.
Update trackers in Excel 2007

The distributions in TreeAge Pro will be updated with the new properties/parameters from the Excel worksheet. There is no need to keep the Excel worksheet after the updates are complete as it can be regenerated at any time.

A few distribution types have additional options that are not updated through the Excel module (e.g., Fractile Gaussian vs. Swanson). These options must be edited in the Add/Change Distribution dialog.

29.1.4 Edit tables in Excel

Variables, trackers and distributions are edited within a list. However, tables are edited individually in Excel since they contain both properties and data.

If you have the Excel Module licensed, the Tables View toolbar’s Open in New Excel Spreadsheet icon/function will be enabled.

To edit a table in Excel:

- Open the Tables View.
- Select a single table.
- Click the To Excel toolbar icon (highlighted below), which exports the table to an Excel worksheet.
Within the worksheet, you can change the table properties and data. Be careful not to change the structure and/or location of the data in the worksheet.

To send the new properties/data back to TreeAge Pro:

- Select the correct tree in the Tree Diagram Editor.
- In Excel 2007 or later, choose the Add-ins ribbon then choose TreeAge Eclipse > Add or Update Distributions from the Excel menu.
- In Excel 2003 or earlier, choose TreeAge Eclipse > Add or Update Distributions from the Excel menu.

To refresh the data in the worksheet from the values in TreeAge Pro:

- In Excel 2007 or later, choose the Add-ins ribbon then choose TreeAge Eclipse > Refresh Trackers from the Excel menu.
- In Excel 2003 or earlier, choose TreeAge Eclipse > Refresh Trackers from the Excel menu.

Note that you can add columns to the table in Excel by adding data to the right of the existing columns. Value columns can have custom headings, but the Index column heading should not be changed.
29.2 Tree Workbook

You can quickly export the model inputs described in the previous sections (variables, trackers, distributions and tables) via a Tree Workbook.

To create a Tree Workbook:

- In Excel 2007 or later, choose the Add-ins ribbon then choose TreeAge Eclipse > Create Tree Workbook from the Excel menu.
- In Excel 2003 or earlier, choose TreeAge > Create Tree Workbook from the Excel menu.

A new Excel workbook will be created with a separate worksheet for each model input (variable list, tracker list, distribution list and each table). These model input worksheets are the same as described previously for variables, trackers, distributions and tables. Additional worksheets are described within this section.

The Tree Control worksheet is used to either open or save the model associated with the Tree Workbook. You can change the name of the tree and save the model in a separate document.

If you have different data scenarios you want to save for the same model. You can save multiple Tree Workbooks for the model. Then, you can use the Tree Workbook to update the model’s data for that specific data scenario.

29.3 TreeAge Pro Object Interface

This interface is described in the TreeAge Pro Object Interface Chapter.

29.4 Exporting analysis output

The Excel module also allows exporting analysis outputs to Excel. The Open in New Excel Spreadsheet icon is frequently enabled for graphical and text output.

When this icon is enabled at the top right of the output, you can use it to export the results to Excel.
30. Using the TreeAge Pro Object Interface

The Excel Module (included with TreeAge Pro Excel and TreeAge Pro Suite) provides a powerful scripting interface that can be used to open, update and analyze models via program code.

⚠️ The Object Interface for TreeAge Pro is different from previous versions of TreeAge Pro. You can continue to use the older version of TreeAge Pro as you choose to modify the code which accesses TreeAge Pro.

30.1 Java vs. Other Programming Languages

You can open, update and analyze models via program code written in virtually any language, including:

- Java
- Visual Basic in an Excel macro
- Visual Basic in other environments
- C++
- etc.

TreeAge Pro is written in Java, so the Java programming language provides the most transparent look at the Object Interface via the Java package com.treeage.treeagepro.oii. This package includes the model element and analysis objects, which makes coding in Java easier because the Java IDE can "see" the TreeAge Pro objects and provides guidance on programming syntax.

However, many TreeAge Pro customers use the Object Interface through other programs, frequently via Visual Basic in an Excel macro. Languages other than Java connect to the Object Interface through the ActiveX Java package com.treeage.treeagepro.oiiactivex. The ActiveX Java package allows you to instantiate the TreeAgeProApplication object. The TreeAgeProApplication object then provides access to instantiate other objects (trees, nodes, etc. from com.treeage.treeagepro.oii).

The API documentation describes the syntax for both Java packages.

ℹ️ Note that on some computers, you may need to run TreeAge Pro with elevated privileges in order to access it via an external program.

30.2 Object Interface API Documentation

The Object Interface's Application Programming Interface (API) is described via standard javadoc documentation, which provides documentation for all objects and methods supported by the Object Interface.

A few of the primary application and modeling objects are highlighted in the following table. These and other objects are documented in the API documentation.
<table>
<thead>
<tr>
<th>Object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TreeAgeProApplication</td>
<td>A reference to the TreeAge Pro application. This is the first object you must create to start using the Object Interface when not using Java.</td>
</tr>
<tr>
<td>Tree</td>
<td>Standard tree model created in TreeAge Pro.</td>
</tr>
<tr>
<td>Node</td>
<td>A specific node within the tree.</td>
</tr>
<tr>
<td>Variable</td>
<td>A variable within a tree. Use this object to read/update variable properties.</td>
</tr>
<tr>
<td>VariableDefinition</td>
<td>A variable definition within a tree at a specific node.</td>
</tr>
<tr>
<td>Tracker</td>
<td>A tracker within a tree. Use this object to read/update tracker properties.</td>
</tr>
<tr>
<td>TrackerModification</td>
<td>A tracker modification within a tree at a specific node.</td>
</tr>
<tr>
<td>Table</td>
<td>A table within a tree. Use this object to read/update table properties.</td>
</tr>
<tr>
<td>TableRow</td>
<td>A row of data within a table.</td>
</tr>
<tr>
<td>Distribution</td>
<td>A distribution within a tree. Use this object to read/update the distribution's type, parameters and properties.</td>
</tr>
</tbody>
</table>

**Primary modeling objects**

The Object Interface Additional also includes objects that support analysis. Most analyses are run on the Tree object. However, several types of analyses require objects for handling inputs/parameters and outputs.

A few of the primary application and modeling objects are highlighted in the following table. These and other objects are documented in the API documentation.

<table>
<thead>
<tr>
<th>Object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report</td>
<td>Output from any analysis. The type of analysis executed determines the format of the data within the object. Some Report objects can be used to create other Report objects to generate secondary analysis outputs (i.e., graphs from Monte Carlo simulation output). Analysis parameters are passed via a hashmap of named values prior to generating the report.</td>
</tr>
<tr>
<td>Graph</td>
<td>Graphical output from a Report object.</td>
</tr>
<tr>
<td>TextReport</td>
<td>Tabular text and numeric output from a Report object.</td>
</tr>
</tbody>
</table>

**30.3 Connecting to the Object Interface via Java**

When using Java code to connect to the Object Interface, you must create the appropriate file structure to be able to "build" your Java project. This requires some experience with creating a Java build environment.

To avoid the need to create an appropriate development environment, you can simply copy the full structure of the Object Interface Example project (described below) to another location on your
computer and network. With the same file structure, you will be able to create Java source code in the folder `../src/com/treeage/treeagepro/tutorials/`, placing your new source files alongside the example file `UseObjectInterface.java`.

Make sure you do not make changes directly in the Object Interface Example project as this project could be overwritten when new software is released. If a new version of the Object Interface Example project is released, copy the appropriate files to your project. Be sure not to overwrite any of your own source code.

### 30.3.1 Sample Java code

Sample Java code is provided in the Object Interface Example project installed with your software. You can access the appropriate file through the Files View (see below).

#### Object Interface Example project

The `UseObjectInterface.java` source file contains sample Java code that opens, edits and analyzes sample trees. You can use this file as a starting point for creating your own Java source code.

If you choose to create your own source code using this example, be sure to save the file using a different filename. In fact, we recommend copying the entire project to a separate location. Otherwise, your source could be overwritten if an updated version of the example code is released.

This section will introduce you to the sample Java code. However, the Java code itself contains comments that serve as the primary documentation.

The `UseObjectInterface.java` file contains a Java class of the same name. That class runs as a Java application based on the existence of the method `main`. The `main` method instantiates the class, which immediately calls the class constructor `UseObjectInterface`, which contains the main processing steps. Additional methods provide the details on opening, modifying and analyzing trees.
Sample Java code

To execute the code, right-click in the Java code document and select Run As > Java Application from the menu.

Execute Java code

As the sample code executes, it writes a status output to the Java output Console. See below.
30.4 Connecting to the Object Interface via ActiveX

Scripting languages communicate with TreeAge Pro via Java Remote Method Invocation (RMI). When TreeAge Pro starts up it starts a service on port 1099 (or slightly higher) which listens for ActiveX requests.

The non-Java objects are instantiated via the library TreeAgeProOI. This library must be referenced for your code to access the TreeAge Pro Object Interface objects. Below is a picture of the library objects as seen from the Excel Visual Basic Editor's Object Browser.
You can use these library objects to open, modify and analyze trees within Excel or other programming environments. Even when not working in Java, refer to the Java API documentation for object/method syntax.

Since ActiveX is registered on the computer, there are no requirements for a build environment as there are for Java projects. You can save the code anywhere on your computer or network.

### 30.4.1 Sample Visual Basic code

Sample Visual Basic (VB) code is provided in the Excel document "Use Object Interface.xls" in the TreeAge Pro Interface tutorial examples project. See below.

The UseObjectInterface.xlsm document contains sample VB code that opens, edits and analyzes sample trees. You can use this file as a starting point for creating your own VB source code.

If you choose to create your own source code using this example, be sure to save the file using a different filename in a different location. Otherwise, your source could be overwritten if an updated version of the example code is released.

This section will introduce you to the sample VB code. However, the VB code itself contains comments that serve as the primary documentation.

**To see the VB code in Excel 2007 or later:**

- Click on the Office button and then click the Excel Options button.
- In the Popular category, make sure the Show Developer tab in the ribbon box is checked.
- Select the Developer tab in the ribbon.
- Click the Visual Basic button.

**To see the VB code in Excel 2003 or earlier:**

- Choose Tools > Macros > Visual Basic Editor from the menu.

The VB code has a primary macro called TestObjectInterface, which contains the main processing steps. Additional methods provide the details on opening, modifying and analyzing trees.
Sample code and output in Excel's VB editor
31. The TreeAge Pro Player

TreeAge Pro 2011 R2.0 introduced a new feature called the TreeAge Pro Player. The Player allows you to share a model with an individual who does not have a license for TreeAge Pro. A consultant might use this feature to share the model to his/her client.

In order to use the Player, the modeler must first create a Player Interface for the model, resulting in a password protected Player Model with the *.trvx extension. The modeler determines which input variables can be changed and which analyses can be executed. The modeler also determines whether or not the player should be able to display the model structure.

The Player Model can be opened with TreeAge Pro, but functions are limited to those exposed by the model interface. Supplying the password will allow you to use an expanded set of functions.

31.1 Creating a Player Model

You create a Player Model by exporting a model in the player format.

To create a Player Model:

1. Save the latest changes to the model.
2. Choose File > Import/Export > Export as Player Model from the menu.
3. Choose the file name and location in the dialog box.
4. Enter the password associated with the Player Model twice.

The model will be exported as a Player Model will be saved with the *.trvx extension.

Export as Player Model Dialog

You cannot change the structure or values within a model within a Player Model. You must return to the original model file to make such changes. However, you can then create a new Player Model and import the Model Interface elements from an existing Player Model.
If you are modifying a model for which an interface had already been created, you have the option of importing the interface from another Player Model. To do so, follow the instructions above plus the following steps:

1. Check the Import interface box.
2. Select an existing Player Model (*.trvx) file.

The resulting Player Model will include the model structure and details from the model that was exported as well as the interface details from the prior Player Model.

If any variable names or stored analysis names from the imported interface are not found in the exported model, they will not be usable in the new interface. They will be displayed in red and can be deleted but cannot be used. This can happen if a variable or stored analysis is renamed since a prior interface was created.

### 31.2 Creating the Player Model Interface

Once the Player Model has been exported, you then need to create a Model Interface to provide access to the parameters and analyses. When you open the Player Model, TreeAge Pro will switch to the Player perspective. The Player Perspective limits access to nearly all of the application views used for editing the model.

The Player Perspective includes the following Views:

- Player Model - for using an existing Model Interface.
- Player Design - for creating a Model Interface.
- Tree Diagram Editor - for viewing the model (if allowed by the interface)
- Console - for viewing system output from analysis runs
- Error Log - for viewing system errors
- Projects - for accessing model files

If no interface has been created, you will only able to view the model.

To create a Player Model Interface:

1. Open the Player Model.
2. Choose Edit > Enter the Designer Password.
3. Enter the password used when creating the Player Model.

If you do not have an authorized version of TreeAge Pro, you will not be able to enter the Designer Password.

The Player Design View will become enabled. You create the interface within this view.

There are several components of the interface:
- Variable parameters that can be updated.
- Stored analyses that can be executed.
- A setting to determine whether the interface should show the model structure or not.

Interface Components

The figure below shows the Player Design View with all of the variables exposed, all stored analyses exposed and the model structure exposed to the interface. This interface was created from the Special Features tutorial example model Three Vars with Stored Analyses.

Player Design View

Variables

A model will have many variables that serve several functions in the model. Some variables are model parameters with a numeric definition at the root node. Only variables such as these should be enabled in the Model Interface, and probably only a subset of those variables.

Check the Unlocked box next to each variable you wish to expose in the Model Interface. It will be helpful to the person using the Model Interface if the variable has a clear name and description. You can also enter additional information in the Comments field.

Stored Analyses

Within the Model Interface, the regular Analysis menu will not be available. Instead, the modeler must create a stored analysis for each analysis they wish to expose in the Model Interface. Comments can be added to the stored analysis to help guide the user of the Model Interface.

Check the Unlocked box next to every stored analysis you wish to expose in the Model Interface.

You can restrict the secondary output options available within the standard Monte Carlo simulation output to make it easier for the Player Model recipient to find the output of interest.

Exposing the Model Structure

The modeler may or may not want the Model Interface to expose the structure of the model. This is controlled by checking or unchecking the box in the Player Design View.
31.3 Using the Model Interface

Once the Model Interface is complete, the Player Model can be opened and analyzed using TreeAge Pro even if the software is not authorized. When the Player Model is opened, the Model Interface will present the specific variable inputs that can be modified, allowing the user to change certain model assumptions. Variable descriptions and comments in the original model can be used to guide someone using the interface, including specifying valid values.

The Model Interface will also show the specific analyses that can be run. The user can run any of the specified analyses and the appropriate output will be presented.
32. Export Model Scenarios to Excel

You can export your model to Excel to allow others to examine your model results under different scenarios within a simple Excel workbook.

You identify the inputs that can be edited, then the export wizard generates a series of results for the applicable data scenarios. Anyone receiving the Excel workbook can easily change input values and view the associated results.

This chapter will detail how to convert the model by following a simple wizard.

TreeAge Pro has another option to convert a Markov cohort model into a standalone Excel model. This generates an Excel Workbook which can be edited more extensively, but does not include any sensitivity analysis. See the Chapter Markov To Excel Conversion for more details.

32.1 Export Model Scenarios to Excel Wizard

This section gives step-by-step instructions for exporting the model to an Excel workbook. We will use an example model, but the same steps apply to all models.

32.1.1 Introduction to the Model

We will use the Health Care Tutorial Example, Markov Conversion Model.trex. This model is a cancer decision model that compares two treatment strategies, Tx 1 and Tx 2, using cost-effectiveness analysis. Each treatment strategy is represented by a single Markov model, with Tx 2 reusing the Markov structure from Tx 1 via a cloned subtree.

The Markov model has three health states - Local Cancer, Metastases and Dead. The two treatments use different values for the following elements of the shared Markov model structure:

- the cost of the Treatment for Local Cancer;
- the probability of transition from Local Cancer to Dead; and
- the probability of transition from Local Cancer to Metastases.

Each of the Markov Models can be evaluated separately by Markov Cohort Analysis, and the decision tree can also be evaluated using cost-effectiveness analysis.

This model is evaluated as a Cohort model using Expected Value calculations. The Conversion also works for Patient Level Simulation models (Markov and DES).
32.1.2 Export the Model

The Workbook Export Wizard walks you through the steps to export the active model to Excel, including adding descriptive text and choosing the editable inputs.

Convert the model:

1. Choose File > Import/Export > Export Model Scenarios to Excel from the menu to start the Workbook Export Wizard for the currently active model.
2. Choose the editable inputs from the list of model parameters on the left. To move the parameters, you can use the arrows to move parameters one-by-one or all at once. You can also drag and drop the model parameters into the Workbook inputs section.

3. Sort the selected parameters in the order you wish to have them presented in the workbook. You can drag and drop parameters within the list to change the order.
4. As you add more parameters to the editable input list, more model calculations are required to generate the results for the exported Excel workbook. Each workbook input will take on 3 different values (low, best, high). With three values per input, selecting 7 inputs requires $3^7 = 2187$ calculations. You can see the number of calculations at the bottom of the figure below, which changes depending on how many inputs you choose.
Workbook Export Wizard with 7 parameters selected as Workbook inputs showing the Number of calculations required is 2187

5. For each selected input, enter a low, best and high value. These entries will default from information already in the model, but they can be edited here.

Use the wizard to set the values for the inputs from low, best and high.

Default Low - from low end of sensitivity analysis range.
Default Best - from the root node definition for the variable.
Default High - from high end of sensitivity analysis range.
6. Choose the proper analysis method for this model. For typical decision trees and Markov models, choose "Expected Value/Cohort Analysis". For patient simulation and DES models, choose "Microsimulation". Also enter the WTP value, which defaults from Tree Preferences.

![Image of Wizard to Choose the Analysis Type]

**Use the wizard to Choose the Analysis Type**

The example model we are using is a cohort model, so we selected Expected Value/Cohort Analysis.

7. Choose whether to include a picture of the TreeAge Pro model in the workbook, and enter descriptive details about the model and strategies to help the workbook recipient understand the underlying model.

![Image of Model Description]

**Model description will appear on the Introduction Sheet for the workbook (and can be edited at any time in Excel).**

- Check the box “Place a picture of the model tree in the workbook” to include the picture.
- Enter a Model description; and
- Enter a description for each strategy.

8. Once all the details are entered, click Finish.

TreeAge will now run the model through all the parameter value combinations to export those model results to the Excel workbook. If you have a simulation model, this could take quite a few minutes or even hours.

The Excel model will be saved to the same folder that holds your original TreeAge Pro Markov model. The filename will be the same as your model with “-ModelExport.xlsm” added to the end. If you convert the model multiple times, a sequence number will be added to the filename. In this example, our model is saved as: Markov Conversion Model-ModelExport.xlsm.

The Excel model will then open and you may need to do the following:

- Enable macros. If your Excel settings do not allow Macros to run without confirmation, you will be prompted to Enable Content in a Security Warning. Without enabling macros, the model likely will not be able to perform all required calculations.
- Resize any column width in the first Model Results sheet. This is sometimes required to get the calculated cells to display correctly.

### 32.2 Examine the Excel Model

The exported Excel workbook contains model results under all data scenarios representing every combination of input parameter values. The results are pre-run in TreeAge Pro. If the TreeAge Pro model changes, you can repeat the export process to reflect those changes in a new exported workbook.

The workbook is split into three different sheets described in the following subsections.

#### 32.2.1 Overview sheet

This sheet contains information about the model and its strategies since the receiver of this workbook may not have the original TreeAge Pro model. It also includes instructions on how to use the workbook to generate and save results using different scenarios.

On the Overview Sheet you will find:

- Model description: This contains the text entered in the wizard to describe the model.
- Strategies: This contains the node label from the strategy nodes as well as the text intered in the wizard to describe each strategy.
- Instructions: These instructions tell the recipient of the model workbook how to use it.
32 Export Model Scenarios to Excel

- Model Diagram: This section will include a picture of the original TreeAge Pro model if the exporter chose to include a picture in the workbook.

After export workbook is created, you can add/edit text as desired.

**Overview Sheet - NEED NEW SCREEN PRINT**

### 32.2.2 Run model sheet

This sheet includes all editable inputs and action buttons described below.
The sheet is split into four main sections:

- **Editable Model Inputs and WTP**: These are the parameters selected in the wizard as editable inputs.
- **Additional Inputs**: These are the other parameters not selected as editable inputs. They are presented here for information purposes only.
- **Action Buttons**:
  - Run Model: Show results for the current selection of input values. Both Rankings and CE analyses will be presented to the right of the buttons.
  - Save Results on New Sheet: Save the current results generated via "Run Model" on a separate sheet for comparison to results for other data scenarios.
  - Restore Base Case Inputs: Set all inputs back to the original base case values.
- **Model results**: Initially there are no model results on this tab, but once you click Run Model, results will appear to the right of these buttons.

When you first open the Run Model tab, all inputs will be set to their base case values. Model results using those base case inputs will be presented in the third sheet "Base Case Results".

**To generate a new set of results:**

- For each of the editable model inputs, click on the green cell to choose from among the three values presented to the right - Low, Base and High.
- Edit the Willingness To Pay (WTP) if desired.
- Click the Run Model button.

The figure below shows the sheet with results.
Run model - with the same base case values in green cells - but with the results generated

The Results are presented as a Rankings Report and a Cost-Effectiveness Analysis Graph (for CE models only) based on the selected inputs. Each time you change the Editable Model Inputs and Run Model, the results on the right in the rankings and the graph will change.

To save a set of results:

- When a set of editable model inputs generates results you want to save, select the Save Results to New Sheet.
- A new tab will open, called Saved scenario 1. Every subsequent set of results will have a sequential number.

To restore the base case inputs:

- If you want to set all the editable model inputs back to their Base case values, select the Restore Base Case Inputs button.
- Once you reset any values, you will need to select Run Model to regenerate the model results.

32.2.3 Base Case and additional sheets

The last sheet generated when the Excel workbook is created has the Base Case results. This and the additional sheets (generated from the Save Results on New Sheet button) are not editable.
The sheet is split into the model inputs on the left hand side and the model outputs - Rankings report and Cost Effectiveness Graph (for CE models only) - on the right hand side.

Base case - generated when the Excel workbook is created from the base case values
An additional sheet generated from running the model with all low inputs - Saved Scenario 1
33. Model Dashboard and Documentation

This chapter describes the Dashboard View which gives an overview of your model and Model Documentation which is a mechanism used to document your model.

33.1 Using the Model Dashboard

TreeAge Pro provides a View to give you an overview of your model. You access the Dashboard through the Views menu. The figure below shows what the Dashboard looks like.

Dashboard View - maximised to fill the whole screen

The Dashboard is split into 3 sections, each providing different information about your model. Selecting any of the text highlighted in blue will take you to where you can edit the details or it will toggle between settings (such as Displayed/Hidden). The 3 sections are:

- **Model Properties**: Access all the main properties of the model including Calculation Method, Payoffs, willingness to pay and any linked Workbooks.
- **Model Structure/Display**: Details about the number of strategies, number and type of nodes, and display settings such as whether to show variables, notes, Markov info and clone copies is found here.
- **Model Inputs**: Any information entered into the model can be updated through this pane including variables, distributions, tables and trackers. Selecting any of the blue text will take you to the appropriate View.
When the Dashboard view is not full size, each of the sections appear as selectable tabs to allow access to all the information by clicking through each tab, as in the figure below. This pane can also be detached from TreeAge Pro, right-clicking on the tab and selecting "detach".

Dashboard View with tabs for each of the 3 panes. Right-click and select Detached to detach and move independently of the main windows.

33.2 Create Model Documentation Help File

TreeAge Pro provides Help html files to describe the software and its functions. You can create a similar Help html file to describe your model.

There are three steps to this process.

- Create an Excel workbook for model documentation based on the model structure.
- Edit the Excel workbook to add documentation text.
- Import the Excel workbook to create a Help html file.

Creating model documentation

We will use the Get Started tutorial example model Three Vars to demonstrate this technique.

To create an Excel workbook for model documentation:

- Open the model.
- Choose File > Model Help/Documentation > Create Help Workbook > Simple Model Docs Template.
- Select the model input types that exist in your model and what you wish to document.

Different Help Workbooks are available for cost-effectiveness and CE Markov models.
This creates a workbook file next to the model file within the same folder with the same name, but with "_ModelDocs.xls" added to the end. The workbook contains placeholder cells for entering model documentation.

To open the workbook for editing in Excel:

- Select the applicable model in the Tree Diagram Editor.
- Choose File > Model Help/Documentation > Open Documentation Spreadsheet.

The cells with labels and "<title>" type tags should be left alone. The cells to the right of these "label" cells are used for entry of descriptive text. See below.

---

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>&lt;section&gt;1. Structure</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>&lt;subsection&gt;1. Strategies</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>&lt;question&gt;1. What is the important background for the decision in this model?</td>
<td>Comparing two investment strategies.</td>
</tr>
<tr>
<td>4</td>
<td>&lt;question&gt;2. What strategies are chosen for comparison?</td>
<td>Risky investment with unknown return. CD with fixed return.</td>
</tr>
<tr>
<td>5</td>
<td>&lt;question&gt;3. Describe the reasons for the inclusion/exclusion of strategies:</td>
<td>No other strategies were used for this simple example.</td>
</tr>
<tr>
<td>6</td>
<td>&lt;subsection&gt;2. Events:</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>&lt;question&gt;4. List the key events in the model. Are they different for different strategies? If so, why?</td>
<td>The risky strategy is dependent on market forces which could result in any of three</td>
</tr>
<tr>
<td>8</td>
<td>&lt;subsection&gt;3. Other assumptions:</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>&lt;question&gt;5. What is the time frame of the model (months, years, etc.)?</td>
<td>One year horizon.</td>
</tr>
<tr>
<td>10</td>
<td>&lt;subsection&gt;4. Other information:</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>&lt;question&gt;6. Is the structure of this model based on other, similar, published or otherwise accessible models?</td>
<td>This is just an example model. No relation to published results.</td>
</tr>
<tr>
<td>12</td>
<td>&lt;question&gt;7. What sources (experts, panels, studies or publications) were used to determine the structure of the model?</td>
<td>No sources were used.</td>
</tr>
</tbody>
</table>

---

Model Documentation Workbook
Once the text in the workbook has been updated, it can be imported back into TreeAge Pro to generate the Help html file.

To create the Help file:

- Select the applicable model in the Tree Diagram Editor.
- Choose File > Model Help/Documentation > Export Workbook to HTML Help

This creates an HTML file next to the model file within the same folder with the same name, but with "_ModelDocs.html". This Help file is then available for documentation of the model.

To open the Help file:

- Select the applicable model in the Tree Diagram Editor.
- Press the F1 key.

The Help file will look like this.

---

Section I - Structure

I. Structure

A. Strategies

1. What is the important background for the decision in this model? Comparing two investment strategies.
2. What strategies are chosen for comparison? Risky investment with unknown return, CD with fixed return.
3. Describe the reasons for the inclusion/exclusion of strategies. No other strategies were used for this simple example.

B. Events:

4. List the key events in the model. Are they different for different strategies? If so, why? The risky strategy is dependent on market forces which could result in any of those measured returns.

C. Other assumptions:

5. What is the time frame of the model (months, years, etc.)? One year horizon.

C. Other information:

6. Is the structure of this model based on other, similar, published or otherwise accessible models? This is just an example model. No relation to published results.
7. What sources (experts, panels, studies or publications) were used to determine the structure of the model? No sources were used.

---

Model Documentation Help
34. Model Debugging and Validation

This chapter describes some mechanisms to debug a model and how to validate your model by looking for commonly found flaws within the model.

34.1 Debug Using the Calculation Trace Console

TreeAge Pro provides debugging options to display the internal calculations performed as a model is analyzed. These calculation details can then be reviewed in the Calculation Trace Console, providing valuable validation and debugging information.

The debugging options provide flexibility to generate debug output for the entire analysis or limit the output to specific calculations, Markov cycles, trials, etc.

To setup debugging options, open Tree Preferences and select the category Analysis Settings > Debugging/Calculation Trace Console as shown in the figure below.

Tree Preferences - Debugging/Calculation Trace Console

The Debugging/Calculation Trace Console options include the following...
- **Show in Console**: Select the items you wish to see in the debug view as TreeAge Pro performs calculations.

  - **Errors, warnings and notes**: Check this box to avoid having TreeAge Pro pop-up dialogs when warnings or error messages need to be displayed; instead, checking this box will have the text added to the Calculation Trace Console.

  - **Text-only analysis output**: Check this box to write text report analysis output to the Console. For example, Rankings output is purely text and would be written to the Console.

  - **Saved analysis abstract/summary**: Check this box to display summary information in the Calculation Trace Console about any new analyses available for storage. This information can be stored for later use via Stored Analysis.

- **Console settings**: Select how you want the output to the console to be displayed.

  - **Clear console before each analysis**: Check this box to clear the console before each new analysis.

  - **Limit console output (if # of lines exceeds)**: Select the maximum number of lines to display within the Calculation Trace Console. Older lines are dropped when the maximum number of lines is exceeded. A larger number holds more outputs in the debug view, which uses more system resources.

- **Show output for r**: Controls whether calculations should be written to the console. These are is the most important debugging settings.

  - **All**: Calculation Trace Console will show all calculations executed during the analysis.

  - **None**: No trace output generated.

  - **Selected Elements**: Calculation Trace Console will show calculations only for specific elements within the model. You then need to select the elements you want to debug in your model in model input views.

    - Variable definitions calculations - via the Variable Properties and Variable Definitions Views
    - Tracker modification calculations - via the Tracker Modifications View
    - Distribution parameter calculations and sampling - via the Distributions View

- **Markov Cycles**: Option to limit output to a specific set of cycles for a Markov model.

- **Trials**: Option to limit output to a specific set of trials for a Microsimulation model.

- **Samples**: Option to limit output to a specific set of PSA iterations for a Sampling/PSA analysis.

- **EVPPI**: Option to limit output to a specific set of EVPPI iterations for a EVPPI Sampling/PSA analysis.

Consider the Health Care tutorial example model, Markov Conversion Model.trex. This is a Cancer Model with two treatment strategies. It is not a microsimulation model and can be run with usual
Expected Value calculations. We will run the model with debug turned on for All and then for Selected Elements in the subsequent sections.

34.1.1 Show Debug Output for All

To show debug output for all calculations:

- Open the Markov Conversion Model.trex.
- Open the Tree Preferences > Analysis Settings > Debugging/Calculation Trace Console
- In “Show Output for” select All. Then select OK.
- Rollback the model and then examine the Calculation Trace Console.

Calculation Trace Console showing internal calculations (this is obviously a limited screenshot)

The Calculation Trace Console shows the extensive output which is every calculation the model makes during analysis. This can be examined for total transparency of the calculations in the model. The figure above shows the first calculations in the model - the termination condition check, the health state initial probabilities, and the Markov rewards for the Local Cancer state.
If your Calculation Trace Console is not open, select the Views menu and select the Console from the dropdown menu.

### 34.1.2 Show Debug Output for Selected Elements

To *show debug output for selected elements/calculations within the model*:

- Open the Markov Conversion Model.trex.
- Open the Tree Preferences > Analysis Settings > Debugging/Calculation Trace Console.
- In “Show Output for” select "Selected Elements". Select OK.
- There is an option to limit the output based on Trials, Samples, EVPPI samples and Markov Cycle. We will not limit the output for this example.
- Next, select elements in the model to Debug. In this example we will review calculations of the variable `pDeathBackground`. Open the Variable Properties View, locate the variable `pDeathBackground`, and check the Debug box (as shown in the figure below).
- Rollback the model and then examine the Calculation Trace Console.

In the Variable Properties View select the variables to Debug.
Calculation Trace Console showing calculation of pDeathBackground

Examining the Calculation Trace Console for \textit{pDeathBackground} we can examine the common elements.

- **\textit{******* pDeathBackground - START *****}**: Indicates the start of the calculation of the parameter selected for debugging.
- \textit{Context}: This indicates where in the tree, for which strategy, sample and cycle the calculation is occurring.
- \textit{Time}: Time of the calculation in TreeAge Pro.
- Details about the calculations, including the calculations for any other elements in the model which need evaluating to complete the calculation.
- **\textit{******* pDeathBackground - END *****}**: Indicates the end of the calculation of the parameter selected for debugging.

This format is used for any model element selected for debug output.

Note that if you want to debug a variable definition that is not at the root node, use the Variable Definitions View with the appropriate node selected.
34 Model Debugging and Validation

34.1.3 Show Debug Output for Payoffs

To show debug output for a payoff calculation:

- Open the Health Care training example model, Example02-Variables.trex.
- Open the Tree Preferences > Analysis Settings > Debugging/Calculation Trace Console.
- In “Show Output for” select ”Selected Elements”. Select OK.
- From the Views menu open the Node Properties View.
- Select the node ”Surgery and Radiation eradicate tumor” where there are cost and effectiveness payoffs set (as highlighted in the figure below).
- In the Node Properties View use the tabs on the left hand side to go down to Payoffs and then check the box next to the cost and effectiveness payoffs for debugging. The figure below shows this.
- Rollback the model and then examine the Calculation Trace Console. The output is similar to debugging as variable, as detailed above, but in the context of evaluating the payoffs.

34.1.4 Show Debug Output for Probability Expressions

To show debug output for a branch probability calculation:

- Open the Markov Conversion Model.trex.
- Open the Tree Preferences > Analysis Settings > Debugging/Calculation Trace Console.
- In “Show Output for” select ”Selected Elements”. Select OK.
- From the Views menu open the Node Properties View.
- Select the node ”Die from Background Mortality” where the probability is pDeathBackground.
- In the Node Properties View use the tabs on the left hand side to go down to Probabilities and then check the box next to pDeathBackground for debugging. The figure below shows this.
34.1.5 Show Debug Output for Trials in a Microsimulation model

For Microsimulation models, you can show debug information for each patient or limit it to specific patients.

To show debug output in a Microsimulation model:

- Open the Health Care tutorial example model, MicrosimulationCancerModel - Distributions.trex. This is a Microsimulation model including Trackers.
- Go to Tree Preferences > Analysis Settings > Debugging/Calculation Trace Console.
- In “Show Output for” select “Selected Elements”. Click OK.
- There is an option to limit the output based on Trials, Samples, EVPPI samples and Markov Cycle. We will not limit the output for this example but we will only run two trials in the analysis.
- Next, select elements in the model to Debug. In this example we will review calculations of the variable \( p_{AE\_Death} \) and the tracker modification \( t\_AE \) at the Adverse Event node. Open the Variable Properties View, locate the variable \( p_{AE\_Death} \), and check the Debug box (as shown in the figure below). Select the Adverse Event node, open the Tracker Modifications View, and check the Debug box next to the tracker modification.
- Run Microsimulation for two trials and then examine the Calculation Trace Console.

When running a microsimulation model, if you select Show Output for All, then it is important to limit the number of trials in your analysis. There will be a large amount of data (the internal calculations) sent to the console and if there are too many, the console will crash and you are likely to get an error.
Calculation Trace Console showing calculation of $p_{AE\_Death}$ and $t_{AE}$

The Calculation Trace Console shows the same details per element selected as with the Cohort model, but now there are also details about the trial included in the context. In the example above, for both trials 1 and 2, $t_{AE}$ and $p_{AE\_Death}$ are evaluated at _stage 8_.

💡 Note that if you run a Monte Carlo Simulation analysis on a computer with multiple processors, the debug output will likely be split by thread as each thread processes different iterations within the analysis.

Note that you can limit the number of threads used for analysis to consolidate this output if necessary.

⚠️ Even if the boxes are checked in the Views, unless the Tree Preferences is set to Show Output for All, then there will be no output to see in the Console.
34.2 Using Debug functions to control output

Most of the time, you will use Tree Preferences to control the debug info written to the Calculation Trace Console. However, you can also generate debug info by placing debugging functions directly in the model.

The following table lists the specialized commands which can be executed to debug a model.

<table>
<thead>
<tr>
<th>Function syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>DebugOn()</code></td>
<td>Turn the calculation trace setting on. After issuing this command, all internal calculations will be written to the Calculation Trace Console.</td>
</tr>
<tr>
<td>Previously <code>Debug(&quot;1&quot;)</code></td>
<td></td>
</tr>
<tr>
<td><code>DebugOff()</code></td>
<td>Turn the calculation trace setting off. After issuing this command, internal calculations are no longer written to the Calculation Trace Console.</td>
</tr>
<tr>
<td>Previously <code>Debug(&quot;0&quot;)</code></td>
<td></td>
</tr>
<tr>
<td><code>DebugExport(filename)</code></td>
<td>Export the current contents of the calculation trace console to a .txt file to a specific location with a specific name. An example of what we could replace file with is: filename = path + &quot;name_of_file&quot; + Str(_trial) + &quot;.txt&quot; where path = &quot;X:\Testing\DocModels\Output_files&quot;; name_of_file = the new name of the file where we save the export; Str(_trial) = the number of the current _trial in the model; and .txt = sets the file type.</td>
</tr>
<tr>
<td><code>DebugExport(index)</code></td>
<td>Export the current contents of the calculation trace console to a file with the same name as the model, followed by &quot;<em>trace</em>&quot; plus the index and with the file extension .txt. The .txt file will be located in the same folder as the original model.</td>
</tr>
<tr>
<td><code>DebugClear()</code></td>
<td>Clear all the output in the calculation trace console.</td>
</tr>
<tr>
<td><code>DebugWrite(text)</code></td>
<td>Send the text argument to the console with a blank line before and after it. Note the text will only be written if debugging is turned on via the Tree Preferences or via the DebugOn() function.</td>
</tr>
<tr>
<td><code>DebugWriteForce(text)</code></td>
<td>Send the text argument to the console with a blank line before and after it. Note the text is written regardless of whether debug output is turned on or off.</td>
</tr>
<tr>
<td><code>DebugTime()</code></td>
<td>Write the current date/time including milliseconds to the console. Note the text will only be written if debugging is turned on via the Tree Preferences or via the DebugOn() function.</td>
</tr>
<tr>
<td><code>DebugTimeForce(text)</code></td>
<td>Write the current date/time including milliseconds to the console. Note the text is written regardless of whether debug output is turned on or off.</td>
</tr>
</tbody>
</table>
If the Debug() function requires the debug output to be turned on then this can be done either via turning on 'Show Output for All' in the Tree Preferences or by using the DebugOn() function.

The Debug() functions can be useful when combined with some of the keywords which are specifically used to select individual trials in Monte Carlo analysis. More information about these keywords can be found on the section about Customizing Simulations, specifically in the section about Monte Carlo special variables. The Model Debugging and Validation Chapter has examples using a number of the Debug tools to debug models.

Below are a couple of examples using the Debug() function.

### 34.2.1 Example: Using the calculation trace dynamically

It is often useful to to turn the Calculation Trace on to examine specific calculations and why the model might be failing. For models with a large number of calculations, it is prohibitive to turn the Calculation Trace on for all trials (microsimulation) and samples (sensitivity analysis). It may take too long for the Calculation Trace to get to the point where the model is failing.

In these situations, looking at the internal calculations from the Calculation Trace Console for all trials may not be required but you may want to look at a specific trial's values.

**To pinpoint a specific trial’s calculations**

Examine the Special Features example model, Debug MicrosimulationCancerModel.trex.

Consider an error which is occurring for trial 999 in a Monte Carlo simulation. To look at the internal calculations for just trial 999, the model has the following definitions included:

- Create a special simulation variable to turn on the calculation trace before trial 999 goes through the model: `_monte_pre_trial_eval = if(_trial=999; DebugOn(); 0)`.
- The special variable/keyword `_monte_pre_trial_eval` is a built-in keyword in TreeAge Pro. It will ensure the expression it equals will be evaluated before every trial in the model is evaluated. In this case the expression will turn the debug function on, using DebugOn(), if _trial = 999. Otherwise the expression will do nothing.
- Create a special simulation variable to turn off the calculation trace after trial 999 has finished with the model: `_monte_post_trial_eval = if(_trial=999; DebugOff(); 0)`.
- The special variable/keyword `_monte_post_trial_eval` is a built-in keyword in TreeAge Pro. It will ensure the expression it equals will be evaluated after every trial in the model is evaluated. In this case the expression will turn the debug function off, using DebugOff(), if _trial = 999. Otherwise the expression will do nothing.

Running microsimulation on the model with 2,000 trials will show one output in the Calculation Trace Console, that is the calculations for _trial = 999.
Other useful keywords, like _monte_pre_trial_eval, can be used to customize your models. They can be found in the section about Customizing simulations.

### 34.2.2 Example: Locating distribution sampling errors

A common Analysis Error which occurs is related to distributions. Distributions may be defined appropriately when sampled independently. However, a combination of distribution samples can cause probability errors during analyses. A typical Error message is shown in the figure below, which was generated by running Probabilistic Sensitivity Analysis on the Special Features example model, Debug WriteForce MarkovCancer.trex.

![Error message generated at runtime from poor distributions.](image)

Open the example model, Debug WriteForce MarkovCancer.trex and examine the two distributions.

Both Dist_p_Local_Death and Dist_p_Local_Mets are Beta distributions with the same parameters, mean of 0.4 and standard deviation of 0.1.

Both the distributions are sampled per Expected Value, so when we run Probabilistic Sensitivity Analysis every re-calculation of the model will re-sample from the distributions.

In the Tree Preferences we have chosen to turn on seeding and threading. We have turned seeding on to replicate the same results over and over again. This is a useful technique if you are trying to locate a problem in a model which keeps moving when the random number seed changes. We have chosen to run the model with a single (“1”) thread which means that the calculations have to take place in order. You can find out more about these options in the following section about Simulation Options.

Run the model by selecting the decision node and then Analysis > Probabilistic Sensitivity Analysis. Run 100 samples. The error message should be similar to the Figure above.
To debug this model we have created a variable which we can add to any variable in the model to examine specific output. The variable is:

```
outputDebug = DebugWriteForce("Sample= " + str(_sample) + ", Prob LocToMets=" + str(Dist_p_Local_Mets) + ", Prob LocToDead=" + str(Dist_p_Local_Death)).
```

Consider the the first few elements of the variable outputDebug:

- `DebugWriteForce( text here )`: This is the command which instructs the model to write whatever is in the place of "text here" to the Console. This command will work even if debug is turned off in the Tree Preferences.
- "Sample = " + str(_sample): This is some of the text which is included within the executable section of the function DebugWriteForce. It has three elements:
  - Quotation marks: Anything written within " " will be written to the console. In this case "Sample = ".
  - The '+ ': This is used to concatenate expressions. In this case, "Sample = " will be first followed by the interpretation of str(_sample).
  - str(_sample): The function str() converts whatever is in the brackets to text for the screen. This example converts the keyword _sample (which gets the current sample number) to a string. We would expect in Probabilistic Sensitivity Analaysis (PSA) a new sample number for each of the PSA samples.

The other elements which make up the variable are similar. Instead of the sample number being written to the screen, the value of Dist_p_Local_Mets and the Dist_p_Local_Death are written respectively.

This variable `outputDebug` can be added anywhere within the model. Because all the debug functions have zero value adding this variable to another variable in the model has no impact on the value calculated. In the example model you will see we have added the variable to the probability under the branch at Local Cancer > Progress to Metastases. The figure below shows the output in the Calculation Console Trace immediately before the Error happens.

![DebugWriteForce output in the Calculation Trace Console](image)

The error can now be identified in the model. The sum of all the probabilities at the Local Cancer node must be 1. By including the '#' under the Stay Here branch, the model first calculates the probabilities at the other two branches and the calculates the probability at the Stay Here branch. The output above
shows that when the PSA gets to the forth sample, the values which are generated from the Beta distributions from $p_{\text{LocalToMets}} = 0.365$ and from $p_{\text{LocalToDeath}} = 0.663$. The sum of these alone is greater than 1 so the model is unable to define the probability under the Stay Here branch. Whilst both the distributions are valid, the Example model needs to reconsider their combined probabilities.

In addition, look at the String Processing section for syntax related to creating string expressions for the DebugWrite and DebugWriteForce functions.

### 34.3 Model Debugging examples

Examples for debugging models can be found in the previous two sections. This section existed prior to the introduction of global commands in the Tree Preferences for Debugging.

### 34.4 Model Validation

This section describes a mechanism used to validate your model by looking for commonly found flaws within the model.

#### 34.4.1 How model validation works

TreeAge Software has identified a set of common flaws in models; the model validation process checks for these flaws in your model and presents any occurrences of these flaws back to you.

The specific validation checks are:

- **End Nodes Validator**: find end nodes that are not terminal nodes.
- **Missing Probability**: find branches of chance nodes with no probability expression.
- **Missing Payoffs**: find terminal nodes (non-Markov) that are missing payoffs.
- **Missing Jump State**: find terminal nodes (Markov) that are missing a jump state.
- **Unused Tracker**: find trackers that are not used in the model.
- **Unused Variables**: find variables that are not used in the model.
- **Unused Distributions**: find distributions that are not used in the model.
- **Unused Tables**: find tables that are not used in the model.
- **File compatibility**: identify features that are not supported by older versions of TreeAge Pro.

#### Model Validation Checks

More validation checks will be added to TreeAge Pro in future releases.

#### 34.4.2 Determine which validators to run

Tree Preferences provide the ability to turn on/off specific validator checks.
Uncheck any of the model validators to skip that check in the validation process.

34.4.3 Run the model validation

To illustrate the model validation process, we will open Special Features tutorial example model ModelValidationTest. As you can see below, it has a few model flaws: missing probabilities, missing payoffs and non-terminal end nodes.

ModelValidationTest model

To run the model validation:

- Open/activate the model in the Tree Diagram Editor.
- Open the Model Validation View from the Views list in the toolbar.
- Click the Validate button (green circle with white triangle).
The Model Validation View will display the results from all the validation checks. See below.

The results are presented in a grid with a row for each validation check/problem.

The first column indicates whether the row represents an error, warning or a successful check. A successful check means that no occurrences of problems were found.

The second column displays the validator name.

The third column displays a message related to the problem.

The fourth column displays the context for that error/warning. The context is used to provide a node label or model input name associated with the problem.

Double-click on any error/warning line in the grid to move either to the tree diagram editor to the highlighted node with the problem or to the proper model input view for the model input with the problem. This gives you immediate access to the context where the problem can be fixed.

### 34.4.4 File compatibility

Model validation identifies features that are used, but are not supported by earlier software versions. If you have used any such features, you will need to ensure that your colleagues have software that supports those features or they will not be able to open the model. Alternatively, you can modify your model to remove those features.

The following model validation output is from the Legal tutorial example model LegalTreeSummation.
Model validation - file compatibility

As indicated in the validation output above, the summation node feature was introduced with TreeAge Pro 2013, R2.
35. Preferences

This chapter describes TreeAge Pro preferences - Tree Preferences and Application Preferences.

The first section of this chapter describes Tree Preferences, which are specific to the active tree model, and are stored with the tree document. The last few sections describe Application Preferences, which are associated with the TreeAge Pro application and apply generally to the functioning of the software and to all models.

35.1 Tree Preferences

Tree Preferences provide control over many settings and options for the active model, including how it is calculated and how it is displayed. Although they are not part of the model structure or numerical data, Tree Preferences hold important configuration settings for a model that are stored within the model document.

Tree Preferences can be broken into a few main categories:

- Calculation preferences
- Display preferences
- Spreadsheet preferences
- Analysis settings

Some frequently used Tree Preferences can be set by using the Model Setup Wizard. The wizard prompts the user through specific elements of the Tree Preferences as listed below:

- Calculation method
- Additional options associated with the selected calculation method
- Payoffs
- Discounting
- Custom payoff names
- Numeric formatting

It is also possible to edit any Tree Preferences directly using the Tree Preferences Dialog.
35.2 Tree Preference Sets

TreeAge Pro allows you to save and load Tree Preference Sets, which include all the preference settings from the Tree Preferences Dialog. For example, you might regularly create two kinds of trees, cost-effectiveness trees and simple trees. You could save a Preference Set for each of these types from a model that you have already created. Then you could load the appropriate Preference Set when creating a new tree.

The controls for Preference Sets are at the bottom left corner of the Tree Preferences Dialog.
Tree Preference Sets with controls listed

In the figure above, the down arrow control has been clicked to show the Tree Preference Set controls, which are described below:

- **New Set**: Create a new preference set for the selected model. The new preference set can be copied from an existing preference set already saved with the model.
- **Load Saved Set**: Load a set of preferences from an XML file into a preference set for the selected model. You will be asked to provide a name for the preference set within the context of the selected model.
- **Save AS XML**: Save the current preference set as an XML file. It can then be loaded into other models.
- **Save as default**: Save the current preference set as the default for new models.
- **Reset default**: Reset the default preference set for new models to the set that comes with the original software installation.

**Tree Preference Set Controls**
35.3 Tree Preferences Dialog

The Tree Preferences Dialog is used to edit Tree Preferences for the active model. You can open the Tree Preferences Dialog by first selecting a model and then using one of the following methods:

- Choose Tree > Tree Preferences from the menu.
- Click the "Tree preferences" icon on the toolbar.
- Windows/Linux: Pressing F11 on the keyboard. Mac OS: Set up a keyboard shortcut, if desired, in the Application Preferences.

![Tree Preferences Dialog - Windows and Mac](image)

35.3.1 Tree Preference Categories

Tree Preferences are broken up into a number of categories as shown on the left side of the dialog. The list of available categories changes depending on what, if any, type of document is currently active. The list of categories can be filtered using the filter text input. Choosing a category from the list changes the page of options that appear in the right side of the dialog. The options in each category are described in this chapter.

35.4 Calculation Method

This is the first and most important category related to calculation preferences.
A model's Calculation Method controls the primary manner in which the model is calculated. TreeAge Pro supports four Calculation Methods.

Calculation Method Selection

- Simple: Make decisions based on a single payoff set.
- Cost-effectiveness: Make decisions based on separate payoff sets for cost and effectiveness values (by default, #1 and #2). This enables many analyses and reports associated with cost-effectiveness models, the most common being Cost-Effectiveness Analysis (CEA).
- Benefit-cost: Make decisions based net value (profit) calculated as the benefit payoff set subtracted from a cost payoff set.
- Multi-attribute: Make decisions based on a weighted combination of several payoff sets.

Calculation Methods

The bottom portion of the dialog will change based on your selection.

35.4.1 Calculation Method - Simple

There are a few options available to control the Simple Calculation Method.

Tree Preferences - Simple Calculation Method

- **Optimal path**: Select *High* for decision analysis to choose the strategy with the highest value. Use this when your decisions are made on the basis of profit, utility, cash flow, quality of life or
other attributes that should be maximized. Select \textit{Low} when payoffs are costs or other attributes that should be minimized.

- \textit{Active payoff}: Choose the payoff set to use for decisions. The default is always 1.

### 35.4.2 Calculation Method - Cost-Effectiveness

There are a few options available to control the Cost-Effectiveness Calculation Method. There are also two subcategories: Cost-Effectiveness Parameters and Weighted Multi-Attribute Costs.

![Tree Preferences - Cost-Effectiveness Calculation Method]

- \textit{Cost payoff}: Select the payoff to use for cost calculations within the model.
- \textit{Effectiveness payoff}: Select the payoff to use for effectiveness calculations within the model.

Additional settings for cost-effectiveness analyses are set via the category "Cost-Eff Params (WTP)".

\textit{Cost-Effectiveness Parameters (WTP)}
Tree Preferences - Cost-Effectiveness Calculation Method - C/E Parameters

- **Willingness to pay**: Enter the weighting to place on effectiveness when balancing against cost. WTP is typically compared to ICERs during cost-effectiveness analyses. It is also used in Net Benefits calculations. You can enter a variable, but it cannot be used for sensitivity analysis because WTP is applied after the model is recalculated.

- **Show Net Benefits in rollback**: Check this box to show Net Monetary Benefits (NMB) with calculated EV values in rollback display.

- **Minimum effectiveness**: Check the box and enter a value to activate the minimum effectiveness value in CE calculations. This rejects any strategies that do not meet or exceed the minimum effectiveness threshold.

- **Maximum cost**: Check the box and enter a value to activate the maximum cost value in CE calculations. This rejects any strategies that are not less than or equal to the maximum cost threshold.

- **Inverting effectiveness**: The inversion options allow you to invert effectiveness when the measurement of effectiveness needs to be minimized (e.g., cases avoided) rather than maximized (e.g., life years).

- **Do not invert**: Do not invert the effectiveness value. This is the default value which assumes that you want to maximize the effectiveness measure.

- **Invert incremental only**: Invert only the incremental values among strategies. *This is usually the preferred method to handle minimizing effectiveness values.*

- **Invert average values**: Invert average cost-effectiveness values. This inverts all effectiveness calculations. When selected, you must enter a maximum effectiveness value.
- **Maximum value**: Enter a fixed maximum effectiveness value from which to subtract all nodes' calculated effectiveness values during cost-effectiveness calculations.
- **Select Graph Orientation**: Choose which graph format you wish to output.
- **Draw graph with cost on vertical axis**: Places cost on the Y-axis of the graph. This is the default setting.
- **Draw graph with cost on horizontal axis**: Places cost on the X-axis of the graph.

### Weighted Multi-Attribute Costs

![Weighted Multi-Attribute Costs](image)

Tree Preferences - Cost-Effectiveness Calculation Method - Weighted Multi-Attribute Costs

- **Use weighted multi-attribute costs**: Check this box to activate weighted multi-attribute costs.
- **Payoff/weight grid**: Enter a weight for each payoff set.

### 35.4.3 Calculation Method - Benefit/Cost

There are a few options available to control the Benefit/Cost Calculation Method.

![Calculation Method](image)

Tree Preferences - Benefit/Cost Calculation Method

- **Cost payoff**: Select the payoff to use for cost calculations within the model.
- **Benefit payoff**: Select the payoff to use for benefit calculations within the model.
35.4.4 Calculation Method - Multi-Attribute

There are a few options available to control the Multi-Attribute Calculation Method.

Tree Preferences - Multi-Attribute Calculation Method

- **Optimal path**: Select High when the weighted multi-attribute calculated values should be maximized. Select Low when they should be minimized.
- **Payoff/weight grid**: Enter a weight for each payoff set. (This example has 3 payoffs).

35.5 Payoff Preferences

The Payoffs Tree Preferences category allows you to control the number of payoffs that are enabled in the model. This allows you to add payoffs to measure model outcomes beyond the primary outcome(s) for the model's calculation method.

Tree Preferences - Payoffs

- **Calculate extra payoffs**: Check this box to include the model's additional payoffs (beyond the primary outcomes) in most calculations (Rankings, Markov Cohort, Monte Carlo Simulation, etc.).
- **Number of enabled payoffs**: Select the number of payoffs to enable. Your calculation method will likely have 1 or 2 active payoffs. Increase this number to add more payoffs.
35.5.1 Discounting Rewards

The Payoffs - Discounting Tree Preferences category allows you to discount entire rewards sets based on the passage of time in Markov and DES models. For more information about the formula used in discounting, review the appropriate section about Markov models or DES models.

Tree Preferences - Discounting

- **Use global discounting**: Check this box to enable Global Discounting for the model.
- **Markov cycle length (in years)**: Enter the appropriate cycle length for your Markov model in one of two ways.
  1. Choose a common cycle length from the dropdown menu (Annually, Quarterly, Monthly, etc.). This pre-fills the time cycle value to the right. ....or....
  2. Manually enter the cycle length if you do not see the appropriate option in the list above. For example, 4 monthly cycles would be entered as 1/3.
- **DES time unit (in years)**: This refers to the units returned by time-to-event distributions. The two options to set the time interval for DES are the same as for Markov cycle length as described above.
- **Reward set/Discount rate grid**: This is where you set the discount rate to be applied to each reward set. The reward sets are generated from the enabled payoffs. If the model calls for a discount rate to only be applied to one reward set (unlikely) do not enter a discount rate for that reward set.

Enabling global discounting and apply to Markov model with Monthly cycle lengths (1/12) and 3% discount rate.

Note that you can enter either a numeric value (percentage or fraction) or you can use a variable accessible via the formula editor "=fx" button.
The figure below shows a model's Markov Info View highlighting those rewards which have been discounted with global discounting. Note there is no change to the reward in the value column, but the word *Discounted* next to the reward name indicates Global Discounting has been applied.

![Markov Info view illustrating where rewards have been discounted.](image)

**35.5.2 Custom Payoff Names**

The Payoffs - Custom Names Tree Preferences category allows you to create custom names for the enabled payoffs. You should always enter custom names if you added more payoffs to your model.

![Tree Preferences - Custom Payoffs Names](image)

- *Use custom payoff names*: Check this box to enable custom payoff names.
- *Payoff/Custom name grid*: Enter a custom name for each payoff set.

Note that the custom payoff names will be used for entry fields for payoffs and Markov rewards as well as in output reports.

**35.5.3 Markov To Excel Payoffs**

The Payoffs - Markov to Excel Payoffs Tree Preferences category allows you to select which payoffs you want to export in your Markov To Excel conversion. In the example below, the model has 5 payoffs and all are checked to export into the Excel model.

Find more details about using this feature to share models in the Markov to Excel Conversion Chapter.
35.6 Numeric Formatting

The Numeric Formatting Tree Preferences category allows you to control how numerical output is displayed within TreeAge Pro.

You can enter separate numeric formatting settings for each payoff, including both active and inactive payoff(s). As the Calculation Method preferences change, so too will the order of payoff(s) in Numeric Formatting, with the active payoff(s) presented first. In the figure below, the Calculation Method is Simple and payoff 1 is active. Any further inactive payoffs would be seen by scrolling down.

If the Calculation Method were Cost-effectiveness, then the active cost and the active effectiveness payoffs would be displayed, as well as numeric formatting for cost-effectiveness (a combination of the two payoffs). Further inactive payoffs would be displayed further down the screen.

- For payoff _: Indicates the payoff for which these Numeric Formatting preferences apply.
- Decimal places: Select the number of decimal places to display for the selected payoff.
- Add trailing zeros: This add zeros after the decimal place up to the defined number of decimal places. For example, 200.3 would be presented as 200.30 if "Decimal places" is set to 2 and "Add trailing zeros" is selected.
- **Use thousands separator**: Check this box to separate thousands using the defined separator for the model or for the computer.
- **Show numbers**: Select what order of magnitude you want to show numbers. Options include *exactly, in thousands, in millions, in billions* and *in percent*. The option you choose will depend on the size of the numbers used in the model.
- **Units**: Select the units that apply to that payoff.
  - *None*: Show calculated values with no units.
  - *Currency*: Show calculated values as currency. Note that the currency normally derives from the standard operating system settings on the computer. However, the currency can be overridden within the Regional Settings Tree Preferences.
  - *Custom prefix*: Display custom text before the calculated values.
  - *Custom suffix*: Display custom text after the calculated values.
- **Prefix/suffix**: Enter the custom text to be used when the *Units* are defined as *Custom prefix* or *Custom suffix*.
- **Sample**: Shows how calculated values will be displayed based on the Numeric Formatting preferences.

### 35.6.1 Probabilities

The Tree Preferences for numeric formatting Probabilities allows you to control how probabilities are displayed within TreeAge Pro.

![Tree Preferences - Numeric Formatting, Probabilities](image)

- **Decimal places**: Select the number of decimal places to display for all probabilities. For example, a probability of 0.045678 would be shown as 0.046 with the number of decimal places set to 3.
- *Show as %*: Select this box to show the probability as a percentage as opposed to a decimal value. For example, a probability of 0.045678 would be shown as 4.568% with this box checked and the number of decimal places set to 3.

- *Add trailing zeros*: This adds zeros after the decimal place up to the defined number of decimal places. For example, a probability of 0.3 would be presented as 0.300 if Decimal places is set to 3 and Add trailing zeros is selected.

### 35.7 Roll Back

The Roll Back Tree Preferences category allows you to control how roll back analysis results are displayed.

**Tree Preferences - Roll Back**

- *Display calculated probabilities*: Check this box to display the calculated value of each of the probabilities using numeric formatting preferences during roll back. Turning off roll back will show the original, uncalculated probability expression.

- *Display EV at terminal and decision nodes & options only*: Check this box to display expected value roll back boxes only at terminal nodes, decision nodes, and branches of a decision node rather than at every node in the model.

- *Rollback calculates*: There are four options for the roll back display:
  - *Active Payoffs and Path Probabilities*: Displays the Expected Values for the calculation method's Active Payoffs at all nodes and Path Probabilities at terminal nodes. This is the default setting.
  - *Path Probabilities*: Displays only the path probabilities for all nodes.
  - *Active Payoffs*: Displays the Expected Values for the calculation method's Active Payoffs only.
  - *Maximin*: Select the most pessimistic option at each chance node and the best option at each decision node. This helps you choose the optimal strategy if every uncertain event goes badly.
- *Display path probabilities with all EVs*: Display path probabilities at every node along with the expected values.
- *Show Formulas and Calculated Values*: Displays the formula for payoffs and probabilities along with the calculated values.

### 35.8 Risk Preferences

The Risk Preferences Tree Preferences category allows you to determine whether to use risk preferences in expected value calculations or not. Refer to the Utility Functions and Risk Preference Chapter for more information.

**Tree Preferences - Risk Preferences**

- *Use risk preference function*: Check this box to calculate the model based on a risk function rather than expected value.
- *Risk function*: Select either a constant or non-constant risk function.

### 35.8.1 Constant Risk Preference Assessment

The Constant Risk Preference Assessment Tree Preferences category allows you to enter the risk preference coefficient.
- **Risk preference coefficient**: Enter a value that defines an amount you are willing to risk for the lottery above. This is used to create a risk preference curve. (More details are found in the Risk Preferences Chapter).

### 35.8.2 Non-Constant Risk Preference Assessment

The Non-Constant Risk Preference Assessment Tree Preferences category allows you to enter a series of risk values to generate a non-constant risk preference curve.

![Tree Preferences - Non-Constant Risk Preference Assessment](image)

### 35.9 Regional Settings

The Regional Settings Tree Preferences category allows you to define regional numeric and currency settings. For new models, these settings are pulled from your computer's operating system. However, you can override the settings in the Tree Preferences; this can be particularly useful when collaborating with colleagues in other countries.

Regional Settings within Tree Preferences control the format of input values (probabilities, payoffs, rewards, variable definitions, etc.). However, the formatting of outputs (roll back, graphs, Monte Carlo output, etc.) is controlled by the computer's regional settings. The default computer Regional Settings from the computer will be saved with the model, so it will open and run an a computer setup with different Regional Settings.
Tree Preferences - Regional Settings

- **Locale**: Select the locale that defines the numeric format for model inputs.
- **Use custom regional numeric settings**: Check this box to override the locale's regional settings for model inputs.
- **Decimal separator**: Select a period (.) or comma (,) as the decimal separator for model inputs.
- **Thousands separator**: Enter a character to use to separate thousands in model inputs. In the US, a comma is used so one million dollars could be entered like this: $1,000,000.00.
- **Currency symbol**: Enter the currency symbol to use for model inputs.
- **Symbol to the left of the number**: Check this box to enter the currency symbol to the left of the number. Uncheck it to enter the currency symbol to the right of the number.
- **Replace Separators button**: Click this button to replace the separators within the model inputs. This is described in the next section.

### 35.9.1 Replace Regional Settings

The Replace Regional Settings Tree Preferences category allows you to replace the regional settings within numerical expressions in the model.

These Tree Preferences are enabled only if the "custom regional numeric settings" preference is checked.
Tree Preferences - Replace Regional Settings

- **Inversion method**: Choose from among the following inversion methods. Each changes the values in numeric expressions within the model.
  - *Invert periods and commas*: Replace all periods with commas and vice versa.
  - *From period to comma only*: Replace all periods with commas.
  - *From comma to period only*: Replace all commas with periods.
  - *Custom*: Create custom inversion methods.

- **Find/Replace with grid**: Use the "+" and "X" buttons to add and delete rows from the grid. Enter the target value into the Find column and the replacement value into the Replace With column.

### 35.10 Other Calc Settings

The Other Calc Settings Tree Preferences category allows you to set a few additional calculation settings.
35 Preferences

Tree Preferences - Other Calc Settings

- **Allow probabilities to not sum to 100%**: When checked, TreeAge Pro will not generate an error when probabilities do not sum to 100% and analyses will run. We recommend against using this option. Instead, you can set specific Chance and Markov nodes to be non-coherent (by selecting the node and then right-click and choose from the dropdown menu options).
- **Max. # allowed stages (cycles)**: Set the maximum number of cycles for any Markov model.
- **Tracker Modification Order**: Select the order for tracker modifications to be calculated at a specific node.
- **Microsimulation Check**: When this option is checked, you will not see the warning when you run Expected Value Calculations on a model with trackers and/or patient level distributions.

> When the Tracker Modification Order sorts by ascending priority, the secondary order is forward alpha. When it is by descending priority, the secondary order is by reverse alpha.

35.11 Tables

These Tree Preferences control whether to look for Global Tables and they allow you to enter a specific location for referencing Global Tables.
Tables Preferences

Check the box to look for table data in Global Table files.

If the path is entered into the input field, then TreeAge Pro will look in that path for Global Table files. If the path is not entered, then TreeAge Pro will look in the following locations within your workspace in order.

1. `<workspace>/Global Tables`
2. `<workspace>/Example Models/Special Features/Global Tables`

If a Global Tables file is found in the first location, it will not search the second location.

### 35.12 Markov/DES

The Markov/DES Tree Preferences allow Half Cycle Correction Method to be set for Markov Models. It also allows the default termination condition to be set for all new Markov or DES nodes.

- **WCC:** For Markov models, the Half Cycle Correction method can be set to either Traditional or Within-Cycle Correction. This impacts how rewards are defined in the model and more details can be found in the Markov Modeling Tools and Techniques Chapter.
- **Default termination conditions**: For both Markov and DES nodes, the default termination condition can be set here for all new nodes of these types.

You can access the Tree Preferences directly for Markov (or DES) models through the Markov (or DES) Info View as indicated in the figure below.

![Access Markov tree preferences](image)

Link to Tree Preferences for Markov/DES directly in the Markov Info View (same for DES Info View)

### 35.13 PartSA

The PartSA Tree Preferences allow time units for the Survival curves and the Time reports to be set.

![PartSA Tree Preferences](image)

**PartSA Tree Preferences**

- **Survival time unit**: Set the time unit for the model to Annual or Monthly. Note that this needs to be consistent with the time units for your Survival Functions.
- **Time Report unit**: Set the time unit for the Time Report to Annual or Monthly. This only affects the Time Report output.
- **Integration step**: Use Default or Custom. We strongly recommend using the Default, which will calculate 360 individual steps per year.
- **Default time horizon**: The default value used when new PartSA nodes are added to the model.
- Survival curves graph: Set the number of points to graph in the Survival Curve graph.

You can access the Tree Preferences directly for PartSA models through the PartSA Info View as indicated in the figure below.

35.14 Fonts

This is the first category related to Display settings.

The Fonts Tree Preferences allows you to specify the font type for several labels/values within the model.
Tree Preferences - Fonts

- **Node Font**: Click this button to select the default font for node labels/text. The font selected in this manner will apply to any new nodes created in the active tree and to any existing nodes, except for any nodes where the font has been set individually.

- **Prob Font**: Click this button to select the default font for probability expressions in both the rolled-back and unrolled-back state. This allows you to clearly distinguish between probability variable names and adjacent node descriptions.

- **EV Font**: Click this button to select the default font for expected value boxes generated during roll back. It also applies to other information which is not user-editable and displayed next to a node, such as clone names when clones are hidden, or payoff names when Always show payoff names is selected.

- **Var Font**: Click this button to select the default font for variable definitions when shown within the tree.

After clicking one of the font buttons, the font selection dialog allows you to specify the font, font style, etc.
35 Preferences

Tree Preferences - Fonts - Font Dialog

35.15 Node Text/Comments

The Node Text/Comments Tree Preferences category allows you to show/hide certain text labels/values within the model.

- *Mark nodes with comments*: Check this box to display a small flag above the node symbol for all nodes with associated Node Comments. This flag does not print or export.
- *Hide all node texts*: Check this box to suppress all textual information in the Tree Diagram Editor. Use this flag to get a picture of the structure of your tree.
- *Hide probabilities only*: Check this box to hide only probabilities expressions in the Tree Diagram Editor, while all other textual information is visible. Use this flag to temporarily simplify the display of complex trees with many uncertainties.
- *Wrap long probability expressions*: Check this box to wrap probability expressions that may exceed the width of a node.
- **Show IDs of nodes**: Show node IDs next to the node labels in the Tree Diagram Editor and Tree Explorer.
- **Hide all notes**: Check this box to hide/show all the notes in the Tree Diagram Editor.

### 35.15.1 Node ID Report

In addition to the option to "Show IDs of nodes", you can create a Node ID Report outside of the Tree Preferences. In your model, go to the menus and choose Node > Node ID Report from the menu. The Node ID Report is displayed below.

![Node ID Report generated from the Node menu](image)

### 35.16 Printing

The Printing Tree Preferences category allows you to specify printing options for the model.

- **Printing zoom factor**: Set the zooming scale for printed output of the model. A lower percentage will fit more of the model on a page.
Note also that it is independent of any scaling specified under Page Setup. Thus, if your printer driver allows scaling via the Page Setup command, you run the risk of applying one percentage against another.
The printing zoom factor is also independent of the screen-display zoom factor, set via the Modeling Palette.

35.16.1 Page Header/Footer

The Page Header/Footer Tree Preferences category allows you to specify a page header and a page footer that are used when printing the model.

Tree Preferences - Page Header/Footer

- **Header**: Text to display at the top of each printed page of model.
- **Header Font**: Font to use for header text.
- **Header Align**: Horizontal alignment for header.
- **Footer**: Text to display at the bottom of each printed page of model.
- **Footer Font**: Font to use for footer text.
- **Footer Align**: Horizontal alignment for footer.

35.17 Terminal Columns

The Terminal Columns Tree Preferences category allows you to create terminal columns to display during roll back of the model.
When enabled, terminal columns are presented to the right of the standard payoff values at each terminal node.

Note that you can now show extra payoffs in the Rankings report by configuring the model to "calculate extra payoffs". This is simpler and easier than Terminal Columns if all you need is the expected values for all enabled payoffs.

The following figure shows the preferences for the the Special Features tutorial example model Terminal Columns.trex.

Tree Preferences - Terminal Columns

- **Show terminal columns**: Check this box to show terminal columns on roll back instead of expected values.
- **Terminal column grid**: Grid showing existing terminal columns.

Terminal columns can be edited directly in the grid. Click the "plus" icon to add a terminal column to the grid. Click the "X" icon to delete the selected terminal column. There is no separate terminal column dialog. The columns in the grid are described below.

- **Header**: Enter text to be displayed above the terminal column data.
- **Calculation**: Select the type of calculation to be performed for the terminal column.
  - **Expected Value**: Show the expected value of the active payoff.
  - **Incremental Value**: Show the incremental change in expected value between this strategy and the previous one.
  - **Path Probability**: Show the path probability for the terminal node.
- **Scenario Number**: Show the scenario number which counts from one starting at the top terminal node.
- **Custom**: Show a custom expression as defined in the Custom calculation column.

- **Custom calculation**: Enter a custom expression using TreeAge Pro variables, functions, etc.
- **Algorithm**: Determines how to calculate the value for a collapsed subtree. This only applies to columns using custom calculations.
  - **Weighted**: Use the weighted average from the terminal nodes contained within the collapsed subtree.
  - **At Node**: Use the value from the node at the base of the collapsed subtree.

- **Numeric format**: Select the numeric formatting to use for this value.
  - **Standard**: Use formatting for active payoff.
  - **Probability**: Use formatting for probabilities.
  - **Custom**: Use custom formatting.

- **Custom font**: Change the font preferences for the column.

Terminal columns are discussed in further detail in the Tree Display Preferences and Options Chapter.

### 35.18 Terminal Nodes

The Terminal Columns Tree Preferences category allows you to specify how terminal nodes are displayed within the model.

- **Display payoff names**: Check this box to display the name/expression of the active payoff at every terminal node. This can be helpful for identifying terminal nodes where a payoff has not been assigned. In the case of trees having multiple payoffs, this feature makes it possible to see at a glance which payoff is active.
- **Display payoffs boxed**: If you have chosen to always display payoff names, check this box to enclose the payoff names/expressions in a box. This option relates only to tree display prior to roll back; during roll back, calculated values are always boxed.
- **Automatic node numbering**: Check this box to display a node number for every terminal node. The numbering format is controlled by the *Numbering text format* field.
- **Number all nodes in tree**: Check this box to number all nodes in the model rather than numbering only the terminal nodes.
- **Numbering text format**: Use this field to specify the custom text for node numbering. Use the ^ (caret) symbol in the text to represent the scenario number.
- **Show terminal node symbols as**: Select one of the three methods for showing terminal nodes in the model. Triangles are the default (and standard) method. Diamonds are used to indicate the parallelism between terminal nodes in a tree. Lines are for those applications when you do not want any symbol displayed to the right of a final outcome.

### 35.19 Tree Editing/Layout

The Tree Editing/Layout Tree Preferences category allows you to control a few editing and visual elements of the Tree Diagram Editor.

![Tree Preferences - Tree Editing/Layout](image)

- **Default branches per node**: Select the number of branches to add when you select Add Branches from the context menu at a node. The default number applies only the first time that branches are added at a given node. Once a node has branches, additional branches are added one at a time.
- **Add branches at**: Select the location for new branches relative to existing branches when adding additional branches to a node. Dragging new nodes from the palette provides additional flexibility in this area.
- **Keyboard navigation**: Select the branch to move to when using the right arrow to navigate from a node to one of its branches.
- **Minimize empty space**: Check this box to produce a “compressed” version of your tree that minimizes empty space. Because each node no longer has its own horizontal “slice” of the tree display, this option may not be used with Align endnodes.

- **Align endnodes**: Check this box to force all terminal nodes to line up at the rightmost edge of the tree.

- **Branch lines at right angles**: Check this box to draw all branch connectors as vertical lines. By default branch connectors are drawn at whatever angle is needed to provide the most direct connection from one node to the next.

- **Show clone-copy subtrees**: Check this box to display clone-copy subtrees; display of clone masters is not affected. When this option is selected, all clone-copy subtrees are displayed with their complete structure. When this option is not selected, only the name of the clone is displayed to the right of the clone-copy anchor node, which can dramatically reduce the visual size of your tree within the Tree Diagram Editor.

### 35.20 Variables/Markov Info

The Variables/Markov Info Tree Preferences category allows you to control the way variables, Markov information and other information is displayed in the Tree Diagram Editor.

- **Display definitions at nodes**: Select the option to either hide or show variable definitions beneath nodes in the Tree Diagram Editor.

- **Show Markov information**: Show Markov information beneath the node line where applicable (Markov termination condition, Markov state rewards, Markov transition rewards, etc.). Choose whether to display only the active payoffs or all enabled payoffs.
- *Show tracker initial values*: Check this box to show the initial value of trackers at the root node.
- *Show named distributions*: Check this box to show the names of distributions at the root node.
- *Use variable categories in tree window*: Organize variables by categories in the Tree Diagram Editor.

### 35.21 Dynamic Links

This is the first category related to *Spreadsheet* preferences.

![Tree Preferences - Identifying Variables](image)

The Identifying Variables Tree Preferences category allows you to store specific variables and their values with Monte Carlo simulation output.

### 35.22 Identifying Variables

This is the first category related to *Analysis Settings* preferences.

The Identifying Variables Tree Preferences category allows you to store specific variables and their values with Monte Carlo simulation output.
35 Preferences

Tree Preferences - Identifying Variables

This can be useful if you run/save multiple sets of simulation outputs with different variable values - potentially generated by a stored analysis sequence.

35.23 Debugging/Calculation Trace

The Tree Preference for Debugging allows you to select the information you want to show in the Calculation Trace Console and to control the console settings. The Debugging/Calculation Trace Console settings will apply to the whole model. For models with a large number of internal calculations this may take a long time. The sections about Model Debugging show how to select specific information to write to the console.

The Debugging/Calculation Trace Console Tree Preferences category allows you control over the output in the debug view during analyses.
Tree Preferences - Debugging/Calculation Trace Console

- **Show in Console**: Select the items you wish to see in the debug view as TreeAge Pro performs calculations.

- **Errors, warnings and notes**: Check this box to avoid having TreeAge Pro pop-up dialogs when warnings or error messages need to be displayed; instead, checking this box will have the text added to the Calculation Trace Console.

- **Text-only analysis output**: Check this box to write text report analysis output to the Console. For example, Rankings output is purely text and would be written to the Console.

- **Saved analysis abstract/summary**: Check this box to display summary information in the Calculation Trace Console about any new analyses available for storage. This information can be stored for later use via Stored Analysis.

- **Console settings**: Select how you want the output to the console to be displayed.

- **Clear console before each analysis**: Check this box to clear the console before each new analysis.

- **Limit console output (if # of lines exceeds)**: Select the maximum number of lines to display within the Calculation Trace Console. Older lines are dropped when the maximum number of lines
is exceeded. A larger number holds more outputs in the debug view, which uses more system resources.

The main controls for the output are in the section *Show output for*:

- **All**: Select this for all the internal calculations to be written to the Calculation Trace Console.
- **None**: Turns off debug output.
- **Selected Elements**: Select this to show only specific calculations in the Calculation Trace Console. When you select this choice, you need to select elements of the model to debug via the check boxes in the Variable Properties, Tracker Properties and Distributions Views.

For more details about using these settings see the section about Model Debugging.

### 35.24 Output Reports

The Output Reports Tree Preferences category allows you to filter the secondary reports available from Monte Carlo simulations.

There are two main options...

- Hide PSA reports for microsimulation
- Display only selected reports from list below

### 35.24.1 Hide PSA reports for Microsimulation

The "Hide PSA reports for microsimulation" option specifically hides all secondary reports that are inappropriate for Microsimulation. Microsimulation is patient-level simulation, so secondary reports are invalid if they rely on incremental calculations among strategies on an iteration-by-iteration basis.

This option defaults to checked. Uncheck the box to see all secondary reports.

### 35.24.2 Display only selected reports from list below

The "Display only selected reports from list below" option allows modelers to specify which secondary outputs should be displayed. This is normally used when modelers want to simplify the secondary output display to focus on a specific subset of secondary reports.

Check the option "Display only selected reports from list below" to removing some of the output options to make it easier to find the output options you wish to highlight. A modeler might choose to filter the output generated by a Player Model to make it easier for the recipient of the player model to find a specific output.
Tree Preferences - Output Reports

The reports are all types of Monte Carlo reports, and then there are group-level checkboxes for "Data", "Rankings", "PSA Outputs", "CEA Outputs" and "Distributions (Histograms)" options. Use these to check or uncheck all options within those groups.

The remaining options either include (checked) or exclude (unchecked) that specific output from the Monte Carlo simulation output. Not all options apply to all simulation output. Those restrictions are highlighted below.

- **Identifying Variables** - all output
- **All Data** - Values, Dists, Trackers - all output
- **Strategy Values** - all output
- **Trackers** - only if model contains trackers
- **Extra Payoffs, All** - only if extra payoffs are included in model
- **Distributions (by name)** - only if model contains distributions
- **Distributions (by index)** - only if model contains distributions
- **Trackers, All** - only if model contains trackers
- **Strategy Selection Frequency** - only if non-CE model
- *Distributions, All* - only if model contains distributions
- *Acceptability Curve* - CE models only TOP
- *ICE Scatter + Ellipses* - CE models only
- *EVPI/EVPPI Summary Report* - all output
- *CE Scatter Plot* - CE models only
- *CE Graph* - CE models only
- *CE Graph (inverted)* - CE models only
- *CE Rankings Report* - CE models only
- *NMB v. WTP* - CE models only
- *Incremental (INMB) v. WTP* - CE models only

**Output Report Options**

### 35.25 Report Filters

When you run Monte Carlo Simulations, you can filter the data to focus on a subgroup of those results. When filters are created, they are included here in Tree Preferences, so you can use those filters again for future simulations.

For more information on Filters, please refer to Patient Simulation Chapter.

### 35.26 Monte Carlo Options

The Advanced Monte Carlo Options Tree Preferences category allows you to specify advanced options for Monte Carlo simulation. For more details about these options see the Section Simulation Options.

There are four different options found in this category, starting with *Distribution Sampling.*
35.26.1 Distribution Sampling

There are three main options to determine which distributions to sample - all, none or some. Typically, you would sample all distributions unless you were testing the model by skipping some.

- **Sample all:** Default setting. This will sample all distributions.
- **Sample none:** Check this box so there are no sample distributions.
- **Sample some (make selections below):** Check this box to choose the distributions you want to sample using the selection boxes.
- **Sample per EV calculation (for PSA):** This selection box pair allow you to choose the distributions to sample for the whole cohort for PSA.
- **Sample per trial or stage (for Microsimulation):** This selection box pair allow you to choose the distributions to sample for each individual trial to be used in Microsimulation.
- **EVPPI Sampling:** This selection box pair allows you to choose the distributions to sample for EVPPI. See the section on Value of Information for more details.

**Sample distributions during Monte Carlo:**

If you choose to sample *some* distributions, then you need to specify which distributions to sample in the next two sections.
Sample per EV calculation (for PSA): Choose the PSA-level distributions you want sampled by moving them from the left pane to the right pane using the control buttons.

Sample per trial or stage (for Microsimulation): Choose the patient-level and cycle-level distributions you want sampled by moving them from the left pane to the right pane using the control buttons.

The last section, hidden by default, only applies to EVPPI sampling where there are two simulation loops related to a 2-level PSA.

EVPPI Sampling: Choose the PSA-level distributions you want sampled in the outer PSA loop (for specific study) by moving them from the left pane to the right pane using the control buttons. Distributions in the left pane will still be sampled, but the uncertainty of those distributions will be hidden by aggregation to mean values within the EVPPI analysis. See the section on Value of Information for more details.

35.26.2 Random Number Seeding Options

Monte Carlo Simulation generates stochastic results via random number generation. Seeding options are designed to provide maximum flexibility to stabilize random number generation and hence output values within the simulation context.

- Seed random number generator: Check this box to stabilize the overall model results from one simulation to the next.
- Seed: If the prior option is checked, set the initial seed for the random number sequence. Changing this value will generate a different but repeatable set of results.
- **Stabilize Microsimulation when run as inner loop within PSA.** This option applies only to Microsimulation when running within the context of PSA. Checking this box ensures consistency among sets of patients within the Microsimulation as the outer loop PSA sampled inputs change.

- **Stabilize PSA sampling when run as an inner loop with EVPPI.** This option applies only to EVPPI simulations, which have two PSA loops. Checking this box ensures that the same set of samples are drawn from the PSA-level distributions while the outer-loop PSA sampled inputs change.

- **Stabilize Microsimulation when run as inner loop within Sensitivity Analysis.** This option applies only to Microsimulation when running within the context of deterministic sensitivity analysis (1-way, 2-way, 3-way, tornado). Checking this box ensures consistency among sets of patients within the Microsimulation as the input parameters vary within their respective ranges.

### Seeding options

All seeding should be used cautiously. Seeding generates repeatable results from analysis to analysis or from inner loop to inner loop. It is not a substitute for running a representative number of iterations to stabilize the overall mean results from any analysis.

### 35.26.3 Threading Options

 Threads are separate processes that can run concurrently on your computer. The more threads used for an analysis, the faster it will run.
There may be times when you want to limit the number of threads - when patients interact with each other and need to run on the same thread, or when you want to limit the system resources used by an analysis to leave computer power for other programs.

- **Set number of threads**: Check this box to determine a specific amount of threads you wish to run. If unchecked, TreeAge Pro will run a thread on every chip that's available.

### 35.26.4 Downstream Decision Options

These options are no longer used

![Tree Preferences - Monte Carlo Options - Downstream Decision Options](image)

### 35.27 Time Reporting Selection

Please read the Chapter about Time Reporting which provides extensive detail about Time Reporting incorporating using this Tree Preference.

### 35.28 Stored Analysis Abstracts and Sequences

Stored Analyses and Sequences are described in a separate chapter.

### 35.29 Application Preferences

Application Preferences control many settings and options for the TreeAge Pro application and are not associated with a specific model, and therefore apply to all models.

Application Preferences are edited using the Application Preferences Dialog.

### 35.30 Application Preferences Dialog

The Application Preferences Dialog is used to edit Application Preferences.
To open the Application Preferences Dialog:

- Choose Window > Application Preferences from the menu.

Subsequent sections will describe each category of Application Preferences.

### 35.31 Application Preferences - Backup/Save

The Backup/Save Application Preferences category allows you control on how TreeAge Pro backs up your work.
- **Create backup copy on save**: Check this box, and TreeAge Pro will save a backup copy of each file that you open and subsequently save changes to. The backup file contains the version of the file as it existed when it was opened. No matter how many times you modify or save the file after opening it, its backup file continues to contain the original version of the document. If you close a file and then reopen it, the backup process is restarted; if a backup file already exists for a document that you open, TreeAge Pro will overwrite the existing backup file when you save the document. The backup file is created in the same directory as the original file (unless you check to save in a separate folder). The file is saved with the prefix “zOrig” to the filename; for example, the backup file for “my tree #1.trex” would be saved as “zOrig.my tree #1.trez”.

In the case of a new, untitled document, a backup file is not created the first time it is saved, since no original document file existed on disk at that point; the backup file will be created the next time you save changes to the file.

- **Save backups in a separate subfolder**: Check this box to save the backup copies in a folder called: TreeAge-backups. This folder will be within the original folder the model was in. If it is unchecked, the backups are just saved alongside the original model.

- **Prompt to save analysis output**: Check this box and TreeAge Pro will ask you to save all analysis outputs everytime you try to close them.

### 35.32 Application Preferences - Display

The Display Application Preferences category allows you to control some elements of the display.

- **Prompt to show in empty labels (optional)**: Present this as a prompt when no label has been entered for a node.
35 Preferences

- Disable antialiasing (restart required): No longer used.

35.33 Application Preferences - Keys

The Keys Application Preferences category allows you to setup keyboard shortcuts for functions within TreeAge Pro.

Application Preferences - Keys

Use these settings to add/edit hot key options for actions in the menu. We recommend that you leave the existing hot key options in place.

35.34 Application Preferences - Launch Pad

The Launch Pad Application Preferences category allows you to control the elements which appear in the Launch Pad. Experienced users may not want to see the Assistants (for example).
Application Preferences - Launch Pad

The elements are:

- "Create new" tab: Select the elements you want to see in the Create New tab.
- "Open" tab: Select the elements you want to see in the Open tab.

35.35 Application Preferences - Automatic Updates

The Automatic Updates Application Preferences category allows you control over how the TreeAge Pro application is updated as new updates are released.

Application Preferences - Automatic Updates

- **Automatically find new updates and notify me**: Check this box to have TreeAge Pro automatically check for new updates to the software as they become available.
- **Update schedule**: Select an option for when to check for new updates.
  - *Look for updates each time TreeAge Pro is started*: Check each time TreeAge Pro is started.
  - *Look for updates on the following schedule*: Check based on a custom schedule.
- **When updates are found**: Select a schedule for notifications regarding available updates.
  - *Notify me once about updates*: Notify once when updates are available but never again.
  - *Remind me about updates every*: Notify repeatedly when updates are available based on a custom schedule.

### 35.36 Application Preferences - Monte Carlo Distributed Processing

The Monte Carlo Distributed Processing Application Preferences category allows you to setup helper computers to spread out Monte Carlo simulations over a number of separate computers.

![Application Preferences - Monte Carlo Distributed Processing](image)

- **Use distributed computers**: Check this box to use helper computers.
- **Server name**: The helper computer name. The helper computer can be used to perform some iterations of a Monte Carlo simulation so that the overall simulation runs faster.
- **Status**: The status of the helper computer, which indicates whether the helper computer is available.
- **Reason**: Purpose for which the helper computer was added.
- **Add button**: Add a new helper computer.
- **Remove button**: Remove the selected helper computer.
- **Refresh button**: Refresh the status of all helper computers.
- **Select All button**: Select all helper computers in the grid.
- **Select Ready button**: Select all helper computers that are ready.
- **Deselect All button**: All helper computers are no longer selected.
Note that when you use helper computers, you typically also want to add the local computer as "localhost" to do some of the simulation work.

35.37 Application Preferences - Storage

The Storage Application Preference category allows you to modify the way TreeAge Pro stores data during analyses.

- **Store raw Monte-Carlo simulation data on disk** - Analysis data is stored on disk by default so that you do not exceed the computer's memory. Check this box to store the data in memory instead. Note that this option is only available for 64-bit versions of TreeAge Pro.
- **Storage location for temporary analysis** - Change the folder TreeAge Pro uses to store data for model analysis. You might change this to a different location if your workspace is on a drive with limited disk space. **NOTE** this folder is deleted after analyses so do not choose a folder where you want to save any other files.

35.38 Application Preferences - Python

Control the way Python functions within TreeAge Pro.
Application Preferences - Python

- Do not show enable Python question - Stop warning question each time you open a model with Python functions.
- Use external Python installation - Use a version of Python installed on your computer rather than the version bundled with TreeAge Pro (Java Python).
- Override path to Python - Enter a path to a specific installation of Python that is not the default version for your computer.
36. Technical Details & Utilities

This chapter contains technical details on the TreeAge Pro application and TreeAge Pro utilities.

36.1 TreeAge Pro products and modules

TreeAge Pro follows a modular design. The "Core" module includes both decision tree functionality, Monte Carlo simulation, multi-way sensitivity analysis, and much more. Additional features for Healthcare analysis may be added in the optional Healthcare module. Both "Core" and "Healthcare" products include the Excel™ add-in module.

The TreeAge Pro Healthcare module integrates core decision analysis functionality with specialized capabilities, including:

- Markov cohort analysis
- Individual-level, Markov simulation
- Cost-Effectiveness analysis
- Net Benefits analysis
- Additional information available at https://www.treeage.com/shop/treeage-pro-healthcare/

Healthcare Module Functions

The TreeAge Pro Excel module is included in both products. It can help:

- Automate the creation of Excel charts and reports from within TreeAge Pro
- Simplify the integration of spreadsheets and TreeAge Pro models
- Edit input data in Excel
- Output analysis data to Excel
- Additional information about the "Core" product is available at https://www.treeage.com/shop/treeage-pro/

Excel Module Functions

36.2 Node Types

Decision trees can include nodes with a number of different node types. This section lists the node types and their typical usage. The Tree Diagram Editor Palette displays all the available node types.
- **Chance**: Used to represent a situation with an unknown outcome. Each branch of the chance node represents one of the outcomes. There must be a branch for every possible outcome, and each branch will include a probability expression for the likelihood of that outcome. The hashtag (#) can be used for one of the branch probabilities, which is calculated as the complement of the sum of all other probability expressions.

- **Terminal**: Used to terminate endpoints in a model. All endnodes (no branches) must be terminal nodes. In a decision tree, a terminal node represents the end of a scenario, and payoff values are required to place value(s) on that scenario. In a Markov model, a terminal node represents the end of a cycle, and a jump state is used to return the cohort to a health state to start the next cycle. In DES models, terminal nodes function the same as in Markov models.

- **Decision**: Used to represent a decision point within a model. Each branch represents a strategy which will be evaluated separately to determine the optimal strategy at that decision node. It is typical for a model to contain a single decision node as the left most node in the model (the root node).

- **Logic**: Used like a chance node with an unknown outcome. However, each branch will have a logical expression instead of a probability expression. Logical expressions are checked from the top branch down. The model will flow to the first branch with a logical expression that evaluates to true. It is common to use the hashtag (#) for the bottom branch for when all logical expressions for the other branches are false.

- **Markov**: Used as the start of a Markov model. The Markov node and its entire subtree are part of the Markov model, which is normally part of a larger decision tree model.

- **Label**: Used to simply flow from a node to its one and only branch. It functions the same as a chance node with a single branch with probability of 100%. This is commonly used to separate dependent calculations, so the calculations at the label node are complete before the calculations are performed at the branch node.

- **Summation**: Used to sum the expected values (EVs) of all branches within a decision tree, rather than use a weighted average as is done for chance nodes. This is commonly used when there
are multiple separate value calculations and the sum of those values represents the total EV. For example, branches could be used in a legal model for compensatory damages and punitive damages, such that the total value is the sum.

- **DES**: Used as the start of a Discrete Event Simulation (DES) model. The DES node and its entire subtree are part of the DES model, which is normally part of a larger decision tree model.

- **Time**: Used only within a DES model. Each branch of a DES node represents a possible event with a time-to-event expression. Time passes and time-based value is accumulated at this node until an event occurs.

- **Entry**: Used in Dynamic Cohort models. The Entry node is used to add members to the cohort. The node branch itself has no impact on the cohort size but the branches of the entry node add members to different health states. The node must be set to non-coherent to enable additional members to be added.

- **Stop**: Used in Parallel Trial models. The Stop node is used at the point in the model where trials running through a model in parallel need to wait for resources before they can complete their actions.

### Node Types

#### 36.3 Random number generator details

Monte Carlo simulations in TreeAge Pro make use of a robust pseudo-random number generator (RNG) algorithm, the Mersenne Twister, which has the following useful properties:

1. Has a period of $2^{19937}$, or approximately $10^{6001}$ unique sequences.
2. Has negligible serial correlation between successive values in the output sequence.
3. Works fast.
4. Passes numerous tests for statistical randomness.

Distribution sampling and discrete simulation random walks utilize the RNG. By default, each RNG is "seeded" using the computer clock. This "random" seeding can be overridden by the user specifying a random seed value in the Simulation options. The Simulations Options can be found in Tree Preferences > Analysis Settings > Monte Carlo Options > Random Number Seeding Options.

In a multi-processor simulation, each thread has a separate RNG, which is started at a different position based on the clock seed or the user-specified.

Click here to review seeding options.

#### 36.4 Report Output Files (*.rptx)

Report outputs from Monte Carlo, Sensitivity, and Markov Cohort analyses can be saved in *.rptx files. These files can be reopened in TreeAge Pro to generate graphical and text output.
The *.rptx file is a zip file, which contains an H2 datasource/database (plus other files). This datasource is queryable from outside of TreeAge Pro through an H2 browser console.

You can copy the *.rptx files, change the extension to *.zip, and uncompress the files ("datasource" and "datasource.*" files are needed). The path to “datasource” will be used to connect in the browser console.

It is possible to then run the H2 database service/console from an "h2.jar" file zipped within the TreeAge Pro plugins directory; it will be easier to install H2 separately. Click here to go to the H2 site. The Download page will allow you to download the H2 Database Engine. The Quickstart page provides information on installation.

You can then run the h2.jar to open the console in a browser, add/browse to the path of your datasource, and enter the username ("sa") and password ("sa").

The H2 Console then provides access to the database tables, allowing you to create queries to pull data as needed.
36.5 Importing TP 2009 Simulation Output

The current TreeAge Pro software can import the *.MCS simulation output files generated by TreeAge Pro 2009 and earlier software versions.

To import an *.MCS file:

- Choose File > Import/Export > Import TreeAge 200X MCS File... from the menu.
- Enter options in the Import MCS dialog (see below) and click OK.

The options in the dialog above allow you to filter the number of rows and/or columns to include in the imported output. This can reduce the size of the data imported.
36.6 TreeAge Pro News Reader

The News Reader is used to provide TreeAge Pro users with important information regarding product updates, new products, training, licensing issues, etc. When new news items are available, the News Reader will retrieve and display the items.

News Reader View

Under Window, there are Application Preferences available to control the type of news items you wish to see.

News Feed Application Preferences
36.7 Integration with other software

In TreeAge Pro, users of the Excelmodule gain access to powerful features that allow automation of TreeAge Pro tasks via scripts and macros, in order to control the updating and analysis of your models.

In addition, the embedded Python script interpreter has been improved, giving modelers easy access to the powerful Python programming language.

36.8 Installation and system requirements

To install TreeAge Pro, please go to www.treeage.com/install and enter your serial number. You will be presented with a list of installers. Choose the one that is appropriate for your computer. After installing, you will need to authorize TreeAge Pro with your license serial number.

System requirements are available at https://www.treeage.com/support/system-requirements/.

36.9 Cross-Platform Compatibility

TreeAge Pro 2011 and subsequent versions are built in the Eclipse architecture, which allows the software to run on Windows, Mac, and Linux operating systems. There are different installers for each OS available at our website. In each OS, the software should have a look and feel that for the most part matches the native view for that OS.

Since TreeAge Pro 2009 and earlier versions ran only on the Windows OS, most of the instructions in this manual describe Windows operations. There are some differences in commands/mouse-clicks on Mac and Linux. The table below describes some of these differences.

<table>
<thead>
<tr>
<th>Windows</th>
<th>Mac</th>
<th>Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control + key</td>
<td>Command + key</td>
<td>?</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control-click</td>
<td></td>
</tr>
<tr>
<td>Function keys</td>
<td>Fn key + function key</td>
<td></td>
</tr>
</tbody>
</table>

Command differences among operating systems

36.9.1 Mac Function Keys

Mac computers often use function keys to interact with the Mac Operating System. You can release those function keys from their OS functions by changing settings in the System Preferences under the category Keyboard. Specifically...

- Check the box to use F1, F2, etc. as standard function keys.
- Uncheck the box for active use of "Exposé & Spaces" or "Mission Control".
36.9.2 Linux with GNOME Desktop Environment

If you use Unix-like operating systems with the GNOME desktop environment, you may be unable to see the application's menu icons.

If you experience this problem:

- Start the gconf-editor.
- Select the checkbox in /desktop/gnome/interface/menus_have_icons

36.10 File compatibility

TreeAge Pro 2011 introduced a new XML-based model file structure.

- Models saved in TreeAge Pro 2011 or later use the file extension .trex.
- Models saved in TreeAge Pro 2009 or earlier use the file extension .tre or .pkg.

File formats

36.10.1 Compatibility issues with new features

Every 6 months, a new version of TreeAge Pro is released. This may make models built in newer software incompatible with older software. Please be careful using new features if you need to share models with a colleague that uses older software.

Model validation allows you to identify features that will not work in older post-2011 software. Use of those features must be removed if sharing with a colleague with older software.

36.10.2 Compatibility between models from TP 2009 and TP 2011

Older *.tre and *.pkg files can be opened in TreeAge Pro 2011 and subsequent versions. When you open a files from an older format, you are asked whether you want to save the file in the new format or the old format.